Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 29 Jul 2014, 23:09
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » REQUESTS
WikidPad for Puppy Linux 5.2
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [11 Posts]  
Author Message
docsulo

Joined: 22 Apr 2010
Posts: 25

PostPosted: Tue 01 Feb 2011, 02:10    Post subject:  WikidPad for Puppy Linux 5.2  

I've done everything I could to get Wikidpad 2.0 to work in Lucid Puppy 5.2.

I've even gone and asked the guy who runs Portable Linux Apps (he created a portable app of Wikidpad) but alas I can't get it to run.

I went to another portable app type created by Philip Guo http://www.stanford.edu/~pgbovine/cdepack.html and after much trial and error got it to work but it wouldn't load my Wiki. Mr. Guo was truly helpful and spent days e-mailing back and forth helping me to get the package to work. It would have been awesome if it did because I'm pretty sure I could then have used it on ANY Linux distro.

Finally, I tried to just install it normally and and after many, many errors that I haven't been able to fix - I have given up trying to install it myself.

It's obviously not hard for some because someone put a screenshot of their machine running on Lucid 5.2 on the Wikidpad Yahoo group but didn't give a PET or instructions on how they installed it.

Anyway, I use this program almost exclusively and would love to have it work on Lucid Puppy 5.2.

If someone can figure out how to install it and create a PET that would be awesome. However, if you do - Can you put up some basic instructions on how you accomplished it? I'd love to be able to do it myself without begging for help on this forum every time there is a new Puppy release and unfortunately the developer of Wikidpad is not familiar with Linux so there are really no good instructions on the site or in the package.

The Wikidpad 2.0 source code can be found here: http://wikidpad.sourceforge.net/

-Chris
Back to top
View user's profile Send private message Visit poster's website 
666philb


Joined: 07 Feb 2010
Posts: 1634
Location: wales

PostPosted: Tue 01 Feb 2011, 03:19    Post subject:  

You're in luck, live just tried the portable wiki pad available here, and it seems to works on my lucid puppy520
http://portablelinuxapps.org/

666philb

_________________
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
LÖVE2d, a collection of 27 lua gameshttp://www.murga-linux.com/puppy/viewtopic.php?t=76739
Back to top
View user's profile Send private message 
docsulo

Joined: 22 Apr 2010
Posts: 25

PostPosted: Tue 01 Feb 2011, 10:16    Post subject:  

Whoops - double post.
Last edited by docsulo on Tue 01 Feb 2011, 10:23; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
docsulo

Joined: 22 Apr 2010
Posts: 25

PostPosted: Tue 01 Feb 2011, 10:21    Post subject:  

[quote="docsulo"]
666philb wrote:
You're in luck, live just tried the portable wiki pad available here, and it seems to works on my lucid puppy520
http://portablelinuxapps.org/

666philb


I was the original person that suggested that portable app in this thread http://www.portablelinuxapps.org/forum/viewtopic.php?f=5&t=145 (although it seems that my posts have been deleted on that forum - weird).

Anyway - it didn't and doesn't work for me. So if anyone can still help it would be appreciated.
Back to top
View user's profile Send private message Visit poster's website 
CatDude


Joined: 03 Jan 2007
Posts: 1450
Location: UK

PostPosted: Tue 01 Feb 2011, 12:27    Post subject:  

Hello docsulo

Puppy does not include Python in the ISO image (i suppose because it would make it too big), but is in the devx_xxx.sfs
So if you are running a frugal install,
you need to download the lupu_devx_520.sfs
and put it where your lupusave file is, then have the BootManager load it up (requires that you reboot).

Then the portable WikidPad 2.0rc10_1 app should work (it did for me)

I didn't like the space it that name, so i renamed it to WikidPad-2.0rc10_1 (it still worked)

If you are running a full install, then hopefully someone will give details how to add the lupu_devx_520.sfs to it.

CatDude
.

_________________

Back to top
View user's profile Send private message 
docsulo

Joined: 22 Apr 2010
Posts: 25

PostPosted: Tue 01 Feb 2011, 12:51    Post subject:  

CatDude wrote:
Hello docsulo

Puppy does not include Python in the ISO image (i suppose because it would make it too big), but is in the devx_xxx.sfs

.


Thanks CatDude.

I had no idea that Python was in the devx file. I had the impression that Barry and others were not fond of Python (because of bloat) so it wasn't there.

I will try it.

That said. I do have Python installed. I also installed python-wxgtk2.8 and python-support.

That's why I'm frustrated Sad.

Nevertheless I'm glad to know that you may have given me the fix I'm looking for.

Thanks.
Back to top
View user's profile Send private message Visit poster's website 
docsulo

Joined: 22 Apr 2010
Posts: 25

PostPosted: Tue 01 Feb 2011, 14:52    Post subject:  

CatDude wrote:

So if you are running a frugal install,
you need to download the lupu_devx_520.sfs
and put it where your lupusave file is, then have the BootManager load it up (requires that you reboot).

Then the portable WikidPad 2.0rc10_1 app should work (it did for me)

.


It worked.

Thanks for that.

I'd still like to be able to install the thing myself but I'm very happy to have it working on Puppy.

-Chris
Back to top
View user's profile Send private message Visit poster's website 
scsijon

Joined: 23 May 2007
Posts: 1023
Location: the australian mallee

PostPosted: Fri 25 Mar 2011, 20:04    Post subject:  

would someone like to put a url up here please, I can't find it in the repositries or an entry in the wika.

thanks
scsijon
Back to top
View user's profile Send private message Visit poster's website 
666philb


Joined: 07 Feb 2010
Posts: 1634
Location: wales

PostPosted: Fri 25 Mar 2011, 20:19    Post subject:  

did you mean this ? http://uploadingit.com/file/9ltb5kbbfgmrtfqk/WikidPad%202.0rc10_1
_________________
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
LÖVE2d, a collection of 27 lua gameshttp://www.murga-linux.com/puppy/viewtopic.php?t=76739
Back to top
View user's profile Send private message 
scsijon

Joined: 23 May 2007
Posts: 1023
Location: the australian mallee

PostPosted: Tue 29 Mar 2011, 01:39    Post subject:  

yup, that explains why I couldn't find it! what a url!

thanks
scsijon
Back to top
View user's profile Send private message Visit poster's website 
666philb


Joined: 07 Feb 2010
Posts: 1634
Location: wales

PostPosted: Fri 01 Apr 2011, 08:56    Post subject:  

it's not available on the portable app site anymore, lot's of the links are now dead. Luckily i downloaded 80% of them.
_________________
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
LÖVE2d, a collection of 27 lua gameshttp://www.murga-linux.com/puppy/viewtopic.php?t=76739
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [11 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » REQUESTS
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1510s ][ Queries: 12 (0.0894s) ][ GZIP on ]