Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 23 Oct 2014, 09:32
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
amsn
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 2 Posts_count   Goto page: 1, 2 Next
Author Message
Geoffrey


Joined: 30 May 2010
Posts: 1430
Location: Queensland Australia ɹǝpu∩uʍop

PostPosted: Sun 30 Jan 2011, 08:04    Post_subject:  amsn
Sub_title: amsn-0.98.4
 

Here is a pet for amsn-0.98.4, I compiled this in lucid 5.2

It is limited in it functions not being totally compatible with windows live messenger.

Depending on which version of live messenger is being used doesn't always send files, but it works with other amsn messengers.

I added the snack lib for audio and voice clips, the webcam works but not when connecting to Windows Live Messenger, neither do voice clips.

The tray icon is shown in openbox wm with Lxpanel, icewm and XFCE wm but not in jwm, so don't enable minimize to tray if jwm is used or the GUI will be lost

This needs tk-8-5 and tcl-8-5, the tk-8_5_4-i486-1ga.pet and tcl-8_5_4-i486-1ga.pet packages below also contain example programs.
Use the tk-8.5.6.pet and tcl-8.5.6-v1.pet to keep it small.

amsn-0.98.4_lucid_5.2.pet HERE size 15 meg also works with Lighthousepup LHP-502

amsn-0.98.4_fluppy.pet HERE size 15 meg

amsn-0.98.4-wary_510.pet HERE size 15 meg also works with mywolf-028 and Quirky-NOP 1.20

tk-8_5_4-i486-1ga.pet HERE or faster download HERE size 1751 kb

tcl-8_5_4-i486-1ga.pet HERE or faster download HERE size 2168 kb

Here are newer Tcl/Tk files that are at http://www.pa-mcclamrock.com/icebox.html#Tcl/Tk or get them from the links below

tk-8.5.6.pet HERE size 620k

tcl-8.5.6-v1.pet HERE size 602k

Edit: added faster download links for tk-8_5_4 and tcl-8_5_4
Edit: updated information.

Edited_times_total
Back to top
View user's profile Send_private_message 
Geoffrey


Joined: 30 May 2010
Posts: 1430
Location: Queensland Australia ɹǝpu∩uʍop

PostPosted: Wed 02 Feb 2011, 02:26    Post_subject:  

I have compiled amsn for fluppy see first post
Back to top
View user's profile Send_private_message 
Geoffrey


Joined: 30 May 2010
Posts: 1430
Location: Queensland Australia ɹǝpu∩uʍop

PostPosted: Fri 18 Feb 2011, 06:29    Post_subject:  

Updated download links, see first post
Back to top
View user's profile Send_private_message 
DM was on fire!


Joined: 12 Sep 2009
Posts: 156
Location: N.E. Georgia Mountains, USA

PostPosted: Tue 22 Feb 2011, 03:10    Post_subject:  

Gonna try these in a second. Thank you! Smile
Back to top
View user's profile Send_private_message MSNM 
GustavoYz


Joined: 07 Jul 2010
Posts: 897
Location: .ar

PostPosted: Wed 23 Feb 2011, 01:16    Post_subject:  

Sound Support working?
_________________

Back to top
View user's profile Send_private_message 
DM was on fire!


Joined: 12 Sep 2009
Posts: 156
Location: N.E. Georgia Mountains, USA

PostPosted: Wed 23 Feb 2011, 02:48    Post_subject:  

I haven't had someone send me a sound clip. I'll see if someone wouldn't mind and I'll give you a report, Gustav.

It's running great, and solved all the issues I had with the previous verison Smile Running Lucid 2.3.8 beta. I did notice that with the tcl and tk files you provided, it was informing me there were missing libs. So I used the other tcl and tk .pets I had (on top of the ones you provided, actually; so I don't know if it resolves the issue wtih just mine alone) and it works fine. If someone else has the issue, I'll attach my tcl and tk pets for use. Smile

Doesn't work on KDE though, but that's why Pidgin is for when I'm over there.
Back to top
View user's profile Send_private_message MSNM 
GustavoYz


Joined: 07 Jul 2010
Posts: 897
Location: .ar

PostPosted: Wed 23 Feb 2011, 04:24    Post_subject:  

Thanks, would love to have a confirmation... I'm wondering if 'mic-on-mic' conversations are supported, nothing else.

My tcl/tk files?
Those were 'patched' to work with Pd, sorry if doesn't work for this app.

_________________

Back to top
View user's profile Send_private_message 
Geoffrey


Joined: 30 May 2010
Posts: 1430
Location: Queensland Australia ɹǝpu∩uʍop

PostPosted: Wed 23 Feb 2011, 09:18    Post_subject:  

Compiled amsn for wary_510.

GustavoYz said
"Thanks, would love to have a confirmation... I'm wondering if 'mic-on-mic' conversations are supported, nothing else."

voice chat don't work, it has been disabled, it is supposed to be fixed in the next release along with the webcam, farsight is needed to use these features which is in the fluppy version.

voice clips should work though, it has trouble if the user your connected to is using windows live messenger, file transfer seems to work transferring to another amsn clients.

Thats strange about the tcl/tk files, I've had no problems.
Back to top
View user's profile Send_private_message 
DM was on fire!


Joined: 12 Sep 2009
Posts: 156
Location: N.E. Georgia Mountains, USA

PostPosted: Wed 23 Feb 2011, 14:13    Post_subject:  

It could've even been the fact I'm only running Puppy beta and not the actual thing.
Either way it works. I'm so ecstatic that I have my offline messaging again.

Thank you again Geoffrey!
Back to top
View user's profile Send_private_message MSNM 
Geoffrey


Joined: 30 May 2010
Posts: 1430
Location: Queensland Australia ɹǝpu∩uʍop

PostPosted: Sun 27 Feb 2011, 10:11    Post_subject:  

I just tested the webcam with someone using amsn, it works fine, also voice clips work, the only thing disabled is the conference voice chat, though I haven't been able to get the webcam or voice clips to connect to windows live messenger, I will endeavor to get all the required packages together when the next release of amsn is available, hopefully it will have conferencing fixed.
Back to top
View user's profile Send_private_message 
Geoffrey


Joined: 30 May 2010
Posts: 1430
Location: Queensland Australia ɹǝpu∩uʍop

PostPosted: Sun 27 Feb 2011, 23:09    Post_subject:  

The amsn-0.98.4-wary_510.pet also works with mywolf-028, which uses XFCE.
In the amsn Preferences under Other set
Browser: " firefox $url "
File Manager: "Thunar $location "
Open file command: " Thunar $file "
Use the tk-8.5.6.pet and tcl-8.5.6-v1.pet as they are smaller,
the other tk-8_5_4-i486-1ga.pet and tcl-8_5_4-i486-1ga.pet can be used
if you want the tk sample programs that are included.
Back to top
View user's profile Send_private_message 
kitkunthon

Joined: 28 Feb 2011
Posts: 4

PostPosted: Mon 28 Feb 2011, 11:37    Post_subject: test thai language
Sub_title: this aMSN very good in LUPU520
 

I try aMSN in LUPU520
can type Thai letter

but in Wary5.1.1
can type only English letter
cannot type Thai letter
Back to top
View user's profile Send_private_message 
Geoffrey


Joined: 30 May 2010
Posts: 1430
Location: Queensland Australia ɹǝpu∩uʍop

PostPosted: Mon 28 Feb 2011, 19:46    Post_subject: Re: test thai language
Sub_title: this aMSN very good in LUPU520
 

kitkunthon wrote:
I try aMSN in LUPU520
can type Thai letter

but in Wary5.1.1
can type only English letter
cannot type Thai letter


I don't really know why that is, maybe Wary does not have Thai support.

I can only suggest that you have a look at shinobar's Multilingual Wary RC.
http://www.murga-linux.com/puppy/viewtopic.php?t=63503
Back to top
View user's profile Send_private_message 
kitkunthon

Joined: 28 Feb 2011
Posts: 4

PostPosted: Mon 28 Feb 2011, 20:26    Post_subject:  

thank you
wary5.1.1 support Thai language
I can use seamonkeys , libre office in Thai
aMSN in LUPU5.2 complete work with Thai
Back to top
View user's profile Send_private_message 
Geoffrey


Joined: 30 May 2010
Posts: 1430
Location: Queensland Australia ɹǝpu∩uʍop

PostPosted: Wed 02 Mar 2011, 01:35    Post_subject:  

Updated first post, amsn-0.98.4-wary_510.pet works with Quirky-NOP 1.20, would like to know if any of the amsn pet's work with any other versions of puppy, so that I can update the list, Thank you in advance.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 2 Posts_count   Goto page: 1, 2 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0700s ][ Queries: 12 (0.0041s) ][ GZIP on ]