Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 24 Oct 2014, 21:00
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Documents
How to install LaTeX in Wary 5?
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
Nadi82001

Joined: 26 Feb 2011
Posts: 5

PostPosted: Sat 26 Feb 2011, 08:53    Post_subject:  How to install LaTeX in Wary 5?  

HI,
I've just installed Puppy (WARY 5) on an old Dell latitude c400 with 256 Mb RAM.
I would like to install latex on it (with some kind of editor - kile, texmaker?)
Does anyone know how to do it? I have done some searching - all lead me to old/broken links and I couldn't do it.
I need instructions for download and install.

Thanks,
Back to top
View user's profile Send_private_message 
disciple

Joined: 20 May 2006
Posts: 6449
Location: Auckland, New Zealand

PostPosted: Sat 26 Feb 2011, 17:48    Post_subject:  

There is an .sfs with Lyx at http://murga-linux.com/puppy/viewtopic.php?t=61226
I thought the .sfs I had was smaller though. If I remember I'll check that tomorrow.

_________________
DEATH TO SPREADSHEETS
- - -
Classic Puppy quotes
- - -
Beware the demented serfers!
Back to top
View user's profile Send_private_message 
Nadi82001

Joined: 26 Feb 2011
Posts: 5

PostPosted: Sun 27 Feb 2011, 02:44    Post_subject:  

Thanks,
I will try to download it today.
Do I need to know anything about installation? It says Python is needed, how do I install Python?
And one more question: Do you know anything about TeX editors (I am not familiar with lyx. I know Kile and Texmaker. Is there an easy way to use one of them on Puppy)?
Back to top
View user's profile Send_private_message 
emil

Joined: 10 Nov 2009
Posts: 618
Location: Austria

PostPosted: Sun 27 Feb 2011, 04:20    Post_subject:  

some short remarks:
for the Latex/lynx.sfs: there are some specific python packages around, but the easiest is to install the devx.sfs for your puppy version. It will have python included (check with python from commandline).

If you want to use Latex alone, there is the Texlive distribution
http://www.tug.org/texlive/acquire-netinstall.html
several people have reported success with this, but I think the vanilla install is bigger then diddiks "latex/lyx" package.

Kile will most probably not work easily because *i think* it needs KDE as Desktop environment. You may try to use Texmaker (there is a Debian/ubuntu deb package at their Hompage). I think it will need Qt, maybe the Qt included with Lyx is sufficient.

Another idea would be to use emacs, which will of course have an latex mode.
Anyhow if you have success with Texmaker it would be nice you report it here, maybe there is even the chance for a pet package?

Cool best
emil
Back to top
View user's profile Send_private_message Visit_website 
Nadi82001

Joined: 26 Feb 2011
Posts: 5

PostPosted: Mon 28 Feb 2011, 04:12    Post_subject:  

Thanks, but I'm still where I was yesterday:
Trying to run the installer I get:

Can't locate Pod/Usage.pm in @INC.....
.............
at install-tl line 48.
BEGIN failed--compilation aborted at install-tl line 48


The installer needs perl(?) and I don't now how to install it. tried to follow old instructions I found, but it didn't help. I understand I need devx - what is it? Are there few versions of it? (I got Wary 5.1.1) Where can I find it? and what do I do with it after I download the file?

Another question - about TeXmaker: I got the .deb package - now what?
Is there a way to install it on Puppy?

Thanks again - I appreciate your help.
Back to top
View user's profile Send_private_message 
emil

Joined: 10 Nov 2009
Posts: 618
Location: Austria

PostPosted: Tue 15 Mar 2011, 04:11    Post_subject:  

It's a bit late for a repy, but I check forum rarly -
You seem to be stuck at the very basics:
perl is included in the devx.sfs that is available for every puppy version and includes development relevant stuff. Check the puppylinux homepage, there is a chapter about "DEVELOPEMENT" http://puppylinux.com/development/index.html with instructions how to install sfs packages (Menu/System/Bootmanager)

In Ubuntu based puppies you can install deb packages by cklicking on it. I don't know if this works in Wary or other variants. There is also a program "debbi" which can convert deb packages to extractable packages. Unfortunatly very often you will need additional dependencies, so you have start the program in console, watch eventual error messages and then try to install the missing libraries etc.

It would be great if we had some Latex / Texmaker expertise here on the forum. Unfortunatly I have limited time/INternet access for the next months, so I cannot help much with the grunt work.
Back to top
View user's profile Send_private_message Visit_website 
Nadi82001

Joined: 26 Feb 2011
Posts: 5

PostPosted: Tue 15 Mar 2011, 17:06    Post_subject:  

Yes, I realized I needed the devx.sfs - already installed it. After that I had some trouble with the personal storage file - I had to resize it.

When I have time for it, I will try this "debbi" and see if I can use it to install the .deb package. If it works, I will tell you here.
Back to top
View user's profile Send_private_message 
emil

Joined: 10 Nov 2009
Posts: 618
Location: Austria

PostPosted: Wed 16 Mar 2011, 00:58    Post_subject:  

Maybe skip "debbi" and try unrpm/undeb from this recent post
http://murga-linux.com/puppy/viewtopic.php?p=504743&sid=c215dec9f3cb97e479b4cf804c62452d#504743
Back to top
View user's profile Send_private_message Visit_website 
disciple

Joined: 20 May 2006
Posts: 6449
Location: Auckland, New Zealand

PostPosted: Wed 16 Mar 2011, 01:36    Post_subject:  

Did you actually try the Lyx .sfs?
_________________
DEATH TO SPREADSHEETS
- - -
Classic Puppy quotes
- - -
Beware the demented serfers!
Back to top
View user's profile Send_private_message 
Nadi82001

Joined: 26 Feb 2011
Posts: 5

PostPosted: Sun 20 Mar 2011, 17:04    Post_subject:  

O.K.,
I did it. and it worked. I had Lyx running (it wasn't Lyx.sfs, but something like Latex_Lyx_v09.sfs).
Right now, I have a different kind of troubles. I will return when I've done with them.

Thanks again,
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Documents
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0644s ][ Queries: 12 (0.0085s) ][ GZIP on ]