Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 23 Apr 2014, 06:35
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
Canon MP/MX/MG Scanner Drivers - Updated 2012
Post new topic   Reply to topic View previous topic :: View next topic
Page 3 of 7 [103 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7 Next
Author Message
rcrsn51


Joined: 05 Sep 2006
Posts: 8563
Location: Stratford, Ontario

PostPosted: Thu 17 Feb 2011, 09:43    Post subject:  

Attached below is the common package for the Scangear MP v1.30 series and the driver for the MX 330.

You will need both, plus the libgimp package from the start of this thread.

If you own an MX 330 and download these packages, would you please report back with their success or failure.
scangearmp_common-1.30.pet
Description 
pet

 Download 
Filename  scangearmp_common-1.30.pet 
Filesize  219.73 KB 
Downloaded  864 Time(s) 
scangearmp_mx330series_1.30.pet
Description 
pet

 Download 
Filename  scangearmp_mx330series_1.30.pet 
Filesize  244.17 KB 
Downloaded  862 Time(s) 

Last edited by rcrsn51 on Fri 17 Aug 2012, 16:14; edited 2 times in total
Back to top
View user's profile Send private message 
vtpup


Joined: 15 Oct 2008
Posts: 1077
Location: Republic of Vermont

PostPosted: Thu 03 Mar 2011, 02:23    Post subject:  

rcrsn51, thanks so much for all the work you've done.

I just got a Pixma MX870 all in one, and with your and Patriots help, upgraded CUPS to 1.311 on my Puppy 4.32 and loaded Canon wireless printer drivers, etc. Wireless printing now works, and I'm focusing on scanning.

I've started with your Pixma package for Xsane, since I'm used to using that scanning program. But the Puppy opening script for Xsane asks if the scanner is connected via USB, Parallel, or SCSI, only. Not via network. So wireless doesn't seem to be a possibility, at present.

The next choice, Canon scan software doesn't look like there's a driver for the MX870, unless I'm mistaken about that. So if you plan on writing any more drivers for this thread, that's one I'd like to see.

Thanks!
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 8563
Location: Stratford, Ontario

PostPosted: Thu 03 Mar 2011, 17:45    Post subject:  

Attached below is the common package for the Scangear MP v1.50 series and the driver for the MX870.

You need both. However, this series does NOT need the libgimp package. You will find a menu item under Graphic for the ScangearMP scanner program.

@vtpup: Could you test this by first connecting your MX870 directly by USB? Then try by wireless. If you are very lucky, it may detect the wireless scanner!

[Edit] The MX340 driver below also requires the scangearmp_common-1.5.pet.
scangearmp_common-1.50.pet
Description 
pet

 Download 
Filename  scangearmp_common-1.50.pet 
Filesize  241.57 KB 
Downloaded  837 Time(s) 
scangearmp_mx340-1.50.pet
Description 
pet

 Download 
Filename  scangearmp_mx340-1.50.pet 
Filesize  267.69 KB 
Downloaded  554 Time(s) 
scangearmp_mx870-1.50.pet
Description 
pet

 Download 
Filename  scangearmp_mx870-1.50.pet 
Filesize  273.98 KB 
Downloaded  835 Time(s) 

Last edited by rcrsn51 on Fri 17 Aug 2012, 16:14; edited 3 times in total
Back to top
View user's profile Send private message 
nyunda

Joined: 12 Apr 2011
Posts: 5
Location: west java

PostPosted: Tue 12 Apr 2011, 03:04    Post subject: canon mp270 scanner
Subject description: its work
 

i download pixma-backend-qrky-1.0.21.pet posted by rcrsn51, run xsane image scanner in puppy 520, & my scanner is detected, thanks rcrsn51.
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 8563
Location: Stratford, Ontario

PostPosted: Sun 22 May 2011, 15:36    Post subject:  

Here is the scangearmp driver package for the MP495. It also requires the scangearmp_common-1.60.pet from Page 2. However, it does NOT require the Gimp package. When installed, there will be a menu entry for the scangear program under Graphic.

The MG5100 driver attached below also requires the scangearmp_common-1.60.pet from Page 2.
scangearmp_mg5200series-1.60.pet
Description  Requires the scangearmp_common-1.60.pet from Page 2.
pet

 Download 
Filename  scangearmp_mg5200series-1.60.pet 
Filesize  237.97 KB 
Downloaded  532 Time(s) 
scangearmp_mg5100series-1.60.pet
Description 
pet

 Download 
Filename  scangearmp_mg5100series-1.60.pet 
Filesize  237.4 KB 
Downloaded  656 Time(s) 
scangearmp_mp495-1.60.pet
Description 
pet

 Download 
Filename  scangearmp_mp495-1.60.pet 
Filesize  239.1 KB 
Downloaded  763 Time(s) 

Last edited by rcrsn51 on Sat 01 Dec 2012, 20:49; edited 4 times in total
Back to top
View user's profile Send private message 
charlie6

Joined: 30 Jun 2008
Posts: 940
Location: South of Belgium

PostPosted: Sat 01 Oct 2011, 05:13    Post subject: Canon MP160 on Slacko  

Hi rcrsn51,
on Slacko4.99.7
works fine after only installed:
scangearmp-common-1.40.pet
libgimp2.0-2.6.8.pet
scangearmp-mp160-1.00.pet
scangearmp-locale-1.40.pet

Just one slight detail which ennoys me a bit: (on Slacko or on puppy 4.20 as well)

usually, when in a 'save as' dialog box, the path where to save the to-be-saved-file may be selected just:
- browsing across directories by using the mouse cursor and click once on the choosen folders name
- and then entering the file name;

here with scangearmp, one has to double click on each selection instead this in spite of other applications gtkdialog 'save as' boxes are 'single click navigation' settled.

Moreover, I'm using a pen tablet. So I use to position the cursor using the pen and validate the selection by pressing just once whether the 'Enter' or the 'SpaceBar' key with the other hand. This cannot be done with scangearmp.

Is there a way to get the scangearmps dialog box working as the other 'save as' dialog box (as on abiword, or whatever else application)?

Thanks for any advice!
Cheers, Charlie
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 8563
Location: Stratford, Ontario

PostPosted: Sat 01 Oct 2011, 08:19    Post subject: Re: Canon MP160 on Slacko  

charlie6 wrote:
here with scangearmp, one has to double click on each selection instead this in spite of other applications gtkdialog 'save as' boxes are 'single click navigation' settled.

Scangearmp is using the GTK file chooser for its "Save as" which has that annoying double-click function. There is nothing I can do about it.

However, you could just save the file to some place easy, like /root, then copy it to the desired location afterwords.
Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 1223
Location: Queensland Australia ɹǝpu∩uʍop

PostPosted: Thu 08 Dec 2011, 02:37    Post subject:  

rcrsn51 wrote:
Attached below is the common package for the Scangear MP v1.60 series and the driver for the MP280.

You will need both. However, it appears that this series does NOT need the libgimp package.

If you own an MP280 and download these packages, would you please report back with their success or failure.


Thanks, scanner works in racy 5.2.2 and Saluki and also prints with your canon_mp280-3.40.pet

Geoffrey
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 8563
Location: Stratford, Ontario

PostPosted: Sat 17 Mar 2012, 09:34    Post subject:  

Here are the Scangear drivers for the MX410 and MX880. These units are wifi-enabled, so they are capable of network scanning. Depending on your Puppy version, they may be auto-detected by the pixma backend in SANE, so you can use Xsane or Peasyscan without installing these drivers.

If not, download both the common PET and the model-specific PET. Run ScangearMP from the Graphic menu. Perform an Update operation and wait for Scangear to locate your device. Canon detects a networked scanner by its MAC address instead of the usual IP address.
scangearmp_common-1.70.pet
Description 
pet

 Download 
Filename  scangearmp_common-1.70.pet 
Filesize  244.11 KB 
Downloaded  627 Time(s) 
scangearmp_mx410-1.70.pet
Description 
pet

 Download 
Filename  scangearmp_mx410-1.70.pet 
Filesize  250.41 KB 
Downloaded  622 Time(s) 
scangearmp_mx880-1.70.pet
Description 
pet

 Download 
Filename  scangearmp_mx880-1.70.pet 
Filesize  251.72 KB 
Downloaded  596 Time(s) 

Last edited by rcrsn51 on Fri 17 Aug 2012, 16:15; edited 1 time in total
Back to top
View user's profile Send private message 
bones01

Joined: 11 Aug 2008
Posts: 370
Location: Melbourne, Aus

PostPosted: Fri 22 Jun 2012, 00:03    Post subject:
Subject description: Canon MP800
 

Hi RCRN,
My office has a Canon Pixma MP800 and I can't find the specific .pet for that. If you have the time, could you put one together please?

I'm using Lucid 528 mostly, on a frugal install. do you need any other info?

Thanks

Bones

_________________
Dell Latitude D630 running Puppy 5.2.8 frugal, Macpup 525 frugal (if I can get it working again)
Precise Puppy 5.4 live DVD
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 8563
Location: Stratford, Ontario

PostPosted: Fri 22 Jun 2012, 09:57    Post subject:  

Unfortunately, Canon does not make a Linux driver for the MP800. But the newest version of Gutenprint does!

I have posted it here. This driver has not had much testing, so please report back.

Oops! Are you looking for a printer driver or a scanner driver? If you need a scanner driver, did you try the pixma-backend-qrky-1.0.21 from the first post?

If it doesn't detect your scanner, try the updated version attached below.

[Edit] No feedback provided. Attachment deleted.

Last edited by rcrsn51 on Fri 29 Jun 2012, 23:40; edited 1 time in total
Back to top
View user's profile Send private message 
bones01

Joined: 11 Aug 2008
Posts: 370
Location: Melbourne, Aus

PostPosted: Sat 23 Jun 2012, 00:28    Post subject:  

Thanks for that. I'll give it a crack on Monday and let you know how it goes.
I am having some truoble with the laptop separate to this, so it may take a while to get it back.

Bones

_________________
Dell Latitude D630 running Puppy 5.2.8 frugal, Macpup 525 frugal (if I can get it working again)
Precise Puppy 5.4 live DVD
Back to top
View user's profile Send private message 
KJ

Joined: 20 Jul 2006
Posts: 176
Location: Above sea level .. about 320m

PostPosted: Tue 26 Jun 2012, 14:07    Post subject: Canon MX-340  

I have a Canon Pixma MX340 and now need to use the scanner .. your printer .pet works great. If you have the time, could you put a .pet together please? Thanks ... KJ
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 8563
Location: Stratford, Ontario

PostPosted: Tue 26 Jun 2012, 14:54    Post subject:  

What Puppy version are you running?

According to SANE, your MX340 should be auto-detected. So it should work OOTB in the Xsane scanner program.

If not, try the pixma_backend_lupu-1.0.22.pet I have posted just above.
Back to top
View user's profile Send private message 
KJ

Joined: 20 Jul 2006
Posts: 176
Location: Above sea level .. about 320m

PostPosted: Wed 27 Jun 2012, 09:39    Post subject: MX340 scanner  

Thanks for your quick response. Sorry .... I should have given more background. I'm running Fluppy 12 as my main OS ... so I loaded the pixma-backend-431-1.0.21.pet for Puppy 4.3.1 and then tried xsane .... no joy ... 'scanner no detected'. Tried the 'sane-find-scanner and 'scanimage -L ' CLI commands 'scanner not detected'.

Your MX-340 printer .pet works on this OS but I found that manually copying the driver over when installing the printer in CUPS works best.

I have Saluki 22 and a couple other newer 5xx pups on a 'testing' USB flashdrive ... I will check them out later as we have relatives staying with us few days. Thanks for your help .... KJ
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 3 of 7 [103 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0795s ][ Queries: 13 (0.0057s) ][ GZIP on ]