Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 31 Oct 2014, 22:04
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Puppy 5.3.3 and Puppy School for Beginners
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 4 of 7 [93 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7 Next
Author Message
bpopilek

Joined: 21 Sep 2010
Posts: 2

PostPosted: Tue 21 Sep 2010, 23:52    Post subject:  xwin video drivers  

I am hoping someone can point me in the right direction. Here is my situation. I have 2 older Gateway Solo 1150 laptops that I decided to try and get a little more life out of. They are mere Celeron 700mhz, 192mb Ram, CD-Rom, 20gb HDD, & USB WiFi adapters. These things are primarily used for web browsing and maybe writing a school paper occasionally. After trying many versions of Linux on them, Puppy Linux is the only one I can get to install. And it works quite well!

My problem is this. I am running v4.3.1 right now, installed to the hard drive. I would however prefer to use the newer v5.1.1 that I downloaded. Unfortunately, I cannot get v5 to boot into the GUI on these laptops. They have the following:

800x600x16 LCD Laptop Display
SMI Lynx 3DM Video Chip w/4megs video ram

Under Puppy v4, I seem to be able to use either the xorg or vesa drivers. However, on v5, I cannot get any graphics to appear. I have tried booting with the "puppy pfix=nox" command in order to stop short of booting right into xwindows. From the command prompt I then run "xorg-setup" and then setup my video settings the same as I have them in v4.3.1. After it completes, it dumps me back to a command prompt where I type in xwin. Now I get a couple of screen flickers and lines across the display as xwindows starts, but that is it and the screen stays black and I am forced to shut the laptop off since it will no longer respond to any input.

Was there a video driver change between v4.3.1 & v5.1.1 that would cause this behavior? Is there a way to copy the video driver from the v4.3.1 CD into the v5.1.1 install CD? Can I just upgrade my hard drive install to v5 without having to boot from the v5 CD?

While I have 15+ years of experience with Windows, I am a very limited beginner with Linux. Does anyone know what I could be doing wrong, or point me to where I can find the info I need. I have tried searching for 2 days, but am lost. I am either looking in the wrong place or with the wrong key words, or I am just blind! Any help would be greatly appreciated! Thanks for reading!
Back to top
View user's profile Send private message 
canbyte


Joined: 10 Jan 2009
Posts: 266
Location: Hamilton, Canada

PostPosted: Fri 24 Sep 2010, 23:48    Post subject:  

Hi. Can the new 5.1 be installed on top of my 4.2.1 ie using the same pup_save file in order to keep the settings? Getting my OKI printer to run was very difficult so if there's no carryover, I probably should just stick to the older version.
Thanks

_________________
1. Dell Dimension E521, AMD Athln 64, 2 GHz 1.93GB ram,
Puppy 533 on CD, accesses flash drive only,
FFox Nightly12.0
2. Compaq P3 733Hz 375RAM
Printer: Oki C3400 > LAN

Back to top
View user's profile Send private message 
Barko

Joined: 22 Jul 2008
Posts: 11

PostPosted: Wed 03 Nov 2010, 13:24    Post subject: Easily Recover after a Crash?  

Lucid Puppy works much better on my old Toshiba Satellite 2590CDT (PII 400, 192MB RAM) than previous versions of Puppy. I have done a full install to the HD. I have no issues with normal operation.

However Lucid Pup does not recover well after an abnormal shutdown or crash (I tested to see what does happen if I suddenly yank the battery).

I know how to fix things up, (boot pfix=ram on CD, copy backup of PuppyPin and use f2sck to repair "missing inodes" etc etc), till everything is all well and good.

But does it need to be that hard, to get things back to normal after a crash?
Thanks.
Back to top
View user's profile Send private message 
Duskao

Joined: 12 Dec 2010
Posts: 13

PostPosted: Wed 15 Dec 2010, 17:46    Post subject: 5.2 phenomenal
Subject description: beta
 

So I have been trying out the 5.2 beta, and so far I have found it to be phenomenal! It looks and feels great. Also lots of the packages and sfs I have been trying have been working great. Very easy through quickpet. At this point I am already going to switch to it. Hope there will be a way to easily upgrade puppy from version to version soon. Great work guys.
Back to top
View user's profile Send private message 
canbyte


Joined: 10 Jan 2009
Posts: 266
Location: Hamilton, Canada

PostPosted: Fri 31 Dec 2010, 16:41    Post subject:  

I tried 511 in a brand spanking new laptop. Since john made this thread a sticky (prematurely imo because 511 is the official latest puppy not 5.2), i'll stick my prelim findings here fyi if interested. It took some doing but finally worked minus my infamous oki printer problem. But since i'm such a nooby nerd, i found a bug..

Me, noob, found a bug. You see I use a Dvorak keyboard and in trying to set that up, found 511 is very difficult compared to 421, which asks right away about keyboard on first bootup. In 511 you have several routes but end up in a non-escapable sequence that wants to set up keyboard and monitor TOGETHER. Mistake, imo. Finding an ok screen setting (i think slightly different/ worse) than puppy default) by trial and error took some doing. There is no reason for lumping keyboard and monitor together - but I can understand i'm probably one of very few that wants to mess with strange keyboards.

The other thing that came out of this was that on exiting from that first bootup a bug appeared in that the key definitions were neither standard qwerty nor dvorak! They seemed quite random/ hard to make a sensible _save file name! No big deal but a bug nonetheless, but not something i need to spend any time fixing. So this is just for puppy developers to consider at some point.

I'm not too sure what I'll do with Puppy in a Win7 machine that has every bell and whistle one could dream of -- with the typical Bill Gates style exception that Win 7 will only network with other Win7 machines - not with any older versions! Go figure, but again, with the ease of exchanging files on usb sticks, this is something i don't need to spend time on.

Puppy 421 has been my mainstay for a year now on my older machines. Will the new laptop displace all this? Dunno but it would help if my 421 were a bit more stable (contamination issue) and/or i could get 511 working with devx & oki printer.

Hope everyone is enjoying the holidays.

_________________
1. Dell Dimension E521, AMD Athln 64, 2 GHz 1.93GB ram,
Puppy 533 on CD, accesses flash drive only,
FFox Nightly12.0
2. Compaq P3 733Hz 375RAM
Printer: Oki C3400 > LAN

Back to top
View user's profile Send private message 
don570


Joined: 10 Mar 2010
Posts: 3359
Location: Ontario

PostPosted: Thu 06 Jan 2011, 16:46    Post subject: right click package available  

I been working hard to get a right click package
ready for Lucid Puppy 5.2.

This makes using the computer a lot more enjoyable.
Try it and see for yourself.

Here it is... Lupu-Right-click-4.1.pet

I corrected a couple of minor bugs and added two new features.

1) Archive a folder with a right click .
It uses pupzip which is clumsy but it works!

2) A pmusic playlist (.m3u) can be added to pmusic playlist
with a right click

Available
http://www.datafilehost.com/download-511ef5d4.html

________________________________________________
Back to top
View user's profile Send private message 
ednanda

Joined: 28 Jan 2011
Posts: 1

PostPosted: Fri 28 Jan 2011, 02:56    Post subject: install pup files in puppy linux 5.2  

hi all, im indonesian. i try to find my problem in indonesian website, but sadly i did'nt find! i just wanna to learning linux rather than using an illegal operating system such as Win***s. so please anybody answear my question. (am my english grammar ok? Very Happy)
i can't install .pup file on puppy linux 5.2
there is a pop up message that inform me to install dotpuphandler.pet and basicpuppy.pet, where should i download these files?

thanks before,
Back to top
View user's profile Send private message 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Fri 28 Jan 2011, 07:03    Post subject:  

Thanks Sylvander!

Edit only read my text if you fail to do what Sylwander below me suggests. His way is the correct way to do it Smile

Warning the following text is long way around that teach you to do search.

I've never heard of it before but found it this way.

Put dotpuphandler.pet in the following search engine.

http://www.wellminded.com/puppy/pupsearch.html

Then it says these things

How to install .pup files?

http://www.murga-linux.com/puppy/viewtopic.php?t=44809

and maybe use this site?


http://dotpups.de/

I've never done it but you maybe use a special puppy that needs such?

Hope somebody knowing more than me can explain when does one need such seldom spoken of things?

_________________
I use Google Search on Puppy Forum
not an ideal solution though

Last edited by nooby on Fri 28 Jan 2011, 08:39; edited 2 times in total
Back to top
View user's profile Send private message 
Sylvander

Joined: 15 Dec 2008
Posts: 3478
Location: West Lothian, Scotland, UK

PostPosted: Fri 28 Jan 2011, 08:26    Post subject: Re: install pup files in puppy linux 5.2  

ednanda wrote:
to install dotpuphandler.pet and basicpuppy.pet, where should i download these files?

1. I always use the "Puppy Package Manager" [PPM] to download and install these.
For example:
1. Here in BoxPup-431...
In PPM...
Repo: Puppy-4...

(a) I search for:
puppybasic
And the "Package" = "puppybasic-2.5b" is displayed.
I click on that, and it installs.
You will need to choose [when offered the list] a repository [any one will do] from which to download.

Then...
(b) I search for:
dotpuphandler
And the "Package" = "dotpuphandler-0.0.4-2" is displayed.
I click on that, and it installs.
You will need to choose [when offered the list] a repository [any one will do] from which to download.

Job done. Very Happy
Back to top
View user's profile Send private message 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Sat 29 Jan 2011, 09:40    Post subject:  

My incredibly naive question, don't get angry at me.

Lupu 510 and 511 both boot. Lupq 511 none of Lupu 520 do boot.

What can I make use of from Lupu 520 on 510 or 511

I use IceWM on both of these if that is important.

My Computer is in my sgn. Acer D250 Netbook 10" screen and scsi HDD.

When 520 fails the debug message is not warning or anything it just stop at displaying where it was when stopping.

b43-pci-bridge and IRQ 16


My extreme wild guess is that something goes wrong either to activate the pci bridge or that IRQ 16 is polled??? by two processes and lock because if one don't give up but boot say ten times then the 10th time it sometimes boot. So something is timed so it fail to wait for the IRQ or something to settle?

What can I add to the kernel line for this to work around.

What programs that work for lupu 520 can also be used on 510 and 511?

_________________
I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send private message 
trio


Joined: 21 Dec 2008
Posts: 1818
Location: अनुमोदना

PostPosted: Fri 18 Feb 2011, 12:45    Post subject: Re: install pup files in puppy linux 5.2  

ednanda wrote:
hi all, im indonesian. i try to find my problem in indonesian website, but sadly i did'nt find! i just wanna to learning linux rather than using an illegal operating system such as Win***s. so please anybody answear my question. (am my english grammar ok? Very Happy)
i can't install .pup file on puppy linux 5.2
there is a pop up message that inform me to install dotpuphandler.pet and basicpuppy.pet, where should i download these files?

thanks before,


saran saya, jangan install paket dgn extensi .pup krn sdh terlalu lama.. paket yg lebih baru adalah dgn extensi .pet ... itu pun tidak semua aplikasi compatible dgn semakin barunya release puppy. Boleh tahu apa yg anda mau install dgn .pup? atau cari (baca: search) forum untuk aplikasi yg sama namun dgn extensi .pet 9masih mungkin compatible dgn LUPU)

salam

_________________
PET Maker|EasyLauncher
Back to top
View user's profile Send private message 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Sun 06 Mar 2011, 20:45    Post subject:  

nooby wrote:
My incredibly naive question, ...
Lupu 510 and 511 both boot. Lupq 511 none of Lupu 520 do boot.


Since then I have realized that Lupu needed nosmp on the kernel line.

Maybe could help others if it fail to boot on your Atom computer like the small Netbooks.

_________________
I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 5255
Location: Charleston S.C. USA

PostPosted: Tue 05 Apr 2011, 20:01    Post subject:  

canbyte wrote:
Hi. Can the new 5.1 be installed on top of my 4.2.1 ie using the same pup_save file in order to keep the settings? Getting my OKI printer to run was very difficult so if there's no carryover, I probably should just stick to the older version.
Thanks

No, too much different between version 4 series and version 5 series.
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 5255
Location: Charleston S.C. USA

PostPosted: Tue 05 Apr 2011, 20:11    Post subject: Re: xwin video drivers  

bpopilek wrote:
I am hoping someone can point me in the right direction. Here is my situation. I have 2 older Gateway Solo 1150 laptops that I decided to try and get a little more life out of. They are mere Celeron 700mhz, 192mb Ram, CD-Rom, 20gb HDD, & USB WiFi adapters. These things are primarily used for web browsing and maybe writing a school paper occasionally. After trying many versions of Linux on them, Puppy Linux is the only one I can get to install. And it works quite well!

My problem is this. I am running v4.3.1 right now, installed to the hard drive. I would however prefer to use the newer v5.1.1 that I downloaded. Unfortunately, I cannot get v5 to boot into the GUI on these laptops. They have the following:

800x600x16 LCD Laptop Display
SMI Lynx 3DM Video Chip w/4megs video ram

Under Puppy v4, I seem to be able to use either the xorg or vesa drivers. However, on v5, I cannot get any graphics to appear. I have tried booting with the "puppy pfix=nox" command in order to stop short of booting right into xwindows. From the command prompt I then run "xorg-setup" and then setup my video settings the same as I have them in v4.3.1. After it completes, it dumps me back to a command prompt where I type in xwin. Now I get a couple of screen flickers and lines across the display as xwindows starts, but that is it and the screen stays black and I am forced to shut the laptop off since it will no longer respond to any input.

Was there a video driver change between v4.3.1 & v5.1.1 that would cause this behavior? Is there a way to copy the video driver from the v4.3.1 CD into the v5.1.1 install CD? Can I just upgrade my hard drive install to v5 without having to boot from the v5 CD?

While I have 15+ years of experience with Windows, I am a very limited beginner with Linux. Does anyone know what I could be doing wrong, or point me to where I can find the info I need. I have tried searching for 2 days, but am lost. I am either looking in the wrong place or with the wrong key words, or I am just blind! Any help would be greatly appreciated! Thanks for reading!

Puppy 4.3.1 is the last Puppy that has a good chance of supporting old hardware. The newer versions may or may not depends on hardware.
Many reasons for this. Newer Linux kernels have dropped support for older hardware to make room for the new stuff.
When you start Puppy 5.1.1 with puppy pfix=nox
Type Xorgwizard.
Choose the vesa driver
set resolution.
Test.
If tests OK.
Xwin at prompt.
May work for you.
Back to top
View user's profile Send private message 
Al13n

Joined: 07 Apr 2011
Posts: 4

PostPosted: Thu 07 Apr 2011, 18:08    Post subject: Puppy 5.2.5
Subject description: Some help
 

Hey guys, i tried puppy 5.2.5 and it is super fast, however i am having a few troubles. The volume seems to be very low, it doesn't detect my graphics card, its very hard to find things you need, i downloaded compiz and i can't find it anywhere after i install it. I wanted to run xpgnome on it and it won't.

my stats are

nvidia geforce GT 430
motherboard gigabyte g31m-es2l
pentium dual core CPU e5200 2.50ghz
realtek HD audio sound
I have 2 gig RAM and 320GB HD
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 4 of 7 [93 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1131s ][ Queries: 13 (0.0058s) ][ GZIP on ]