Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 29 Aug 2014, 22:49
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
miss my puppybrowser
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [11 Posts]  
Author Message
fenex2004


Joined: 12 Jun 2010
Posts: 34

PostPosted: Sat 19 Feb 2011, 01:52    Post subject:  miss my puppybrowser  

I like dillo ok, but have gotten used to the puppybrowser. In the 5.2 release, I tried to d/l it (pb-0.5.1.1-pup4) and i all went well until the libgee.so.0 and libgtkembededmoz.so came up missing. it won't even run after installing Sad so, any ideas where i can find thee libraries or is there gong to be a 'fix' for it (maybe including the lib files in the d/l?)? Also, the PB-lucid-1.1, although it exists on a few of the listed repositories, does't meet the file size it's supposed to - can't even d/l it. arg Rolling Eyes Crying or Very sad

Anywho, I miss my old puppybrowser! I can use Dillo, but things just don't look the same in it.
Back to top
View user's profile Send private message 
GustavoYz


Joined: 07 Jul 2010
Posts: 896
Location: .ar

PostPosted: Sun 20 Feb 2011, 01:41    Post subject:  

Hi fenex...
You mean the pBrowser on previous Lucid versions -like 501-?
The default one?
If you still have the Live-CD (or the ISO), i think that you could just try to copy the libgee files from it... Mount the main sfs file and check on /usr/lib (the missing file could be a symlink, just a thought).

I was playing with the SeaMonkey source code and libgtmembedmoz.so its there so get the tarball.

Hope it helps.
Libggtkembedmoz.tar.gz
Description 
gz

 Download 
Filename  Libggtkembedmoz.tar.gz 
Filesize  33.49 KB 
Downloaded  289 Time(s) 

_________________

Back to top
View user's profile Send private message 
fenex2004


Joined: 12 Jun 2010
Posts: 34

PostPosted: Tue 22 Feb 2011, 17:50    Post subject:  

Thanks, GustavoYz!

I didn't think about that. I'll have to try it. Thanks for the t-ball. It helped me get another one running as well. Reaally appreciate your input! That's an "ATTA_BOY" for you ! Very Happy

.
Back to top
View user's profile Send private message 
GustavoYz


Joined: 07 Jul 2010
Posts: 896
Location: .ar

PostPosted: Wed 23 Feb 2011, 01:13    Post subject:  

Glad to hear that.
Sometimes I miss the 'old' Pbrowser too...
Dillo? Oh... no-no, thanks. Very Happy
Regards.

_________________

Back to top
View user's profile Send private message 
DM was on fire!


Joined: 12 Sep 2009
Posts: 156
Location: N.E. Georgia Mountains, USA

PostPosted: Wed 23 Feb 2011, 03:06    Post subject:  

Midori I think was the best choice for the default browser. It had the best of Firefox, Opera and SeaMonkey, and truth be told I'm not entirely sure why the switch?
Back to top
View user's profile Send private message MSN Messenger 
majorfoo

Joined: 07 Mar 2011
Posts: 445
Location: Wish I knew

PostPosted: Fri 11 Mar 2011, 00:07    Post subject: Re: miss my puppybrowser  

fenex2004 wrote:
I like dillo ok, but have gotten used to the puppybrowser. In the 5.2 release, I tried to d/l it (pb-0.5.1.1-pup4) and i all went well until the libgee.so.0 and libgtkembededmoz.so came up missing. it won't even run after installing Sad so, any ideas where i can find thee libraries or is there gong to be a 'fix' for it (maybe including the lib files in the d/l?)? Also, the PB-lucid-1.1, although it exists on a few of the listed repositories, does't meet the file size it's supposed to - can't even d/l it. arg Rolling Eyes Crying or Very sad

Anywho, I miss my old puppybrowser! I can use Dillo, but things just don't look the same in it.


I also like puppybrowser - at one time there was a link to puppybrowser_lucid-1.1.pet, however, i cannot locate it
if you can find this version it requires libgee-20081125-i486.pet

I have used this successfully in luci series, lucid-5.20, spup-056 and snowpuppy-014

may playdayz can provide location since this was lucid pet. you might try pm to see if he still has this version
Back to top
View user's profile Send private message 
amigo

Joined: 02 Apr 2007
Posts: 2236

PostPosted: Fri 11 Mar 2011, 05:24    Post subject:  

So what was the puppybrowser anyway -can't you find the sources for it and rebuild to match your running libs?
Back to top
View user's profile Send private message 
Dougal


Joined: 19 Oct 2005
Posts: 2505
Location: Hell more grotesque than any medieval woodcut

PostPosted: Fri 11 Mar 2011, 16:38    Post subject:  

amigo wrote:
So what was the puppybrowser anyway -can't you find the sources for it and rebuild to match your running libs?

It was something MU put together around gtkmozembed.
The sources are inside /usr/local/PuppyBrowser... but gtkmozembed doesn't exist anymore in newer Mozilla products.

_________________
What's the ugliest part of your body?
Some say your nose
Some say your toes
But I think it's your mind
Back to top
View user's profile Send private message 
playdayz


Joined: 25 Apr 2008
Posts: 3788

PostPosted: Fri 11 Mar 2011, 19:10    Post subject:  

PuppyBrowser in Lucid 5.00 was based on Seamonkey 1.1.18, using the gtkmoz interface to the seamonkey gecko. It could be packaged to work, but it would not be any smaller than most other browsers, and it would be only as advfanced as seamonkey 1.1.18.

Someone could use xulrunner to make a PuppyBrowser out of new Firefox, and it could also be done with latest webkit.
Back to top
View user's profile Send private message 
majorfoo

Joined: 07 Mar 2011
Posts: 445
Location: Wish I knew

PostPosted: Fri 18 Mar 2011, 14:24    Post subject: Re: miss my puppybrowser  

fenex2004 wrote:
I like dillo ok, but have gotten used to the puppybrowser. In the 5.2 release, I tried to d/l it (pb-0.5.1.1-pup4) and i all went well until the libgee.so.0 and libgtkembededmoz.so came up missing. it won't even run after installing Sad so, any ideas where i can find thee libraries or is there gong to be a 'fix' for it (maybe including the lib files in the d/l?)? Also, the PB-lucid-1.1, although it exists on a few of the listed repositories, does't meet the file size it's supposed to - can't even d/l it. arg Rolling Eyes Crying or Very sad

Anywho, I miss my old puppybrowser! I can use Dillo, but things just don't look the same in it.


playdayz has posted puppybrowser at

http://www.murga-linux.com/puppy/viewtopic.php?t=65136&start=645

check it out - works great in my full install of luci-255
Back to top
View user's profile Send private message 
fenex2004


Joined: 12 Jun 2010
Posts: 34

PostPosted: Sat 19 Mar 2011, 01:05    Post subject:  

Very Happy W0oho0 Exclamation Exclamation Thanks for letting me know majorfoo AND

Thank you Playdayz Exclamation Very Happy
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [11 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0650s ][ Queries: 13 (0.0045s) ][ GZIP on ]