Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 20 Sep 2014, 10:24
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Drivers
hpliplite: dynamic packages
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 5 [73 Posts]   Goto page: 1, 2, 3, 4, 5 Next
Author Message
lluamco

Joined: 16 Mar 2007
Posts: 207
Location: Banyoles, Spain

PostPosted: Wed 04 Aug 2010, 17:34    Post subject:  hpliplite: dynamic packages
Subject description: HP PSC (Printer Scanner Copier) all-in-one software package
 

hpliplite packages are "lite" versions of the Hewlett-Packard's Linux Imaging and Printing software HPLIP.
They allow Printing and also Scanning (for HP PSC models, for instance).

Dynamic ppd versions are much lighter than previous static ones, since do not contain static ppds.
Instead, ppds are generated dynamically for capable versions of cups, such as 1.3.11 in Quirky or 1.4.x in lupu.
The dynamical packages have been compiled and tested in Wary and should also be suited for Quirky, Precise and, hopefully, lupu and slacko.
Please note that they are NOT functional for standard puppy's, up to and including 4.3.1.
Those versions REQUIRE STATIC hpliplite packages, obtainable from http://murga-linux.com/puppy/viewtopic.php?p=184635&search_id=133786018#184635

Please check whether your printer is supported by hplip and that it DOES NOT require additional plugins, at
http://hplipopensource.com/hplip-web/supported_devices/combined.html.
Devices requiring additional plugins for printing/scanning/faxing are not (fully) supported by hpliplite packages.

To install the latest hpliplite, dynamic version, please proceed as follows:

1. Install libnetsnmp-15.pet
2. Install hpliplite-3.14.3.pet from http://goo.gl/cFE1Ol

NOTE for lucid and slacko puppy users: The latest hpliplite-3.14.3 and also hpliplite-3.12.11 pets require executing
Code:
ln -s /usr/lib/libcrypto.so.0.9.8 /usr/lib/libcrypto.so.1.0.0
in order to work. This is not necessary for the previous hpliplite-3.11.10.pet
End of NOTE for lucid and slacko puppy users


Note added on may 18th, 2012
Slacko-5.3.3 users can choose to install full hplip.
For more information, see http://www.murga-linux.com/puppy/viewtopic.php?p=628193&search_id=1165431670#628193
hpliplite-3.12.11.pet
Description 
pet

 Download 
Filename  hpliplite-3.12.11.pet 
Filesize  569.55 KB 
Downloaded  1745 Time(s) 
hpliplite-3.11.10.pet
Description 
pet

 Download 
Filename  hpliplite-3.11.10.pet 
Filesize  548.22 KB 
Downloaded  1737 Time(s) 
libnetsnmp-15.pet
Description  library needed by hpliplite
pet

 Download 
Filename  libnetsnmp-15.pet 
Filesize  222.52 KB 
Downloaded  4030 Time(s) 

Last edited by lluamco on Fri 09 May 2014, 04:56; edited 37 times in total
Back to top
View user's profile Send private message 
lluamco

Joined: 16 Mar 2007
Posts: 207
Location: Banyoles, Spain

PostPosted: Wed 06 Oct 2010, 04:13    Post subject: hpliplite updated to version 3.10.9  

hpliplite updated to version 3.10.9
See first post.
Back to top
View user's profile Send private message 
lluamco

Joined: 16 Mar 2007
Posts: 207
Location: Banyoles, Spain

PostPosted: Mon 24 Jan 2011, 07:28    Post subject:  

hpliplite updated to version 3.11.1
See first post.
Back to top
View user's profile Send private message 
reckrhodes

Joined: 30 May 2007
Posts: 116

PostPosted: Sat 12 Feb 2011, 22:34    Post subject:  

Is HP Deskjet 3740 can be installed using this pet? Because our school has it only being installed on the Windows OS and I wanted to have my Puppy Linux Lucid 5.2 on usb flash drive to use it.
Back to top
View user's profile Send private message 
disciple

Joined: 20 May 2006
Posts: 6435
Location: Auckland, New Zealand

PostPosted: Sat 12 Feb 2011, 23:05    Post subject:  

See http://www.openprinting.org/printer/HP/HP-DeskJet_3740
Apparently you don't even need HPLIP, just HPIJS or even Gutenprint.

_________________
DEATH TO SPREADSHEETS
- - -
Classic Puppy quotes
- - -
Beware the demented serfers!
Back to top
View user's profile Send private message 
cfischer69

Joined: 12 Mar 2011
Posts: 7

PostPosted: Tue 15 Mar 2011, 13:50    Post subject:    

Awesomely simple!! Worked flawlessly for my 6 mo old HP Office AIO printer.

Thanks!!
Back to top
View user's profile Send private message 
lluamco

Joined: 16 Mar 2007
Posts: 207
Location: Banyoles, Spain

PostPosted: Fri 18 Mar 2011, 06:17    Post subject:  

@cfischer69 Thanks for your feedback! Glad to help.
Back to top
View user's profile Send private message 
lluamco

Joined: 16 Mar 2007
Posts: 207
Location: Banyoles, Spain

PostPosted: Fri 18 Mar 2011, 06:18    Post subject:
Subject description: hpliplite updated to version 3.11.3
 

hpliplite updated to version 3.11.3
See first post.
Back to top
View user's profile Send private message 
lluamco

Joined: 16 Mar 2007
Posts: 207
Location: Banyoles, Spain

PostPosted: Fri 13 May 2011, 05:29    Post subject: hpliplite updated to version 3.11.5  

hpliplite updated to version 3.11.5
See first post.
Back to top
View user's profile Send private message 
shenen

Joined: 03 Dec 2006
Posts: 39

PostPosted: Mon 30 May 2011, 20:52    Post subject:  

Hi,
I am wondering if someone can make a pet package for latest version of hplip, not just lite.

The reason being the other epson printer I have, Epson made their own linux version called iscan, that one enables me to use the scan button on the printer so I can scan a large volume of pages in very short time(I have kids), just press the scan button, it will save to a file with a sequence number.

My HP F4480 also have a scan button, but it doesn't work in hpliplite, I am thinking maybe the full package of hplip the scan button will work.

If there is a way to make the scan button work, please also advise.

Thank you.
Back to top
View user's profile Send private message 
lluamco

Joined: 16 Mar 2007
Posts: 207
Location: Banyoles, Spain

PostPosted: Fri 03 Jun 2011, 06:01    Post subject:  

Hi shenen,
my understanding is that hplip currently does not support scanning using the scan button. Pity...
Back to top
View user's profile Send private message 
lluamco

Joined: 16 Mar 2007
Posts: 207
Location: Banyoles, Spain

PostPosted: Mon 15 Aug 2011, 11:46    Post subject: Plugin install for some HP printers  

Some models of HP printers require plugins. This is not automatically handled by hpliplite. I have packed a package trying to fill this gap. The package's name is hp_plugin_install.pet
and is included in the first message of this thread. The package has been tested in Wary for a HP LaserJet Professional P 1102w
printer by forum member autogestion. Many thanks to autogestion for his patience and assistance!
Back to top
View user's profile Send private message 
Bruce_n_Duane

Joined: 01 Nov 2005
Posts: 68
Location: Washington State

PostPosted: Fri 09 Sep 2011, 20:12    Post subject: Lucid 525 & 528 Success for CUPS and Xsane on HP Printer  

I installed three of the pet from page one of this post.
hp-plugin-install.pet
hpliplite-3.11.7.pet
libnetsnmp-15.pet

This got my HP PhotoSmart C5280 All-in-one Printer/scanner working
in both Lucid Puppy 5.25 and Lucid Puppy 5.28 for printing by CUPS
and scanning by Xsane.

Thank you for posting this fix.
-Bruce.
Back to top
View user's profile Send private message 
lluamco

Joined: 16 Mar 2007
Posts: 207
Location: Banyoles, Spain

PostPosted: Mon 12 Sep 2011, 03:31    Post subject: Re: Lucid 525 & 528 Success for CUPS and Xsane on HP Printer  

Bruce_n_Duane wrote:
I installed three of the pet from page one of this post.
hp-plugin-install.pet
hpliplite-3.11.7.pet
libnetsnmp-15.pet

This got my HP PhotoSmart C5280 All-in-one Printer/scanner working
in both Lucid Puppy 5.25 and Lucid Puppy 5.28 for printing by CUPS
and scanning by Xsane.

Thank you for posting this fix.
-Bruce.

Thanks for your feedback. Please note that your printer does not require plugin, so there was no need to use hp-plugin-install.pet
Back to top
View user's profile Send private message 
Bruce_n_Duane

Joined: 01 Nov 2005
Posts: 68
Location: Washington State

PostPosted: Mon 12 Sep 2011, 04:56    Post subject: Lucid 525 & 528 Success for CUPS and Xsane on HP Printer  

lluamco,

I installed the pets in the reverse (bottom-up) order listed. Xsane did not recognize the scanner until I installed hp-plugin-install.pet. It actually did not download anything off the internet as I was not connected. It did run the install script from the pet and that seemed to fix it so my printer/scanner was recognized by Xsane.

I do not know how to look inside a pet to see what the scripts do. I may have created a missing simlink or an empty file.

-Bruce.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 5 [73 Posts]   Goto page: 1, 2, 3, 4, 5 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Drivers
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0852s ][ Queries: 13 (0.0165s) ][ GZIP on ]