Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 24 Apr 2014, 23:14
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Security/Privacy
Cryptsetup 1.0.5
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [8 Posts]  
Author Message
Wolf Pup

Joined: 27 Apr 2006
Posts: 637

PostPosted: Tue 05 Aug 2008, 21:25    Post subject:  Cryptsetup 1.0.5
Subject description: Hard Drive Encryption
 

Note: Needs device_mapper to work.

device_mapper-1.02.27.pet
md5sum

md5sum:
Code:
d95f35cb76d8f4574b6e59fe90057130  cryptsetup-1.0.5.pet
cryptsetup-1.0.5.pet
Description  Hard Drive Encryption
pet

 Download 
Filename  cryptsetup-1.0.5.pet 
Filesize  35.14 KB 
Downloaded  617 Time(s) 

_________________

Visit The Repository - Helpful and hard-to-find treats for Puppy 3.
Click Here for Puppy Support Chat, + Helpful Links.

Last edited by Wolf Pup on Tue 03 Feb 2009, 21:59; edited 2 times in total
Back to top
View user's profile Send private message 
gollath

Joined: 05 Aug 2008
Posts: 5

PostPosted: Tue 19 Aug 2008, 11:37    Post subject: Additional Libraries  

Hi,

thanks for that, but it complained about missing libraries.
One of it is libgcrypt, which doesn't come in your packages. Maybe you can help?

Occurs on latest Puppy 4.

Regards
Back to top
View user's profile Send private message 
Wolf Pup

Joined: 27 Apr 2006
Posts: 637

PostPosted: Tue 19 Aug 2008, 15:15    Post subject:  

Have a look Here.
_________________

Visit The Repository - Helpful and hard-to-find treats for Puppy 3.
Click Here for Puppy Support Chat, + Helpful Links.
Back to top
View user's profile Send private message 
NoNameAmI


Joined: 31 Aug 2008
Posts: 77

PostPosted: Wed 01 Jul 2009, 19:12    Post subject: Re: Cryptsetup 1.0.5
Subject description: Hard Drive Encryption
 

EDIT: Problem solved
_________________
Pup2p - Puppy Linux aimed for use with the anonymous network I2P.
Released! http://www.puppylinux.org/downloads/puplets/pup2p
Back to top
View user's profile Send private message Visit poster's website 
Luluc


Joined: 16 Mar 2011
Posts: 200

PostPosted: Thu 17 Mar 2011, 06:21    Post subject:  

I can't get device mapper or libcrypt, the two links have expired. Can someone please rescue me?
Back to top
View user's profile Send private message 
Luluc


Joined: 16 Mar 2011
Posts: 200

PostPosted: Thu 17 Mar 2011, 06:39    Post subject:  

OK, I sent the hounds on the scent and they found what I asked them, I have cryptsetup installed to some extent. But it doesn't work!
Quote:

puppypc[332-251]#/lib> cryptsetup luksOpen /dev/sda10 crypthome
Enter LUKS passphrase:
Failed to setup dm-crypt key mapping.
Check kernel for support for the aes-cbc-essiv:sha256 cipher spec and verify that /dev/sda10 contains at least 258 sectors.
Failed to read from key storage
Command failed: No key available with this passphrase.

This sucks! This absolutely sucks. Puppy is useless to me without cryptsetup. I don't understand why it is not built-in anyway. Crying or Very sad Crying or Very sad Crying or Very sad
Back to top
View user's profile Send private message 
Graf_Koks

Joined: 21 Jan 2014
Posts: 16

PostPosted: Tue 21 Jan 2014, 15:48    Post subject:  

Hello,

is there a solution to this problem? Since three years later, it is still not working:

Quote:

# sudo cryptsetup luksOpen /dev/sdb2 crypthome
Enter passphrase for /dev/sdb2:
device-mapper: reload ioctl failed: No such file or directory
Failed to setup dm-crypt key mapping for device /dev/sdb2.
Check that kernel supports aes-xts-plain64 cipher (check syslog for more info).
Failed to read from key storage.


How to solve this issue? The encrypted partition was created using Ubuntu.

I am using precise puppy 5.7.1 and it seems that xts support is not set in the kernel:

Quote:

zcat /proc/config.gz | grep CRYPTO
CONFIG_BLK_DEV_CRYPTOLOOP=m
CONFIG_RT2X00_LIB_CRYPTO=y
CONFIG_RTLLIB_CRYPTO_CCMP=m
CONFIG_RTLLIB_CRYPTO_TKIP=m
CONFIG_RTLLIB_CRYPTO_WEP=m
CONFIG_CRYPTO=y
CONFIG_CRYPTO_ALGAPI=y
CONFIG_CRYPTO_ALGAPI2=y
CONFIG_CRYPTO_AEAD=m
CONFIG_CRYPTO_AEAD2=y
CONFIG_CRYPTO_BLKCIPHER=m
CONFIG_CRYPTO_BLKCIPHER2=y
CONFIG_CRYPTO_HASH=y
CONFIG_CRYPTO_HASH2=y
CONFIG_CRYPTO_RNG=m
CONFIG_CRYPTO_RNG2=y
CONFIG_CRYPTO_PCOMP=m
CONFIG_CRYPTO_PCOMP2=y
CONFIG_CRYPTO_MANAGER=y
CONFIG_CRYPTO_MANAGER2=y
# CONFIG_CRYPTO_USER is not set
CONFIG_CRYPTO_MANAGER_DISABLE_TESTS=y
# CONFIG_CRYPTO_GF128MUL is not set
# CONFIG_CRYPTO_NULL is not set
# CONFIG_CRYPTO_PCRYPT is not set
CONFIG_CRYPTO_WORKQUEUE=y
# CONFIG_CRYPTO_CRYPTD is not set
CONFIG_CRYPTO_AUTHENC=m
# CONFIG_CRYPTO_TEST is not set
# CONFIG_CRYPTO_CCM is not set
# CONFIG_CRYPTO_GCM is not set
# CONFIG_CRYPTO_SEQIV is not set
CONFIG_CRYPTO_CBC=m
# CONFIG_CRYPTO_CTR is not set
# CONFIG_CRYPTO_CTS is not set
CONFIG_CRYPTO_ECB=m
# CONFIG_CRYPTO_LRW is not set
CONFIG_CRYPTO_PCBC=m
# CONFIG_CRYPTO_XTS is not set
CONFIG_CRYPTO_HMAC=y
# CONFIG_CRYPTO_XCBC is not set
# CONFIG_CRYPTO_VMAC is not set
CONFIG_CRYPTO_CRC32C=y
# CONFIG_CRYPTO_CRC32C_INTEL is not set
# CONFIG_CRYPTO_CRC32 is not set
# CONFIG_CRYPTO_CRC32_PCLMUL is not set
# CONFIG_CRYPTO_GHASH is not set
CONFIG_CRYPTO_MD4=m
CONFIG_CRYPTO_MD5=y
CONFIG_CRYPTO_MICHAEL_MIC=m
# CONFIG_CRYPTO_RMD128 is not set
# CONFIG_CRYPTO_RMD160 is not set
# CONFIG_CRYPTO_RMD256 is not set
# CONFIG_CRYPTO_RMD320 is not set
CONFIG_CRYPTO_SHA1=y
CONFIG_CRYPTO_SHA256=m
CONFIG_CRYPTO_SHA512=m
# CONFIG_CRYPTO_TGR192 is not set
# CONFIG_CRYPTO_WP512 is not set
CONFIG_CRYPTO_AES=y
CONFIG_CRYPTO_AES_586=m
# CONFIG_CRYPTO_AES_NI_INTEL is not set
# CONFIG_CRYPTO_ANUBIS is not set
CONFIG_CRYPTO_ARC4=m
CONFIG_CRYPTO_BLOWFISH=m
CONFIG_CRYPTO_BLOWFISH_COMMON=m
# CONFIG_CRYPTO_CAMELLIA is not set
CONFIG_CRYPTO_CAST_COMMON=m
CONFIG_CRYPTO_CAST5=m
# CONFIG_CRYPTO_CAST6 is not set
CONFIG_CRYPTO_DES=m
# CONFIG_CRYPTO_FCRYPT is not set
# CONFIG_CRYPTO_KHAZAD is not set
# CONFIG_CRYPTO_SALSA20 is not set
# CONFIG_CRYPTO_SALSA20_586 is not set
# CONFIG_CRYPTO_SEED is not set
# CONFIG_CRYPTO_SERPENT is not set
# CONFIG_CRYPTO_SERPENT_SSE2_586 is not set
# CONFIG_CRYPTO_TEA is not set
# CONFIG_CRYPTO_TWOFISH is not set
# CONFIG_CRYPTO_TWOFISH_586 is not set
CONFIG_CRYPTO_DEFLATE=m
CONFIG_CRYPTO_ZLIB=m
CONFIG_CRYPTO_LZO=m
CONFIG_CRYPTO_ANSI_CPRNG=m
# CONFIG_CRYPTO_USER_API_HASH is not set
# CONFIG_CRYPTO_USER_API_SKCIPHER is not set
CONFIG_CRYPTO_HW=y
# CONFIG_CRYPTO_DEV_PADLOCK is not set
CONFIG_CRYPTO_DEV_GEODE=m
Back to top
View user's profile Send private message 
Graf_Koks

Joined: 21 Jan 2014
Posts: 16

PostPosted: Tue 21 Jan 2014, 17:17    Post subject:  

What works under puppy is the following:

Take

http://wiki.ubuntuusers.de/LUKS

as manual (it is in german). But exchange

sudo cryptsetup luksFormat -c aes-xts-plain64 -s 512 GERÄTEDATEI

to

sudo cryptsetup luksFormat -c aes-cbc-essiv:sha256 -s 256 GERÄTEDATEI

Then it should work. However, the provided encryption is not state of the art:

http://security.stackexchange.com/questions/39306/how-secure-is-ubuntus-default-full-disk-encryption
http://code.google.com/p/cryptsetup/wiki/Cryptsetup160

So it is really necessary, that aes-xts-plain64 works out of the box.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [8 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Security/Privacy
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0631s ][ Queries: 13 (0.0092s) ][ GZIP on ]