Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 23 Aug 2014, 03:52
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
PupServer-435
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 4 of 7 [98 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7 Next
Author Message
irishrm


Joined: 14 Mar 2009
Posts: 210

PostPosted: Sat 09 Apr 2011, 22:04    Post subject: Re: pupserver 435 printing.  

jrb wrote:

When you open CUPS on your clients do they see the printers on the other clients? What version of Puppy are you using on the clients?

I just see the printers installed on the individual computers.
I'm running Wary 5.1.1 on one client and lupu 5.1.1 on the other.
Would you recommend trying the server you have uploaded in the post on the previous page? If so I'll try it to-morrow-irishrm.
Back to top
View user's profile Send private message 
jrb


Joined: 11 Dec 2007
Posts: 1031
Location: Smithers, BC, Canada

PostPosted: Sat 09 Apr 2011, 22:17    Post subject: Re: pupserver 435 printing.  

irishrm wrote:
jrb wrote:

When you open CUPS on your clients do they see the printers on the other clients? What version of Puppy are you using on the clients?

I just see the printers installed on the individual computers.
I'm running Wary 5.1.1 on one client and lupu 5.1.1 on the other.
Would you recommend trying the server you have uploaded in the post on the previous page? If so I'll try it to-morrow-irishrm.

I don't think that will make a difference. CUPS is the same in both. Let me try playing with some settings in Wary and lupu and I'll get back to you.

Cheers, J
Back to top
View user's profile Send private message 
p310don

Joined: 19 May 2009
Posts: 691
Location: Brisbane, Australia

PostPosted: Sun 10 Apr 2011, 00:08    Post subject:  

jrb wrote

Quote:
I just uploaded
http://puppylinuxstuff.meownplanet.net/choicepup/PupServer435/pupserver435tngG.iso.
http://puppylinuxstuff.meownplanet.net/choicepup/PupServer435/pupserver435tngG.iso-md5.txt
This is the same Pupserver435 but using rcrsn51's tng samba server. Give it a try and see if your n900 will talk to it.

Good Luck, J


Sorry jrb, I have already tried rcrsn51's samba-tng pet, which is also great to set up like your PupServer, but the phone doesn't like it. I did pm with rcrsn51 earlier to let him know that the phone doesn't play nicely. It's just finicky.

I have two machines that are used as file servers, an old one, using pupserver435 and a newer machine with lupu running sambaTNG by rcrsn51. They are both great solutions for everything, except the nokia n900.

Seeing as though you have made it though, I will try your modified PupServerTNG and see if it plays any nicer.

Thanks, will let you know the results.

Paul
Back to top
View user's profile Send private message 
irishrm


Joined: 14 Mar 2009
Posts: 210

PostPosted: Sun 10 Apr 2011, 05:31    Post subject: cups printing  

Thanks for that jrb but hold off an that for a while. I have a feeling that the problem is a bad download. I have just done a fresh download and run it with pfix=ram. I think it installed cleaner and I notice some differences in how its working. As soon as I get a chance I'll install it properly and have a go at setting up the printing. I'll post back and let you know how I get on. This is something I really want to get working thanks again-irishrm
Back to top
View user's profile Send private message 
p310don

Joined: 19 May 2009
Posts: 691
Location: Brisbane, Australia

PostPosted: Sun 10 Apr 2011, 07:17    Post subject:  

Samba mounting on the n900 works fine. Well, almost fine.

On the n900 there is an app called wizard mounter that mounts samba shares. This does not work with standard pupserver, nor pupserverTNG, not samba TNG.pet etc. It does work with shinobar's samba sfs.

If I go into the command line, I can mount any type of samba share using -

Quote:
mount -t cifs //<server>/<path> /<your>/<local>/<path> -o user=<user>,pass=<pass>,ip=<ip of server>,direct


Works, but not pretty. So thanks guys for your help making the different servers etc, but the problem is in the phone app, not puppy anything. Might have to get onto them to make it puppy compatible!!
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9040
Location: Stratford, Ontario

PostPosted: Sun 10 Apr 2011, 09:14    Post subject:  

Is this just because shinobar's Samba doesn't require a login, but the others do? Read the Samba-TNG thread for how to set it for no-login mode. It just requires a change to its smb.conf.

[Edit] I looked at PupServer-435 again and it's already running in share mode.
Back to top
View user's profile Send private message 
jrb


Joined: 11 Dec 2007
Posts: 1031
Location: Smithers, BC, Canada

PostPosted: Sun 10 Apr 2011, 09:54    Post subject: Re: cups printing  

irishrm wrote:
This is something I really want to get working

Here's what I have found so far. If you have the firewall enabled on Pupserver435 it will block access to your shared printer when you try to access it with the CUPS easy install as mentioned above.

You can however install it on your client in CUPS as an "Internet Printing Protocol (ipp)" printer and setting
Code:
ipp://xxx.xxx.x.xxx:631/printers/printer_name
where xxx.xxx.x.xxx is the ip address of the server. Get this by typing
Code:
# ifconfig
in a console. Should give you something like:
Code:
eth0      Link encap:Ethernet  HWaddr 00:17:A4:1F:AD:3A 
          inet addr:192.168.1.102  Bcast:192.168.1.255  Mask:255.255.255.0

This works for me even with firewall enabled.

Good Luck, J

Note: I gave this a try after reading rcrsn51's How to Install Your Printer/Scanner in Lupu/Quirky/Wary. Thanks rcrsn51. Very Happy
Back to top
View user's profile Send private message 
irishrm


Joined: 14 Mar 2009
Posts: 210

PostPosted: Sun 10 Apr 2011, 18:11    Post subject: Re: cups printing  

[quote="jrb"]
Good Luck, j
jbr an update:
I made a fresh download:
Made a frugal hard-drive install booted with grub4dos:
Installed printer with cups on server:
Followed your instructions on installing the server printer on the client:
Found the printer and made it the default:

I'm delighted to report that both the server and the printer are working perfectly and as you said it works even with firewall installed.

Can I thank you again for your help on this and for the very easy to follow instructions on how to complete the job. You certainly went out of your way to be helpful.
Could I throw in a big thank you to rcrsn51 as well.
irishrm.
Back to top
View user's profile Send private message 
shivish

Joined: 10 Oct 2011
Posts: 3

PostPosted: Thu 13 Oct 2011, 09:01    Post subject: Print from OS X and upgrade to lupu 528  

Hello!

First-off thank you so much for making this. Its made life so much easier. I had a bunch of ext4 hard disks with stuff on it and my attempt to install Freenas didn't go so well as it wanted to format all my HDD to ufs.

pupserver435 works like a charm, and I used p910nd to set up my printer for which there is no native linux driver, and it prints great from win7.

So here are my questions
1. For some reason my Mac can't print I used IP printing with Jetdirect, while win7 prints great
2. Is there a way to set this server up with lupu528, my system is fairly newer system and can be used as desktop in a pinch. I installed samba-tng-rcrsn-0.5-rc1.pet, p910nd and mini-dlna. Now I cant get all the drives to auto-mount, and show up for smb mount. I copies the smb.comf from pupserver-435 to lupu but still no effect. I dont know what the passwd for root is either so user=root and passwd=woofwoof didnt work.

Please help.

Thanks again

shivish
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9040
Location: Stratford, Ontario

PostPosted: Thu 13 Oct 2011, 09:30    Post subject:  

This is confusing. You have posted to a thread about Pupserver-435, but are talking about installing Samba-TNG in Lupu528. Which is it?

I tested samba-tng-rcrsn-0.5-rc1.pet in Luci528 and it worked fine. The login to the samba server is still root-woofwoof.

If you want to continue discussing Samba-TNG, you should post here.
Back to top
View user's profile Send private message 
shivish

Joined: 10 Oct 2011
Posts: 3

PostPosted: Sun 16 Oct 2011, 09:23    Post subject: Sorry about that  

I guess I am talking about Samba-TNG in Lupu528 and should post in that section. The reason I posted it here is that, I wanted to recreate the 435 experience. Samba-TNG started samba server but the drives didn't auto mount, nor would startmount application do it (it keeps saying save the session, for it to work, but I have saved the session, and rebooted multiple times). So I guess if you can tell me how you managed the automount of all drives on each boot. I'll be all set.

Thanks a bunch

shivish
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9040
Location: Stratford, Ontario

PostPosted: Sun 16 Oct 2011, 16:19    Post subject:  

rcrsn51 wrote:
If you want to continue discussing Samba-TNG, you should post here.
Back to top
View user's profile Send private message 
jrb


Joined: 11 Dec 2007
Posts: 1031
Location: Smithers, BC, Canada

PostPosted: Mon 17 Oct 2011, 13:25    Post subject: Re: Sorry about that  

shivish wrote:
I guess I am talking about Samba-TNG in Lupu528 and should post in that section. The reason I posted it here is that, I wanted to recreate the 435 experience. Samba-TNG started samba server but the drives didn't auto mount, nor would startmount application do it (it keeps saying save the session, for it to work, but I have saved the session, and rebooted multiple times). So I guess if you can tell me how you managed the automount of all drives on each boot. I'll be all set.

Thanks a bunch

shivish

See here for an answer. Cool
Back to top
View user's profile Send private message 
tubeguy


Joined: 28 Aug 2009
Posts: 1326
Location: Park Ridge IL USA

PostPosted: Mon 17 Oct 2011, 21:28    Post subject: Re: PupServer-435
Subject description: Dedicated Samba file and print server
 

jrb wrote:
Pupserver435 is a dedicated samba file and print server designed to be as easy as possible to use, no configuration required.

Right you are! Just turned my old lappie with a busted screen into a fileserver in about 3 minutes. Man this is great, thanks so much!

_________________
Toshiba M115-S1061: PupServer |HP/Compaq D330ST: Dpup 486
Back to top
View user's profile Send private message Visit poster's website 
tubeguy


Joined: 28 Aug 2009
Posts: 1326
Location: Park Ridge IL USA

PostPosted: Mon 21 Nov 2011, 13:27    Post subject: connections limit?  

Is there a limit to the number of connections that can be made to PupServer? I'm thinking about using it at work as a simple file server (no printing) and we have 10 users.

Thanks

_________________
Toshiba M115-S1061: PupServer |HP/Compaq D330ST: Dpup 486
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 4 of 7 [98 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0903s ][ Queries: 13 (0.0060s) ][ GZIP on ]