Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 28 Jul 2014, 16:52
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
Canon pixma printer drivers
Post new topic   Reply to topic View previous topic :: View next topic
Page 8 of 11 [153 Posts]   Goto page: Previous 1, 2, 3, ..., 6, 7, 8, 9, 10, 11 Next
Author Message
rcrsn51


Joined: 05 Sep 2006
Posts: 8917
Location: Stratford, Ontario

PostPosted: Sun 22 May 2011, 14:20    Post subject:  

Here are drivers for the MP280, MP495 and MG5100 series.

The MG5100 has never been tested. Please provide feedback.
canon_mg5100-3.40.pet
Description 
pet

 Download 
Filename  canon_mg5100-3.40.pet 
Filesize  1.7 MB 
Downloaded  428 Time(s) 
canon_mp280-3.40.pet
Description 
pet

 Download 
Filename  canon_mp280-3.40.pet 
Filesize  1.64 MB 
Downloaded  358 Time(s) 
canon_mp495-3.40.pet
Description 
pet

 Download 
Filename  canon_mp495-3.40.pet 
Filesize  1.64 MB 
Downloaded  536 Time(s) 

Last edited by rcrsn51 on Mon 10 Oct 2011, 14:39; edited 5 times in total
Back to top
View user's profile Send private message 
joelh

Joined: 03 May 2011
Posts: 15

PostPosted: Sun 22 May 2011, 14:58    Post subject: pixma  

with this .pet it works fine, now i just got to test the scanner, thanks a lot : great job !
Back to top
View user's profile Send private message 
joelh

Joined: 03 May 2011
Posts: 15

PostPosted: Sun 22 May 2011, 15:03    Post subject: pixma scanner  

# sane-find-scanner

# sane-find-scanner will now attempt to detect your scanner. If the
# result is different from what you expected, first make sure your
# scanner is powered up and properly connected to your computer.

# No SCSI scanners found. If you expected something different, make sure that
# you have loaded a kernel SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x04a9 [Canon], product=0x1747 [MP495 series]) at libusb:002:002
found USB scanner (vendor=0x041e [Creative], product=0x401d [Creative WebCam NX Ultra]) at libusb:001:002
# Your USB scanner was (probably) detected. It may or may not be supported by
# SANE. Try scanimage -L and read the backend's manpage.

# Not checking for parallel port scanners.

# Most Scanners connected to the parallel port or other proprietary ports
# can't be detected by this program.
#
The scanner doesn't work yet but it's detected, did i miss something?? thanks a lot for guide me Wink
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 8917
Location: Stratford, Ontario

PostPosted: Sun 22 May 2011, 15:08    Post subject:  

For Canon scanning, read here.

Your first choice should be the pixma-backend-qrky-1.0.21.pet. Test it with Xsane in the Graphic menu.
Back to top
View user's profile Send private message 
joelh

Joined: 03 May 2011
Posts: 15

PostPosted: Sun 22 May 2011, 15:18    Post subject: pixma  

still the "no devices avaible" message with pixma-backend-qrky-1.0.21.pet
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 8917
Location: Stratford, Ontario

PostPosted: Sun 22 May 2011, 15:39    Post subject:  

Read here;
Back to top
View user's profile Send private message 
joelh

Joined: 03 May 2011
Posts: 15

PostPosted: Sun 22 May 2011, 16:03    Post subject:  

WELL DONE. It works fine but it makes a png file, no other choice? pdf for example ? i didn't see how to change it in the preference menu.
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 8917
Location: Stratford, Ontario

PostPosted: Sun 22 May 2011, 16:19    Post subject:  

Glad to help.

Quote:
but it makes a png file, no other choice? pdf for example


IIRC, Scangearmp doesn't offer many choices. If you really want a PDF file, you could do it manually as follows
Code:
pngtopnm scan.png > scan.pnm
pnmtops scan.pnm > scan.ps
ps2pdf scan.ps scan.pdf
Back to top
View user's profile Send private message 
joelh

Joined: 03 May 2011
Posts: 15

PostPosted: Sun 22 May 2011, 17:38    Post subject:  

ok, works with puppyPDF in document/document utilities menu but very very ugly definition when zoom is used (no problem with the png file when zooming)
Back to top
View user's profile Send private message 
steve_s


Joined: 26 May 2008
Posts: 1545
Location: Austin, TX, USA

PostPosted: Fri 24 Jun 2011, 16:42    Post subject:  

Using cups 1.3.1.1, trying to get a canon i550 to work...suggestions? As it stands I don't even have Canon listed as an available make even though it does see it when I search for printers...
Back to top
View user's profile Send private message Visit poster's website 
rcrsn51


Joined: 05 Sep 2006
Posts: 8917
Location: Stratford, Ontario

PostPosted: Fri 24 Jun 2011, 20:27    Post subject:  

Quote:
Using cups 1.3.1.1, trying to get a canon i550 to work...suggestions?

What Puppy are you using?
Quote:
As it stands I don't even have Canon listed as an available make even though it does see it when I search for printers...

All Puppies have the Gutenprint driver package, so you should definitely be seeing SOME Canon printers.
Back to top
View user's profile Send private message 
steve_s


Joined: 26 May 2008
Posts: 1545
Location: Austin, TX, USA

PostPosted: Fri 24 Jun 2011, 20:41    Post subject:  

rcrsn51 wrote:
Quote:
Using cups 1.3.1.1, trying to get a canon i550 to work...suggestions?

What Puppy are you using?
Quote:
As it stands I don't even have Canon listed as an available make even though it does see it when I search for printers...

All Puppies have the Gutenprint driver package, so you should definitely be seeing SOME Canon printers.


In this case, Puppy 4.0 (it's the only one that works with this Linksys usb wireless, another baffling mystery). And no, the word "Canon" is not even listed at all.
Back to top
View user's profile Send private message Visit poster's website 
rcrsn51


Joined: 05 Sep 2006
Posts: 8917
Location: Stratford, Ontario

PostPosted: Fri 24 Jun 2011, 20:58    Post subject:  

IIRC, Puppy 4.0 had CUPS 1.1.23. Did you attempt to upgrade CUPS?
Back to top
View user's profile Send private message 
steve_s


Joined: 26 May 2008
Posts: 1545
Location: Austin, TX, USA

PostPosted: Fri 24 Jun 2011, 20:59    Post subject:  

rcrsn51 wrote:
IIRC, Puppy 4.0 had CUPS 1.1.23. Did you attempt to upgrade CUPS?


I have! Smile As mentioned before, I'm using 1.3.1.1 Per one of your other posts/threads. (thanks by the way!)
Back to top
View user's profile Send private message Visit poster's website 
rcrsn51


Joined: 05 Sep 2006
Posts: 8917
Location: Stratford, Ontario

PostPosted: Fri 24 Jun 2011, 21:08    Post subject:  

Then you also need to install the Gutenprint driver package as described in the other thread here.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 8 of 11 [153 Posts]   Goto page: Previous 1, 2, 3, ..., 6, 7, 8, 9, 10, 11 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0940s ][ Queries: 13 (0.0294s) ][ GZIP on ]