Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 23 Aug 2014, 01:39
All times are UTC - 4
 Forum index » Advanced Topics » Cutting edge
GUI to download LibreOffice - beta quality
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 18 [260 Posts]   Goto page: Previous 1, 2, 3, 4, ..., 16, 17, 18 Next
Author Message
Jim1911

Joined: 19 May 2008
Posts: 2455
Location: Texas, USA

PostPosted: Mon 21 Mar 2011, 16:21    Post subject:  

01micko wrote:
Ok, I see that (from a brief look at your thread Christian) that there are issues with LO-331 and and that LO-332rc is better. Well hopefully 332 will be the latest stable for LO very soon and hopefully too this program, when it is run, will detect the version number difference. Well as long as the Libre server structure stays the same then this program should do just that!
How about adding an option to download libreoffice beta's or rc? Also, you can tackle OpenOffice so I won't need to upload that to playdayz anymore? Laughing

Regards,
Jim
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7794
Location: qld

PostPosted: Mon 21 Mar 2011, 23:57    Post subject:  

possibility of extra locales --- done!
possibility of latest testing version --- done!

Open office? Maybe. Maybe not.

Cheers!

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
wuwei


Joined: 15 Sep 2007
Posts: 774
Location: de

PostPosted: Tue 22 Mar 2011, 04:16    Post subject:  

Gee whizz micko,

you are outdoing yourself.
Can't keep up with you on the German side, but trying to,... Wink
Back to top
View user's profile Send private message 
Jim1911

Joined: 19 May 2008
Posts: 2455
Location: Texas, USA

PostPosted: Tue 22 Mar 2011, 18:15    Post subject:  

My, you are super fast. Very Happy Interface is great, but I haven't been able to download the testing version, apparently their download site is getting a lot of traffic.

EDIT: 03/23/11, 1440 Still unsuccessful for the testing version, get "Failed to download Please try again later" message. I managed to snap picts of the download screens as they flashed by.

EDIT 2: Disregard above. The stable version doesn't download either, I went to the libreoffice site and discovered that they now offer LibreOffice 3.3.2 Final (2011-03-22) so there probably isn't a testing version available now. Because of the new release, the site probably has heavy traffic.

Cheers, Very Happy
Jim
image-5.png
Description 
png

 Download 
Filename  image-5.png 
Filesize  415.99 KB 
Downloaded  837 Time(s) 
image-1.png
Description 
png

 Download 
Filename  image-1.png 
Filesize  412.36 KB 
Downloaded  827 Time(s) 
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7794
Location: qld

PostPosted: Thu 24 Mar 2011, 05:44    Post subject:  

Quote:
EDIT 2: Disregard above. The stable version doesn't download either, I went to the libreoffice site and discovered that they now offer LibreOffice 3.3.2 Final (2011-03-22) so there probably isn't a testing version available now. Because of the new release, the site probably has heavy traffic.


Thanks Jim,

Ok, looks like you trapped the libre site in their transitional period. Good news is that I just got the 'stable' version as 3.3.2 Very Happy .. so that part of the code works. Now.. how to compare whether the latest stable is not the same as testing? Hmmm... a bit more difficult as I just checked and listed as 'testing' is 3.3.2rc2 Confused . (now defunct). Well I guess this app may be a little premature, but in saying that, the libre guys probably haven't figured out their structure yet, so in that respect they are probably a bit immature.

I have been looking for the WM's (webmaster's) address to see if I can communicate with him/her/them but nothing found. (They may be a bit suspicious of all the hits they've been getting from my IP addy over the past week or so Shocked ).

Thanks for testing and if you come across any peculiarities let me know.

Cheers

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
Jim1911

Joined: 19 May 2008
Posts: 2455
Location: Texas, USA

PostPosted: Thu 24 Mar 2011, 12:54    Post subject:  

Mick,

Sorry, but I believe that there is now a problem with the file name or path with the updated 3.3.2, since I still haven't been able to download the stable version either. I did download the files without any delay just using the download site. Sad

Cheers,
Jim
Back to top
View user's profile Send private message 
swiatmar


Joined: 09 Aug 2008
Posts: 241
Location: Danube, AT

PostPosted: Wed 06 Apr 2011, 18:31    Post subject:  

Hello 01micko Smile
I`ve got some massage by trying get libreoffice:
Code:
Pupmode 13 is unsupported, sorry

what does it mean?
I am using lupu 5.2 with xfce
Back to top
View user's profile Send private message Visit poster's website 
01micko


Joined: 11 Oct 2008
Posts: 7794
Location: qld

PostPosted: Wed 06 Apr 2011, 20:34    Post subject:  

Rolling Eyes Yes, well I guess that doesn't mean much... I have changed the message to "USB and DVD installs are unsupported". Reason is that you need lots of RAM, sure, I can do a test for that, but at the moment I'll wait until we see if this app is stable enough.

Thanks for report.

ver 0.6 is posted, the program quits if you choose "testing" and there is no testing version and recommends you get the stable version. It also quits if the servers are unresponsive with a "try again later" message.

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
rhadon


Joined: 27 Mar 2008
Posts: 1291
Location: Germany

PostPosted: Mon 06 Jun 2011, 15:33    Post subject:  

Hi Mick,

for your interest:

I just tried to build LibO_3.4.0rc2. It downloads OK, but fails to build the sfs.

Here is the output from a terminal:

Code:
# ./get_libreoffice
ok
mkdir: cannot create directory `/initrd/mnt/dev_save/libre_download': File exists
LibO_3.4.0rc2_Linux_x86_install-deb_en-US.tar.gz
./get_libreoffice: line 478: 25994 Terminated              gtkdialog-splash -close never -icon /usr/share/pixmaps/throbber.gif -bg green -text "$INFOMSG1"
true
true
CHKBOX0="true"
CHKBOX1="true"
EXIT="getlibre"
# tar: LibO_3.4.0rc2_Linux_x86_helppack-deb_de: Cannot read: Is a directory
tar: At beginning of tape, quitting now
tar: Error is not recoverable: exiting now

gzip: stdin: unexpected end of file
tar: Child returned status 2
tar: Exiting with failure status due to previous errors
rm: cannot remove `LibO_3.4.0rc2_Linux_x86_helppack-deb_de': Is a directory
tar: LibO_3.4.0rc2_Linux_x86_install-deb_en-US: Cannot read: Is a directory
tar: At beginning of tape, quitting now
tar: Error is not recoverable: exiting now

gzip: stdin: unexpected end of file
tar: Child returned status 2
tar: Exiting with failure status due to previous errors
rm: cannot remove `LibO_3.4.0rc2_Linux_x86_install-deb_en-US': Is a directory
tar: LibO_3.4.0rc2_Linux_x86_langpack-deb_de: Cannot read: Is a directory
tar: At beginning of tape, quitting now
tar: Error is not recoverable: exiting now

gzip: stdin: unexpected end of file
tar: Child returned status 2
tar: Exiting with failure status due to previous errors
rm: cannot remove `LibO_3.4.0rc2_Linux_x86_langpack-deb_de': Is a directory
LibO_3.4.0rc2_Linux_x86_helppack-deb_de
/initrd/mnt/dev_save/libre_download/LibO_3.4.0rc2_Linux_x86_install-deb_en-US/DEBS
mkdir: cannot create directory `workdir': File exists
sh: line 109: cd: /initrd/mnt/dev_save/libre_download/LibO_3.4.0rc2_Linux_x86_install-deb_en-US/DEBS/workdir/opt/libreoffice/share/xdg: No such file or directory
sh: line 1:   598 Terminated              gtkdialog-splash -close never -icon /usr/share/pixmaps/throbber.gif -bg yellow -text "$INFOMSG2a $LIBO_EN_US $INFOMSG2b"  (wd: /usr/sbin)
_de
EXIT="Exit on timeout"


HTH

Rolf

_________________
Ich verwende "frugal", und das ist gut so. Wink
Raspberry Pi without Puppy? No, thanks.
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7794
Location: qld

PostPosted: Tue 07 Jun 2011, 00:07    Post subject:  

Hi Rolf

Thanks for heads up.

Well 3.4 is stable now so I updated the script to grab either 3.3.2 or 3.4.0, both in the stable branch. By the look of your errors the downloads weren't complete Confused

They did change a lot of stuff so failure was inevitable anyway. The .desktop files are all changed.. they add that annoying "%U" to the exec line which fails in puppy, also they have modified the call paths, which actually is an improvement, I need to do less hacking in the script. I have added code to remove that %U and fix the icon paths if the version is greater than or equal to 3.4.0.

(see first post)

Have fun!

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
rhadon


Joined: 27 Mar 2008
Posts: 1291
Location: Germany

PostPosted: Tue 07 Jun 2011, 10:57    Post subject:  

Hi Mick,

thanks for get_libreoffice-0.7.pet. Works fine now in Lupu 5.25 for 3.4. Very Happy

Maybe you can help me to understand two mysteries? Shocked

Mystery 1:
First I used it in Icepuppy 013. Downloading, building sfs and mounting OK, but I'm not able to start any LibreOffice program. Also not after reboot. E.g. Draw:
Menu->Graphic->LibreOffice 3.4 Draw doesn't work.
/usr/share/applications/libreoffice3.4-draw.desktop doesn't work.
/opt/libreoffice3.4/share/xdg/draw.desktop doesn't work.

Running the last one in a terminal, I get 'Permission denied'
Permission set and running again, I get:
Code:
sh-4.1# ./draw.desktop
./draw.desktop: line 1: [Desktop: command not found
./draw.desktop: line 7: --draw: command not found
./draw.desktop: line 8: application/vnd.oasis.opendocument.graphics-flat-xml: No such file or directory
./draw.desktop: line 8: application/vnd.oasis.opendocument.graphics-template: No such file or directory
./draw.desktop: line 8: application/vnd.sun.xml.draw: No such file or directory
./draw.desktop: line 8: application/vnd.sun.xml.draw.template: No such file or directory
./draw.desktop: line 8: application/vnd.stardivision.draw: No such file or directory
./draw.desktop: line 9: 3.4: command not found
./draw.desktop: line 10: 3.4: command not found
./draw.desktop: line 11: Program: command not found
./draw.desktop: line 12: Program: command not found
./draw.desktop: line 14: الرسم: command not found
./draw.desktop: line 15: কাৰ্যক্ৰম: command not found
./draw.desktop: line 16: de: command not found
./draw.desktop: line 17: рысавання: command not found
....

followed by a lot of similiar lines.

Mystery2:

I went back to Lupu 5.25 built and installed again, and tried the same:

Menu->Graphic->LibreOffice 3.4 Draw works.
/usr/share/applications/libreoffice3.4-draw.desktop works.
/opt/libreoffice3.4/share/xdg/draw.desktop works.

Running in a terminal, I get 'Permission denied' and program doesn't work.
Permission set and running from terminal again, program also doesn't work and I get the same as before:
Code:
# ./draw.desktop
./draw.desktop: line 1: [Desktop: command not found
./draw.desktop: line 7: --draw: command not found
./draw.desktop: line 8: application/vnd.oasis.opendocument.graphics-flat-xml: No such file or directory
./draw.desktop: line 8: application/vnd.oasis.opendocument.graphics-template: No such file or directory
./draw.desktop: line 8: application/vnd.sun.xml.draw: No such file or
...

and so on.

That's far beyond my logic Embarassed
Any idea?

Rolf

_________________
Ich verwende "frugal", und das ist gut so. Wink
Raspberry Pi without Puppy? No, thanks.
Back to top
View user's profile Send private message 
wuwei


Joined: 15 Sep 2007
Posts: 774
Location: de

PostPosted: Tue 07 Jun 2011, 12:21    Post subject:  

rhadon

you might want to take a look at my post here...

http://www.murga-linux.com/puppy/viewtopic.php?t=66836&start=690

Same problem from a different angle.

Very mysterious.
Back to top
View user's profile Send private message 
rhadon


Joined: 27 Mar 2008
Posts: 1291
Location: Germany

PostPosted: Tue 07 Jun 2011, 13:10    Post subject:  

@wuwei

very strange, indeed. Shocked have you tested another Puppy with your installed new Libre Office?
So it doesn't seem to be a problem of Mick's pet and it doesn't seem to be a problem of icepuppy (at last not only).

Rolf

_________________
Ich verwende "frugal", und das ist gut so. Wink
Raspberry Pi without Puppy? No, thanks.
Back to top
View user's profile Send private message 
wuwei


Joined: 15 Sep 2007
Posts: 774
Location: de

PostPosted: Tue 07 Jun 2011, 14:52    Post subject:  

rhadon wrote:

Quote:
have you tested another Puppy


LO starts in all my other Puppies. However, in Wary 512 it starts initially, but when I want to install Java through Tools-Options it crashes as soon as I click on "Add".

OO runs fine without any problems.

That's strange, too.
Back to top
View user's profile Send private message 
Henry

Joined: 29 Jul 2006
Posts: 829
Location: Oregon USA

PostPosted: Tue 07 Jun 2011, 16:40    Post subject: Printing problem, Lo3.4  

wuwei wrote:
rhadon wrote:

Quote:
have you tested another Puppy


LO starts in all my other Puppies. However, in Wary 512 it starts initially, but when I want to install Java through Tools-Options it crashes as soon as I click on "Add".

OO runs fine without any problems.

That's strange, too.

Hi, wuwei,

As you know I installed Lo3.4 with your help and have been testing it. For the information of those here I would suggest not rushing into it. It works but is reportedly buggy. My concern is that it doesn't print - at all. Tronkel is pursuing this on the Lo users list now, I see.
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 2 of 18 [260 Posts]   Goto page: Previous 1, 2, 3, 4, ..., 16, 17, 18 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Cutting edge
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1026s ][ Queries: 13 (0.0089s) ][ GZIP on ]