Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 31 Oct 2014, 01:09
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Snow Puppy 020 with more apps, fonts and themes
Moderators: Flash, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 44 of 46 Posts_count   Goto page: Previous 1, 2, 3, ..., 42, 43, 44, 45, 46 Next
Author Message
jim3630


Joined: 13 Feb 2011
Posts: 792
Location: Northern Nevada

PostPosted: Wed 15 Jun 2011, 02:27    Post_subject:  

pemasu wrote:
Jim3630. That Qt package seems to scream for libicu which is international code for unicode.
Install it with PPM from the Ubuntu repo.


added unicode from Ubuntu without change. then did new save file with this these packages added:

pupsaveconfig-1.9.9
unicode_0.9.4_alldebs
quickpet_fix-0.0.1|
qt4-4.8.0
qt4_DEV-4.8.0
QtWeb_browser-3.7.2
screengrab-0.9-i386

qtbrowser works but qtconfig remains same.
code:
# qtconfig
Unable to load library icui18n "Cannot load library icui18n: (libicui18n.so.42: cannot open shared object file: No such file or directory)"
QGtkStyle was unable to detect the current GTK+ theme.
QGtkStyle was unable to detect the current GTK+ theme.

code:
# unicode
Usage: unicode [options] arg

Options:
-h, --help show this help message and exit
-x, --hexadecimal Assume arg to be hexadecimal number
-d, --decimal Assume arg to be decimal number
-r, --regexp Assume arg to be regular expression
-s, --string Assume arg to be a sequence of characters
-a, --auto Try to guess arg type (default)
-m MAXCOUNT, --max=MAXCOUNT
Maximal number of codepoints to display, default: 10;
0=unlimited
-i IOCHARSET, --io=IOCHARSET
I/O character set, I am guessing ISO-8859-1
-c ADDCHARSET, --charset-add=ADDCHARSET
Show hexadecimal reprezentation in this additional
charset
-C USE_COLOUR, --colour=USE_COLOUR
Use colours, on, off or auto
--color=USE_COLOUR synonym for --colour
-v, --verbose Increase verbosity (reads Unihan properties - slow!)
-w, --wikipedia Query wikipedia for the character
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Wed 15 Jun 2011, 03:23    Post_subject:  

Jim3630. You should have added libicu not that unicode_0.9.4_alldebs
Type in PPM libicu and it will find what you should have added.
That unicode alldebs does not help you.
Back to top
View user's profile Send_private_message 
jim3630


Joined: 13 Feb 2011
Posts: 792
Location: Northern Nevada

PostPosted: Wed 15 Jun 2011, 22:25    Post_subject:  

pemasu wrote:
Jim3630. You should have added libicu not that unicode_0.9.4_alldebs
Type in PPM libicu and it will find what you should have added.
That unicode alldebs does not help you.


pemasu. started new savefile and added these to sp20:
pupsaveconfig-1.9.9
SM-21rc1
quickpet_fix-0.0.1
libicu42_4.2.1-3
libicu-dev_4.2.1-3
gongetit-0.1
qt4_DEV-4.8.0
qt4-4.8.0
QtWeb_browser-3.7.2
screengrab-0.9-i386

code:
# qtconfig
QGtkStyle was unable to detect the current GTK+ theme.
QGtkStyle was unable to detect the current GTK+ theme.

at least get fewer errors. while qtconfig can change colors it does not change style. any thoughts?
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Thu 16 Jun 2011, 01:08    Post_subject:  

Jim3630. Qtconfig does not change themes. About that QGtkStyle was unable to detect the current GTK+ theme error. I have no idea what fix will help to that. Somebody wiser than me will be needed. It wont affect to the functionality anyway. You can change for example font, font size still.
And that is the main thing, have big enough menu and submenus.
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sat 18 Jun 2011, 15:53    Post_subject:  

Jim3630. I found one working solution for Qt4 QGtkStyle was unable to detect the current GTK+ theme problem, Now the theme is included in the Qt4 applications menu bars also.

https://bbs.archlinux.org/viewtopic.php?pid=775685

That thread had needed information.
I still dont know what stuff were essential, but.
Adding the first line in below script cut to the /root/.xinitrc near the end:

Code:
export GTK2_RC_FILES="$HOME/.gtkrc-2.0"
#exec $CURRENTWM
#v2.11 GuestToo suggested this improvement...
which $CURRENTWM && exec $CURRENTWM
[ -x $CURRENTWM ] && exec $CURRENTWM
exec jwm


Then I installed most gconf packages, libgconf, libgnomeui and libgnomeui-common.

I restarted the X. And voila the theme was recognized and displayed in Qt applications.

Then I removed all the packages, I had installed with PPM and at least after restarting X, they are still working, theme change is applied.
Back to top
View user's profile Send_private_message 
jim3630


Joined: 13 Feb 2011
Posts: 792
Location: Northern Nevada

PostPosted: Sun 19 Jun 2011, 17:53    Post_subject:  

pemasu wrote:
Jim3630. I found one working solution for Qt4 QGtkStyle was unable to detect the current GTK+ theme problem, Now the theme is included in the Qt4 applications menu bars also.

https://bbs.archlinux.org/viewtopic.php?pid=775685

That thread had needed information.
I still dont know what stuff were essential, but.
Adding the first line in below script cut to the /root/.xinitrc near the end:

Code:
export GTK2_RC_FILES="$HOME/.gtkrc-2.0"
#exec $CURRENTWM
#v2.11 GuestToo suggested this improvement...
which $CURRENTWM && exec $CURRENTWM
[ -x $CURRENTWM ] && exec $CURRENTWM
exec jwm


Then I installed most gconf packages, libgconf, libgnomeui and libgnomeui-common.

I restarted the X. And voila the theme was recognized and displayed in Qt applications.

Then I removed all the packages, I had installed with PPM and at least after restarting X, they are still working, theme change is applied.


same subject reply on polar pup thread.
Back to top
View user's profile Send_private_message 
James C


Joined: 26 Mar 2009
Posts: 5892
Location: Kentucky

PostPosted: Mon 20 Jun 2011, 17:07    Post_subject:  

I just finished installing Mageia Gnome on yet another old box and decided to try Snow Puppy 020 too...... live pfix=ram. Booted to a prompt but ran xorgwizard and got the correct desktop.Sound and internet worked ootb.

Mon 20 Jun 2011 Operating System: Snow Puppy-020 Linux 2.6.35.7
0.0 VGA compatible controller: Trident Microsystems CyberBlade/i1
oem: Copyright 1998 TRIDENT MICROSYSTEMS INC.

X Server: Xorg Driver: trident
X.Org version: 1.7.6
dimensions: 1024x768 pixels (321x241 millimeters)
depth of root window: 24 planes

direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
OpenGL vendor string: Mesa Project
OpenGL renderer string: Software Rasterizer
OpenGL version string: 2.1 Mesa 7.7.1

AMD Athlon(tm) XP 1700+
Core 0: 1466 MHz

# glxgears
117 frames in 5.1 seconds
209 frames in 5.0 seconds
199 frames in 5.0 seconds
191 frames in 5.0 seconds
198 frames in 5.0 seconds
111 frames in 5.0 seconds

-Computer-
Processor : AMD Athlon(tm) XP 1700+
Memory : 1026MB (218MB used)
Operating System : Unknown distribution
User Name : root (root)
Date/Time : Mon 20 Jun 2011 04:17:27 PM CDT
-Display-
Resolution : 1024x768 pixels
OpenGL Renderer : Software Rasterizer
X11 Vendor : The X.Org Foundation
-Multimedia-
Audio Adapter : VIA686A - VIA 82C686A/B rev50

Multimedia audio controller : VIA Technologies, Inc. VT82C686 AC97 Audio Controller (rev 50)
Ethernet controller : ADMtek NC100 Network Everywhere Fast Ethernet 10/100 (rev 11)
VGA compatible controller : Trident Microsystems CyberBlade/i1

# free
total used free shared buffers
Mem: 1026620 717504 309116 0 91788
Swap: 1704956 0 1704956
Total: 2731576 717504 2014072
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Mon 20 Jun 2011, 17:24    Post_subject:  

James C. Your distro hopping, testing and reporting belongs to the AAAA class.

I retuned originally Sheepy`s posted GUI interface for xcompmgr. It creates menu entry to the Desktop section.

Xcompmgr is already installed in Snow Puppies.
gcompmgr-0.21.pet
Description 
pet

 Download 
Filename  gcompmgr-0.21.pet 
Filesize  55.75 KB 
Downloaded  388 Time(s) 
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Mon 20 Jun 2011, 18:02    Post_subject:  

James C. Trident driver. That is rare. I remember struggling with Trident graphics once. I hunted working driver long time once. Eons ago....it was probably about Win 95 time.
Back to top
View user's profile Send_private_message 
john3voltas

Joined: 23 May 2011
Posts: 102

PostPosted: Wed 29 Jun 2011, 16:44    Post_subject:  

JimCockfield wrote:
But, it never seems to go into any kind of suspend mode (even with the cover shut).

I haven't seen any power settings allowing to control suspend/hibernation after X amount of minutes.
Though, I do know that Lucid 5.2.5 can actually go into suspend when you close your laptop's lid.
But apparently there seems to be a bug or something with USB that prevents Lucid from going into suspend when you're running it from USB.
I found out that i can copy Lucid's sfs+vmlinuz+initrd.gz+savefile into an NTFS/FAT32 partition on my HDD and boot Lucid Frugal from HDD.
And this way, when I close the laptop's lid, it actually suspends to ram.
You might be willing to try that workaround.
Even though that way you wouldn't be able to boot from USB/SDHC/etc.
Cheers
Back to top
View user's profile Send_private_message 
heywoodj

Joined: 15 Mar 2009
Posts: 68

PostPosted: Sun 14 Aug 2011, 10:43    Post_subject:
Sub_title: Kernel Panic Snow Puppy 020
 

I'm trying out Snow Puppy 020 and am having trouble booting the CD. It fails after "Setting up the layered filesystem..." with

Code:
Performing a 'switch_root' to the layered filesystem...Kernel panic - not syncing : Attempted to kill init!
Pid: 1, comm: switch_root Not tainted 2.6.35.7 #1
Call Trace:
 [<c12a9879>] ? panic+0x54/0xb9
 [<c1028c76>] ? do_exit+0x5a/0x5a6
 [<c1029266>] ? complete_and_exit+0x0/0x16
 [<c12abb09>] ? syscall_call+0x7/0xb


I have checked the md5 of my download, and also that of the puppy_lupu-020.sfs in the mounted .iso on my hard drive and on the CD, and they have checked out.

This is on a new-to-me machine -- An hp/Compaq nx6125 (1.6 GHz AMD 1.4 GB RAM, 40GB HDD) that I'm trying out various Puppies and Puplets.

I believe that I had kernel panic earlier in the boot previously, but I didn't look that closely.

Any ideas how to fix it?

Thanks.
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sun 14 Aug 2011, 10:47    Post_subject:  

Heywoodj. Not much to help you other than doing manual frugal install using those needed files inside the iso.

There has been some fixes for the boot time usb and cd detection in woof. I am not sure if I will continue to update with 2.6.35.7 kernel. I want and would like to upgrade to newer kernel atm. Not sure if I have stable 2.6.39.3 kernel now or not. Anyway....Snow Puppy 020 is at it is. If I do next version, it will be using latest woof with all improvents through it.
Back to top
View user's profile Send_private_message 
heywoodj

Joined: 15 Mar 2009
Posts: 68

PostPosted: Sun 14 Aug 2011, 19:29    Post_subject:  

Pemasu,
Very interesting... I did a "cheat frugal" by mounting the .iso and copying the files into a directory on my storage partition. Then by inserting some lines into my menu.lst, Snow Puppy boots without a hitch. I'm running Snow Puppy right now!

I'll be assessing its performance for a while. The CD not booting confused me. The trouble must be in my hardware.

Thanks.
Back to top
View user's profile Send_private_message 
heywoodj

Joined: 15 Mar 2009
Posts: 68

PostPosted: Mon 05 Sep 2011, 13:27    Post_subject: Suspend using the lid switch  

I hope this is appropriate to ask, but I'm unable to suspend my laptop with the lid switch in Fluppy 013 but suspend works fine in your SnowPuppy 020.
The machine is a hp/Compaq nx6125 (1.6 GHz, 1.4GB RAM, 40 GB HDD w/ 1.5 GB swap), running Fluppy in a full install, SnowPuppy in a "cheat frugal" install.

I did a XfDiff on the lid.sh and sleep.sh files in each /etc/acpi and they were identical. So, where's the "special sauce" that makes SnowPuppy suspend work, but Fluppy just shuts off the screen, not able to return without some difficulty?

Thanks, HJ
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Mon 05 Sep 2011, 13:32    Post_subject:  

Check /etc/init.d/rc.apci and /etc/acpi/actions. There is also acpid binary demon, so just adding those scripts is probably not enough.
I think I used Shinobar`s acpid pet. You will find it by google from our forum.
I had double mechanism for lid suspending. Stuff from Fluppy, and stuff I added independently.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 44 of 46 Posts_count   Goto page: Previous 1, 2, 3, ..., 42, 43, 44, 45, 46 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1136s ][ Queries: 13 (0.0216s) ][ GZIP on ]