Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 21 Aug 2014, 18:07
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
how to disable the INSERT key? it kills Firefox [SOLVED]
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [16 Posts]   Goto page: 1, 2 Next
Author Message
Shep

Joined: 08 Nov 2008
Posts: 851
Location: GIRT-BY-SEA

PostPosted: Wed 22 Jun 2011, 08:57    Post subject:  how to disable the INSERT key? it kills Firefox [SOLVED]
Subject description: if I bump it in Firefox, the browser crashes
 

Often when I'm typing text into a box in Firefox I accidently tap the Insert key when I intend to hit backspace when correcting a typing mistake. Pressing the Inset key kills Firefox and I have to start it up afresh. This gets to be very tiresome.

I would like to permanently disable that key. (There is another Ins key on the numeric keypad, should I ever want that function.)

Ideally, the key need only be disabled when I'm in Firefox, but that is probably difficult to arrange, and I don't use the key much at other times, anyway. So a permanent solution is okay.

So, how to neuter the pesky Insert key Question

Last edited by Shep on Fri 24 Jun 2011, 08:20; edited 1 time in total
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 5085
Location: Charleston S.C. USA

PostPosted: Wed 22 Jun 2011, 10:55    Post subject:  

What version of Puppy?
The easy way. Physically remove the key from the keyboard.
Back to top
View user's profile Send private message 
Shep

Joined: 08 Nov 2008
Posts: 851
Location: GIRT-BY-SEA

PostPosted: Wed 22 Jun 2011, 11:23    Post subject:  

It's not a new problem, and has happened with every puppy I've ever used, AFAIR. Discovered some older posts that indicate this bug has characterised the Mozilla browsers since 2008, at least. http://www.murga-linux.com/puppy/viewtopic.php?t=65675

I'm currently using Wary 5.1.2

Q) How to emasculate the Insert key?
Back to top
View user's profile Send private message 
Dougal


Joined: 19 Oct 2005
Posts: 2505
Location: Hell more grotesque than any medieval woodcut

PostPosted: Wed 22 Jun 2011, 14:57    Post subject:  

Try this:
Code:
xmodmap -e "clear Insert"

If it works, you can put the expression (clear Insert) into /root/.Xmodmap (hidden file).

_________________
What's the ugliest part of your body?
Some say your nose
Some say your toes
But I think it's your mind
Back to top
View user's profile Send private message 
Bruce B


Joined: 18 May 2005
Posts: 11084
Location: The Peoples Republic of California

PostPosted: Wed 22 Jun 2011, 15:03    Post subject:  

If memory serves me well, Pizzasgood isolated the problem and came up with a fix.

~

_________________
New! Puppy Linux Links Page
Back to top
View user's profile Send private message 
Shep

Joined: 08 Nov 2008
Posts: 851
Location: GIRT-BY-SEA

PostPosted: Thu 23 Jun 2011, 00:52    Post subject:  

Dougal wrote:
Try this:
Code:
xmodmap -e "clear Insert"

If it works, you can put the expression (clear Insert) into /root/.Xmodmap (hidden file).

Code:
#  xmodmap -e "clear Insert"
xmodmap:  commandline:1:  bad clear modifier name 'insert'
xmodmap:  1 error encountered, aborting.

Code:
#  xmodmap -grammar         
xmodmap accepts the following input expressions:

    pointer = default              reset pointer buttons to default
    pointer = NUMBER ...           set pointer button codes
    keycode NUMBER = [KEYSYM ...]  map keycode to given keysyms
    keysym KEYSYM = [KEYSYM ...]   look up keysym and do a keycode operation
    clear MODIFIER                 remove all keys for this modifier
    add MODIFIER = KEYSYM ...      add the keysyms to the modifier
    remove MODIFIER = KEYSYM ...   remove the keysyms from the modifier

where NUMBER is a decimal, octal, or hex constant; KEYSYM is a valid
Key Symbol name; and MODIFIER is one of the eight modifier names:  Shift,
Lock, Control, Mod1, Mod2, Mod3, Mod4, or Mod5.  Lines beginning with
an exclamation mark (!) are taken as comments.  Case is significant except
for MODIFIER names.

Keysyms on the left hand side of the = sign are looked up before any changes
are made; keysyms on the right are looked up after all of those on the left
have been resolved.  This makes it possible to swap modifier keys.

Thanks. If not feasible to disable it, i'd be perfectly happy for it to function identically to the Backspace key, as it's always when I'm trying to jab the Backspace key that I miss the mark and hit Insert.
Back to top
View user's profile Send private message 
Shep

Joined: 08 Nov 2008
Posts: 851
Location: GIRT-BY-SEA

PostPosted: Thu 23 Jun 2011, 02:41    Post subject:  

This looks like it's going to work:
Code:
  xmodmap -e "keysym Insert = BackSpace"

The Insert key becomes a second Backspace key. Smile
Back to top
View user's profile Send private message 
Dougal


Joined: 19 Oct 2005
Posts: 2505
Location: Hell more grotesque than any medieval woodcut

PostPosted: Thu 23 Jun 2011, 14:24    Post subject:  

Shep wrote:
This looks like it's going to work:
Code:
  xmodmap -e "keysym Insert = BackSpace"

The Insert key becomes a second Backspace key. Smile

Even easier (I just tried it and it works):
Code:
xmodmap -e "keysym Insert ="
You can check if it worked with
Code:
 xmodmap -pk | grep Insert

_________________
What's the ugliest part of your body?
Some say your nose
Some say your toes
But I think it's your mind
Back to top
View user's profile Send private message 
Bruce B


Joined: 18 May 2005
Posts: 11084
Location: The Peoples Republic of California

PostPosted: Thu 23 Jun 2011, 14:48    Post subject:  

1) I hated it when the insert killed the browser because it happened when an edit window was open and all the editing gets lost. Also, even without losing text, it is down right annoying.

2) Pizzasgood made a fix and I looked for it and didn't find it. He hasn't been posting lately. However, it wouldn't hurt if someone sent him a PM asking about it.

3) Lupu 5.20 doesn't have the problem.

~

_________________
New! Puppy Linux Links Page
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 5085
Location: Charleston S.C. USA

PostPosted: Thu 23 Jun 2011, 15:37    Post subject:  

What version of Firefox?
I have Firefox 5.0 and the insert key seems to have no effect on Firefox for me.

Got Firefox 5 from here:
http://www.murga-linux.com/puppy/viewtopic.php?p=526013#526013
Back to top
View user's profile Send private message 
Shep

Joined: 08 Nov 2008
Posts: 851
Location: GIRT-BY-SEA

PostPosted: Thu 23 Jun 2011, 21:35    Post subject:  

bigpup wrote:
What version of Firefox?
I have Firefox 5.0 and the insert key seems to have no effect on Firefox for me.

Yes, but do you recognize the precise problem? It reveals itself at the most inconvenient time. Some people have never encountered it; I guess it's only us clumsy typists who keep tripping over that particular stumbling block. I'm still using old faithful 3.6.9
Quote:
Got Firefox 5 from here:
http://www.murga-linux.com/puppy/viewtopic.php?p=526013#526013

I'm a bit hesitant to do anything that risks introducing a new set of bugs. Rolling Eyes

Remember a few puppies back when closing a window that contained the flash player would often crash the browser? - and cleanup involved having to kill a residual mozilla process before the browser could even be started up again? Evil or Very Mad

I think I'll play it safe for now; might wait for version 7 before risking an upgrade Laughing Laughing

Last edited by Shep on Thu 23 Jun 2011, 22:01; edited 1 time in total
Back to top
View user's profile Send private message 
Shep

Joined: 08 Nov 2008
Posts: 851
Location: GIRT-BY-SEA

PostPosted: Thu 23 Jun 2011, 21:55    Post subject:  

Dougal wrote:
Even easier (I just tried it and it works):
Code:
xmodmap -e "keysym Insert ="
You can check if it worked with
Code:
 xmodmap -pk | grep Insert

Code:
# xmodmap -e "keysym Insert ="
xmodmap:  commandline:1:  bad keysym target keysym 'Insert', no corresponding keycodes
xmodmap:  1 error encountered, aborting.

It's still as I set it, emulating Backspace
Code:
# xmodmap -pk | grep Insert
     90       0xff9e (KP_Insert)   0xffb0 (KP_0)
Back to top
View user's profile Send private message 
Shep

Joined: 08 Nov 2008
Posts: 851
Location: GIRT-BY-SEA

PostPosted: Fri 24 Jun 2011, 07:43    Post subject:  

Dougal wrote:
Even easier (I just tried it and it works):
Code:
xmodmap -e "keysym Insert ="
You can check if it worked with
Code:
 xmodmap -pk | grep Insert

While that didn't work for me--apparently xmodmap knows of no "Insert" key here (strange)--the equivalent using keycode does work to silence that key:
Code:
 xmodmap -e "keycode 106 ="

The 'strictly correct' way to do this appears to be:
Code:
 xmodmap -e "keycode 106 = NoSymbol"

Thanks for your help.
Back to top
View user's profile Send private message 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Fri 24 Jun 2011, 08:38    Post subject:  

Pizzasgood solution
But only made and tested for 4.x.x as far as I can see.

_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send private message 
Dougal


Joined: 19 Oct 2005
Posts: 2505
Location: Hell more grotesque than any medieval woodcut

PostPosted: Fri 24 Jun 2011, 09:11    Post subject:  

Shep wrote:
Dougal wrote:
Even easier (I just tried it and it works):
Code:
xmodmap -e "keysym Insert ="
You can check if it worked with
Code:
 xmodmap -pk | grep Insert

While that didn't work for me--apparently xmodmap knows of no "Insert" key here (strange)--the equivalent using keycode does work to silence that key:
Code:
 xmodmap -e "keycode 106 ="

The 'strictly correct' way to do this appears to be:
Code:
 xmodmap -e "keycode 106 = NoSymbol"

Strange that you don't see Insert...
Code:
# xmodmap -pk | grep Insert
     90         0xff9e (KP_Insert)      0xffb0 (KP_0)   
    106         0xff63 (Insert)

Maybe you run it after already unsetting it somehow?

_________________
What's the ugliest part of your body?
Some say your nose
Some say your toes
But I think it's your mind
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 2 [16 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1269s ][ Queries: 12 (0.0349s) ][ GZIP on ]