Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 20 Oct 2014, 09:23
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Chromium 14 - Cutting Edge Development Release
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [27 Posts]   Goto page: 1, 2 Next
Author Message
playdayz


Joined: 25 Apr 2008
Posts: 3788

PostPosted: Mon 27 Jun 2011, 15:55    Post subject:  Chromium 14 - Cutting Edge Development Release
Subject description: The Open Source basis of Google Chrome
 

To run Chromium in Lucid, please read this message.
http://www.murga-linux.com/puppy/viewtopic.php?p=555500#555500

------------------------------------------------------------------------

Chromium 14 has made it easier to run as root. Thank you Chromium. This is a nightly build from JUN 28, 2011.

http://distro.ibiblio.org/puppylinux/pet-packages-lucid/Chromium-14-lucid525.pet

By request, here is an sfs version
http://distro.ibiblio.org/puppylinux/pet-packages-lucid/Chromium-14-lucid525.sfs

Both versions have been revised as Dave S explains below so there is only one menu entry. Also, the start page has been changed to the one Chromium wants to use, because sometimes it failed to open the Puppy home page.

The pet version uses the browse icon on the desktop and the menu--the sfs version uses only the menu. I don't know what kind of problems it might have, but it starts and runs youtube for me.

It is relatively easy to use the Chromium pet to keep updated with Chromium. Just download the latest nightly and extract--it will make a folder named chrome-linux.

Then just delete /usr/lib/chrome-linux and replace it with the new one you just downloaded and extracted.
http://build.chromium.org/f/chromium/snapshots/Linux/

Last edited by playdayz on Sun 21 Aug 2011, 20:37; edited 9 times in total
Back to top
View user's profile Send private message 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Mon 27 Jun 2011, 16:14    Post subject:  

I get curious if it is difficult to make an sfs out of a pet?

Pets kind of get into the pupsave file while an sfs can be used by many puppies that have SFStray or other such SFS loaders. Very practical.

_________________
I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send private message 
playdayz


Joined: 25 Apr 2008
Posts: 3788

PostPosted: Mon 27 Jun 2011, 17:01    Post subject:  

Quote:
I get curious if it is difficult to make an sfs out of a pet?

Pets kind of get into the pupsave file while an sfs can be used by many puppies that have SFStray or other such SFS loaders. Very practical.


Not difficult. Let's see how long it takes.
Mon Jun 27, 2011 5:00 pm

It's done
Mon Jun 27, 2011 5:03 pm Wink

It will take a few minutes to upload.

While we are waiting, here's the easy way to make any pet into an sfs.

1. Change the extension of the pet to tgz
2. Click the tgz file and extract
3. open a terminal in the directory that contains the extracted folder and enter
Code:
mksquashs nameofthepetfolder nameofthepetfolder.sfs -noI


Pets and sfs are not totally equivalent. For instance, in the Chromium pet the browse icon on the desktop works to start Chromium, but in the sfs it does not--you have to use the menu entry. The reason is that, as I understand it, pets will overwrite files, but sfs's won't.

The -noI parameter is something that seems to work for me to make reliable sfs's. As I understand it, it prevents the inode names or something from being compressed.

All done and uploaded
Mon Jun 27, 2011 5:22 pm

http://distro.ibiblio.org/puppylinux/pet-packages-lucid/Chromium-14-lucid525.sfs
.
Back to top
View user's profile Send private message 
maxpro4u


Joined: 19 Jun 2010
Posts: 290
Location: Rittman,Ohio,USA, In dog years,I'm dead

PostPosted: Mon 27 Jun 2011, 17:28    Post subject:  

I installed in on 5.2.5 and it doesn't start. What am I missing?
_________________
Dell D610 1.7M w/1024mb
Testing Slacko and a few others
I'm Max Wachtel and I approve this message.
Registered Linux User #393236
Back to top
View user's profile Send private message Visit poster's website Yahoo Messenger MSN Messenger 
playdayz


Joined: 25 Apr 2008
Posts: 3788

PostPosted: Mon 27 Jun 2011, 19:12    Post subject:  

Quote:
I installed in on 5.2.5 and it doesn't start. What am I missing?

The pet or the sfs? If the sfs use the menu entry to try to start.
Back to top
View user's profile Send private message 
maxpro4u


Joined: 19 Jun 2010
Posts: 290
Location: Rittman,Ohio,USA, In dog years,I'm dead

PostPosted: Mon 27 Jun 2011, 19:14    Post subject:  

playdayz wrote:
Quote:
I installed in on 5.2.5 and it doesn't start. What am I missing?

The pet or the sfs? If the sfs use the menu entry to try to start.


the pet. -full install of 5.2.5

_________________
Dell D610 1.7M w/1024mb
Testing Slacko and a few others
I'm Max Wachtel and I approve this message.
Registered Linux User #393236
Back to top
View user's profile Send private message Visit poster's website Yahoo Messenger MSN Messenger 
playdayz


Joined: 25 Apr 2008
Posts: 3788

PostPosted: Mon 27 Jun 2011, 19:19    Post subject:  

I don't know. I just installed the pet on a pristine frugal install of 5.2.5 and it worked.

Try this: go to the directory /usr/lib/chrome-linux and click chrome-wrapper. It should say, Chromium cannot be run as root. OK. Then open a terminal in that directory and enter
Code:
./chrome-wrapper --user-data-dir=/root/chromium14


Open a terminal by right-clicking while your cursor is in the directory, then choose Window -> Terminal here.
Back to top
View user's profile Send private message 
maxpro4u


Joined: 19 Jun 2010
Posts: 290
Location: Rittman,Ohio,USA, In dog years,I'm dead

PostPosted: Mon 27 Jun 2011, 19:41    Post subject:  

playdayz wrote:
I don't know. I just installed the pet on a pristine frugal install of 5.2.5 and it worked.

Try this: go to the directory /usr/lib/chrome-linux and click chrome-wrapper. It should say, Chromium cannot be run as root. OK. Then open a terminal in that directory and enter
Code:
./chrome-wrapper --user-data-dir=/root/chromium14


Open a terminal by right-clicking while your cursor is in the directory, then choose Window -> Terminal here.


clicking chrome-wrapper did nothing

_________________
Dell D610 1.7M w/1024mb
Testing Slacko and a few others
I'm Max Wachtel and I approve this message.
Registered Linux User #393236
Back to top
View user's profile Send private message Visit poster's website Yahoo Messenger MSN Messenger 
playdayz


Joined: 25 Apr 2008
Posts: 3788

PostPosted: Mon 27 Jun 2011, 20:04    Post subject:  

Quote:
clicking chrome-wrapper did nothing

OK. what about the rest?

Is it possible you have installed and uninstalled pets on this full install? But giving the command in a terminal should show if any libraries are missing.
Back to top
View user's profile Send private message 
dawnsboy


Joined: 03 Dec 2008
Posts: 248
Location: Indiana - Republic of New Canada

PostPosted: Mon 27 Jun 2011, 21:29    Post subject:  

I downloaded the .pet and manually inserted it into Rexbang 2.3.3 in place of google-chrome 12.

So far so good. None of the issues that I have experienced with versions 11 or 12 have presented as yet.

Thank you playdayz!
Back to top
View user's profile Send private message 
maxpro4u


Joined: 19 Jun 2010
Posts: 290
Location: Rittman,Ohio,USA, In dog years,I'm dead

PostPosted: Mon 27 Jun 2011, 21:35    Post subject:  

yes I have installed/uninstalled several things. Chromium7 installed and works fine. 14 added 2 entries to the internet and 2 to the network menus and none start it.

bash: /chrome-wrapper: No such file or directory

_________________
Dell D610 1.7M w/1024mb
Testing Slacko and a few others
I'm Max Wachtel and I approve this message.
Registered Linux User #393236
Back to top
View user's profile Send private message Visit poster's website Yahoo Messenger MSN Messenger 
playdayz


Joined: 25 Apr 2008
Posts: 3788

PostPosted: Mon 27 Jun 2011, 22:33    Post subject:  

Quote:
/chrome-wrapper: No such file or directory


Should be in /usr/lib/chrome-linux/. If it is not then something went wrong with the installation of the pet.
Back to top
View user's profile Send private message 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Tue 28 Jun 2011, 00:46    Post subject:  

Great thanks playdayz for the SFS. I did a test using SFStray SFS loader and it works but as usual act up in a typical C. way. Refuses to find pages and one have to kill them and start all over and write www. and try again and kill them again and then suddenly it do accept to show some sites like streaming video on a local TV station but then refuses to show youtube and one have no idea why and one test Opera 11 SFS and that one instantly just works. So it is kind of a roller coaster ride. Smile

Much appreciated you described how to and uploaded it.

_________________
I use Google Search on Puppy Forum
not an ideal solution though

Last edited by nooby on Wed 29 Jun 2011, 08:48; edited 1 time in total
Back to top
View user's profile Send private message 
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Tue 28 Jun 2011, 02:42    Post subject:  

Running fine in Spup though it needs a lib pack. Some strange behavior with a double menu entry though.
_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send private message 
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Tue 28 Jun 2011, 03:35    Post subject:  

Bum... spoke too soon. Its nagging me over the Flash plugin being out of date Smile
_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 2 [27 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0775s ][ Queries: 12 (0.0040s) ][ GZIP on ]