Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 17 Apr 2014, 23:18
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Graphics
Ufraw: Digital camera raw image utility & gimp-plugin for p4
Post new topic   Reply to topic View previous topic :: View next topic
Page 4 of 4 [52 Posts]   Goto page: Previous 1, 2, 3, 4
Author Message
Mmmm

Joined: 15 Jun 2010
Posts: 22

PostPosted: Tue 07 Jun 2011, 10:08    Post subject:  

nope... no gimp-2.0.pc file and no gimp 2.0 directory either.. I have /usr/share/gimp/2.0 and /usr/lib/gimp/2.0/
The libs in /usr/lib seem to be there..

Bit of a mess then is it?
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6666
Location: lisbon

PostPosted: Tue 07 Jun 2011, 11:07    Post subject:  

No, you just need to download the missing development files. You could download the gimp source package, with same version number, and copy across include files, or it might be simpler to dload & use:

http://distro.ibiblio.org/pub/linux/distributions/puppylinux/pet-packages-lucid/Gimp-Full-2.6.10-Lucid.sfs
Back to top
View user's profile Send private message 
Mmmm

Joined: 15 Jun 2010
Posts: 22

PostPosted: Tue 07 Jun 2011, 16:05    Post subject:  

That sfs file you mention appears to be the same as the one I am already using...!! Does that sound possible to you?

Going the source route, how do I get the development files that I need? do I have to configure and make first or are they just sitting there already waiting to be moved? How do I know which ones I need?

Sorry for all the questions but I'd really love to be able to do this sort of stuff...
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6666
Location: lisbon

PostPosted: Tue 07 Jun 2011, 19:09    Post subject:  

Oh, I thought the Full, in Gimp-Full-2.6.10-Lucid.sfs, usually meant it has all the development stuff. Anyway you could use this instead:

http://ftp.us.debian.org/debian/pool/main/g/gimp/libgimp2.0-dev_2.6.10-1_i386.deb
Back to top
View user's profile Send private message 
Mmmm

Joined: 15 Jun 2010
Posts: 22

PostPosted: Wed 08 Jun 2011, 04:52    Post subject:  

Aha... that did the trick...
So, I can install deb files too?!!

thanks muggins, you've been really helpful..
Much appreciated
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6666
Location: lisbon

PostPosted: Wed 08 Jun 2011, 07:10    Post subject:  

Good to hear. Generally you'll find most debian compiled apps will work with puppy, just that sometimes you might need to do a bit of a search for missing libraries and, rarely, the incompatibilities are too much. But in this case it wasn't a compiled app, just a source file.
Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 1214
Location: Queensland Australia ɹǝpu∩uʍop

PostPosted: Wed 29 Jun 2011, 00:24    Post subject:  

Mmmm wrote:
gimp works if I start in Gimp, but if I start in ufraw and press the gimp button it says it cant find gimp-remote....


I had that problem too, run ufraw go to options , settings, remote gimp command and type "gimp" not "gimp-remote",
then it works or open the .ufrawrc file in root and edit it there " <RemoteGimpCommand>gimp</RemoteGimpCommand> "
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 4 of 4 [52 Posts]   Goto page: Previous 1, 2, 3, 4
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Graphics
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0443s ][ Queries: 13 (0.0051s) ][ GZIP on ]