Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 25 Nov 2014, 23:58
All times are UTC - 4
 Forum index » House Training » HOWTO ( Solutions )
Puppy 2.01 and the International Keyboard - How to
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count_1  
Author Message
dewdrop


Joined: 29 Aug 2005
Posts: 298
Location: Texas USA

PostPosted: Mon 19 Jun 2006, 20:51    Post_subject:  Puppy 2.01 and the International Keyboard - How to  

Hi Pups,


////////Edited on 6-24-06 after reading another thread which mentioned it........

You must be in XORG for this to work. Xvesa doesn't work.

//////end of edit

Here's a way to get your keyboard working in 2 languages without using the Command Line (I don't really know how to use it, so I did the following and it worked for me)... Smile It also worked in Puppy 2.00.

Step 1

Go to this website and download the xkb_108.tar.gz file as directed

http://www.murga.org/~puppy/viewtopic.php?t=6396

pakt's post

Sat Feb 25, 2006 10:53 am Post subject: Fix for int'l keyboards (Xkb) in Puppy 108/108r1 - Rev1

at the bottom of the first post is the entry where to get the necessary file...


The forum's storage space for attachments seems to be full, so Mark (MU) has kindly offered to store xkb_108.tar.gz on his website.
You can download it here

click on the word here, and save the file to your hard drive.

Step 2


The file was automatically saved to my my-documents directory. Left click on the xkb_108.tar.gz file.

This will bring up the XArchive program and you should on Select All, then click on Extract.

You should see a directory (file folder) called usr in your my-documents directory (pass your mouse over the open my-documents directory so the usr folder will appear.

Step 3

Go to /etc/X11/xkb

Drag the usr directory from the my-documents directory to the /etc/X11/xkb directory. Close both directories.

Step 4

Go to /etc/X11 and left click the mouse on xorg.conf. This will cause it to open.

Search for the entry that starts:
Section "InputDevice"
Identifier "Keyboard0"

and erase the entry starting at
Section "inputDevice"
and ending with
EndSection

Step 5

Copy and paste the following into that area you just removed:

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us, il" ### CHANGE il TO YOUR LANGUAGE CODE ###
Option "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll,caps:shift,altwin:menu"
EndSection


Change the "il" to your language code - I use "latam" for Latin America rather than es for Spain, because of the keyboards sold in Latin America...they have a specific combination of keys to get the right accent mark over the letters a e i o u. The key combination is different for Spain, but the results are the same.

Be sure to leave the quote marks around the 2 languages selected.

Step 6

Save the document as xorg.conf , and close the directory.

Step 7

Reboot your computer.

The keyboard should now be able to be switched between English and whatever other language you chose (my case was latam for Spanish - Latin America key combination).

To switch between languages:::
left shift key/alt key combination.


dewdrop
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count_1  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » HOWTO ( Solutions )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0642s ][ Queries: 12 (0.0230s) ][ GZIP on ]