Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 20 Sep 2014, 16:09
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Dpup Exprimo 5.X.15
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 6 of 148 [2207 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, ..., 146, 147, 148 Next
Author Message
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Mon 01 Aug 2011, 16:19    Post subject:  

BUM!
nowifi.png
 Description   
 Filesize   23.99 KB
 Viewed   928 Time(s)

nowifi.png


_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Mon 01 Aug 2011, 16:22    Post subject:  

Dave S. Next build will have only main sfs without separate kernel modules and firmware z....sfs
Back to top
View user's profile Send private message 
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Mon 01 Aug 2011, 16:35    Post subject:  

pemasu wrote:
Dave S. Next build will have only main sfs without separate kernel modules and firmware z....sfs


Cool........

_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send private message 
Jim1911

Joined: 19 May 2008
Posts: 2457
Location: Texas, USA

PostPosted: Mon 01 Aug 2011, 17:12    Post subject:  

Hi pemasu,

Frugal installation is working great, and you have corrected some problems for Iguleder. Still a few concerns:

1. glx-gears is not present

2. Drive partitions are recognized and mounted properly, including ntfs, however gparted is the old version 0.7.0.

3. Uget 1.8.0 does not download files, it just stalls, see attached.

4. The latest NVIDIA-Linux-x86-280.13 driver which installed fine in your last version will not install in 5.0.0.2, and gives the same error that you corrected earlier by recompiling the kernel. Because of this error reintroduction, the Current Operating System: Linux puppypc 2.6.39 #1 SMP Fri Jul 15 19:38:53 GMT-8 2011 i686 may not be your latest kernel version.

Cheers,
Jim
uget-1.8.0.jpg
Description 
jpg

 Download 
Filename  uget-1.8.0.jpg 
Filesize  39.57 KB 
Downloaded  151 Time(s) 
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Mon 01 Aug 2011, 17:33    Post subject:  

Jim1911. Install mesa-tools from the repo and you get glxgears and glxinfo. I think I posted about it earlier.

Uget. I havent used it before. It is Iguleders compile. Maybe I am missing some libs, I need to check. My lucid puppy uget needed libcurl-gnutls which is not included. I need to ldd uget to get more info. Good pick. Thanks.

About kernel. That is weird. The kernel is definitively the same. I dont know what caused the failure. You could try in /usr/src/linux folder run in console: make clean and make prepare .

Anyway. I will soon. Probably tomorrow make next woof build.
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Mon 01 Aug 2011, 17:53    Post subject:  

Hah. I removed fbdev_drv.so. It is possibly needed for Nvidia compiling. It interferes Nvidia kernel module loading but it is possibly needed for compiling. I dont know.
Jim1911. Could you install this pet and try the compiling again. The pet has that fbdev_drv.so back.
fbdev-0.0.1.pet
Description 
pet

 Download 
Filename  fbdev-0.0.1.pet 
Filesize  8.46 KB 
Downloaded  137 Time(s) 
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Mon 01 Aug 2011, 18:08    Post subject:  

I just booted Iguleders squeeze dpup. Uget is stalled in it also. So the Uget compile has not been succesful or there is some unmet dependency which ldd does not show. Need to dig deeper.
Back to top
View user's profile Send private message 
Jim1911

Joined: 19 May 2008
Posts: 2457
Location: Texas, USA

PostPosted: Mon 01 Aug 2011, 18:17    Post subject:  

Installed your fbdev_drv.so pet. Still get ERROR: Unable to find the system utility 'ldconfig'; please make sure that you have 'glibc' installed. If you do have glibc install then please check that you do have ldconfig in your path.

Ldconfig is a dir that only contains an aux-catche file, so that may be the problem. See image.
image-1.jpg
Description 
jpg

 Download 
Filename  image-1.jpg 
Filesize  119.81 KB 
Downloaded  143 Time(s) 
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Mon 01 Aug 2011, 18:23    Post subject:  

No reason to chase the error more. I will make new build tomorrow. It will have z...sfs moved to the main sfs.
I believe that quick update with edit sfs was reason to your compile failure.
I havent removed anything else than fbdev and nouveau kernel module since I believed that they just disturb nvidia loading.
About that fbdev I am not so sure anymore.
Back to top
View user's profile Send private message 
Jim1911

Joined: 19 May 2008
Posts: 2457
Location: Texas, USA

PostPosted: Mon 01 Aug 2011, 18:34    Post subject:  

I ran into a more serious problem. I installed a glibc pet that I have, reran sh NVIDIA-Linux-x86-280.13.run which still failed. Then I went to ppm to remove the glibc pet that I'd installed. PPM corrupted my save file and froze the system, only out was to shut down power.

Thanks for getting rid of nouveau, it's been a continuing headache with my hardware.

I"ll wait for your next build. Isn't bug squashing fun!

Cheers,
Jim
Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 5757
Location: Kentucky

PostPosted: Mon 01 Aug 2011, 18:41    Post subject:  

Attempted Squeeze 500 in this old dual-core however X would not start. Reverted back to iguleder's 4.99.1 Enlightenment build (2.6.39.3) and posting from it now.


VIDEO REPORT: Puppy Squeeze, version 4.9.9.1

Chip description:
oem: NVIDIA
product: MCP61 - mcp61-86 Chip Rev

Driver used by Xorg:
nv

Video mode used by Xorg:
Resolution: Depth 24 Depth: "Display"

...the above also recorded in /tmp/report-video
#



Processor : 2x AMD Athlon(tm) 64 X2 Dual Core Processor 5200+
Memory : 3374MB (235MB used)
Operating System : Unknown distribution
User Name : root (root)
Date/Time : Mon 01 Aug 2011 05:52:13 PM CDT
-Display-
Resolution : 1440x900 pixels
OpenGL Renderer : Unknown
X11 Vendor : The X.Org Foundation
-Multimedia-
Audio Adapter : (null)

Audio device : nVidia Corporation MCP61 High Definition Audio
VGA compatible controller : nVidia Corporation C61 [GeForce 7025 / nForce 630a]

# free
total used free shared buffers
Mem: 3374988 473312 2901676 0 49240
Swap: 4198396 0 4198396
Total: 7573384 473312 7100072
#
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Mon 01 Aug 2011, 18:46    Post subject:  

Thanks Jim1911 of being patient with my experiments.
Anyway, quite a many bugs have been found and many of them has been fixed. I have now almost done the e17 pet which has those modified scripts included.

I just would need nice wm switcher gui.

If I promise to include all PupApps to the dpup, maybe radky could include e17 to the wm switcher or is it there already ?
Back to top
View user's profile Send private message 
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Mon 01 Aug 2011, 18:53    Post subject:  

pemasu wrote:
Thanks Jim1911 of being patient with my experiments.
Anyway, quite a many bugs have been found and many of them has been fixed. I have now almost done the e17 pet which has those modified scripts included.

I just would need nice wm switcher gui.

If I promise to include all PupApps to the dpup, maybe radky could include e17 to the wm switcher or is it there already ?


Can you adapt this:

http://www.murga-linux.com/puppy/viewtopic.php?p=533037#533037

_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send private message 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Mon 01 Aug 2011, 18:55    Post subject:  

I installed the 500.2 FRUGAL Lin'N'Win
It eats 7MB more from the save file compared to 500.
Didn't succeed in knowing where and why.
The application environment is activated and working.

_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Mon 01 Aug 2011, 18:57    Post subject:  

Thanks Dave S. I will give it a shot. It sure looks good candidate.

Probably launching e17 from jwm works with small adaptation quite easily. To get back from e17 to jwm is another story. I have used so far e17 next to not at all.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 6 of 148 [2207 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, ..., 146, 147, 148 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0955s ][ Queries: 13 (0.0227s) ][ GZIP on ]