Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 03 Sep 2014, 01:27
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Wary Puppy 5.1.4 - 29 August 2011
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 13 of 29 [425 Posts]   Goto page: Previous 1, 2, 3, ..., 11, 12, 13, 14, 15, ..., 27, 28, 29 Next
Author Message
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Tue 19 Jul 2011, 16:50    Post subject: Re: Some apis in Wary512 won't close: have to kill
Subject description: One of them is wvdial but has happened with others
 

benny7440 wrote:
I'm not sure if I'm posting in the correct forum &, if I'm, I'm sorry: redirect me to the correct one or move to an appropriate location.

Since my main email acct. is from yahoo & they're changing their service soon to a newer version that requires updated browsers & my Seamonkey one is the 1.1.18 version, which is not a recent one, I need to change.

The other day I decided to accept the browser's recommendation of d/l an update but it didn't work out well, so I decided to give it another chance by doing it manually directly from the Mozilla site. I followed their instructions but the newer version never launched after trying in various ways. Today I tried a previously d/l FF 5.* pet file &, even though it installed correctly & an icon appeared in the Internet tab from the main Menu, it never launched either. Even more, the icon disappeared from its place.

I then went to the repo & selected Seamonkey 2.0.11 & installed it, I'm sure the original browser was still running while the new one was been installed. It never launched, either.

What to do in this case?


This gives you a bit more info, from a few posts above this one http://www.murga-linux.com/puppy/viewtopic.php?p=545352#545352
dbus is the problem.

_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5246
Location: Australia

PostPosted: Fri 22 Jul 2011, 21:31    Post subject:  

Here is the older version of the Ralink rt3070sta driver, to support "middle-era" Ralink-based (RT2070/RT3070) USB wifi devices. These older devices appear to not work properly with the latest rt3370sta driver.
I patched the source code to additionally support these devices:
- Linksys-WUSB100-V2 USB ID 1737:0078
- TP-Link TL-WN321G & older Tenda W541U USB ID 148F:2070

I don't have a Wary development installation, so the driver was graciously compiled by rcrsn51.
rt3070sta-k2.6.32.pet
Description  ONLY for Wary 5.1.x
pet

 Download 
Filename  rt3070sta-k2.6.32.pet 
Filesize  279.21 KB 
Downloaded  386 Time(s) 
Back to top
View user's profile Send private message 
Snail

Joined: 18 Oct 2009
Posts: 238

PostPosted: Wed 27 Jul 2011, 20:52    Post subject: Wrong thread  

sorry Sad
Back to top
View user's profile Send private message 
PANZERKOPF

Joined: 16 Dec 2009
Posts: 280
Location: Earth

PostPosted: Thu 28 Jul 2011, 09:55    Post subject:  

The Remasterpup2 crashes when iso file is mounted.
Incorrect definition of variable: "VIRTUALCD".
Code:

VIRTUALCD=$(mount -t iso9660|grep '^/dev/loop' | sed -e 's/on[ ].*+//' -e 's/[ ]type[ ]iso9660[ ].*$//')

When we mount some iso file as loop device, this variable has three "words" :
"device" "on" "mountpoint". This is incompatible with Xdialog because it needs
tag and item fields of each choice: "device" "mountpoint" .
Example:
Code:

VIRTUALCD=`grep -E "loop.*iso9660" /proc/mounts | cut -f 1-2 -d ' ' | tr '\n' ' '` 

Making "tr" at end of construction prevents crash if we have mounted many iso files.

_________________
SUUM CUIQUE.
Back to top
View user's profile Send private message 
wanderer

Joined: 20 Oct 2007
Posts: 229

PostPosted: Fri 29 Jul 2011, 22:34    Post subject: wary 512 bug
Subject description: mpg wont play in full screen
 

hi guys

puppy is the greatest

and it is the only distro I use

however I have a problem

wary 512 won't play mpg in full screen

just opens a little box

wmv plays full screen automatically

on a related note

ever since puppy 5

I have had video problems of one kind or another

with every variety upup dpup quirky and wary

sometimes the video will crash and need a reboot

sometimes the video will not play full screen

sometimes different resolutions won't work

p217 p301 p400

and 214x from tux work fine

I am now using 214xtop7

thanks a million tux

for developing the 2 series

but back to the video thing

whats the problem

xorg change? media player change?

if anyone can give me any info I would appreciate it

thanks

wanderer
Back to top
View user's profile Send private message 
sandungas

Joined: 22 May 2010
Posts: 59

PostPosted: Tue 02 Aug 2011, 09:24    Post subject:  

I found a bug in wary 5.1.1 (probably is in 5.1.2 too and inherited in other puppyes)

Is in the "grub legacy bootloader config"...
It gives an error when trying to find windows partitions
This only happen in "expert mode" so probably nobody noticed because "simple" mode works fine (in fact by using simple mode you can find windows, but in expert mode dont)
Back to top
View user's profile Send private message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Sun 07 Aug 2011, 18:49    Post subject: Re: separate synaptics from xorg  

broomdodger wrote:
This trackpad is driving me nuts.

It seems the synaptics driver is some how connected to xorg.

/usr/X11R7/lib/xorg/modules/input/synaptics_drv.so
/usr/X11R7/lib/xorg/modules/input/synaptics_drv.la

Can it be separated?

Can disable trackpad tapping be added to:

Menu > Desktop > pupX set properties of X


Xvesa has many limitations, it should only be used as a last resort. Touchpad configuration is one of them. If you can't get a hardware-specific Xorg driver for your video, the Xorg vesa driver usually works, and Flsynclient will work for it.

_________________
http://bkhome.org/news/
Back to top
View user's profile Send private message Visit poster's website 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Sun 07 Aug 2011, 19:03    Post subject: Re: Wary Puppy 5.1.2 final
Subject description: fix for geany_socket error
 

L18L wrote:
aragon,
you have made me check this once again and I have found my solution was not perfect. It was a quickshot because I had solved the same problem in another distro before.

Here is the better puppy solution:

append
Code:
# delete any existing geany_socket.* that might exist from last session
rm /tmp/geany_socket*
rm /root/.config/geany/geany_socket*

to /etc/rc.d/rc.local

#rm $HOME/.config/geany/geany_socket* # does NOT work there is no HOME in rc.local

Yes, /tmp should be cleaned up completely on shutdown!
But it is not.
Maybe because fido was shutting down?

Deleting the sockets at start is in every case (think about unproper shutdown, power failure) efficient.

Anyhow, Barry is wanting solutions for fido, not problems.
And he might put the 2 lines into rc.sysinit

Thanks again for your feedback

Edited
Rethinking about it...
It is NOT the solution, just a workarund Embarassed


Thanks for the feedback, I have put your "workaround" into /etc/rc.d/rc.shutdown, about line 1067:

Code:
#when the working files run in tmpfs in ram, they are saved above and /tmp and /var
#are screened out. however, some PUPMODES mount ${DISTRO_FILE_PREFIX}save.2fs directly on /initrd/pup_rw,
#the top unionfs layer, meaning that there is no intermediary tmpfs in ram for working
#files, hence everything is saved directly, ditto for PUPMODE=2 a full h.d. install.
#hence need to do some explicit wiping here...
echo -n "" > /var/log/messages #delete, as it keeps growing.(note choosepartfunc uses this)
rm -f /var/log/X*
rm -rf /tmp/*
rm -f /var/lock/LCK*
rm -f /var/run/*.pid
rm -rf /root/tmp 2> /dev/null #...note, not screening this out in any of above save modes.
rm -rf /root/.thumbnails/* 2> /dev/null
[ -d /var/tmp ] && rm -rf /var/tmp/* 2> /dev/null #100820
#110808 L18L if geany still running at shutdown, need these...
rm -f /tmp/geany_socket* 2>/dev/null
[ -d /root/.config/geany ] && rm -f /root/.config/geany/geany_socket* 2>/dev/null
sync

_________________
http://bkhome.org/news/
Back to top
View user's profile Send private message Visit poster's website 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Sun 07 Aug 2011, 19:06    Post subject:
Subject description: 5.1.2 final - browser suite- PPM GUI
 

dogle wrote:
I was pleased with Barry's choice of old Seamonkey + Adblock, a combination with which I have long been happy.

1. Although I find Adblock very useful in its own right, it is my understanding (correction welcome!) that Adblock suppresses display of barred material, but does not necessarily prevent it being downloaded at your expense. OTOH, Sc0ttman's excellent Puppy Advert Blocker operating via the hosts file prevents the unwanted download, a great boon if you are lumbered with slow/expensive download capability (as many are). I wondered therefore whether Barry might have seen fit to elevate the Puppy Advert Blocker to official PET status - so I went into Puppy Package Manager to check but no, it's not there.

2. I was finding that the 'cancel' button in the PPM was not working, very annoying, I was having to invoke kill to get out of it. Experimenting further, I found said button did work if I clicked in the extreme top left of the rectangle. I deduce that there is some slight misalignment either in my test box or in the latest GUI, anyone else experiencing this?


Puppy Advert Blocker is in Wary 5.1.2, see Internet menu.

_________________
http://bkhome.org/news/
Back to top
View user's profile Send private message Visit poster's website 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Sun 07 Aug 2011, 19:35    Post subject: Re: vobcopy  

rodin.s wrote:
I was testing pdvdsub and found an error:
Code:
vobcopy: error while loading shared libraries: libdvdread.so.3: cannot open shared object file: No such file or directory

I've made a link to fix it:
Code:
ln -s /usr/lib/libdvdread.so.4.1.2 /usr/lib/libdvdread.so.3

Also window dvd-info doesn't close by clicking QUIT button. No big deal though. It could be closed usual way.


Thanks, symlink created.

_________________
http://bkhome.org/news/
Back to top
View user's profile Send private message Visit poster's website 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Sun 07 Aug 2011, 20:00    Post subject:  

PANZERKOPF wrote:
The Remasterpup2 crashes when iso file is mounted.
Incorrect definition of variable: "VIRTUALCD".
Code:

VIRTUALCD=$(mount -t iso9660|grep '^/dev/loop' | sed -e 's/on[ ].*+//' -e 's/[ ]type[ ]iso9660[ ].*$//')

When we mount some iso file as loop device, this variable has three "words" :
"device" "on" "mountpoint". This is incompatible with Xdialog because it needs
tag and item fields of each choice: "device" "mountpoint" .
Example:
Code:

VIRTUALCD=`grep -E "loop.*iso9660" /proc/mounts | cut -f 1-2 -d ' ' | tr '\n' ' '` 

Making "tr" at end of construction prevents crash if we have mounted many iso files.


Thanks, fixed.

_________________
http://bkhome.org/news/
Back to top
View user's profile Send private message Visit poster's website 
tempestuous

Joined: 10 Jun 2005
Posts: 5246
Location: Australia

PostPosted: Mon 08 Aug 2011, 07:33    Post subject:  

Barry (and rerwin)
I now have two reports of the modules-preference setting failing in Lucid, and this bug may be carried over to Wary/Quirky/Woof;

my Ralink rt3070sta driver dotpet includes a modified /etc/rc.d/MODULESCONFIG with these lines:
rt2800usb:rt3070sta
rt2870sta:rt3070sta
but after forum member Rafal07BC installed this driver, the rt2800usb driver continued to load, and he only sorted out the problem by blacklisting the rt2800usb module -
http://www.murga-linux.com/puppy/viewtopic.php?p=548374#548374

and aarf tried to set this line in modules-preference "rt2800usb:rt2870sta"
but after a reboot, both modules were still loaded -
http://www.murga-linux.com/puppy/viewtopic.php?p=551308#551308
and again, he had to blacklist the rt2800usb driver.
Back to top
View user's profile Send private message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Mon 08 Aug 2011, 16:05    Post subject:  

tempestuous wrote:
Here is the older version of the Ralink rt3070sta driver, to support "middle-era" Ralink-based (RT2070/RT3070) USB wifi devices. These older devices appear to not work properly with the latest rt3370sta driver.
I patched the source code to additionally support these devices:
- Linksys-WUSB100-V2 USB ID 1737:0078
- TP-Link TL-WN321G & older Tenda W541U USB ID 148F:2070

I don't have a Wary development installation, so the driver was graciously compiled by rcrsn51.


tempestuous,
Would you mind sending me the patched source. I can add this to the fully automatic build scripts that I have for the 2.6.32.x kernel. As it will conflict with the regular rt drivers, I will get the script to automatically create a PET for your driver.

See details of the 2.6.32.43 source and build scripts:
http://bkhome.org/blog/?viewDetailed=02388

_________________
http://bkhome.org/news/
Back to top
View user's profile Send private message Visit poster's website 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Mon 08 Aug 2011, 16:14    Post subject:  

tempestuous wrote:
Barry (and rerwin)
I now have two reports of the modules-preference setting failing in Lucid, and this bug may be carried over to Wary/Quirky/Woof;

my Ralink rt3070sta driver dotpet includes a modified /etc/rc.d/MODULESCONFIG with these lines:
rt2800usb:rt3070sta
rt2870sta:rt3070sta
but after forum member Rafal07BC installed this driver, the rt2800usb driver continued to load, and he only sorted out the problem by blacklisting the rt2800usb module -
http://www.murga-linux.com/puppy/viewtopic.php?p=548374#548374

and aarf tried to set this line in modules-preference "rt2800usb:rt2870sta"
but after a reboot, both modules were still loaded -
http://www.murga-linux.com/puppy/viewtopic.php?p=551308#551308
and again, he had to blacklist the rt2800usb driver.


tempestuous,
aarf posted to my blog about this, and I posted a reply there:

http://bkhome.org/blog/?viewDetailed=02389

To be more specific, Lucid is using the Woof release of February 28, 2011. A lot of water under the bridge since then!

_________________
http://bkhome.org/news/
Back to top
View user's profile Send private message Visit poster's website 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Mon 08 Aug 2011, 16:25    Post subject:  

Wary 5.1.2.7 is now available. This is a beta for the upcoming 5.1.3. See my blog announcement:

http://bkhome.org/blog/?viewDetailed=02390

The download link has xdelta files, for easy download and upgrade if you already have downloaded Wary 5.1.2.

_________________
http://bkhome.org/news/
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 13 of 29 [425 Posts]   Goto page: Previous 1, 2, 3, ..., 11, 12, 13, 14, 15, ..., 27, 28, 29 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1118s ][ Queries: 13 (0.0095s) ][ GZIP on ]