Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 25 Nov 2014, 16:55
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » System
Ymount 002
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 5 of 7 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6, 7 Next
Author Message
L18L

Joined: 19 Jun 2010
Posts: 2579
Location: www.eussenheim.de/

PostPosted: Sat 20 Aug 2011, 07:31    Post_subject: ymount
Sub_title: translation of gtk buttons
 

Iguleder,
thank you for your comment but ymount did not succed international quality control yet Laughing

rodin.s and Bert,
thank you for reporting.
I have corrected the language names in /usr/l0cal/ymount/lang_list
Code:
ru Русский
nl Nederlands

and added
Code:
slv Slovio
for sc0ttmann Smile

Now the gtk button texts:

Have you yad-NLS installed?
Please do it and/or confirm.
Of course there is no reason why you should do it (there are no translations to ru or nl in it) but this is the only difference in our systems I can see now.

yad-NLS is containing German translation
I have got everything correctly in other languages on my system while yad-NLS is installed and if I uninstall yad-NLS the button texts are English.

I cannot confuse the yad developer by using the term NLS. pet so please confirm that you have installed yad-NLS.pet

Thank you
with-yad-NLS.png
 Description   Russian with yad-NLS installed
 Filesize   30.25 KB
 Viewed   1218 Time(s)

with-yad-NLS.png

Back to top
View user's profile Send_private_message 
Bert


Joined: 30 Jun 2006
Posts: 975

PostPosted: Sat 20 Aug 2011, 08:10    Post_subject:  

Hi L18L,

First off, thanks for all your efforts trying to help us!

I installed yad-NLS (from Barry's blog). It made no difference.

I then moved the german yad.mo to the nl-LC_Messages. Only "language" button becomes "Sprache"...

I then changed my locale settings to German. Still no luck..

The only difference I can see now is that you are running Wary and I (and maybe rodin.s too?) am using Lucid.

Could that be the reason?
Thanks!

_________________


Back to top
View user's profile Send_private_message 
L18L

Joined: 19 Jun 2010
Posts: 2579
Location: www.eussenheim.de/

PostPosted: Sat 20 Aug 2011, 08:22    Post_subject: ymount
Sub_title: gtk button text
 

Bert wrote:
... I (and maybe rodin.s too?) am using Lucid.

So I will test it in Lupu525 now (I have lang_packs converted to sfs)
Thank you Bert. Smile

Now in lupu525 (not lupq)
No yad-NLS installed
working correct
-> yad-NLS is not required
---------------------------------
Edited 2011-08-29
Now in wary514
yad-NLS is required to show gtk button text localized
---------------------------------
Bert, rodin.s,
are you using lupq or lupu Question
ymount_without_yad-NLS.png
 Description   in lupu525
 Filesize   25.87 KB
 Viewed   1112 Time(s)

ymount_without_yad-NLS.png


Edited_time_total
Back to top
View user's profile Send_private_message 
Bert


Joined: 30 Jun 2006
Posts: 975

PostPosted: Sat 20 Aug 2011, 12:52    Post_subject:  

L18L, I'm using Lupu, in fact Three Headed Dog (5.2.9)

I just tested Ymount localization In Wary, with and without yad-NLS, with and without utf-8..
No luck Sad

_________________


Back to top
View user's profile Send_private_message 
Bert


Joined: 30 Jun 2006
Posts: 975

PostPosted: Sat 20 Aug 2011, 12:54    Post_subject:  

Hi again L18L,

What's the gtk20.mo you are using, or rather where did you get it from?
Thanks

_________________


Back to top
View user's profile Send_private_message 
rodin.s

Joined: 22 Sep 2010
Posts: 338
Location: Ukraine

PostPosted: Sat 20 Aug 2011, 15:13    Post_subject: yad_NLS  

I'm using Wary-5.1.3. And installation of yad_NLS-0.12.4-w5.pet from Barry's blog helped. On clean system it doesn't work but on localized one it does.
I have the same result as on the picture above.
I've noticed on another yad application - urxvtset that NLS-pet somehow allows localization. urxvtset calls gcolor2 and without yad_NLS pet installed it is in English but with it installed it's in Russian.
Back to top
View user's profile Send_private_message 
Bert


Joined: 30 Jun 2006
Posts: 975

PostPosted: Sat 20 Aug 2011, 15:51    Post_subject: Re: yad_NLS  

rodin.s wrote:
I'm using Wary-5.1.3. And installation of yad_NLS-0.12.4-w5.pet from Barry's blog helped. On clean system it doesn't work but on localized one it does.
I have the same result as on the picture above.

Thanks for your testing rodin.s!

So, the plot thickens..L18L is able to get full localization, without the need of yad-NLS and in your testing adding yad-NLS helped to get full translation of the buttons.

Did you add anything to /usr/share/locale/ru/LC_MESSAGES that wasn't part of the pristine Wary-5.1.3?

Thank you! I'm sure we'll find the solution. (What a great forum this is Cool )

_________________


Back to top
View user's profile Send_private_message 
rodin.s

Joined: 22 Sep 2010
Posts: 338
Location: Ukraine

PostPosted: Sat 20 Aug 2011, 16:18    Post_subject: Re: yad_NLS  

Bert wrote:
Did you add anything to /usr/share/locale/ru/LC_MESSAGES that wasn't part of the pristine Wary-5.1.3?

I've added a lot of ru.mo files.
yad_NLS contains only mo-files so maybe yad.mo for different languages was already included in Lupu so no NLS-pet was needed.
Back to top
View user's profile Send_private_message 
L18L

Joined: 19 Jun 2010
Posts: 2579
Location: www.eussenheim.de/

PostPosted: Sat 20 Aug 2011, 17:01    Post_subject: ymount
Sub_title: gtk button texts
 

Hello Bert and rodin.s,

sorry, I cannot share Bert's hope Sad
ru and de OK
nl not OK

yad has localization for de sk ru and uk.

That is what de and ru have in common. Confused

The gtk button texts are translated by gtk20.mo (Bert, I have used what is in lang_pack)

Maybe a gtk guru can solve the problem.
And I will roll back to text only buttons to be on the safe side.

The new language switcher was just an experiment and I am thinking it is sufficient to use just plain text buttons which are always translated by ymount.mo

The icons on the buttons are really not necessary, we all can read and the language switcher is about text, not about pictures. Laughing

Another change will be to correct the following bad behavior:
Trying to mount /initrd/mnt/dev_save (open /mnt/home in rox) results in an error message. I have to change this and then it is version 1.0

Have a nice weekend and
thank you for your help Smile
L
Back to top
View user's profile Send_private_message 
Bert


Joined: 30 Jun 2006
Posts: 975

PostPosted: Sat 20 Aug 2011, 18:06    Post_subject:  

Okay, one last try for today,
L18L wrote:
sorry, I cannot share Bert's hope Sad
ru and de OK
nl not OK


But how then did you arrive at this result, with all the buttons correctly localized :
ymount_without_yad-NLS.png
 Description   
 Filesize   25.87 KB
 Viewed   949 Time(s)

ymount_without_yad-NLS.png


_________________


Back to top
View user's profile Send_private_message 
L18L

Joined: 19 Jun 2010
Posts: 2579
Location: www.eussenheim.de/

PostPosted: Sun 21 Aug 2011, 05:42    Post_subject: gtk button text
Sub_title: nl - Nederlands
 

Bert wrote:
Okay, one last try for today,
L18L wrote:
sorry, I cannot share Bert's hope Sad
ru and de OK
nl not OK


But how then did you arrive at this result, with all the buttons correctly localized :

wary513
loaded lang_packs: de ru nl
yad-0.12.2-1
Code:
# locale -a
C
de_DE@euro
de_DE.utf8
en_US
POSIX
#


That is what we know so far:
- use of LANGUAGE shows languages other than my de !
- LANGUAGE is a list of languages separated by colon
- it is set in the script to: LANGUAGE:$LANG
- it is working with LANG=de and LANG=ru

Perhaps you might try changing your locale (Configure Puppy for your country) to Deutsch or Русский ?
Other lang_packs not needed, the buttons should always show Nederlandse (correct with e ?) language.

Last post for today Smile
My regards
L
Back to top
View user's profile Send_private_message 
L18L

Joined: 19 Jun 2010
Posts: 2579
Location: www.eussenheim.de/

PostPosted: Sat 27 Aug 2011, 13:39    Post_subject: ymount
Sub_title: maybe final version
 

L18L wrote:
And I will roll back to text only buttons to be on the safe side.

No roll back but something better now Exclamation

In Preferences there is a button now
which toggles gtk buttons or text only buttons.
(some changes in translations needed)

Another improvement
/initrd/mnt/dev_save is showing as /mnt/home and can be opened in rox.

Note, no limit in partition numbering, see screenshot.

Separate NLS package to keep package size low.
There is just one language included so that the language switcher has something useful to do.

Have fun
L

Edited 2011-08-29
yad and yad-NLS required

Get NativeLanguageSupport ymount-NLS.pet from
Localization

Edited 2011-09-11
Link to latest version provided always here:
http://www.murga-linux.com/puppy/viewtopic.php?p=557739
ymount-0.9.1.png
 Description   -
 Filesize   38.26 KB
 Viewed   1375 Time(s)

ymount-0.9.1.png

ymount-0.9.1.pet
Description  mount and unmount multiple partitions
pet

 Download 
Filename  ymount-0.9.1.pet 
Filesize  10.48 KB 
Downloaded  417 Time(s) 

Edited_times_total
Back to top
View user's profile Send_private_message 
rodin.s

Joined: 22 Sep 2010
Posts: 338
Location: Ukraine

PostPosted: Mon 05 Sep 2011, 06:06    Post_subject: UTF-8 support.  

When I mount my USB-flash with ymount Russian characters displayed as '???????'. It's OK with pmount or event manager.
Back to top
View user's profile Send_private_message 
L18L

Joined: 19 Jun 2010
Posts: 2579
Location: www.eussenheim.de/

PostPosted: Mon 05 Sep 2011, 10:14    Post_subject: Re: UTF-8 support.
Sub_title: Russian on usb-flash
 

rodin.s wrote:
When I mount my USB-flash with ymount Russian characters displayed as '???????'. It's OK with pmount or event manager.


Now in wary5141
I have tried to reproduce it. (täßt is misspelled for test)
But for me it is not clear where are the '????????'
Question

Is your locale set to utf8 ?
ymount-ru.png
 Description   
 Filesize   41.33 KB
 Viewed   1267 Time(s)

ymount-ru.png

Back to top
View user's profile Send_private_message 
rodin.s

Joined: 22 Sep 2010
Posts: 338
Location: Ukraine

PostPosted: Mon 05 Sep 2011, 12:56    Post_subject: ?????? mount  

I found out that this command mounts my USB-flash with no '??????'
Code:
# mount /dev/sdc1 /mnt/sdc1 -o shortname=mixed,quiet,utf8


I have fixed it. I have changed mount lines in /usr/local/ymount/functions.
functions.gz
Description  mounts utf-8
gz

 Download 
Filename  functions.gz 
Filesize  3.22 KB 
Downloaded  379 Time(s) 
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 5 of 7 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6, 7 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » System
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0900s ][ Queries: 13 (0.0058s) ][ GZIP on ]