Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 23 Oct 2014, 13:24
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Video
USB 2.0 Camera doesn't work in 5.25 [RESOLVED]
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [4 Posts]  
Author Message
mpierrat25


Joined: 23 Aug 2007
Posts: 105
Location: France (25)

PostPosted: Tue 23 Aug 2011, 04:59    Post subject:  USB 2.0 Camera doesn't work in 5.25 [RESOLVED]
Subject description: need patch in driver ??
 

Here is the camera my PC use :

Code:

# dmesg | grep video
pci 0000:03:00.0: Boot video device
Linux video capture interface: v2.00
uvcvideo: Found UVC 1.00 device USB 2.0 Camera (13d3:5103)
usbcore: registered new interface driver uvcvideo
#


nothing works (VLC Mplayer Motion ..)
it works perfectly under Windows 7

Please help,


Edit 11/8/25

I do not understand fully , but have a look at this :
http://www.mail-archive.com/linux-uvc-devel@lists.berlios.de/msg05196.html

could it help ??

Last edited by mpierrat25 on Tue 13 Sep 2011, 12:07; edited 1 time in total
Back to top
View user's profile Send private message MSN Messenger 
tempestuous

Joined: 10 Jun 2005
Posts: 5271
Location: Australia

PostPosted: Mon 05 Sep 2011, 21:53    Post subject:  

mpierrat25 wrote:
Code:
uvcvideo: Found UVC 1.00 device USB 2.0 Camera (13d3:5103)

I'm surprised that the uvcvideo driver loaded at all, since the version of that driver contained in Puppy 5.2.5 doesn't actually support your device ID !

I found updated source code and device ID's for the uvcvideo driver here -
http://cateee.net/lkddb/web-lkddb/USB_VIDEO_CLASS.html
so it's feasible that the uvcvideo driver in Puppy 5.2.1 - 5.2.8 could be hacked/upgraded ...
but the easiest thing to do would be to use a version of Puppy with newer kernel version - so I suggest you move up to luci-529 (Three Headed Dog)
http://www.murga-linux.com/puppy/viewtopic.php?t=70736
Back to top
View user's profile Send private message 
8-bit


Joined: 03 Apr 2007
Posts: 3382
Location: Oregon

PostPosted: Tue 06 Sep 2011, 03:19    Post subject:  

I could not get the webcam applications in Puppy Lucid 520 to work with my webcam.
In other words, luvcview failed to run and popped up a window stating "Luvcview has encountered an error. Make sure your webcam is connected and configured properly." But there is no info on how to configure the webcam.

I then installed Guvcview and I then had a working application for the webcam.
Oh, I should mention that webcam was built in on my Toshiba laptop.
I have not tried it with Skype though.
But the application allows you to record the video stream and also take snapshots.
Back to top
View user's profile Send private message 
mpierrat25


Joined: 23 Aug 2007
Posts: 105
Location: France (25)

PostPosted: Tue 13 Sep 2011, 12:07    Post subject: [RESOLVED]  

Solved by tempestuous who included the device in 529
Back to top
View user's profile Send private message MSN Messenger 
Display posts from previous:   Sort by:   
Page 1 of 1 [4 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Video
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0452s ][ Queries: 12 (0.0038s) ][ GZIP on ]