Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 30 Jun 2015, 22:04
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Networking » Ethernet
525 full install has problem recognizing network card
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 2 of 2 Posts_count   Goto page: Previous 1, 2
Author Message

Joined: 10 Jun 2005
Posts: 5376
Location: Australia

PostPosted: Fri 29 Jul 2011, 22:28    Post_subject:  

First let's clear up the confusion over pcnet_cs versus axnet_cs:
The Netgear FA411 contains the Asix AX88190 chipset and the fully compatible Linux driver is axnet_cs, however,
the FA411 is also backwards-compatible with (the more basic) NE2000 devices, using the pcnet_cs driver.
In theory you could use either driver, but you would only achieve the highest data throughput from the axnet_cs driver.

bugminer, I suggest you attack the problem in 2 stages;
First, delete any old fixes you have attempted, such as your BootManager settings.

Stage 1)
Both drivers claim the same device ID (and sub-device ID's) and it seems that the pcnet_cs driver gets priority ...
but there's code written into the pcnet_cs driver which should auto-detect any Asix-based devices and send a kernel-event to "bail out" and let the axnet_cs driver take over.
I have done some reading on the web about this portion of the driver code, and it seems that it's unreliable. I have found a patch (which is an update of an earlier patch) which might fix the problem ... but why bother!!
The most straightforward solution would be to disable the pcnet_cs driver, and this will let the axnet_cs driver do its job unencumbered.

So use ROX to browse to /lib/modules/
and there you will see the (driver) file "pcnet_cs.ko"
Open a second ROX window, which will default to the /root location, then drag pcnet_cs.ko into /root
Now you need to "register" the changed state of your system's drivers, by running this command -

Now reboot, and the axnet_cs driver should certainly load. Try it for a while, and see if it's stable.

Stage 2)
It's possible that the axnet_cs driver may still be unreliable, and there are reports on the web of Asix-based devices having trouble interacting with a laptop's bios to get the correct resources (IRQ/DMA).
So using IRQ-related boot options, as rjbrewer suggested, is certainly a good idea, especially since you have an older laptop. I'm certainly familiar with this situation, since I originally used Puppy Linux back in 2005 with a VAIO Pentium1 !

First get into your laptop's bios and see if there's a setting for "PnP OS = YES/NO". If so, set it for "NO".
Save bios settings, reboot, and I suspect that will work well.
But if you don't have that bios option, or the device is still unreliable, these are the best three boot options you should try:



irqpoll routeirq
Back to top
View user's profile Send_private_message 

Joined: 25 Jul 2011
Posts: 26

PostPosted: Sat 30 Jul 2011, 06:07    Post_subject:  

Thank you for the great reply, I'll put your advice into practice when I'm next using the laptop. I'll get back with results after a few days of testing.
Back to top
View user's profile Send_private_message 

Joined: 25 Jul 2011
Posts: 26

PostPosted: Thu 11 Aug 2011, 22:59    Post_subject:  

Sorry for taking so long!

I'm up to trying "acpi=noirq" to see if that fixes the problem and it's worked twice so far. Hopefully it'll keep on working but I won't be happy until it works properly for a decent amount of time. It's just taken me long to test which works due to various reasons.

Hopefully I'll get through testing things before too long.
Back to top
View user's profile Send_private_message 

Joined: 25 Jul 2011
Posts: 26

PostPosted: Fri 26 Aug 2011, 01:10    Post_subject:  

ok, it looks like I'm up tp trying "irqpoll routeirq". I haven't used the laptop is a fair while so it's not like it's worked with "acpi=noirq" for ages before not working.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 2 of 2 Posts_count   Goto page: Previous 1, 2
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Networking » Ethernet
Jump to:  

You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0476s ][ Queries: 12 (0.0036s) ][ GZIP on ]