Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 30 Jun 2015, 12:48
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Video
GeForce GTS 450 graphics card in Two-Headed Dog 528
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 2 of 2 Posts_count   Goto page: Previous 1, 2
Author Message

Joined: 20 Aug 2011
Posts: 12

PostPosted: Fri 26 Aug 2011, 05:07    Post_subject:  


Thanks for idea but unfortunately it still will only work if I use a vesa driver.

Perhaps I'll just stick with Ubuntu and try again at the next release.

Thanks again

Back to top
View user's profile Send_private_message 

Joined: 29 Jan 2009
Posts: 286

PostPosted: Fri 26 Aug 2011, 17:27    Post_subject:  

I'm not sure I would give in just yet.

I have a difficult hardware setup for Linux: an addon PCI Nvidia GeForce4 card with an onboard Intel AGP card. Once coaxed, however, Linux lends its rewards.

I am assuming the the xorg.conf file was initially created from the xorg wizard? I gave up using xorgwizard a few years back as it couldn't cope with the above outlined setup.

But IIRC I built a basic xorg.conf from another command line program:


and took it from there.

The xorg.conf posted looks a bit minimalistic I can't see an obvious flaw, however a fairly detailed log is available (at least on my system) located at:


And in the past when I have messed with my config I have looked at this file which usually pointed in the right direction.
Back to top
View user's profile Send_private_message 

Joined: 20 Aug 2011
Posts: 12

PostPosted: Sat 27 Aug 2011, 03:28    Post_subject:  

I've attached my log but it doesn't mean much to me. Any advice?
Description  Xorg.0.log

Filename  Xorg.0.log.tar.gz 
Filesize  5.98 KB 
Downloaded  370 Time(s) 
Back to top
View user's profile Send_private_message 

Joined: 29 Jan 2009
Posts: 286

PostPosted: Sat 27 Aug 2011, 08:38    Post_subject:  


It appears that the gziped tar file was truncated, I don't think the log file is that large, I would try an attach an uncompressed copy if that is easier and if murga-linux allows it.

From the information that was uploaded I am curious to see the lines

(==) Using config file: "/etc/X11/xorg.conf"
(==) Using config directory: "/usr/lib/X11/xorg.conf.d"

The directory /usr/lib/X11/xorg.conf.d is not used on my system. As a general rule of debugging I try to start as simple as possible: get Xorg up and running with a minimal configuration and then look at seeing what can be added step by step and reverting if there is a failure.

So I would look to see what is in /usr/lib/X11/xorg.conf.d and perhaps if there is extra config information in it to temporarily rename file or files to get Xorg to only use /etc/X11/xorg.conf.

The log file states

(II) VESA(0): Not using mode "1920x1080" (no mode of this name)

I would edit xorg.conf to use resolution 1024x768, not 1920x1080. Even if that is not the native resolution of the monitor my view is you start with a basic configuration which can be tweaked later. Starting with a lesser resolution in my experience means there is more tolerance if refresh rates are not configured correctly.
Back to top
View user's profile Send_private_message 

Joined: 20 Aug 2011
Posts: 12

PostPosted: Sat 27 Aug 2011, 10:43    Post_subject:  

Opens with abiword. Hope you can make sense of this.
Description  Opens with abiword ok

Filename  Xorg.).log.gz 
Filesize  147.77 KB 
Downloaded  349 Time(s) 
Back to top
View user's profile Send_private_message 

Joined: 06 Jan 2008
Posts: 3270
Location: Chickasha Oklahoma

PostPosted: Sat 27 Aug 2011, 10:43    Post_subject:  

Very Happy Hello,
After much struggling, finally got GLX going on my sons NVidia box..
My 4 yr old son loves Lugaru, a game battleshooter posted a while back...
But I wanted my laptop back... Very Happy
I tried every pet available, to no avail, just nv and vesa worked.

His machine is a Sony Vaio Desktop
1.4g P4, 128mb ram, 512mb swap
NVidia geforce 400 video card...

Make sure you have about 200mb free space in your save file first..

1 Download the NVidia Linux package for your card.
For his it was :

2 Download the devx for your system.
His is Wary 5.10 so wary_devx.501.sfs.

3 Download the kernel sources for your system.
His was kernel sources

4 Enable both sfs files in the bootmanager, and reboot..

5 After rebooting, and making sure both sfs files are enabled..
Drop out of X to the command prompt and run the installer..
For his I typed:
Let the installer do its thing, and watch for any errors..
(If you have the wrong driver, which I did the first time around, the installer scans your card, and will tell you which package you need...)
When it is finished, reboot...
After rebooting, run xorgwizard, and choose nvidia..
Now his old machine gets way better frame rates than mine.... Shocked
And I get my laptop back.... Cool

Close the Windows, and open your eyes, to a whole new world
Puppy Linux Users Group on Facebook

Puppy since 2.15CE...
Back to top
View user's profile Send_private_message Visit_website 

Joined: 29 Jan 2009
Posts: 286

PostPosted: Sat 27 Aug 2011, 15:41    Post_subject:  

I'm not clear why the log file refers to vesa frequently, according to xorg.conf you listed the driver being loaded is nvidia, I should mention that my Xorg version goes back to 2007 though the puppy linux version is from 2010. Its a version intended to be kinder to older hardware, loads the nvidia driver for a GeForce4 and the log makes no reference to vesa.

There was one error (EE) in the logfile:

(EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)

There seems to be some kind of mismatch with the glx module, however when I disabled the glx module and restarted X, I still had a functioning screen albeit without 3D acceleration (would affect games etc). I would leave that for later.

On the xorg.conf previously listed in this thread, the line (in the "screen" section near the end of xorg.conf) there is this line:

#Option "metamodes" "1280x1024_60 +0+0" #METAMODES_0

That line is commented out (preceded by a #)? You might want to amend 4 of these lines according to the following suggestions, (backing up xorg.conf first of course).


Option         "metamodes" "1280x1024_60 +0+0; 1920x1080_60  +0+0" #METAMODES_0
   Subsection "Display"
      Depth       24
      Modes      "1280x1024"  "1920x1080" 

I hope this would provide two resolutions to choose from 1280x1024 and 1920x1080

Both modes 1280x1024 and 1920x1080 are specified at 60HZ (a tolerant frequency, may be flicker).

If that helps your problem you can see if you can run the resolutions at a higher refresh rate e.g. 75HZ:


Option         "metamodes" "1280x1024_75 +0+0; 1920x1080_75  +0+0" #METAMODES_0
   Subsection "Display"
      Depth       24
      Modes      "1280x1024"  "1920x1080"

BTW if you have it working in Ubuntu it may be worth looking at ubuntu's xorg.conf and log files, see also:

Back to top
View user's profile Send_private_message 

Joined: 11 Oct 2009
Posts: 6266
Location: Charleston S.C. USA

PostPosted: Sat 27 Aug 2011, 17:22    Post_subject:  


Your problem is you need the proper Nvidia driver for your video card.

If the test in quickpet suggested using the Xorg-High driver, that is the best optional driver that comes readily available with Two Head Dog 528.
The Xorg-High driver adds more capabilities to the Vesa driver. Adds OpenGL and 3D.

You need to go to Nvidia driver support and see what Nvidia driver your video card needs.

You need to start over with a fresh install of Puppy.

If you do a frugal install.
Make the save file before trying to install a new video driver.
Minimum free space is 200MB to do a driver install. Nvidia drivers are big after being uncompressed.

You can find pets for some drivers in the Additional Software (Pets & Stuff)->drivers section of this forum.
Make sure the driver pet was made to work with Puppy 528
The thing to look for is what kernel it was compiled for.

I know I told you about this one before and you had problems installing, but I
would try it again.

If you try a driver and it does not work.
Need to follow these directions to try another one.

If you can not find an already made driver pet. You may have to do the driver compile method that is described above by puppyluvr.

I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send_private_message 

Joined: 20 Aug 2011
Posts: 12

PostPosted: Mon 29 Aug 2011, 16:45    Post_subject:  

It works!

Many thanks to all who helped, eventually using bigpup's and puppyluvr's posts I downloaded the .run from Nvidia and now I have 1920x1080 displyed.

Thanks again.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 2 of 2 Posts_count   Goto page: Previous 1, 2
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Video
Jump to:  

You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0835s ][ Queries: 13 (0.0122s) ][ GZIP on ]