Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 21 Dec 2014, 12:38
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Introducing PULP - 125 MB Puplet for older hardware
Moderators: Flash, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 13 of 18 Posts_count   Goto page: Previous 1, 2, 3, ..., 11, 12, 13, 14, 15, 16, 17, 18 Next
Author Message
sindi

Joined: 16 Aug 2009
Posts: 397

PostPosted: Mon 18 Apr 2011, 18:04    Post_subject: Compaq Presario 1200
Sub_title: sound works, Firefox does not
 

Compaq Presario 1200 with 32MB onboard and 64MB added RAM, 475MHz AMD-K6-2 cpu.
800x600 res, cheap video/sound chip, via82cxxx which refuses to work with OSS sound (Basiclinux)
but works perfectly in pulp with mplayer. Most mplayer binaries won't work on AMD-K6-2
but this one must have been compiled for i586. I could play streaming audio from a few
online radio stations by pointing mplayer at the URL, but some need javascript and:

Firefox refuses to load - illegal instruction.
Opera 9.64 loads but the menu is missing. F11 does not help.
Seamonkey 1.1.19 worked. It also crashed a lot until I
made a swap file. (I need to find a 128MB PC2100 SODIMM).

Firefox 2 from DSL linux works on this computer in Basiclinux.
(But so does Opera).
I suggest that it or Seamonkey be in future versions.

Could not get mplayer to play mp3s or pls automatically at
several sites. Running from rxvt revealed that they now
require avisynth.dll (video codec) which pulp does not have.

The laptop has lovely JBL Pro speakers with volume buttons,
and a great keyboard. Screen is a bit streaky and low res.
Same case, keyboard, and sound as better quality presarios.

To use it as an internet radio, I assembled a collection of URLs to use
directly with mplayer and made scripts which I put into /root/my_app*/bin/.
mp3blaster also works but cannot do pls asx ram wma etc. (Which I
have not yet tested with mplayer either).

Win98 sound works on here but mplayer for Windows is not i586.
IE 5 and Netscape can't handle today's internet.
Back to top
View user's profile Send_private_message 
sindi

Joined: 16 Aug 2009
Posts: 397

PostPosted: Tue 19 Apr 2011, 23:41    Post_subject: Pulp won't work on Presario 1675
Sub_title: no boot
 

After determining that even 160MB memory is not enough to keep
Seamonkey from crashing in Pulp on Presario 1200, I copied
the sfs, vmlinuz, and initrd.gz to ext2 hard drive on a
Presario 1675 with Win2k in first partition and set it up
to dual boot 2K and LILO, with Pulp as default. It kept
booting to my other linux, with lilo installed to hda2.
I installed lilo to fd0 and it started to boot to pulp
and stalled at "loading kernel modules".

This computer recently stopped recognizing its added
memory but has 64MB onboard. Today the pcmcia bridge
went bad and my other linux has no support for USB
wireless so I was going to switch to pulp. Don't know
if it objects to the hardware in general or just to
the broken parts. I will try DSL live CD instead.
Or use it as an mp3 player - volume buttons and nice
JBL Pro speakers. It even plays DVDs but with large
moving colored squares (few pixels) at 400MHz. I think
the AMD-K6-2 cpus are a lot slower than others with
that rated speed.

Will check if anyone else got puppy working on
these two Presarios.
Back to top
View user's profile Send_private_message 
puppyiso


Joined: 12 Jan 2009
Posts: 595

PostPosted: Sat 30 Apr 2011, 01:24    Post_subject:  

http://rapidshare.com/files/351589378/PULP_0.1.iso.html

no file.

I have 2 web accounts.

Willing to host..

contact wanted.

John
Back to top
View user's profile Send_private_message 
cthisbear

Joined: 29 Jan 2006
Posts: 3469
Location: Sydney Australia

PostPosted: Sat 30 Apr 2011, 19:45    Post_subject:  

puppyiso :

Best I can do.

Versions 2 & 3.

You have to rename >>> the doc file...

PULP 0.03 rename the .doc to .iso as usual.

http://flusslinie.wordpress.com/2009/05/04/pulp-003-is-out/

md5sum: 6a630a82e966ea5f030e08528636adc4 pulp_0.03.iso

//////////

f you download the file below, rename the .doc to .iso burn it to a cd and off you go.

pulp_002

http://flusslinie.wordpress.com/2009/04/28/pulp-the-ultralight-puplet/

md5sum: 84eb7006a3aa3e26fe54f6ec89312e3e

///////

Regards....Chris.
Back to top
View user's profile Send_private_message 
sindi

Joined: 16 Aug 2009
Posts: 397

PostPosted: Mon 04 Jul 2011, 00:59    Post_subject: Flash 10 in Pulp Linux
Sub_title: With Opera 11, Seamonkey 2.0 and Firefox 4
 

Download the browsers, unpack to their own directories in /mnt/home.
Firefox and Seamonkey require libdbus pet which I have a copy of
at http://keesan.freeshell.org/bl/libdbus-1.3.pet.
You can tar -zxvf the pet and copy the libraries to /usr/lib (cp -a lib*).

I made scripts in /usr/local/bin to start the browsers:

/usr/local/bin/opera
cd /mnt/home/opera*
./opera

seamonkey
cd /mnt/home/seamonkey*
./seamonkey

similarly for firefox

I edited /root/.jwmrc by adding lines at the beginning on the model of Firefox 2, using the above scripts. Alt-F1, down arrow, Enter.

Flash

Download the latest installer of flashplayer tar.gz to some place.
tar -zxvf install* libflashplayer.so (extracts just that one file)
mv libflashplayer.so /usr/lib/mozilla/plugins

Delete the package - the rest of it is irrelvant (for gnome etc).

All three browsers are set (in profile) to look here for plugins, but Opera was not recognizing flash because some libraries which it requires were not on the library path. They come with seamonkey and firefox, and the wrapper script lets them be found when the browser is loaded.
Opera's wrapper script does not look for libraries in other browsers.

I symlinked these libraries to /usr/lib/ which is on the path.

cd /usr/lib/
ln -s /mnt/home/seamonkey/* .
(or firefox would also work).

You could instead edit /etc/profile to change the library path and reboot.

Supposedly opera will also look in /opera*/lib/opera/plugins/ so put the libflashplayer.so there if you don't use firefox or seamonkey.
Firefox 2 which comes with pulp (FirePup) also has these libraries, which you can symlink as above to /usr/lib, but they are older (did not test).

Flash is now working for me on this DELL Latitude D600, but on my HP
N5415, if libflashplayer.so is in any plugin directory, seamonkey (2.1) and
firefox (5.0) crash when I access Youtube site. AMD K-7 cpu, 900MHz. I have not yet tried Opera with flash there (or Puppy 4.31 with seamonkey 1.1.1Cool. xpdf also segfaults, and Netflix says the cpu is not supported.
Back to top
View user's profile Send_private_message 
sindi

Joined: 16 Aug 2009
Posts: 397

PostPosted: Mon 04 Jul 2011, 11:01    Post_subject: Flash 10.3 with pulp01
Sub_title: Works on one of two computers with pulp, on both with puppy 431
 

Flash 10.3 in /usr/lib/mozilla/plugins (set up as described in previous post).
Works in Pulp on a 1.6GHz DELL Latitude (which only runs at 600MHz - something failed)
and in Puppy 431 on that and HP N5415 900MHz (AMD K-7). ldd libflashplayer in all three works.

On the HP in Pulp01, ldd: exited with unknown exit code (135) when I ldd libflashplayer
(but works with other binaries), Seamonkey 2.1 and Firefox 5.0 both crash when I
have libflashplayer.so in plugins and go to youtube, and Opera cannot find libflashplayer
(not listed as a plugin even with refresh).

What difference between Puppy 4.31 and Pulp01 (based on 4.12) might cause the same
exact libflashplayer and browsers not to work together, and ldd to fail, in pulp
on the HP? I have all the browsers stand-alone on another partition.

Adobe claims Flash 10 requires 2.33GHz - obviously it does not.

I symlinked defaultmediaplayer to mplayer (it was a script using gxine which is not in pulp).

The following default scripts use programs not found in pulp.

Not found Equivalent
calendar - ical cal (CLI)
chat - pidgin centerim
contact - gaby (is there an address book?)
draw - sodipodi mtpaint
htmleditor - mozedit (I only found text editors)
spreadsheet - gnumeric siag

imageviewer is mtpaint and could be gqview instead.

Perhaps the author would like to fix these scripts and add something
for contact and htmleditor (or remove those scripts).

Lots of other useful programs in here are not on the menu (e3pi, cdrecord).
Back to top
View user's profile Send_private_message 
harii4


Joined: 30 Jan 2009
Posts: 444
Location: La Porte City, IA , U.S.A.

PostPosted: Mon 04 Jul 2011, 13:30    Post_subject:  

sindi
Quote:
Perhaps the author would like to fix these scripts and add something
for contact and htmleditor (or remove those scripts).

It sounds like PULP might be an dead pup? Question
You could remaster your own pulp?
Quote:

harii4 wrote:
any plans for an new pulp?
seamonkey and rox gtk1.2 ?


zenfunk
Quote:
Nope, so far pulp does what I want it to do.
It's all free software- so feel free to roll your own. Personally I'd love to see what people can do with GTK 1.2 apps. So far all filemanagers for GTK 1.2 are not ideal (IMHO).

sorry--

_________________
3.01 Fat Free / Fire Hydrant featherweight/ TXZ_pup / 431JP2012
----------------------------------------------------------------------------------------
Peace and Justice are two sides of the same coin.
Back to top
View user's profile Send_private_message Visit_website 
sindi

Joined: 16 Aug 2009
Posts: 397

PostPosted: Mon 04 Jul 2011, 15:04    Post_subject: Pulp01 is not dead  

It works fine with the latest versions of Seamonkey, Firefox, and
Opera, and even Flash except on one
rather screwy laptop, so is hardly
dead. I use it instead of Puppy because I prefer to work in a real terminal, with framebuffer text, and I like the smaller simpler apps. I have added/modified (lynx, pico). Just suggesting a few small fixes in case there is ever a new version. I have recommended pulp to users of Basiclinux, which will not support gtk2 or flash without a lot of updates, because Pulp uses little RAM and has many of the same GTK1 programs we are used to in BL.
Back to top
View user's profile Send_private_message 
`f00


Joined: 06 Nov 2008
Posts: 809
Location: the Western Reserve

PostPosted: Mon 11 Jul 2011, 16:45    Post_subject:
Sub_title: good ideas rarely 'die'
 

Amen to that (smaller, simpler, more robust apps). Far too often I run into gtk error messages in recent pups when trying something different (or it's missing this, that or some other whatever bulk).

The difference is quite noticeable on older kit (have to smile a bit at puplets that need >256 ram)
Pulp rocks, even when you load it up with simple candy Smile

@harii4 - personal remasters can be a learning experience
(in other words, zenfunk did well in creating a few pups with character)
Back to top
View user's profile Send_private_message 
technosaurus


Joined: 18 May 2008
Posts: 4424

PostPosted: Mon 29 Aug 2011, 13:48    Post_subject:  

this is a pet that will install the last gtk1 standalone flashplayer - you will need an internet connection (due to uncertain license issues) but you don't need a browser & the RAM footprint is only ~8mb (the player is just over 1MB)

to test it out try:
gflashplayer /usr/share/examples/vector-images/omelette.swf

p.s. donot try to strip the binary with --strip-all, it will break

Note: it appears to have used code from xscreensaver (X11 license)
gflashplayer-6_r79_linux_sa.pet
Description 
pet

 Download 
Filename  gflashplayer-6_r79_linux_sa.pet 
Filesize  743 Bytes 
Downloaded  315 Time(s) 

_________________
Web Programming - Pet Packaging 100 & 101
Back to top
View user's profile Send_private_message 
zenfunk

Joined: 18 Mar 2009
Posts: 222

PostPosted: Wed 31 Aug 2011, 04:44    Post_subject: Future of pulp  

Hey, good to see that some still have interest in my puplet. I'd love to help out, since I have enough time on my hand again. Unfortunately I am currently on a long sailing trip which also means that you will get access to an acceptable internet connection just once every couple of WEEKS!!! So I'm sort of out of the game right now. If someone wants to bring PULP to the next level- please go ahead.
Just after the finish of the last version the gtk1.2 version of rox somehow appeared in this forum again, so integrating this file manager back into pulp would sound promissing- since many puppy scripts heavily depend on it.

Keep truckin' Christian
Back to top
View user's profile Send_private_message 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Wed 31 Aug 2011, 05:06    Post_subject:  

If one compare Pulp with Pupngo both being small and more into CLI than big WM versions?

Do them differ in how them set things up? I ask because I did get pupngo for a while to work for me but I needed too much hand holding for my own taste. I felt guilty of taking up the Dev time too much. So true!

So pulp is it easier to use? less comlicated? how does it differ?

_________________
I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send_private_message 
sindi

Joined: 16 Aug 2009
Posts: 397

PostPosted: Tue 27 Sep 2011, 21:49    Post_subject: Flash 10
Sub_title: Works with Opera in Pup 431 but not Pulp, works in Pulp with Seamonkey 2, Firefox 6 but not 7
 

Firefox 5 won't even load, 7 complains if I try to watch Youtube, 6 works fine. The latest Flash 10 for linux copied to /usr/lib/mozilla/plugins (where /etc/profile looks for it).

Opera 11.51 works with flash in pup 431 but not pulp - I tried putting libflashplayer in
the opera directory in plugins (I use opera standalone) and in /usr/lib/opera/plugins but it cannot find it. Opera plugins are not listed in /etc/profile even in pup431. What file in puppy 431 should I imitate in pup to make Opera work with flash?

Pulp is working quite nicely on a 333MHz DELL Inspiron 7000 (Xorg, not Xvesa - which goes haywire) with ES1869 sound and hardware volume control, except that mplayer also won't work. PII processor. The touchpad even scrolls.

5GB hard drive because someone threw it in a dumpster when the 14GB drive failed. Flash is rather jerky but usable. It will take 2x128MB plus 64MB onboard but so far 256MB has been adequate even at Youtube (with swap file not accessed yet).

MicroXP 0.91 installed here (slowly) but even after loading wireless driver it could not find a signal, and the wired pcmcia driver would not load. MicroXP 0.83 would not even install (asms error) though it came with both drivers. Puppy to the rescue! It makes a fine internet radio even without external speakers.
Back to top
View user's profile Send_private_message 
greengeek

Joined: 20 Jul 2010
Posts: 2751
Location: New Zealand

PostPosted: Fri 30 Sep 2011, 15:54    Post_subject:  

Hey Sindi...which pulp are you using? 0.1, 0.02 or 0.03?
thx
Back to top
View user's profile Send_private_message 
sindi

Joined: 16 Aug 2009
Posts: 397

PostPosted: Fri 30 Sep 2011, 17:33    Post_subject: Pulp 0.1 flash
Sub_title: works with seamonkey/firefox not opera
 

Pulp 0.1 (latest). It also works nicely on the Inspiron 8100 (1400x1050 Xorg). There must be some file to edit so Flash will work in Opera.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 13 of 18 Posts_count   Goto page: Previous 1, 2, 3, ..., 11, 12, 13, 14, 15, 16, 17, 18 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1108s ][ Queries: 13 (0.0165s) ][ GZIP on ]