Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 20 Dec 2014, 14:10
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Desktop
E17 windowmanager all in one pet, wmswitcher, usual modules
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 3 [44 Posts]   Goto page: 1, 2, 3 Next
Author Message
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Wed 24 Aug 2011, 11:29    Post subject:  E17 windowmanager all in one pet, wmswitcher, usual modules
Subject description: Svn 62731 version. Compiled in Polarpup, Lucid Puppy derivative.
 

E17 windowmanager pack. Compiled using magnificent Iguleders build scripts. Svn 62731 version.
It is one pet which has all needed. Install the pet and use Menu > Desktop > Wm switcher.
The pet includes system file changes which are needed, and it has modified /usr/sbin scripts.
No additional themes, default lookout, so it will need tweaking after install. I added couple of wallpapers, but they are in Polarpup already.
This should be good for Lucid Puppies and puplets based on it.

Otherwise I refer to existing e17 forum threads and puplet info. There is really good knowledge in this forum.

About 8 Mb.

Download link: http://www.smokey01.com/pemasu/Pets/e17-62731.pet

Last edited by pemasu on Tue 20 Sep 2011, 14:25; edited 1 time in total
Back to top
View user's profile Send private message 
Eyes-Only


Joined: 10 Aug 2006
Posts: 1046
Location: La Confederation Abenaquaise

PostPosted: Wed 24 Aug 2011, 11:59    Post subject:  

Thanks pemansu for taking the time and trouble to compile this. Should be rather interesting to see what you got from this and his scripts! e17 is truly a gorgeous desktop environment that never gets mentioned enough... at least elsewhere that is! Wink

Thanks again for all that you do in service to the Puppy Community! We'd be MUCH poorer off without people like you here, trust me.

Cheers/Amicalement,

Eyes-Only
"L'Peau-Rouge d'Acadie"

_________________
*~*~*~*~*~*
Proud user of LXpup and 3-Headed Dog. Cool
*~*~*~*~*~*
Back to top
View user's profile Send private message 
backi

Joined: 27 Feb 2011
Posts: 466
Location: GERMANY

PostPosted: Sun 28 Aug 2011, 14:38    Post subject:
Subject description: Gadget mixer
 

Hi Pemasu !
Tried your E17 pet on lucid 529. running fine so far
but gadged mixer says " no alsamixer found".
Any idea ?
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Sun 28 Aug 2011, 15:13    Post subject:  

I would open mixer gadget settings with right click and check that you have right sound card selected. I remember I had same problem and selecting right sound card fixed it.
Back to top
View user's profile Send private message 
Jim1911

Joined: 19 May 2008
Posts: 2457
Location: Texas, USA

PostPosted: Sun 28 Aug 2011, 15:49    Post subject:  

Tried it on lucid 629. I get a mixed desktop which can probably be cleaned up, however to switch WM it required Ctrl>Alt>Backspace and then xwin since restart X would not work.
image-2.jpg
Description 
jpg

 Download 
Filename  image-2.jpg 
Filesize  68.46 KB 
Downloaded  1022 Time(s) 
Back to top
View user's profile Send private message 
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Sun 28 Aug 2011, 16:07    Post subject:  

Jim1911 wrote:
Tried it on lucid 629. I get a mixed desktop which can probably be cleaned up, however to switch WM it required Ctrl>Alt>Backspace and then xwin since restart X would not work.

Same for me, except I got black desktop with jwm tray at top and fbpanel at bottom. No sign of enlightenment. Smile

_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Sun 28 Aug 2011, 16:13    Post subject:  

Reboot after installing pet is probably reguired. To change after that to e17 should work in console state by:
Code:
xwin enlightenment_start

In /etc/windowmanager should be the wanted wm row only:jwm or enlightenment_start.
These should help the right wm selection. Otherwise, it can be that my setup is not as universal as I hoped.
Back to top
View user's profile Send private message 
aragon

Joined: 15 Oct 2007
Posts: 1698
Location: Germany

PostPosted: Mon 29 Aug 2011, 03:27    Post subject:  

Jim1911 wrote:
Tried it on lucid 629. I get a mixed desktop which can probably be cleaned up, however to switch WM it required Ctrl>Alt>Backspace and then xwin since restart X would not work.


the problem with the panel 'could' be, that some panels like fbpanel/lxpanel are started from the /root/.xinitrc (which is a bad habit).

please look at this thread

http://www.murga-linux.com/puppy/viewtopic.php?p=263815

last post explains it (for ratpoison).

hope that help (couldn't give more details as i'm not on puppy-os right now).

aragon

_________________
PUPPY SEARCH: http://wellminded.com/puppy/pupsearch.html
Back to top
View user's profile Send private message 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Mon 29 Aug 2011, 11:30    Post subject:  

Being a fan now I downloaded the pet and made a sfs out of it.
Have done this for pet's before and that works well usually.
In spup 499.1 I loaded the sfs.
Went to the X prompt and started with enlightenment start.
Got messages about some 7 missing lib's, but could get them from Lucid 529.

But after getting them all, I still have a problem.
Enlightenment doesn't start.
Code:
ESTART: 0.00001 [0.00001] - Begin Startup
ESTART: 0.00008 [0.00007] - Signal Trap
ESTART: 0.00009 [0.00002] - Signal Trap Done
ESTART: 0.00013 [0.00004] - Eina Init
ESTART: 0.00040 [0.00027] - Eina Init Done
ESTART: 0.00041 [0.00001] - Determine Prefix
=================================
Enlightenment relocation handling
=================================
PREFIX:  /initrd/pup_ro4/opt/e17
BINDIR:  /initrd/pup_ro4/opt/e17/bin
LIBDIR:  /initrd/pup_ro4/opt/e17/lib
DATADIR: /initrd/pup_ro4/opt/e17/share/enlightenment
LOCALE:  /initrd/pup_ro4/opt/e17/share/locale
=================================
ESTART: 0.00056 [0.00015] - Determine Prefix Done
ESTART: 0.00069 [0.00013] - Environment Variables
ESTART: 0.00073 [0.00003] - Environment Variables Done
ESTART: 0.00074 [0.00001] - Parse Arguments
ESTART: 0.00075 [0.00001] - Parse Arguments Done
ESTART: 0.00075 [0.00001] - Eet Init
ESTART: 0.00383 [0.00308] - Eet Init Done
ESTART: 0.00385 [0.00002] - Ecore Init
ESTART: 0.00921 [0.00536] - Ecore Init Done
ESTART: 0.00923 [0.00003] - Ecore Event Handlers
ESTART: 0.00926 [0.00002] - Ecore Event Handlers Done
ESTART: 0.00927 [0.00001] - Ecore_IMF Init
ESTART: 0.01043 [0.00116] - Ecore_IMF Init Done
ESTART: 0.01045 [0.00002] - Ecore_File Init
ESTART: 0.01100 [0.00054] - Ecore_File Init Done
ESTART: 0.01102 [0.00002] - Ecore_Con Init
ESTART: 0.01246 [0.00144] - Ecore_Con Init Done
ESTART: 0.01247 [0.00002] - Ecore_Ipc Init
ESTART: 0.01250 [0.00002] - Ecore_Ipc Init Done
ESTART: 0.01251 [0.00001] - Ecore_X Init
<<<< Enlightenment Error >>>>
Enlightenment cannot initialize Ecore_X!

E17: Begin Shutdown Procedure!
Why would ecore not be initialized?
_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send private message 
Jim1911

Joined: 19 May 2008
Posts: 2457
Location: Texas, USA

PostPosted: Mon 29 Aug 2011, 11:59    Post subject:  

pemasu wrote:
Reboot after installing pet is probably reguired. To change after that to e17 should work in console state by:
Code:
xwin enlightenment_start

In /etc/windowmanager should be the wanted wm row only:jwm or enlightenment_start.
These should help the right wm selection. Otherwise, it can be that my setup is not as universal as I hoped.
Tried this, it would not work and somehow, it corrupted the WM selection and the save file. It just doesn't work with 529.
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Mon 29 Aug 2011, 13:08    Post subject:  

Jim1911. That is bad. I uploaded my compile in good purpose. I have no intention to harm anyones savefiles. I am sorry about that. It can be that e17 compile is kernel sensitive, though it seems about work in Lucid 528.
Back to top
View user's profile Send private message 
Jim1911

Joined: 19 May 2008
Posts: 2457
Location: Texas, USA

PostPosted: Mon 29 Aug 2011, 13:53    Post subject:  

pemasu wrote:
Jim1911. That is bad. I uploaded my compile in good purpose. I have no intention to harm anyones savefiles. I am sorry about that. It can be that e17 compile is kernel sensitive, though it seems about work in Lucid 528.
No problem, save files should always be backed up, especially when testing software.
Back to top
View user's profile Send private message 
Superdooper

Joined: 28 Aug 2011
Posts: 4

PostPosted: Mon 29 Aug 2011, 22:39    Post subject:  

Pemasu just wanted to say thanks for the upload. Ive been trying to figure out how to load e17 for days now. The alsa mixer error showed up for me too , but grabbed the alsa gui from the ppm and everythings fine now. Just wondering if there could be something in the gadget thats not working correctly.. Sorry still new to linux but im trying lol. Oh im running puppy 5.2.5. if that helps at all.
Back to top
View user's profile Send private message 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Tue 30 Aug 2011, 04:24    Post subject: E17 in polarpup 004  

E17 in polarpup 004
I transformed the pet in sfs
In polarpup 004 I activated this enlightenment sfs and started enlightenment. I didn't get the E17 desktop.

This morning I booted polarpup and I got directly the E17 desktop. Nice.
E17-polarpup.png
 Description   
 Filesize   19.91 KB
 Viewed   4287 Time(s)

E17-polarpup.png


_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send private message 
night_mare007

Joined: 07 Aug 2011
Posts: 30

PostPosted: Tue 30 Aug 2011, 20:30    Post subject:  

@pemasu
Did you compiled e17 with SCALE-module and "comp module" ?
if not - Can yo add them at all ?
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 3 [44 Posts]   Goto page: 1, 2, 3 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Desktop
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0910s ][ Queries: 13 (0.0070s) ][ GZIP on ]