Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 19 Dec 2014, 11:50
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
Lucid528 wlan0 network problem- Siocsifflags: protocol error
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [21 Posts]   Goto page: 1, 2 Next
Author Message
stiginge


Joined: 22 Mar 2007
Posts: 420
Location: Kerry, Ireland

PostPosted: Thu 18 Aug 2011, 07:11    Post subject:  Lucid528 wlan0 network problem- Siocsifflags: protocol error  

When I try to connect to wlan0 I get an error message:
Input to rxvt:
Code:
 ifconfig wlan0 up


Output from rxvt:
Code:
 Siocsifflags: device not found


When 'scan' within network wizard is selected a connection cannot be made no matter how many attempts are made.

_________________
Buy silver, crash JPMorgan

Last edited by stiginge on Tue 30 Aug 2011, 03:26; edited 1 time in total
Back to top
View user's profile Send private message 
stiginge


Joined: 22 Mar 2007
Posts: 420
Location: Kerry, Ireland

PostPosted: Tue 23 Aug 2011, 03:25    Post subject:  

Anybody have ideas what this might be?
_________________
Buy silver, crash JPMorgan
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 5482
Location: Charleston S.C. USA

PostPosted: Tue 23 Aug 2011, 16:11    Post subject:  

First are you following these steps:
http://www.murga-linux.com/puppy/viewtopic.php?t=65346

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
cthisbear

Joined: 29 Jan 2006
Posts: 3468
Location: Sydney Australia

PostPosted: Tue 23 Aug 2011, 20:40    Post subject:  

Also try my post.

And come on mate....SPECSSSSSSS???

Please supply your exact Puppy version and your hardware.
More correct answers.
Les frustration for you and us.

http://murga-linux.com/puppy/viewtopic.php?t=70965

Chris.
Back to top
View user's profile Send private message 
stiginge


Joined: 22 Mar 2007
Posts: 420
Location: Kerry, Ireland

PostPosted: Wed 24 Aug 2011, 03:38    Post subject:  

hi cthisbear, my puppy version is 528 livecd and the wireless hardware is a broadcom 4312.
_________________
Buy silver, crash JPMorgan
Back to top
View user's profile Send private message 
stiginge


Joined: 22 Mar 2007
Posts: 420
Location: Kerry, Ireland

PostPosted: Thu 25 Aug 2011, 05:35    Post subject:  

here is the /var/log/messages printout (just final 4 lines relating to connection issue):

Code:
Aug 26 08:43:18 zimmer user.info kernel: [drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 0
Aug 26 08:43:24 zimmer user.info kernel: b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
Aug 26 08:43:24 zimmer user.err kernel: b43-phy0 ERROR: Initial Values Firmware file-format error.
Aug 26 08:43:24 zimmer user.err kernel: b43-phy0 ERROR: You must go to http://wireless.kernel.org/en/users/Drivers/b43#devicefirmware and download the correct firmware for this driver version. Please carefully read all instructions on this website.


The connection sometimes is made on bootup (about 1 in 5) but if it fails then no amount of attempts using network wizard will make a difference.

_________________
Buy silver, crash JPMorgan
Back to top
View user's profile Send private message 
cthisbear

Joined: 29 Jan 2006
Posts: 3468
Location: Sydney Australia

PostPosted: Thu 25 Aug 2011, 07:49    Post subject:  

http://www.murga-linux.com/puppy/viewtopic.php?t=50570

""""""""

http://208.109.22.214/puppy/viewtopic.php?t=70369&sid=36b28652cf599bfebaa04244af211730

""""""

4.3.1 with Broadcom 4312 Wireless Drivers by jrb -

http://www.wisdom-seekers.com/puppy.html

"""""""""

Why not try 529...3 headed Dog...may be better

http://murga-linux.com/puppy/viewtopic.php?t=70736

Chris.
Back to top
View user's profile Send private message 
stiginge


Joined: 22 Mar 2007
Posts: 420
Location: Kerry, Ireland

PostPosted: Thu 25 Aug 2011, 15:16    Post subject:  

cthisbear wrote:
http://www.murga-linux.com/puppy/viewtopic.php?t=50570

""""""""

http://208.109.22.214/puppy/viewtopic.php?t=70369&sid=36b28652cf599bfebaa04244af211730

""""""

4.3.1 with Broadcom 4312 Wireless Drivers by jrb -

http://www.wisdom-seekers.com/puppy.html

"""""""""

Why not try 529...3 headed Dog...may be better

http://murga-linux.com/puppy/viewtopic.php?t=70736

Chris.


Thanks but unfortunately that doesn't resolve the problem i've got with this OS, 528 Smile

Wifi seems to work without issue in 5.1.1.56 but unfortunately that distro doesn't have any of the greatness of 528. I want to get this working in 528, not move to another distro.

_________________
Buy silver, crash JPMorgan
Back to top
View user's profile Send private message 
stiginge


Joined: 22 Mar 2007
Posts: 420
Location: Kerry, Ireland

PostPosted: Tue 30 Aug 2011, 17:08    Post subject:  

Anybody have any ideas?
_________________
Buy silver, crash JPMorgan
Back to top
View user's profile Send private message 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Tue 30 Aug 2011, 18:33    Post subject:  

Try lucid 529 (three headed dog)
_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send private message 
stiginge


Joined: 22 Mar 2007
Posts: 420
Location: Kerry, Ireland

PostPosted: Wed 31 Aug 2011, 05:23    Post subject:  

I've just tried 529 and no BEEm, it doesn't work. I've still got the same problem with siocsifflags error coming up for ifconfig wlan0 up.
_________________
Buy silver, crash JPMorgan
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5293
Location: Australia

PostPosted: Wed 31 Aug 2011, 05:31    Post subject:  

First try the "LP-PHY" variant of Broadcom wifi firmware, from here -
http://www.murga-linux.com/puppy/viewtopic.php?p=448464#448464
Obviously reboot after installing.

If that doesn't work, you will need the proprietary Broadcom wifi driver, compatible with Puppy versions 5.1 - 5.2.8 here -
http://www.murga-linux.com/puppy/viewtopic.php?p=421596#421596
Follow the instructions in that post carefully, especially the part about blacklisting the "ssb" driver.
Back to top
View user's profile Send private message 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Wed 31 Aug 2011, 06:10    Post subject:  

Sorry to hear that, stiginge.
Hope that tempestuous advise will help you out.

_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 5482
Location: Charleston S.C. USA

PostPosted: Wed 31 Aug 2011, 16:54    Post subject:  

tempestuous is the Puppy master on issues with wireless network connections.
Follow his advice. He is all knowing when it comes to network connection problems.

If it has not been said recently.
Thank you very much tempestuous for your efforts to support Puppy networking!!

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
stiginge


Joined: 22 Mar 2007
Posts: 420
Location: Kerry, Ireland

PostPosted: Thu 01 Sep 2011, 03:38    Post subject:  

Hi tempestuous, bigpup
I've downloaded and installed the .pet above and it seems to be doing the trick so far, good on you temp Very Happy

It was an intermittent problem before (only 1 out of 5 successful connections due to siocsifflags error) but it seems to be connecting successfully 100% at the moment, will post back in a few days to confirm success.

_________________
Buy silver, crash JPMorgan
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 2 [21 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0721s ][ Queries: 12 (0.0044s) ][ GZIP on ]