Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 25 Oct 2014, 16:04
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Engineering/Science/Simulation
Problem to install spice3, ncurses (libtinfo.so.5) is requried
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
anujkaushal

Joined: 02 Sep 2011
Posts: 2

PostPosted: Fri 02 Sep 2011, 03:24    Post_subject:  Problem to install spice3, ncurses (libtinfo.so.5) is requried  

I have problem to install "spice3" software.
The "libinfo.so.5" is required but while installing it through ncurses-lib, the ncurses itself not installing.
here is the process i did:-
[root@localhost Desktop]# rpm -ivh spice-3f5sfix-2.i386.rpm
error: Failed dependencies:
libtinfo.so.5 is needed by spice-3f5sfix-2.i386
[root@localhost Desktop]#
## to install libtinfo the ncurses-libs are required which must be lower version of the ncurses installed in system
## but no lower version ncurses are available . lower than 5.6-13 Otherwise it will conflicts
## so new version of ncurses package si requred

[root@localhost Desktop]# rpm -ivh ncurses-libs-5.9-2.20110716.fc16.i686.rpm
warning: ncurses-libs-5.9-2.20110716.fc16.i686.rpm: Header V3 RSA/SHA256 signature: NOKEY, key ID a82ba4b7
error: Failed dependencies:
ncurses-base = 5.9-2.20110716.fc16 is needed by ncurses-libs-5.9-2.20110716.fc16.i686
rpmlib(FileDigests) <= 4.6.0-1 is needed by ncurses-libs-5.9-2.20110716.fc16.i686
rpmlib(PayloadIsXz) <= 5.2-1 is needed by ncurses-libs-5.9-2.20110716.fc16.i686
ncurses < 5.6-13 conflicts with ncurses-libs-5.9-2.20110716.fc16.i686
[root@localhost Desktop]#

[root@localhost Desktop]# rpm -ivh ncurses-5.9-2.20110716.fc16.i686.rpm
warning: ncurses-5.9-2.20110716.fc16.i686.rpm: Header V3 RSA/SHA256 signature: NOKEY, key ID a82ba4b7
error: Failed dependencies:
libtic.so.5 is needed by ncurses-5.9-2.20110716.fc16.i686
libtinfo.so.5 is needed by ncurses-5.9-2.20110716.fc16.i686
ncurses-libs = 5.9-2.20110716.fc16 is needed by ncurses-5.9-2.20110716.fc16.i686
rpmlib(FileDigests) <= 4.6.0-1 is needed by ncurses-5.9-2.20110716.fc16.i686
rpmlib(PayloadIsXz) <= 5.2-1 is needed by ncurses-5.9-2.20110716.fc16.i686


##### and when i try to instal the ncurses downloaded form gnu site then it also stuck:-
[root@localhost Desktop]# rpm -qa | grep ncurses
ncurses-5.5-24.20060715
ncurses-5.5-24.20060715
[root@localhost Desktop]#

[root@localhost ncurses-5.9]# cd /root/Desktop/ncurses-5.9
[root@localhost ncurses-5.9]# ./configure
checking for egrep... grep -E
Configuring NCURSES 5.9 ABI 5 (Mon Aug 29 16:44:03 IST 2011)
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking target system type... x86_64-unknown-linux-gnu
Configuring for linux-gnu
checking for prefix... /usr
checking for gcc... no
checking for cc... no
checking for cc... no
checking for cl... no
configure: error: no acceptable cc found in $PATH
[root@localhost ncurses-5.9]#

[root@localhost ncurses-5.9]# make
make: *** No targets specified and no makefile found. Stop.
[root@localhost ncurses-5.9]#
Back to top
View user's profile Send_private_message 
muggins

Joined: 20 Jan 2006
Posts: 6689
Location: lisbon

PostPosted: Fri 02 Sep 2011, 05:05    Post_subject:  

Seems ready to go after I downloaded this:

ftp://rpmfind.net/linux/fedora/development/rawhide/i386/os/Packages/ncurses-libs-5.9-2.20110716.fc16.i686.rpm

then extracted it & copied libtinfo.so.5.9 to /lib directory, then:

Code:
ln -s /lib/lib/libtinfo.so.5.9 /lib/libtinfo.so.5
Back to top
View user's profile Send_private_message 
anujkaushal

Joined: 02 Sep 2011
Posts: 2

PostPosted: Fri 02 Sep 2011, 05:41    Post_subject:  

it will be the same results.
But the solution i get from somewher is to install ngspice .
i hope it will be installed.
i will tell it later
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Engineering/Science/Simulation
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0569s ][ Queries: 12 (0.0133s) ][ GZIP on ]