Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 20 Dec 2014, 00:26
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Compiling
Problem compiling programs with SDL mixer
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [7 Posts]  
Author Message
JSonic


Joined: 21 Aug 2011
Posts: 37
Location: Finland

PostPosted: Tue 13 Sep 2011, 00:31    Post subject:  Problem compiling programs with SDL mixer
Subject description: Lucid Puppy 5.2.8
 

Hello!
I have problems compiling applications, which need SDL_mixer library.
The libsdl-mixer1.2-dev package is installed, from ubuntu repo, but configure says (this is from Xmoto):

checking for SDL - version >= 1.0.0... checking for sdl-config... /usr/bin/sdl-config yes
checking for Mix_OpenAudio in -lSDL_mixer... no
configure: error: SDL_mixer required

I've tried with other programs as well and can't figure it out myself.
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6690
Location: lisbon

PostPosted: Tue 13 Sep 2011, 01:30    Post subject:  

If you install this SDL package here, you'll get past that error.

Unfortunately I then get this one:

Code:
checking for library containing luaopen_math... no
./configure: line 366: test: liblualib50: integer expression expected
configure: error: liblualib5.1
./configure: line 263: return: liblualib50: numeric argument required
./configure: line 273: exit: liblualib50: numeric argument required


And then I'm lost...any lua experts around?
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6690
Location: lisbon

PostPosted: Tue 13 Sep 2011, 01:42    Post subject:  

Maybe ask 666philb as he compiled v0.5.6 here.
Back to top
View user's profile Send private message 
JSonic


Joined: 21 Aug 2011
Posts: 37
Location: Finland

PostPosted: Tue 13 Sep 2011, 09:00    Post subject:  

muggins wrote:
If you install this SDL package here, you'll get past that error.


Thanks, this was the solution.
Editing as solved.

JSonic
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6690
Location: lisbon

PostPosted: Tue 13 Sep 2011, 23:24    Post subject:  

JSonic,

which lua packages did you need to use to bypass my lua problems above?
Back to top
View user's profile Send private message 
JSonic


Joined: 21 Aug 2011
Posts: 37
Location: Finland

PostPosted: Wed 14 Sep 2011, 08:31    Post subject:  

muggins wrote:
JSonic,

which lua packages did you need to use to bypass my lua problems above?

I made the lua package myself from Lua Binaries and you can download it from here. It solves lua problems.

But then, I ran into
Code:
configure: error: libode required

That is solved by installing libode-dev from Ubuntu repository.

And now configure runs fine and I can get to compiling.
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6690
Location: lisbon

PostPosted: Thu 15 Sep 2011, 02:02    Post subject:  

Thanks for the extra info Jsonic.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [7 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Compiling
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0541s ][ Queries: 12 (0.0046s) ][ GZIP on ]