Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 16 Apr 2014, 06:21
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Network
pnethood 0.6.8 - samba share mounter
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [18 Posts]   Goto page: 1, 2 Next
Author Message
clarf


Joined: 13 Jun 2007
Posts: 612
Location: The old Lone Wolf

PostPosted: Thu 04 Aug 2011, 23:06    Post subject:  pnethood 0.6.8 - samba share mounter
Subject description: Updated 0.6.8 version (use scrollable windows for server shares)
 

Hi,

I´m proud to announce the immediate release of pnethood 0.6.8, this update includes minor GUI changes. The mayor addition is the use of scrollable windows for shares thanks to new features on gtkdialog added by user thunor (http://murga-linux.com/puppy/viewtopic.php?t=69188), the code is backward compatible and it enable the new GUI features only if the new gtkdialog version is found.

0.6.8 version is based on my latest 0.6.7 version (http://murga-linux.com/puppy/viewtopic.php?t=64206) and latest HairyWill version 0.65 (http://www.murga-linux.com/puppy/viewtopic.php?t=23464).

Fixes:

* Run out of screen space for large number of shares. Needs 0.7.21 gtkdialog version, you can compile latest from https://code.google.com/p/gtkdialog/

* Save button on options window does not close the options child window.

New Features:

* Hanlde servers with lots of shares (using new features in gtkdialog 0.7.21)

* Separate options Window
- Added option to define the minimun number of servers for the initial scan to enable the popup window server list

Credits

Special Thanks to HairyWill who originally developed pnethood, your work is greatly appreciated.

Thanks to thunor for mantaining and developing new features for gtkdialog.

Thanks to the people that helped to make this updated possible and everyone that tested and helped to improve the original version.

Any previous pnethood configuration file (/root/.pnethood/pnethood.rc) must be removed before use this new version. New information is written to the configuration file and previous versions (0.6.6 or earlier) are not supported, there is not problem if you already have pnethood 0.6.7 version.

Greetings,
clarf


EDIT:


pnethood 0.6.8.1 released

This is a quick fix release backward compatible for the password visibility (this is the proper fix discussed below).

I also added width adjustem for the GUI window, it´ll change according to actual display resolution. For 800x600 or lower display resolutions the GUI is set to 400x300, for higher display resolutions the GUI is set to 500x400. To change the deafult size just edit the pnethood executable file and modify the XBOX_SIZE and YBOX_SIZE variables. Needs 0.7.21 gtkdialog version otherwise won´t change in GUI size
clarf_pnethood-0.6.8.1.pet
Description  pnethood 0.6.8.1, quick fix for password visibility entry and width GUI auto-setting
pet

 Download 
Filename  clarf_pnethood-0.6.8.1.pet 
Filesize  27.4 KB 
Downloaded  782 Time(s) 
Scrollable Window shares.jpg
 Description   Scrollable Windows for shares using gtkdialog 0.7.21
 Filesize   38.67 KB
 Viewed   2677 Time(s)

Scrollable Window shares.jpg

clarf_pnethood-0.6.8.pet
Description  pnethood 0.6.8
pet

 Download 
Filename  clarf_pnethood-0.6.8.pet 
Filesize  27.36 KB 
Downloaded  663 Time(s) 

Last edited by clarf on Sat 10 Sep 2011, 12:36; edited 6 times in total
Back to top
View user's profile Send private message 
clarf


Joined: 13 Jun 2007
Posts: 612
Location: The old Lone Wolf

PostPosted: Thu 04 Aug 2011, 23:33    Post subject: gtkdialog 0.7.21 -  

I add the 0.7.21 gtkdialog version (r14) compiled in puppy 214X, minimun gtkdialog version needed for new GUI pnethood features.

Regards,
clarf
gtkdialog-r14-i486.pet
Description 
pet

 Download 
Filename  gtkdialog-r14-i486.pet 
Filesize  49.96 KB 
Downloaded  612 Time(s) 
Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 1212
Location: Queensland Australia ɹǝpu∩uʍop

PostPosted: Thu 18 Aug 2011, 07:45    Post subject:  

I have just updated the gtkdialog , I now seem to have a small problem with pnethood 0.6.8, it still works but the password input won't highlight so that whats typed in can be seen.
In other words there is no indication that anything as been inputted, so just wondering if anyone else has found that also or is it just me.

edit: just checked it by replacing gtkdialog to the version posted here and it works fine, so it is the latest version of thunor's that's causing it.
I complied the latest in quirky 1.20 which seems to have complied correctly with no errors.
Back to top
View user's profile Send private message 
clarf


Joined: 13 Jun 2007
Posts: 612
Location: The old Lone Wolf

PostPosted: Thu 18 Aug 2011, 15:18    Post subject:  

Hi Geoffrey. Thanks for using pnethood and feedback your test.

I´m glad you could solve your problem, haven`t tried the latest gtkdialog version but if there are problems with it, you should report the issue in the gtkdialog thread or in the project HomePage. Thunor is very diligent solving these kind of bugs.

IF you find any other issue with pnethood, please feel free to report here.

Regards,
clarf
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7547
Location: qld

PostPosted: Thu 18 Aug 2011, 16:11    Post subject:  

Clarf, seems to work fine in latest Slacko Beta 1, running r220 of gtkdialog.

I have had a feature request.. an adjustment of the GUI size to be a little wider and perhaps not so tall.

Regards , 01micko

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
01micko


Joined: 11 Oct 2008
Posts: 7547
Location: qld

PostPosted: Sun 21 Aug 2011, 06:43    Post subject:  

Hi again clarf,

With the very latest gtkdialog the password syntax seems to fail.. It's the same in PupDial. There is a backward compatible solution. Just making you aware.

http://www.murga-linux.com/puppy/viewtopic.php?p=555419#555419

Cheers

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
clarf


Joined: 13 Jun 2007
Posts: 612
Location: The old Lone Wolf

PostPosted: Sun 21 Aug 2011, 13:29    Post subject:  

Hi 01micko, thanks for using latest pnethood.

Quote:
I have had a feature request.. an adjustment of the GUI size to be a little wider and perhaps not so tall.


In this version I implemented some GUI adjustment on heigh, it resize the Windows according to screen resolution. I could do the same for the weight size:

Code:

line 42:
[ $SCRN_Y -le 600 ] && SBOX_SIZE=300 || SBOX_SIZE=400

line 423:
PNETHOOD_GUI=$PNETHOOD_GUI"<vbox height-request=\"$SBOX_SIZE\">"


or I could implement the share window size as an additional user option. But I think there are enough user options (automatic size could be enough and the scrollable Window could handle the rest).


Quote:
With the very latest gtkdialog the password syntax seems to fail.. It's the same in PupDial. There is a backward compatible solution. Just making you aware.


Thanks for the advise.

Seems like thunor is going to support the backward solution but I don`t know which is better for older gtkdialog versions:
use invisible-char="120" or use <visible>password</visible>

EDIT:
OK. I read the Gtkdialog Development thread, thunor explained that the correct implementation is
<sensitive>password</sensitive>
and the invisible-char="120" will work for newer gtkdialog only, then the best option for backward compatibility seems to be:
<visible>password</visible>

thank you 01micko

Regards,
clarf
Back to top
View user's profile Send private message 
clarf


Joined: 13 Jun 2007
Posts: 612
Location: The old Lone Wolf

PostPosted: Sat 10 Sep 2011, 19:29    Post subject:  

new release (minor fix update) on first post.

clarf
Back to top
View user's profile Send private message 
ttuuxxx


Joined: 05 May 2007
Posts: 10730
Location: Ontario Canada,Sydney Australia

PostPosted: Wed 14 Sep 2011, 03:46    Post subject: Re: gtkdialog 0.7.21 -  

clarf wrote:
I add the 0.7.21 gtkdialog version (r14) compiled in puppy 214X, minimun gtkdialog version needed for new GUI pnethood features.

Regards,
clarf


Hi clarf your gtkdialog package places the gtkdialog bin in usr/local/bin where as the default gtkdialog bin is located in usr/sbin, so there are now 2 gtkdialog bin files. will this mess things up, its in the next release like this.
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile

Back to top
View user's profile Send private message Visit poster's website 
clarf


Joined: 13 Jun 2007
Posts: 612
Location: The old Lone Wolf

PostPosted: Wed 14 Sep 2011, 10:11    Post subject:  

Hi ttuuxxx,

I didn´t find any backward problem with the r14 release posted here, it should replace the default gtkdialog executable in usr/sbin without problems on 214X. I apologize, I didn´t check what default path is used for each Puppy version so I used the default one when I compiled the source.

Advice for the gtkdialog package users:

The user that loads this package also must check if his Puppy version has a gtkdialog3 symlink and correct this if necessary.

In case of having two gtkdialog binaries then the first coincidence in the "PATH" user environment variable will have priority over others. This is like this, if the PATH variable contains "PATH=/usr/local/bin; /usr/sbin", the system will look on /usr/local/bin path first for the executables given (in this example gtkdialog or gtkdialog3) and if the executable is found then the system will use it and omit the executables on the following /usr/sbin path.

To find what gtkdialog executable the system will lookup and use first, launch "which gtkdialog" and check the path returned.

Regards,
Andrés Caro
Back to top
View user's profile Send private message 
ttuuxxx


Joined: 05 May 2007
Posts: 10730
Location: Ontario Canada,Sydney Australia

PostPosted: Wed 14 Sep 2011, 10:17    Post subject:  

clarf wrote:
Hi ttuuxxx,

I didn´t find any backward problem with the r14 release posted here, it should replace the default gtkdialog executable in usr/sbin without problems on 214X. I apologize, I didn´t check what default path is used for each Puppy version so I used the default one when I compiled the source.

Regards,
Andrés Caro

are you sure did you manually delete the one in usr/sbin? since yours install in a different location.
Also the next release is almost ready, a couple of hours away, Its the last of the stable 2.14X branch before I change to the latest GTK2, I used the newer GTK without any issues for 2+ weeks, so it should be good, but I'll play it safe first Smile
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile

Back to top
View user's profile Send private message Visit poster's website 
clarf


Joined: 13 Jun 2007
Posts: 612
Location: The old Lone Wolf

PostPosted: Wed 14 Sep 2011, 11:26    Post subject:  

Hi ttuuxxx,

well, there is always a small risk present changing gtkdialog as it´s an important/extensive component.

I don´t habituate to mix such kind of changes (in this case GTK and gtkdialog) releasing new software and don´t wan to affect latest stable 214X either.

Anyway pnethood 0.6.8.1 detects actual gtkdialog version and disable new features when needed, so pnethood is fail safe where gtkdialog has a risk...

In other words, I also bet for a latest stable first. Smile

clarf
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 1272
Location: Malvern, Worcs, UK

PostPosted: Wed 05 Oct 2011, 04:27    Post subject:  

Hi there

pnethood works great for me - but I've noticed in all recent puppies that the display isn't quite wide enough.....screenie attached from latest wary5.1.103

Thanks
peebee
screen-pnethood.png
 Description   
 Filesize   36.19 KB
 Viewed   2119 Time(s)

screen-pnethood.png


_________________
LxPup-14.03 = Puppy + LXDE
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 1272
Location: Malvern, Worcs, UK

PostPosted: Sat 11 Feb 2012, 06:11    Post subject: pnethood in k3.1.n  

Hi there

Just a possible "heads up".........

pnethood on puppies using k3.0.n is saying in dmesg:

Quote:
CIFS VFS: default security mechanism requested. The default security mechanism will be upgraded from ntlm to ntlmv2 in kernel release 3.1


Does this mean a pnethood update will be needed???

Thanks
peebee

_________________
LxPup-14.03 = Puppy + LXDE
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7547
Location: qld

PostPosted: Sat 11 Feb 2012, 06:17    Post subject:  

peebee,

Working fine here in slacko beta k3.1.10, I've been playing with mount.cifs to day .. same message though but it says kernel 3.2!

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 2 [18 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Network
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0772s ][ Queries: 13 (0.0043s) ][ GZIP on ]