Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 24 Apr 2014, 12:51
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Networking » Dialup
[CLOSED] Problem with Agere HDA modem on HP550 laptop
Post new topic   Reply to topic View previous topic :: View next topic
Page 3 of 3 [35 Posts]   Goto page: Previous 1, 2, 3
Author Message
tempestuous

Joined: 10 Jun 2005
Posts: 5139
Location: Australia

PostPosted: Thu 22 Sep 2011, 06:51    Post subject:  

rerwin, let's take the technical discussion of ALSA-compatibility offline. I have sent you a PM.
Back to top
View user's profile Send private message 
rerwin


Joined: 24 Aug 2005
Posts: 1469
Location: Maine, USA

PostPosted: Thu 22 Sep 2011, 15:41    Post subject:  

peebee,
I have something for you to try. Tempestuous sent me a dot-pet of the ALSA 1.0.21 library and utilities that I have tested on my PC. The same test as before, forcing loading of agrmodem, produced a better-looking set of messages -- and no distress calls!
    Sep 23 17:38:30 puppypc user.info kernel: usbcore: registered new interface driver agr12dec2006
    Sep 23 17:38:30 puppypc user.warn kernel: serial8250_register_ports: BaseAddress 0x0400 Irq 3
    Sep 23 17:38:30 puppypc user.info kernel: ttyAGS3 at I/O 0x400 (irq = 3) is a AgereModem
    Sep 23 17:38:30 puppypc user.err kernel: agrserial - ret_val 0, call: lt_modem_ops.init_modem
    Sep 23 17:38:30 puppypc user.info kernel: Loading module Agere Modem Interface driver version 2.1.80.0 (2007-10-01)

This suggests that the package may solve the problem. However, it restores ALSA 1.0.21 for everything, so new features provided by 1.0.24 will be lost.

I have modified the package slightly, to add scripts to deal with the fact that lupu puts 2 files in /sbin, while the package has them in /usr/sbin. If you uninstall the package, the mods will be undone. The package can be installed on top of everything else, so you need not start afresh. Here's hoping.
Richard
alsa-lib-utils-1.0.21-lucid.pet
Description  Restores ALSA 1.0.21 to Lucid Pup
pet

 Download 
Filename  alsa-lib-utils-1.0.21-lucid.pet 
Filesize  509.89 KB 
Downloaded  459 Time(s) 
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 1274
Location: Malvern, Worcs, UK

PostPosted: Fri 23 Sep 2011, 04:02    Post subject:  

rerwin wrote:
peebee,
I have something for you to try. Here's hoping.
Richard


So so sorry Richard - but I still get a crash even with the alsa 1.0.21 pet

Messages attached for lupu528
messages230911.gz
Description 
gz

 Download 
Filename  messages230911.gz 
Filesize  58.52 KB 
Downloaded  527 Time(s) 
dmesg230911.gz
Description 
gz

 Download 
Filename  dmesg230911.gz 
Filesize  30.19 KB 
Downloaded  513 Time(s) 

_________________
LxPup-14.03 = Puppy + LXDE
Back to top
View user's profile Send private message 
rerwin


Joined: 24 Aug 2005
Posts: 1469
Location: Maine, USA

PostPosted: Tue 04 Oct 2011, 19:35    Post subject:  

peebee,
I am surprised by the failure of the ALSA 1.0.21 package to resolve the crash problem. The idea was to have all parts -- library, utilities and driver -- at the same version. If the agrsm driver was coded for 1.0.20, 1.0.21 must be too different for it to handle.

Although I doubt it will help, you might also try installing the new compiled version of the ALSA 1.0.24 driver into a normal lupu 528, to match the library and utilities there. But since it crashes with 1.0.21, I don't expect any better from matching ALSA 1.0.24 components, either.

I think we will have to wait for the agrsm driver maintainer to upgrade it to at least ALSA 1.0.24.
Richard
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 1274
Location: Malvern, Worcs, UK

PostPosted: Wed 05 Oct 2011, 15:04    Post subject:  

Hi Richard

I guess the advice we should give anybody with the AGERE HDA modem is to use Wary in the first instance.

If they really want lupu or slacko then it is possible to switch their kernels to use the wary kernel as described in:
http://www.murga-linux.com/puppy/viewtopic.php?t=60180

I've put the kernel from wary5.1.103 into both lupu528 and slacko4.99.7 today and both seem to work fine AND have a working modem - see the attached screen dump.

I'll put this thread back to CLOSED.

Cheers
peter
screen.png
 Description   
 Filesize   147 KB
 Viewed   519 Time(s)

screen.png


_________________
LxPup-14.03 = Puppy + LXDE
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 3 of 3 [35 Posts]   Goto page: Previous 1, 2, 3
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Networking » Dialup
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0516s ][ Queries: 13 (0.0093s) ][ GZIP on ]