Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 23 Oct 2014, 05:21
All times are UTC - 4
 Forum index » Off-Topic Area » Security
Urgent: Patch Adobe Flashto Protect against Zero-Day Exploit
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [12 Posts]  
Author Message
James C


Joined: 26 Mar 2009
Posts: 5860
Location: Kentucky

PostPosted: Thu 22 Sep 2011, 04:14    Post subject:  Urgent: Patch Adobe Flashto Protect against Zero-Day Exploit  

Read here
http://www.pcworld.com/businesscenter/article/240376/urgent_patch_adobe_flash_to_protect_against_zeroday_exploit.html#tk.rss_news
Back to top
View user's profile Send private message 
wuwei


Joined: 15 Sep 2007
Posts: 774
Location: de

PostPosted: Thu 22 Sep 2011, 05:32    Post subject:  

Thanks for the warning, James.
Back to top
View user's profile Send private message 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15117
Location: Paradox Realm

PostPosted: Thu 22 Sep 2011, 08:16    Post subject:  

Upgrades.
http://puppylinux.org/wikka/libflashplayer

_________________
Puppy WIKI
Back to top
View user's profile Send private message Visit poster's website 
faifpuhp


Joined: 22 Sep 2011
Posts: 97

PostPosted: Thu 22 Sep 2011, 12:30    Post subject:  

Done! (Man, that was fast...)

You know, there's no reason that Adobe couldn't have a ton of experimental versions with known exploits laying around, specifically to let people take over your computer. Not saying they would! But there's no reason they couldn't, and it would look like an innocent mistake on their part Very Happy Like a poison in two parts, where either alone is innocuous.

_________________
Strawberry is dead!
Back to top
View user's profile Send private message 
big_bass

Joined: 13 Aug 2007
Posts: 1747

PostPosted: Thu 22 Sep 2011, 23:43    Post subject:  

flash updater script

keep updated always

just un compress it then
and click on flash-updater

it asks if you want to install click ok
it take a few minutes because it downloads the file then installs it in the background
when its done a box pops up for 3 seconds and says its done

hope this makes it easier
http://www.murga-linux.com/puppy/viewtopic.php?mode=attach&id=46494

_________________
debian wheezy ,linux mint, slackware I use them all and they all have good points
Mint would be best for general users though
Back to top
View user's profile Send private message 
DPUP5520

Joined: 16 Feb 2011
Posts: 801

PostPosted: Fri 23 Sep 2011, 02:25    Post subject:  

Didn't download the latest version, it redownloaded 10.3.183.7 so maybe the site just doesn't update flash all that quick. Also it might be a good idea to
Code:
rm -fr /usr
or whatever the command would be since it does no good in there anyway and just takes up space.
_________________
PupRescue 2.5
Puppy Crypt 528
Back to top
View user's profile Send private message 
faifpuhp


Joined: 22 Sep 2011
Posts: 97

PostPosted: Fri 23 Sep 2011, 02:54    Post subject:  

DPUP5520 wrote:
Also it might be a good idea to
Code:
rm -fr /usr
or whatever the command would be


?! You'll want to explain that one, most of the time (in other distros, for example) you probably would not want to do that...

_________________
Strawberry is dead!
Back to top
View user's profile Send private message 
DPUP5520

Joined: 16 Feb 2011
Posts: 801

PostPosted: Fri 23 Sep 2011, 03:14    Post subject:  

sorry I put the / there by mistake i mean to put
Code:
rm -fr usr
which would delete the usr folder from /usr/lib/mozilla/plugins folder, I think.
_________________
PupRescue 2.5
Puppy Crypt 528
Back to top
View user's profile Send private message 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Fri 23 Sep 2011, 03:17    Post subject:  

dpup wow you mean we still ahve the old one then?
I felt so happy that now I have a patched version but if I get you
we still ahve the old one? So what to do?

_________________
I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send private message 
faifpuhp


Joined: 22 Sep 2011
Posts: 97

PostPosted: Fri 23 Sep 2011, 03:30    Post subject:  

DPUP5520 wrote:
sorry I put the / there by mistake i mean to put
Code:
rm -fr usr
which would delete the usr folder from /usr/lib/mozilla/plugins folder, I think.


perhaps
Code:
rm -fr ../plugins/usr
just to be sure? that way if you're not in the right folder, it (probably) won't delete anything
_________________
Strawberry is dead!
Back to top
View user's profile Send private message 
DPUP5520

Joined: 16 Feb 2011
Posts: 801

PostPosted: Fri 23 Sep 2011, 03:32    Post subject:  

I suppose but if you take a look at the script it already changes to that directory so that it can download and install the lib in there and then delete the tar'd file so there should be no need for writing out the whole path though it couldn't hurt

Edit: just modified the script and tested adding in
Code:
rm -fr usr
underneath line 13 does the trick
flash-updater.gz
Description 
gz

 Download 
Filename  flash-updater.gz 
Filesize  340 Bytes 
Downloaded  203 Time(s) 

_________________
PupRescue 2.5
Puppy Crypt 528
Back to top
View user's profile Send private message 
faifpuhp


Joined: 22 Sep 2011
Posts: 97

PostPosted: Fri 23 Sep 2011, 04:16    Post subject:  

DPUP5520 wrote:
I suppose but if you take a look at the script it already changes to that directory


I missed that part, gotcha now.

_________________
Strawberry is dead!
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [12 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Off-Topic Area » Security
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0760s ][ Queries: 13 (0.0122s) ][ GZIP on ]