Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 30 Jul 2014, 17:24
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Introducing PULP - 125 MB Puplet for older hardware
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 14 of 18 [258 Posts]   Goto page: Previous 1, 2, 3, ..., 12, 13, 14, 15, 16, 17, 18 Next
Author Message
sindi

Joined: 16 Aug 2009
Posts: 389

PostPosted: Fri 30 Sep 2011, 20:39    Post subject: pulp 0.1 with mplayer on DELL Inspiron 7000 and 8200
Subject description: mplayer (alsa) cannot find /dev/dsp
 

No sound with mplayer and this chip. Cannot find audio device /dev/dsp
(which really does not exist, or dsp1 or dsp2)/ Both DELLs use maestro3 driver.

Other linux users report similar problems with mplayer, alsa and intel 810 sound.
Both use ac97_codec. aplay will play wav files that mplayer will not.
Gxine plays DVDs with sound on here, OSS and XP sound also work.

Has anyone installed a different DVD player in pulp linux yet? VLC?
Back to top
View user's profile Send private message 
sindi

Joined: 16 Aug 2009
Posts: 389

PostPosted: Fri 30 Sep 2011, 21:05    Post subject: xine on DELL Inspiron 7000 and 8200, maestro3 sound chip
Subject description: plays mp3s where mplayer does not
 

Installed with puppy package manager. Install the library and plugin. No need to reboot.
Plays MP3s offline, with Seamonkey and Opera (set /usr/bin/xine as the default MP3 player), and plays DVDs (not full-screen though).

I tried to use it CLI pointed at a URL for streaming MP3, like mplayer, and got noise instead of music. I can listen with Opera instead but cannot use a large collection of scripts I put together for mplayer and classical streaming mp3s. Is there any CLI MP3 player that works online besides mplayer?
Back to top
View user's profile Send private message 
sindi

Joined: 16 Aug 2009
Posts: 389

PostPosted: Sat 01 Oct 2011, 20:16    Post subject: Opera 11.51 now working in Pulp with latest Flash 10
Subject description: libflashplayer.so needs some libraries found in firefox
 

cd /usr/lib/mozilla/plugins

ldd libflashplayer.so
reveals several missing libraries, which come with firefox (so that they are on the path
when you run firefox, or seamonkey, where flash works)

cd /usr/lib
ln -sf /mnt/home/firefox/lib* .

This symlinks the firefox libraries (unpacked outside of the file system)
to /usr/lib where they are found. It probably also updates some files in /usr/lib.

I could also have edited /etc/profile to include the firefox libraries on the library path.
LD_LIBRARY_PATH (ahead of the files in /usr/lib since they are newer). The same libraries are found in Seamonkey 2.0.14 but are a bit older, April instead of September.


I exited and restarted Opera and no longer get a message about missing plugins.

Opera is already set to look in /usr/lib/mozilla/plugins for the plugins (see pluginpath.ini).

Flash 9 requires far fewer libraries than Flash 10 so should have worked but it is outdated for Youtube, therefore I need to "update my plugin".

Mplayer may simply not work with this maestro3 alsa driver due to a bug in the kernel.
I will get used to using Opera instead of CLI for streaming audio.
Back to top
View user's profile Send private message 
sindi

Joined: 16 Aug 2009
Posts: 389

PostPosted: Wed 05 Oct 2011, 09:41    Post subject: Pulp 0.1 with maestro3 driver; browser memory
Subject description: no sound with mplayer on SOME laptops; reduce seamonkey and firefox memory use
 

DELL Inspiron 7000 and 8100 mplayer cannot find
audio device /dev/dsp so no sound. Both use maestro3
(I don't recall which ess chip - es1988 and others
use this ALSA driver for sound and modem).
I had to install xine to use for mp3 playing.

HP Pavilion n5415 uses the same driver, and mplayer works.
DELL and HP may use different ess chips.

Someone reported that ALSA driver has a bug starting in
kernel 2.6.24 but mplayer won't work on the DELLs in
pulp (2.6.21.7) or puppy with 2.6.30 kernel, for
their machine (with 00.0d.0 elspci -l output, whereas
the HP has 00.08.0 - did not check the DELLs yet)

Anyway, be prepared for mplayer not to play ALSA sound
with maestro3 driver, on certain laptops.

I have added lynx and links2 and nano to pulp.

Which battery monitor program do we have, and how do
I figure out what the other programs are linked with
the other icons at the top?

I installed both seamonkey (2.0.14) and Firefox 6
outside the file system - just unpack to /mnt/home
and run from the directory (cd /seamonkey then ./seamonkey).
Takes a bit longer to load (but pulp probably boots faster).

Seamonkey can be set to store its cache outside
the puppy/pulp file system (preferences, advanced, cache).
Does the save file load into memory? If not, this is
irrelevant.

Firefox6 uses a lot of memory (in /root/.mozilla/firefox)
to store information about fraudulent websites - turn off
that feature in preferences, security - uncheck 2 boxes -
about reported attack sites and web forgeries and delete
urlclassifier3.sql (it can get huge). Firefox 2 (bon echo)
has this feature greyed out (turned off) already.
Advanced, general, override automatic cache management,
delete history on exit. (Firefox 2 Advanced, set Cache size).

The firefox directory is now down to 8MB including addons,
from nearly 50MB, with cache cleared.
Back to top
View user's profile Send private message 
Puppyt

Joined: 09 May 2008
Posts: 561
Location: Gatton, Queensland

PostPosted: Sat 15 Oct 2011, 19:23    Post subject:  

Thanks for all the updates and your hard work, sindi Smile
_________________
Toowoomba Linux Community
http://groups.google.com/group/toowoombalinux
Back to top
View user's profile Send private message Visit poster's website 
sindi

Joined: 16 Aug 2009
Posts: 389

PostPosted: Wed 19 Oct 2011, 22:12    Post subject: battery monitor
Subject description: for acpi instead of apm
 

My DELL Inspiron 8100 does not work with the Pulp battery monitor (apm) - I get a blank terminal window with no information in it.

I wrote a script /usr/local/bin/bat which is
cat /proc/acpi/battery/BAT1/state

chmod +x /usr/local/bin/bat

My 8100 has no battery 0 so I used BAT1. You could have a bat0 and bat1.
(I think the floppy drive can theoretically be exchanged for another battery).

What file do I edit to replace the script that tries to display apm battery status when I left or riight click on the little picture of the battery at screen top (tray?). How about the ones at screen bottom?
Back to top
View user's profile Send private message 
sindi

Joined: 16 Aug 2009
Posts: 389

PostPosted: Fri 09 Mar 2012, 19:04    Post subject: xine works where mplayer does not
Subject description: Compaq Presario 1200
 

Mplayer was working on my Compaq Presario 1200 AMD-K6 3D 375MHz laptop
then suddenly no longer worked (missing /dev/dsp as with the DELL).
Download xine for Puppy 4 and associated packages and xine works but
only as GUI. Is there a CLI xine usable with Pulp/Puppy 4.12?
Back to top
View user's profile Send private message 
Colonel Panic


Joined: 16 Sep 2006
Posts: 1502

PostPosted: Fri 09 Mar 2012, 20:28    Post subject: Re: Pulp 0.1 with maestro3 driver; browser memory
Subject description: no sound with mplayer on SOME laptops; reduce seamonkey and firefox memory use
 

sindi wrote:
DELL Inspiron 7000 and 8100 mplayer cannot find
audio device /dev/dsp so no sound. Both use maestro3
(I don't recall which ess chip - es1988 and others
use this ALSA driver for sound and modem).
I had to install xine to use for mp3 playing.

HP Pavilion n5415 uses the same driver, and mplayer works.
DELL and HP may use different ess chips.

Someone reported that ALSA driver has a bug starting in
kernel 2.6.24 but mplayer won't work on the DELLs in
pulp (2.6.21.7) or puppy with 2.6.30 kernel, for
their machine (with 00.0d.0 elspci -l output, whereas
the HP has 00.08.0 - did not check the DELLs yet)

Anyway, be prepared for mplayer not to play ALSA sound
with maestro3 driver, on certain laptops.

I have added lynx and links2 and nano to pulp.

Which battery monitor program do we have, and how do
I figure out what the other programs are linked with
the other icons at the top?

I installed both seamonkey (2.0.14) and Firefox 6
outside the file system - just unpack to /mnt/home
and run from the directory (cd /seamonkey then ./seamonkey).
Takes a bit longer to load (but pulp probably boots faster).

Seamonkey can be set to store its cache outside
the puppy/pulp file system (preferences, advanced, cache).
Does the save file load into memory? If not, this is
irrelevant.

Firefox6 uses a lot of memory (in /root/.mozilla/firefox)
to store information about fraudulent websites - turn off
that feature in preferences, security - uncheck 2 boxes -
about reported attack sites and web forgeries and delete
urlclassifier3.sql (it can get huge). Firefox 2 (bon echo)
has this feature greyed out (turned off) already.
Advanced, general, override automatic cache management,
delete history on exit. (Firefox 2 Advanced, set Cache size).

The firefox directory is now down to 8MB including addons,
from nearly 50MB, with cache cleared.


Thanks for the advice here Sindi. I'm posting from Flock right now (which was based on Firefox) but have unchecked some of these boxes anyway.

BTW, I believe I remember you from the Basic Linux site. Amazing distro for old computers wasn't it? Hope all's well with you.

_________________
Stone Pentium IV (2.4 GHz), 2 GB of RAM, 160 GB hard drive running Puppy Carolina 1.2, Puppy EmSee v2.1, Puppy 4.31 Workhorse, Legacy OS2 LTS and Puppy Midnight Sun 003.
Back to top
View user's profile Send private message 
greengeek

Joined: 20 Jul 2010
Posts: 2409
Location: New Zealand

PostPosted: Thu 15 Mar 2012, 00:49    Post subject:  

Sindi - it sounds as if you have managed to update quite a bit of pulp 0.1

Any chance of posting a new iso somewhere for me to download and trial?

many thanks
Back to top
View user's profile Send private message 
sindi

Joined: 16 Aug 2009
Posts: 389

PostPosted: Fri 21 Sep 2012, 00:50    Post subject: Pulp 01
Subject description: New ISO
 

I don' t have a new iso, just my save file for pulp which changes the original sfs file. I have made different changes to pulp on various laptops. Some of the files are outside the file system (browsers). It is rather a mess. Can you just follow my postings and make your own customized version? Pulp boots much faster than Puppy.

I was just able to unthrottle the speed in Puppy 4.3.1 using a cpu frequency tool which pulp does not have. Anyone know how to add it to pulp? DELL laptops have (had, anyway) a clever setup in which the laptop and the power supply had to recognize each other (OEM power supply required) and if either chip (or maybe wire) went bad, the computer speed is throttled to minimum. My D600 runs at 40% of maximum speed with pulp but 100% with puppy 4.3.1, now that I have reset the min to the max CPU speed.
Back to top
View user's profile Send private message 
sindi

Joined: 16 Aug 2009
Posts: 389

PostPosted: Fri 21 Sep 2012, 01:23    Post subject: cpufreq
Subject description: modules exist, manually add a start file
 

Used to unthrottle speed of a DELL D600 with hardware
problem. See my posting related to the D600 and unthrottling.
Two modules and one script that echoes the correct cpu speeds
to some files in /sys/. Back from 600MHz to 1600MHz.
Windows requires some huge slow programs to accomplish the same.
Back to top
View user's profile Send private message 
sindi

Joined: 16 Aug 2009
Posts: 389

PostPosted: Fri 21 Sep 2012, 01:44    Post subject: /root/Startup
Subject description: has a copy of itself in it
 

/root/Startup contains a README.txt
then another ./Startup with README.txt
which should be deleted.
Back to top
View user's profile Send private message 
sindi

Joined: 16 Aug 2009
Posts: 389

PostPosted: Thu 27 Sep 2012, 23:45    Post subject: pulp xpdf segfaults
Subject description: fonts not where expected
 

/usr/local/etc/xpdfrc supplied with pulp looks by default for fonts in
/usr/local/share/ghostscript/fonts

pulp has /usr/share/ghostscript/fonts which is a symlink to /usr/share/fonts/default/Type1

It also has the required fonts in /usr/share/AbiSuite/fonts

The AbiSuite fonts that are duplicated in /usr/share/fonts could be
deleted to save space, and symlinked to the other fonts.

One fix for the segfaulting xpdf is

mkdir /usr/local/share/ghostscript
mkdir /usr/local/share/ghostscript/fonts
ln -s /usr/share/fonts/default/Type1 /usr/local/share/ghostscript/fonts
(And probably get rid of /usr/share/ghostscript unless something else uses it).

Or you could edit xpdfrc by removing the # in front of all the lines pertaining
to fonts and deleting /local/ (change to /usr/share/ghostscript/fonts)

or changing /usr/local/share/ghostscript/fonts
to /usr/share/fonts/default/Type1
or to /usr/share/AbiSuite/fonts

When I edited xpdfrc, xpdf (run from an rxvt) no longer complained
about not being able to create Times New Roman, but it still segfaults.
Any ideas?

I tried installing xpdf 3.02 but after downloading it, I can't find it.
Back to top
View user's profile Send private message 
sindi

Joined: 16 Aug 2009
Posts: 389

PostPosted: Thu 27 Sep 2012, 23:59    Post subject: pulp and pdf files
Subject description: use pdftoppm
 

A workaround for xpdf segfaulting (on a D600 DELL) even
after fixing the fonts in xpdfrc, is pdftoppm
pdftoppm filename.pdf > filename.ppm
(or look up the switches for converting to mono .pbm).

View with xli (or convert to gif and view with browser)
xli is showing me only the upper left part of the image.
??
Back to top
View user's profile Send private message 
sindi

Joined: 16 Aug 2009
Posts: 389

PostPosted: Sun 30 Sep 2012, 01:20    Post subject: pdf viewing in pulp
Subject description: Opera extension gPDF
 

Install gPDF extension in Opera 11 (Opera 12 seems not to play Youtube) which uses Google Docs to display pdf files (quickly). Said to display other Google Doc formats as well such as ppt and docx.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 14 of 18 [258 Posts]   Goto page: Previous 1, 2, 3, ..., 12, 13, 14, 15, 16, 17, 18 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0931s ][ Queries: 13 (0.0084s) ][ GZIP on ]