Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 22 Aug 2014, 23:53
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
apt-get working on Puppy 5 lupu pretty simple
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 3 of 3 [33 Posts]   Goto page: Previous 1, 2, 3
Author Message
sickgut


Joined: 23 Mar 2010
Posts: 1157
Location: Tasmania, Australia in the mountains.

PostPosted: Thu 06 Oct 2011, 06:20    Post subject:  

hi ppl
im sorry but i lost my apt-get package when i had an accident of the server and lost the entire repo

if i can find someone with the package intact then ill host it somewhere again
Back to top
View user's profile Send private message Visit poster's website 
edoc


Joined: 07 Aug 2005
Posts: 4365
Location: Southeast Georgia, USA

PostPosted: Mon 04 Feb 2013, 13:44    Post subject:  

Any news re. this?

Sure could use apt-get or some equivalent way to get Debian apps into Puppy Linux Exprimo.

Right now I am trying to load a weather-related program weewx which has several python-related dependencies.

The recommended app to load python add-ons is pip - but pip requires gtk2.0-binmver-2.0.0 which is supposed to be in libgtk2.0-0 but is not.

The usual Debian demon-spawn of dependency hell & poor documentation.

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602
Back to top
View user's profile Send private message Visit poster's website 
edoc


Joined: 07 Aug 2005
Posts: 4365
Location: Southeast Georgia, USA

PostPosted: Mon 04 Feb 2013, 14:23    Post subject:  

OK, Puppy Package Manager handles the python loads but here's the typical Debian complexity and failure list when one tries to install just one little weather-related app (weewx):

python-configobj
python-support (extra dependency)
python-central (extra dependency)
python-cheetah (plus 6 dependencies)
python-imaging
python-mysql
mysql-client-plus (plus 7 dependencies)
python-seial

Missing:

gtk2.0-binver-2.10.0
libmime-base64-perl
libstorable-perl
perl-dbdabi-94

Nothng unexpected from Debian but a show-stopper for access to weewx at the moment.

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 3 of 3 [33 Posts]   Goto page: Previous 1, 2, 3
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0432s ][ Queries: 12 (0.0050s) ][ GZIP on ]