Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 22 Aug 2014, 00:08
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
How to use a Lexmark Prevail Pro705 in Lupu 528?
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 2 [26 Posts]   Goto page: Previous 1, 2
Author Message
popguy

Joined: 15 Oct 2007
Posts: 31

PostPosted: Thu 06 Oct 2011, 03:34    Post subject:  

yes, it works fine, networked, on my ubuntu machine, XSANE is ok with it. I tried looking somewhere for settings, but really i don't have a clue of what to do to understand any further. Maybe lexmark's driver does all of it, but i really don't know how to look inside.
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9039
Location: Stratford, Ontario

PostPosted: Thu 06 Oct 2011, 08:16    Post subject:  

In Xsane, check File > Info. This will show you the device URI and the loaded backend.

Also, if you run the CUPS web interface at localhost:631, what URI does Ubuntu use with the printer? Is it also socket?
Back to top
View user's profile Send private message 
popguy

Joined: 15 Oct 2007
Posts: 31

PostPosted: Fri 07 Oct 2011, 13:07    Post subject:  

yep,

vendor: Lexmark
Model: Pro700 series
device: libnet/0020008E77CE
Loaded backend: LexmarkLegacy_1_0_0

(my sane version is 1.0.22)

and in cups it says:

Description: Lexmark_Pro700_Series
Location:
Driver: Lexmark Pro700 Series, 1.0 (color, 2-sided printing)
Connection: lxhcp://0020008E77CE
Defaults: job-sheets=none, none media=iso_a4_210x297mm sides=two-sided-long-edge

sorry for late reply, but i do need to work inbetween threading Wink
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9039
Location: Stratford, Ontario

PostPosted: Fri 07 Oct 2011, 13:22    Post subject:  

popguy wrote:
device: libnet/0020008E77CE
Loaded backend: LexmarkLegacy_1_0_0

Try the following from the command line in Puppy
Code:
xsane LexmarkLegacy_1_0_0:/libnet/0020008E77CE

Quote:
Driver: Lexmark Pro700 Series, 1.0 (color, 2-sided printing)
Connection: lxhcp://0020008E77CE

In CUPS, try doing a manual install using the above URI. Pick LPD/LPR for the protocol.
Back to top
View user's profile Send private message 
popguy

Joined: 15 Oct 2007
Posts: 31

PostPosted: Sat 08 Oct 2011, 03:45    Post subject:  

when i type

xsane LexmarkLegacy_1_0_0:/libnet/0020008E77CE

xsane says: "scanning for devices". After about 5 seconds an error window appears saying it failed to open the device LexmarkLegacy_1_0_0:/libnet/0020008E77CE, and that the operation is not supported.

In cups, do you mean i have to delete my printer (now with the socket setup) and reinstall it using LPD/LPR? or must i add a printer with LPD/LPR settings keeping this one with the socket settings?
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9039
Location: Stratford, Ontario

PostPosted: Sat 08 Oct 2011, 06:42    Post subject:  

popguy wrote:
when i type

xsane LexmarkLegacy_1_0_0:/libnet/0020008E77CE

xsane says: "scanning for devices". After about 5 seconds an error window appears saying it failed to open the device LexmarkLegacy_1_0_0:/libnet/0020008E77CE, and that the operation is not supported.

That's too bad. The Ubuntu installer is doing something extra to set up network scanning.

Did we ever confirm that LexmarkLegacy_1_0_0 works as a USB backend? It would be nice to know that for sure.

Quote:
In cups, do you mean i have to delete my printer (now with the socket setup) and reinstall it using LPD/LPR? or must i add a printer with LPD/LPR settings keeping this one with the socket settings?

You can keep your current socket printer.
Back to top
View user's profile Send private message 
popguy

Joined: 15 Oct 2007
Posts: 31

PostPosted: Sat 08 Oct 2011, 14:03    Post subject:  

Quote:
Did we ever confirm that LexmarkLegacy_1_0_0 works as a USB backend? It would be nice to know that for sure.


maybe not. How could i do that?
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9039
Location: Stratford, Ontario

PostPosted: Sat 08 Oct 2011, 16:22    Post subject:  

Just plug it in with a USB cable and run Xsane.
Back to top
View user's profile Send private message 
popguy

Joined: 15 Oct 2007
Posts: 31

PostPosted: Sun 09 Oct 2011, 04:19    Post subject:  

works absolutely perfect with usb cable, damn it! do you believe there could be any way to configure it via my network?
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9039
Location: Stratford, Ontario

PostPosted: Sun 09 Oct 2011, 05:28    Post subject:  

popguy wrote:
do you believe there could be any way to configure it via my network?

Without having your exact setup, it's impossible to tell what the Ubuntu installer is doing with this unit.

Did you ever try the printer setup I suggested? That might provide some hints.
Back to top
View user's profile Send private message 
popguy

Joined: 15 Oct 2007
Posts: 31

PostPosted: Sun 09 Oct 2011, 12:07    Post subject:  

You mean connecting via usb? it works perfect there! but did i miss any suggestion regarding network setup?
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 2 [26 Posts]   Goto page: Previous 1, 2
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0647s ][ Queries: 12 (0.0050s) ][ GZIP on ]