Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 30 Aug 2014, 04:32
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Bluetooth in lucid puppy ----> blueman is here
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 4 of 6 [80 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6 Next
Author Message
Master_wrong

Joined: 19 Mar 2008
Posts: 456

PostPosted: Sat 10 Sep 2011, 02:18    Post subject:  

@stu90
hmmmm... maybe because the pet i make for 5.2 contain part of lucid 5.2 which broken the program when installed on 528 ?
because now the size of 528 pet were around 16M, when pet for 5.2 is 23 M.

thank for the info, i guess dpup bluetooth will work too in 528, and that will give more option for puppy user to handle bluetooth.

_________________
Cluster-Pup v.2-Puppy Beowulf Cluster
http://www.murga-linux.com/puppy/viewtopic.php?p=499199#499199
Back to top
View user's profile Send private message 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Tue 20 Sep 2011, 16:35    Post subject:  

I am confused.
I want to install blueman in Dpup 5X7, but I am not sure which pet's to install.
I downloaded things from the first post.

_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send private message 
tlcstat

Joined: 28 Oct 2007
Posts: 82
Location: SW Virginia mountains

PostPosted: Wed 21 Sep 2011, 10:33    Post subject: Lucid 5.2.8 Bluetooth working  

Greetings,
Install these two file from the Dpup post.

http://hotfile.com/dl/117232563/c197fe0/python26.pet.html
http://hotfile.com/dl/129175521/d604f21/blueman121.528.pet.html

Use the Bluetooth connection manager in the System Status menu to setup your devices.

Works with my machine no problem.
You may want to reboot after install.
tlcstat
Back to top
View user's profile Send private message AIM Address 
john3voltas

Joined: 23 May 2011
Posts: 102

PostPosted: Tue 27 Sep 2011, 03:24    Post subject:  

Greetings.
I'm running lupu 5.2.8 on my laptop.
I have just installed the new python 2.6 and blueman 1.2.1 (both for 528) from the 1st page.
From my understanding I don't need to install BlueZ, do I?
But when I try to load the "Bluetooth Manager" I get this error message.
Hope someone can help me.
Cheers
bt-bluez_error.jpg
Description 
jpg

 Download 
Filename  bt-bluez_error.jpg 
Filesize  120.64 KB 
Downloaded  517 Time(s) 
Back to top
View user's profile Send private message 
john3voltas

Joined: 23 May 2011
Posts: 102

PostPosted: Thu 29 Sep 2011, 09:19    Post subject:  

Come on guys, please give me a hand.
I've talked to exxtreme down at the IRC channel and he told me he ran into the same issue that I did.
I must be missing some package that you guys have on your system.
Cheers
Back to top
View user's profile Send private message 
Master_wrong

Joined: 19 Mar 2008
Posts: 456

PostPosted: Sat 01 Oct 2011, 11:35    Post subject:  

Hi,

sorry, i'm busy lately...

i never had that problem, but are you sure you have inserted the bluetooth ?
if you have please try to type on terminal

dbus-uuidgen --ensure &
dbus-daemon --system
modprobe bluetooth
modprobe l2cap
modprobe rfcomm
modprobe btusb
hciconfig hci0 up
hciconfig hci0 class 0x3e0100
mknod -m 666 /dev/rfcomm0 c 216 0
bluetoothd
mkdir /root/a
hcitool scan
blueman-applet

@beem
try 2 last file
edit sept 7.2011
http://hotfile.com/dl/129175521/d604f21/blueman121.528.pet.html
blueman 121, for 528 is here (need python 26 below)

python 26 which i use (ALL use this)
http://hotfile.com/dl/117232563/c197fe0/python26.pet.html

_________________
Cluster-Pup v.2-Puppy Beowulf Cluster
http://www.murga-linux.com/puppy/viewtopic.php?p=499199#499199
Back to top
View user's profile Send private message 
john3voltas

Joined: 23 May 2011
Posts: 102

PostPosted: Sun 09 Oct 2011, 19:07    Post subject:  

@Master_wrong,

Could you please try your blueman+python on a fresh new frugal lupu528 with a brand new savefile without any other pets than blueman+python?
Can you make a flash video of what you do?
I just can't replicate your success on my lupu528.
Cheers
Back to top
View user's profile Send private message 
Master_wrong

Joined: 19 Mar 2008
Posts: 456

PostPosted: Mon 10 Oct 2011, 03:02    Post subject:  

@john
why is your lupu 528 looks like 520 ?
as i know 528 looks like this...
http://puppylinux.org/main/Download%20Latest%20Release.htm

if it is different then it may never work because it was compiled specifically on it, i suggest you to compile from the source... its not that difficult it only takes time.

_________________
Cluster-Pup v.2-Puppy Beowulf Cluster
http://www.murga-linux.com/puppy/viewtopic.php?p=499199#499199
Back to top
View user's profile Send private message 
stu90


Joined: 25 Feb 2010
Posts: 1401
Location: England. Dell Inspiron 1501. Dpup

PostPosted: Mon 10 Oct 2011, 06:50    Post subject:  

I haven't installed lucid 528 yet - first thing to check it it has the needed bluetooth kernel modules in /lib/modules/2.6.39.4/kernel/net/bluetooth
(2.6.39.4 will be different number as Lucid pup uses different kernel)
bluetooth.ko bnep hidp rfcomm modules are needed for bluetooth.

If if is just simple file transer you are after:
Dpup bluetooth.pet worked in Lucid 525 so if the needed modules are included in 528 that this .pet will probably work in Lucid 528 as well.

Install bluetooth.pet > reboot.
http://www.smokey01.com/stu90/dpup.squeeze.pets/bluetooth-0.4.pet

Tool for setting up a mount point (requires yad):
http://www.murga-linux.com/puppy/viewtopic.php?p=569072#569072
Back to top
View user's profile Send private message 
XXX-Man

Joined: 02 Sep 2011
Posts: 5

PostPosted: Fri 28 Oct 2011, 16:17    Post subject:  

john3voltas I have the same problem, haven't found any solution...
Back to top
View user's profile Send private message 
Master_wrong

Joined: 19 Mar 2008
Posts: 456

PostPosted: Thu 03 Nov 2011, 01:07    Post subject:  

@xxxman
@johnvoltas

here is what i do...

1. install blueman 121.528

2. install python26

3. put bluetooth dongle into usb.... WAIT until bluetooth light start flashing on-off (bt-bluez_error.jpg happen to me when i did not wait, solution plug out then plug in again)

4. run blueman-applet in terminal

please if there is error let me know what the error are ?

_________________
Cluster-Pup v.2-Puppy Beowulf Cluster
http://www.murga-linux.com/puppy/viewtopic.php?p=499199#499199
Back to top
View user's profile Send private message 
XXX-Man

Joined: 02 Sep 2011
Posts: 5

PostPosted: Thu 03 Nov 2011, 11:50    Post subject:  

I connected my bluetooth dongle, and waited but led didn't start flashing, so I have problem on the step 3.
looks like it didn't get recognized, then I tryed with another one but same thing

checked it on windows and it works without problems

btw. sorry for bad english Embarassed
Back to top
View user's profile Send private message 
Master_wrong

Joined: 19 Mar 2008
Posts: 456

PostPosted: Thu 03 Nov 2011, 12:09    Post subject:  

looks like unsupported bluetooth ? or bug from btusb ?

from
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/268502

Quote:
Bluetooth doesn't work for at least the following devices:
ID 1131:1001 Integrated System Solution Corp. KY-BT100 Bluetooth Adapter
ID 1131:1004 Integrated System Solution Corp. Bluetooth Device
ID 2001:f111 D-Link Corp. [hex] DBT-122 Bluetooth adapter
ID 0a5c:200a Broadcom Corp. Bluetooth dongle

They don't work properly with the newer btusb driver, which replaced hci_usb by default in 2.6.27. This hasn't been fixed upstream as of v2.6.29-rc3.


and its affecting lucid too if you read the full report...

or check this https://wiki.archlinux.org/index.php/Bluetooth#Resources

it has good tutorial on checking your bluetooth

_________________
Cluster-Pup v.2-Puppy Beowulf Cluster
http://www.murga-linux.com/puppy/viewtopic.php?p=499199#499199
Back to top
View user's profile Send private message 
XXX-Man

Joined: 02 Sep 2011
Posts: 5

PostPosted: Thu 03 Nov 2011, 13:38    Post subject:  

I checked your links

when I type hciconfig I get message command not found
looks like I am missing some files or something

or it's a driver problem
Back to top
View user's profile Send private message 
Master_wrong

Joined: 19 Mar 2008
Posts: 456

PostPosted: Thu 03 Nov 2011, 22:05    Post subject:  

@xxxman
if you install my pet you will find it
try type this /usr/local/sbin/hciconfig

_________________
Cluster-Pup v.2-Puppy Beowulf Cluster
http://www.murga-linux.com/puppy/viewtopic.php?p=499199#499199
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 4 of 6 [80 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0738s ][ Queries: 13 (0.0056s) ][ GZIP on ]