Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 20 Apr 2014, 19:41
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects » Next Puppy Development
pet packages
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [5 Posts]  
Author Message
yr1945

Joined: 17 Apr 2010
Posts: 132

PostPosted: Sun 16 Oct 2011, 12:21    Post subject:  pet packages
Subject description: e.g. gnumeric
 

i downloaded gnumeric. when i click on gnumeric, it asks what do i want to do with it? of course, i want to install it. how do i install it? if i learn to install gnumeric, can i install any pet package for Next Puppy in the same manner... or, do i need a different script for each one? thanks for your support.
Back to top
View user's profile Send private message 
Dewbie

Joined: 15 Apr 2010
Posts: 1768

PostPosted: Sun 16 Oct 2011, 13:25    Post subject:  

When you click on the .pet, you should see "OK" and "Cancel" options.
Click on "OK" to install.
Back to top
View user's profile Send private message 
yr1945

Joined: 17 Apr 2010
Posts: 132

PostPosted: Sun 16 Oct 2011, 16:46    Post subject:  

For "Next Puppy"... the choices are 1)add 2)view 3)open 4)close.

Add doesn't seem to do anything... and, "Open" looks like a script is required.

Anyway, thanks for responding.
Back to top
View user's profile Send private message 
pacer106

Joined: 11 Jan 2011
Posts: 365

PostPosted: Sun 16 Oct 2011, 17:04    Post subject:  

To install .pets use open with & then type in petget or read below.

This is a little walk through for how to add installing .pets with a double click in emelfm2 file manager.

There are 2 pictures to reference if my instructions are not clear enough.

In image 1 you will see the right click menu for emelfm2 & the option for editing filetypes. click on that & you will see image 2.

As you can see in image 2 I have already added the pet option.

To do what I have done is pretty simple.

Step 1 is to scroll to the bottom of the Catergories column and click on the bottom item which should be object files so it is hi-lited in blue.

Step 2 is to click on the +Add button at the bottom of the screen as seen in image 2. You should now see a new item named new & it should be hi-lited in blue. Click on the word new & you should be able to edit the word from new to pet. After you enter pet press enter key so it sticks.

Step 3 is to click on the column named Extensions then click the +Add button at the bottom. You should now have a blue hi-lited item in the Extensions column. Click on that item & enter in pet then press enter to commit the item.

Step 3 is to click on the column named Labels & Commands. click in the blank area anyplace under Labels & Commands once it is showing a blue hi-lited item click on the +Add button at the bottom. Now click on the blue hi-lited item under the Label part & enter in install.pet then press enter to commit it. Next you will want to click the blue hi-lited area under command enter petget then press enter to commit.

Step 4 (final step) is to click on Apply then Commit at the bottom. (I am not sure if both Apply & Commit need to be clicked on. I did it just to be sure.)

If all went correctly a double click on any .pet should install the .pet.

Feedback is always welcome. I am no writer (far from it). I probably have grammer & punctuation errors in this. I am sorry if it bothers some people.






This is the normal thread for Next Puppy: http://www.murga-linux.com/puppy/viewtopic.php?t=70758
Back to top
View user's profile Send private message 
yr1945

Joined: 17 Apr 2010
Posts: 132

PostPosted: Sun 16 Oct 2011, 18:35    Post subject:  

pacer106... i followed your instructions. after i double clicked on the pet package, i get this message

>petget "gnumeric-1.10.17.pet" (7015)
cat: /root/.packages/Packages-puppy-*: No such file or directory
/usr/local/petget/installpkg.sh: line 38: /etc/xdg/menus/hierarchy: No such file or directory
EXIT="abort"



anyway, i have my gnumeric pet in mnt/home. looking at the above error message perhaps i should place the gnumeric pet into another folder? not sure how to find /root/.packages/Packages-puppy

any more suggestions for me? thanks
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [5 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects » Next Puppy Development
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0532s ][ Queries: 12 (0.0142s) ][ GZIP on ]