Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 01 Oct 2014, 20:50
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Slacko RC2
Moderators: Flash, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 5 of 9 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, 9 Next
Author Message
Sage

Joined: 04 Oct 2005
Posts: 4790
Location: GB

PostPosted: Sun 23 Oct 2011, 00:56    Post_subject:  

Sorry, mick - sound, X, and now irreproducible lock-ups. This one has been a bit of a disaster. Strongly recommend not declaring gold, long way to go.
[and this board's dictionary is driving me crazy - 'unreproducible' is just plain wrong]
Back to top
View user's profile Send_private_message 
bigpup


Joined: 11 Oct 2009
Posts: 5167
Location: Charleston S.C. USA

PostPosted: Sun 23 Oct 2011, 01:23    Post_subject:  

Frugal install to USB flash drive
Save option - save to partition sdb1(the flash drive)

menu->shutdown->reboot or poweroff

Goes to saving session to sdb1 message

Then back to desktop.

Does not poweroff computer or reboot.

If you make a save file to flash drive. no problems.

This only happens if you use save option save to sdb1 (the flash drive)
first shutdown.jpg
 Description   
 Filesize   74.34 KB
 Viewed   1059 Time(s)

first shutdown.jpg


_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send_private_message 
8-bit


Joined: 03 Apr 2007
Posts: 3368
Location: Oregon

PostPosted: Sun 23 Oct 2011, 01:42    Post_subject:  

01micko wrote:
Am using shino's gtkdialog splash but with a mod so you can use a non-stock icon


Ok, now I am confused?
After shinobar's post of the line change, I did that to gtkdialog-splash and it worked fine.
I previously had tried Barry's script and it worked, but did not allow the custom font to be displayed whereas the modded original in Slacko RC2 allowed the custom font and still worked fine.

I download your new file and it does not look anything like any of the others when I examine the script and although it works, it is back to a basic font being used.

So with 3 choices,
(1) Original Provided in Slacko RC 2 with modded line provided by shinobar.

(2) Barry's gtkdialog-splash script from Wary.

(3) The latest one you have modified and provided.

And each one is different and each one works for me.
The visual difference is that option 1 still will display the fancy font in the yaf-splash message.

Now on to scanpci.
I pulled the file from your woof download and copied it to /usr/bin.

And the original file in /root/.packages/builtin_files/scanpci should have had 3 lines in it being:
/usr
/usr/bin
scanpci

The last line was missing and to me, that means that woof evidently failed to install it.

Consider the following a rant and it can be ignored.
I should say that I have never used woof to build anything and when I try to follow the directions in the readme, modify the files needed to be modified, the download fails to find some files, finds new files and wants to download files for all the series of puppies.
Also, step one never seems to complete.
But that shows me that building a Puppy is not as easy as we are lead to believe.
End of rant.
Back to top
View user's profile Send_private_message 
bigpup


Joined: 11 Oct 2009
Posts: 5167
Location: Charleston S.C. USA

PostPosted: Sun 23 Oct 2011, 01:54    Post_subject:  

Slickpet->drivers->click here to test your graphics card->nvidia button
Nvidia driver 173.14.28
Download, install, run xorgwizard probe, and back to desktop using Nvidia driver.

PPM has listed 173.14.28 installed
Nvidia X server settings has 173.14.30 in system info.

Hardinfo has no information for opengl
Nvidia X sever settings shows info for opengl

The Nvidia opengl driver is installed and working.

Note:
The Nvidia driver install was much better.
Everything went as expected and was easy to follow progress.
All info screens showed at proper time and followed proper sequence.

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send_private_message 
Billtoo


Joined: 07 Apr 2009
Posts: 2116
Location: Ontario Canada

PostPosted: Sun 23 Oct 2011, 02:19    Post_subject: Slacko RC2  

Manual frugal install of Slackorc2
On first boot I had to choose vesa at a low resolution.
I installed the Nvidia proprietary driver.

Sun 23 Oct 2011 Operating System: Slacko Puppy-5.2.97 Linux 2.6.37.6
0.0 VGA compatible controller: nVidia Corporation GF108 [GeForce GT 430] (rev a1)
oem: NVIDIA product: GF108 Board - 1071v0p1 Chip Rev

X Server: Xorg Driver: nvidia
X.Org version: 1.9.5
dimensions: 1920x1080 pixels (524x292 millimeters)
depth of root window: 24 planes


AMD Phenom(tm) II X6 1045T Processor
Core 0: 2700 1: 2700 2: 2700 3: 2700 4: 2700 5: 2700 MHz

...the above also recorded at '/tmp/root/report-video-glx'.

It's working well, no problems with either kernel on this pc.
rc2-scrn.jpg
 Description   
 Filesize   51.49 KB
 Viewed   1056 Time(s)

rc2-scrn.jpg

Back to top
View user's profile Send_private_message 
shinobar


Joined: 28 May 2009
Posts: 2630
Location: Japan

PostPosted: Sun 23 Oct 2011, 02:48    Post_subject: virtualbox (SFS)  

OK, now available:
virtualbox-4.1.4-2-slacko.sfs for slacko both RC2 and RC++.
It contains virtualbox with kernel modules and some dependencies, SDL and GL.
http://www.murga-linux.com/puppy/viewtopic.php?p=481055#481055

it runs both on Slacko RC2/RC++, but RC++ cannot be the guest OS in the VirtualBox.

EDIT: RC++ can be the guest OS in the VirtualBox with the PAE setting at the VirtualBox, Settings >> System >> Processor.
http://www.virtualbox.org/manual/ch03.html#settings-processor

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html

Edited_times_total
Back to top
View user's profile Send_private_message Visit_website 
Tasgarth

Joined: 06 Oct 2008
Posts: 202
Location: France, Besancon

PostPosted: Sun 23 Oct 2011, 04:47    Post_subject:  

Shinobar :
lang_pack_all-0.9.sfs and Slacko (RC2 or RC2++)
pupsave in sda2 (ext3)
Sometimes it's good,sometimes Menu displays half English, half French... sometimes only a black background (I must do "restart X server')....
And after installing a new program (PPM) Menu is always bad...
Menu3.png
 Description   
 Filesize   22.18 KB
 Viewed   324 Time(s)

Menu3.png

Menu1.png
 Description   
 Filesize   49.04 KB
 Viewed   1045 Time(s)

Menu1.png

Back to top
View user's profile Send_private_message Visit_website 
shinobar


Joined: 28 May 2009
Posts: 2630
Location: Japan

PostPosted: Sun 23 Oct 2011, 07:53    Post_subject: Puppy Package Manager (dotpup/petget) i18n  

Tasgarth wrote:
Shinobar :
lang_pack_all-0.9.sfs and Slacko (RC2 or RC2++)
pupsave in sda2 (ext3)
Sometimes it's good,sometimes Menu displays half English, half French... sometimes only a black background (I must do "restart X server')....
And after installing a new program (PPM) Menu is always bad...

Right. The problem is the Puppy Package Manager Sad
There is 'Puppy Package Manager (dotpup/petget) i18n', but can be outdated...
http://www.murga-linux.com/puppy/viewtopic.php?t=64708

You can repair the menu by running the ''Refresh Desktop' at Main menu >> Desktop.

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send_private_message Visit_website 
Tasgarth

Joined: 06 Oct 2008
Posts: 202
Location: France, Besancon

PostPosted: Sun 23 Oct 2011, 08:17    Post_subject:  

shinobar wrote :
Quote:
Right. The problem is the Puppy Package Manager
There is 'Puppy Package Manager (dotpup/petget) i18n', but can be outdated...
http://www.murga-linux.com/puppy/viewtopic.php?t=64708

You can repair the menu by running the ''Refresh Desktop' at Main menu >> Desktop.

Now it's right
Thanks for the link and your help
Back to top
View user's profile Send_private_message Visit_website 
01micko


Joined: 11 Oct 2008
Posts: 7805
Location: qld

PostPosted: Sun 23 Oct 2011, 08:25    Post_subject:  

8-bit wrote:

Now on to scanpci.
I pulled the file from your woof download and copied it to /usr/bin.

And the original file in /root/.packages/builtin_files/scanpci should have had 3 lines in it being:
/usr
/usr/bin
scanpci

The last line was missing and to me, that means that woof evidently failed to install it.

Man! scanpci has been a pain! It has to be inserted manually. I tried to hide it in other packages.. it just doesn't make it! Some very weird woof bug. Even if it wasn't in it doesn't seem to bork net_setup.sh, and if it does then Frisbee or SNS are viable alternatives. I had such problems with frisbee earlier but it has grown on me! Laughing

Other bugs such as getopt and zdump were easy fixes.

Anyone with a dual sound card test gnome-mplayer-1.02? {here}

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
tasmod


Joined: 04 Dec 2008
Posts: 1461
Location: North Lincolnshire. UK

PostPosted: Sun 23 Oct 2011, 08:35    Post_subject:  

Sorry 'bout zdump Mick. I always have dev.sfs loaded so it's hard to tell whether it's missing.

I should have tested on basic install. When I did that's when I discovered the problem.

_________________
Rob
-
The moment after you press "Post" is the moment you actually see the typso Cool
Back to top
View user's profile Send_private_message Visit_website 
shinobar


Joined: 28 May 2009
Posts: 2630
Location: Japan

PostPosted: Sun 23 Oct 2011, 08:45    Post_subject: unrar  

http://www.smokey01.com/coolpup/unrar-4.0.7-w-20110313.pet
Works fine on Slacko RC2.

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send_private_message Visit_website 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sun 23 Oct 2011, 08:57    Post_subject:  

01micko. Could you have conditional check for scanpci in some pinstall.sh script. Check which has some error in code.

I just uploaded 5.X.9 and wondered where geany.png icon has gone. I checked my cumulative pinstall.sh and it had error in geany.png check (check to make geany.xpm symlink to geany.png). I had made wrong location for ./ folders. The result. Geany.png was removed. Lol.
Back to top
View user's profile Send_private_message 
01micko


Joined: 11 Oct 2008
Posts: 7805
Location: qld

PostPosted: Sun 23 Oct 2011, 09:01    Post_subject:  

pemasu wrote:
01micko. Could you have conditional check for scanpci in some pinstall.sh script. Check which has some error in code.

I just uploaded 5.X.9 and wondered where geany.png icon has gone. I checked my cumulative pinstall.sh and it had error in geany.png check. I had made wrong location for ./ folders. The result. Geany.png was removed. Lol.

Code:
#get rid of this as in xorg 7.5 it no longer works properly...
#(use lspci instead)
if [ -f ./usr/share/pci.ids -o -f ./usr/share/pci.ids.gz ];then
 rm -f ./usr/bin/scanpci
fi
Rolling Eyes Laughing
Well.. looks like it's out! Too old, sorry.

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sun 23 Oct 2011, 09:20    Post_subject:  

/mnt/sda6/woof-pupcamera/packages-templates/libpciaccess/pinstall.sh

Yeah. I found it too. Good remind when you cant mysteriously install whatever you try.

I traced it with this as my help:
Quote:
# find /mnt/sda6/woof-pupcamera -name scanpci
/mnt/sda6/woof-pupcamera/packages-templates/xorg73_base_t2/usr/X11R7/bin/scanpci
/mnt/sda6/woof-pupcamera/packages-templates/libpciaccess/usr/bin/scanpci
/mnt/sda6/woof-pupcamera/packages-templates/xorg_base/usr/bin/scanpci
/mnt/sda6/woof-pupcamera/packages-templates/xorg_base_baby/usr/X11R7/bin/scanpci
/mnt/sda6/woof-pupcamera/packages-templates/xorg_base_t2/usr/X11R7/bin/scanpci
/mnt/sda6/woof-pupcamera/sandbox3/0builtin_files_squeeze-5.X.9/root/.packages/builtin_files/scanpci
/mnt/sda6/woof-pupcamera/sandbox3/rootfs-complete/root/.packages/builtin_files/scanpci
/mnt/sda6/woof-pupcamera/sandbox3/rootfs-complete/usr/bin/scanpci
/mnt/sda6/woof-pupcamera/sandbox3/0builtin_files_squeeze-5.X.8/root/.packages/builtin_files/scanpci
/mnt/sda6/woof-pupcamera/packages-squeeze/libpciaccess/usr/bin/scanpci
/mnt/sda6/woof-pupcamera/packages-squeeze/scanpci
/mnt/sda6/woof-pupcamera/packages-squeeze/scanpci/usr/bin/scanpci
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 5 of 9 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, 9 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1171s ][ Queries: 13 (0.0205s) ][ GZIP on ]