Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 01 Aug 2014, 08:31
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Utilities
sfs_load-2.1 on-the-fly
Post new topic   Reply to topic View previous topic :: View next topic
Page 10 of 20 [291 Posts]   Goto page: Previous 1, 2, 3, ..., 8, 9, 10, 11, 12, ..., 18, 19, 20 Next
Author Message
sc0ttman


Joined: 16 Sep 2009
Posts: 2373
Location: UK

PostPosted: Tue 12 Jul 2011, 10:01    Post subject:  

1.1 does not work for me in puppy 4.2, it fails at line 1180, cos the $PUPSFS variable seems not to be set correctly.. I think it is empty.
_________________
Akita Linux, VLC-GTK, Pup Search, Pup File Search
Back to top
View user's profile Send private message 
8-bit


Joined: 03 Apr 2007
Posts: 3357
Location: Oregon

PostPosted: Fri 16 Sep 2011, 18:20    Post subject:
Subject description: <SOLVED>
 

I have been using sfs_load-0.1 in Puppy Lucid 520 and I have noticed that my selections to load are ignored on a reboot.
Some load, but others do not.
Since I have 1.22gig free in my pupsave, should this be happening?
Also, do I have to unload all my SFS selections before updating to version 1.1?

Inquiring minds want to know.

I am back with news, I uninstalled the older version of sfs_load-0.1 and installed the latest.
All of my selected SFS files loaded except one.
It was reported as being in the que, but not loaded.
Evidently, my 3 gigs of memory is not enough to load it since I also have a LOT of PETs installed taking up memory.
What brought me to this point was the fact that my kernel source and devx SFS fiiles were in my load list, but devx, although all the files for it appeared in the tree was failing to respond to "make" and "gcc".
Now at least if I see some SFS is shown as being in the que, but not loaded, I know I just did not have room for it along with the other SFS files that were loaded.
Back to top
View user's profile Send private message 
shinobar


Joined: 28 May 2009
Posts: 2605
Location: Japan

PostPosted: Thu 22 Sep 2011, 01:33    Post subject: sfs_load-1.1.1.pet  

Updated sfs_load-1.1.1.pet. Get from the top of this topic.
22 Sep 2011 v1.1.1: free(busybox) version compatible

If you are using v1.1 with no problem, you need not upgrade to v1.1.1.
The version 1.1.1 is a fix for incompatible busybox on some pupplets.

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
01micko


Joined: 11 Oct 2008
Posts: 7785
Location: qld

PostPosted: Thu 22 Sep 2011, 01:42    Post subject:  

shino, thanks for the update mate Smile

I have been using 1.1 for awhile in slacko very successfully.

1.1.1 is going straight in.

<ot>Just to draw your attention, some stuff as you know is updated in gtkdialog. Slacko is going with the cutting edge version (for better or worse Laughing ), but I will let you know there is syntax that should be corrected for some icons in some of your apps. (does not affect sfs_load, I think grub4dos-config it does)
Ref:<-- http://www.murga-linux.com/puppy/viewtopic.php?p=558753#558753
</ot>
[edit, actually it's only an "input file stock" error for gtkdialog-info]

Sorry about OT!

Cheers Mick Smile

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
mories

Joined: 21 Dec 2009
Posts: 38

PostPosted: Sat 24 Sep 2011, 11:31    Post subject: sfs_load start  

Quote:

shinobar wrote:
I cannot understand what is the problem.
At boot, 'sfs_load start' is excuted and it may search unloaded sfs in case some is registered but not loaded. Otherwise sfs_load does nothing.


'sfs_load start' at the function mountpart() mount the partition and set UNMOUNTME
.....
UNMOUNTME=""
mount $OPT /dev/$PART /mnt/$MPART || return
UNMOUNTME=/dev/$PART
MNTPNT=/mnt/$MPART

but do not unmount the partition after.
I work in PUPMODE=5
Back to top
View user's profile Send private message 
shinobar


Joined: 28 May 2009
Posts: 2605
Location: Japan

PostPosted: Sat 24 Sep 2011, 21:09    Post subject: Re: sfs_load start  

@mories
maybe i understand the problem.

Old puppies always mount the partition that has the main sfs.
Recent puppies unmount the partition if the PC has enough RAM to store the whole sfs.
The sfs_load mounts the patition as old puppies.

Ok, it will be fixed. Please wait a while.
Tnx mories.

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
shinobar


Joined: 28 May 2009
Posts: 2605
Location: Japan

PostPosted: Mon 26 Sep 2011, 09:08    Post subject: sfs_load-1.2
Subject description: Update
 

UPDATE: sfs_load-1.2.pet. See the top of this topic.

This is a small bugfix release. You need not upgrade if you are happy with the version you are currently using.
But all the pupplet developers are encouraged to upgrade to this new version for their new release.

#26 Sep 2011 v1.2: fix was undesired mount (thanks to mories), fix was fleezed input in combobox, fix ramsize

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html

Last edited by shinobar on Sat 29 Oct 2011, 12:07; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
puppynoob101

Joined: 20 Sep 2011
Posts: 8

PostPosted: Mon 26 Sep 2011, 22:06    Post subject:  

Hi,

I have Lucid Puppy 5.2.8 running on a 2GB flash drive, and PUPMODE=7.

I tried to use Load-on-the-Fly for lupu_devx_528-3.sfs, but it told me that this is experimental for PUPMODE=7. I clicked OK to this message. It then gave me a fatal error (see screenshot, attached). Sad

------------------
puppynoob101
image-6.png
 Description   screenshot of fatal error
 Filesize   7.46 KB
 Viewed   936 Time(s)

image-6.png

Back to top
View user's profile Send private message 
emil

Joined: 10 Nov 2009
Posts: 614
Location: Austria

PostPosted: Mon 10 Oct 2011, 15:01    Post subject:  

link in first post downloads a file named sfs_load-1.2.gz,
just rename it to sfs_load-1.2.pet and it will install
Edit: its fixed now
Back to top
View user's profile Send private message Visit poster's website 
shinobar


Joined: 28 May 2009
Posts: 2605
Location: Japan

PostPosted: Fri 28 Oct 2011, 09:02    Post subject: Test release: sfs_load-1.2.9.pet
Subject description: The first supports unionfs (Racy 5.1.110)
 

Test release: sfs_load-1.2.9.pet available. See the top post.
The first supports unionfs (Racy 5.1.110). Also expected to work on usual Puppy.
(Version 1.2 and older do not support most recent Racy 5.1.110, kernel 3.0.7 with unionfs patch. )

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
mhanifpriatama

Joined: 22 Jan 2011
Posts: 60

PostPosted: Sat 29 Oct 2011, 03:07    Post subject:  

Any body can give me a clue or a link, how run this apps at transparent background (command line) without gui? This because I love fresh frugal, and control the system with startup script.
Before, I created a startup script, and use ln or cp command. Of course this method have a lot trouble and work.
Thanks ....
Back to top
View user's profile Send private message 
shinobar


Joined: 28 May 2009
Posts: 2605
Location: Japan

PostPosted: Sat 29 Oct 2011, 03:15    Post subject: command line  

mhanifpriatama wrote:
how run this apps at transparent background (command line) without gui?

For the usage, on the terminal, type:
Code:
sfs_load --help

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
01micko


Joined: 11 Oct 2008
Posts: 7785
Location: qld

PostPosted: Sat 29 Oct 2011, 07:42    Post subject:  

Thank you Shino

Sfs_load-1.2.9 was able to successfully load the latest Racy devx (unionfs) and libreoffice-3.4.3, an sfs I had previously constructed. (Applications tested and working).

Cheers

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
sc0ttman


Joined: 16 Sep 2009
Posts: 2373
Location: UK

PostPosted: Sat 29 Oct 2011, 11:55    Post subject:  

Working for me as well, in a Puppy 4.2 derivative...Smile Great stuff...
_________________
Akita Linux, VLC-GTK, Pup Search, Pup File Search
Back to top
View user's profile Send private message 
mhanifpriatama

Joined: 22 Jan 2011
Posts: 60

PostPosted: Sun 30 Oct 2011, 01:55    Post subject:  

thanks.... sfs_load --help
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 10 of 20 [291 Posts]   Goto page: Previous 1, 2, 3, ..., 8, 9, 10, 11, 12, ..., 18, 19, 20 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Utilities
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0792s ][ Queries: 13 (0.0085s) ][ GZIP on ]