Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 27 Nov 2014, 01:50
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff)
Lazarus 0.9.30 + FreePascal fpc 2.4.2
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 2 of 5 Posts_count   Goto page: Previous 1, 2, 3, 4, 5 Next
Author Message
panoss

Joined: 31 Oct 2011
Posts: 147

PostPosted: Fri 11 Nov 2011, 13:06    Post_subject:  

I tried the following script: (taken from an example made for ubuntu. Of course, I modified some things. p.e 'sudo' was erased)
I commented out Step 1 so it does not get executed, in puppy 'apt-get' does not work.
It gives an error on Step 5, at 'make clean all'.
Code:
echo ""
echo "Step 1: Installing dependencies..."
echo ""
#apt-get install --force-yes -y subversion fpc fp-utils fpc-source fp-units-misc

echo ""
echo "Step 2: Downloading files..."
echo ""
cd ~
svn co http://svn.freepascal.org/svn/fpc/branches/fixes_2_6 fpc
svn co http://svn.freepascal.org/svn/lazarus/trunk lazarus
cd fpc/
wget -c ftp://ftp.freepascal.org/fpc/snapshot/v25/i386-linux/fpc-2.5.1.i386-linux.tar.gz

echo ""
echo "Step 3: Unzipping FPC..."
echo ""
tar -vzxf fpc-2.5.1.i386-linux.tar.gz

echo ""
echo "Step 4: Updating FPC SVN..."
echo ""
svn update

echo ""
echo "Step 5: Compiling new FPC..."
echo ""
make clean all
make install PREFIX=/usr
Back to top
View user's profile Send_private_message 
RSH


Joined: 05 Sep 2011
Posts: 2420
Location: Germany

PostPosted: Fri 11 Nov 2011, 13:28    Post_subject:  

Hello,

i am using Lazarus and FP. It is the .sfs file, that i use. I have checked out the Problem and i have got the same error message. But i have also compiled, linked and run the project with out any error message.

Maybe the error message is just the error?

RSH
laz-fp.png
 Description   the form1 project running with radiobutton and togglebutton
 Filesize   107.39 KB
 Viewed   1105 Time(s)

laz-fp.png


_________________
LazY Puppy
RSH's DNA
SARA B.
Back to top
View user's profile Send_private_message 
panoss

Joined: 31 Oct 2011
Posts: 147

PostPosted: Fri 11 Nov 2011, 13:32    Post_subject:  

RSH wrote:
Hello,

i am using Lazarus and FP. It is the .sfs file, that i use. I have checked out the Problem and i have got the same error message. But i have also compiled, linked and run the project with out any error message.

Maybe the error message is just the error?

RSH

I can compile, link and run projects, too.
But, when I try, for example, to add an event in a form, it gives an error.
Try it.

(that's why I'm trying to install an svn version, unsuccessfully up to now)
Back to top
View user's profile Send_private_message 
tatamata

Joined: 02 May 2010
Posts: 63

PostPosted: Fri 11 Nov 2011, 13:45    Post_subject:  

Hm, did you download original or stripped version?
It seems that stripped pet has some problems. Could you please try with original one:
http://www.4shared.com/file/q_aktBSR/Lazarus-09300-fpc-242.html
Back to top
View user's profile Send_private_message 
panoss

Joined: 31 Oct 2011
Posts: 147

PostPosted: Fri 11 Nov 2011, 13:50    Post_subject:  

tatamata wrote:
Hm, did you download original or stripped version?
It seems that stripped pet has some problems. Could you please try with original one:
http://www.4shared.com/file/q_aktBSR/Lazarus-09300-fpc-242.html

Yes, that's the file I downloaded.
I'm downloading it again, just in case.
To be 100% sure.
Back to top
View user's profile Send_private_message 
tatamata

Joined: 02 May 2010
Posts: 63

PostPosted: Fri 11 Nov 2011, 14:08    Post_subject:  

Do you have devx for your Puppy?
As I remember, devx is neccessary...
Back to top
View user's profile Send_private_message 
panoss

Joined: 31 Oct 2011
Posts: 147

PostPosted: Fri 11 Nov 2011, 14:25    Post_subject:  

Yes, I have lupu_devx_528-3.sfs . (maybe I should try 528-2 or 528-1?)
I downloaded the above mentioned file, but...no, unfortunatelly it's the same as before.
Back to top
View user's profile Send_private_message 
panoss

Joined: 31 Oct 2011
Posts: 147

PostPosted: Mon 14 Nov 2011, 06:43    Post_subject:  

I foumd here:
'that lazarus projects CANT HAVE SPACES in patch or file names'
I didn't find spaces, but I think that the problem hat to do with some character that puppy uses differently than supposed.
It must be something form Environment>Options:
Compiler path
FPC source directory (that's more possible, I think)
Or something else.

That is, the problem is either a filename or a path.(I think)
Back to top
View user's profile Send_private_message 
RSH


Joined: 05 Sep 2011
Posts: 2420
Location: Germany

PostPosted: Mon 14 Nov 2011, 09:07    Post_subject:  

Please take a look at here!

http://murga-linux.com/puppy/viewtopic.php?p=582779#582779

_________________
LazY Puppy
RSH's DNA
SARA B.
Back to top
View user's profile Send_private_message 
panoss

Joined: 31 Oct 2011
Posts: 147

PostPosted: Mon 14 Nov 2011, 10:28    Post_subject:  

RSH it works!!!!
Thank you very much my friend!!!!!You helped me very much! Thank you!
Back to top
View user's profile Send_private_message 
RSH


Joined: 05 Sep 2011
Posts: 2420
Location: Germany

PostPosted: Mon 14 Nov 2011, 10:48    Post_subject:  

Hello panoss,

could you please tell me something about your puppy and the messages you have got while starting lazarus?

RSH

_________________
LazY Puppy
RSH's DNA
SARA B.
Back to top
View user's profile Send_private_message 
panoss

Joined: 31 Oct 2011
Posts: 147

PostPosted: Mon 14 Nov 2011, 11:10    Post_subject:  

1.
Package file not found
The package cgiLaz is installed, but...

I click 'skip these warnings'

2.
Registration error
Package 'CGILazIDE 0.0'
Unit name: 'CGILazIDEIntf'
Unit not found: 'CGILazIDEIntf'

I click 'Ignore'.

3.
error:
Unable to find the unit of component class TDividerBevel.

This 'TDividerBevel' was not found on th build I tried, and was terminated becase of it, without finishing the build.

I click 'Ignore, use TForm as ancestor".



I forgot to mention something which I should have mentioned earlier.
The file 'lupu_devx_528-3.sfs' is in '/mnt/home/', which is the place where it's supposed to be.
But, when I open System>Bootmanager>Choose which extra SFS file to load on start up, it shows me an error:
"Sorry there are no SFS files in directory /mnt/home or they all have the wrong version number"...
So to load the file 'lupu_devx_528-3.sfs' I used Setup>SetUp puppy>SFS-load on the fly.
Back to top
View user's profile Send_private_message 
panoss

Joined: 31 Oct 2011
Posts: 147

PostPosted: Mon 14 Nov 2011, 11:24    Post_subject:  

Unfortunately, I can't built lazarus.

Environment>Options>Lazarus directory:
/usr/lib/lazarus/0.9.30/

Shouldn't it be /usr/lib/lazarus/0.9.28.2/ as it's the version of Lazarus now installed?

Edited_time_total
Back to top
View user's profile Send_private_message 
RSH


Joined: 05 Sep 2011
Posts: 2420
Location: Germany

PostPosted: Mon 14 Nov 2011, 11:28    Post_subject:  

Ok,

Quote:
cgiLaz is installed, but...
Registration error
Package 'CGILazIDE 0.0'
Unit name: 'CGILazIDEIntf'
Unit not found: 'CGILazIDEIntf'

these are the messages, that i have got as well.

Quote:
This 'TDividerBevel' was not found on th build I tried, and was terminated becase of it, without finishing the build.

I click 'Ignore, use TForm as ancestor".


The build that you tried, was it an lazarus example or created by yourself?

Does it work after using TForm as ancestor?

And please, if you got time, can you post further messages, errors or if you got something fixed here, so that i've been informed and able to check it?

I am using my lupu_devx_528-3.sfs almost from outside (the stick is sdd1 and the sfs is on sdb1) and i am loading it with SFS-Load on-the-fly as well.

RSH

posted while i am writing my post:

Quote:
Unfortunately, I can't built lazarus.


Yes, i knew, there must be problems i havn't seen yet.

_________________
LazY Puppy
RSH's DNA
SARA B.
Back to top
View user's profile Send_private_message 
panoss

Joined: 31 Oct 2011
Posts: 147

PostPosted: Mon 14 Nov 2011, 11:35    Post_subject:  

The built I tried was not a lazarus example, it was the Lazpant.
It worked before I tried to built!!but now it does not. It gives me the error:
"bgrabitmappack.pas(15,3) Fatal: Can't find unit LazarusPackageIntf used by bgrabitmappack".
I don't know if this was caused because of the TForm ancestor being used.

Of course I'll post any other error or information I'll run into.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 2 of 5 Posts_count   Goto page: Previous 1, 2, 3, 4, 5 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff)
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0807s ][ Queries: 13 (0.0080s) ][ GZIP on ]