Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 23 Apr 2014, 11:39
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Drivers
SOLVED - How to use Epson 3490 Scanner in Puppy 525?
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [8 Posts]  
Author Message
icosahedron


Joined: 28 Nov 2011
Posts: 40
Location: UK

PostPosted: Wed 07 Dec 2011, 02:09    Post subject:  SOLVED - How to use Epson 3490 Scanner in Puppy 525?  

My Puppy 5.2.5 seems to work very well 'out of the box', but the one thing that doesn't seem to work for me is I can't get Puppy to recognise my Epson 3490 scanner. It's the only peripheral I have that my Puppy doesn't seem to have drivers for. How do I get it to work? Is there something that I need to tweak, or does it need a PET?

If I need to tweak something, I'm a raw beginner with Puppy and LInux - words of one syllable please. Smile

Thanks in advance.

Last edited by icosahedron on Sun 11 Dec 2011, 12:57; edited 1 time in total
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 8563
Location: Stratford, Ontario

PostPosted: Wed 07 Dec 2011, 08:58    Post subject:  

The SANE scanner package in Puppy should recognize your Epson 3490. Look in the folder /etc/sane.d for the file snapscan.conf. However, this model requires some additional firmware.

Install the attached PET. If that still doesn't work, there is a second workaround.
snapscan_epson_3490_firmware-1.0.pet
Description 
pet

 Download 
Filename  snapscan_epson_3490_firmware-1.0.pet 
Filesize  31.44 KB 
Downloaded  426 Time(s) 

Last edited by rcrsn51 on Sun 11 Dec 2011, 10:24; edited 1 time in total
Back to top
View user's profile Send private message 
icosahedron


Joined: 28 Nov 2011
Posts: 40
Location: UK

PostPosted: Sat 10 Dec 2011, 03:43    Post subject:  

Hi rcrsn51,
Thanks for the PET. I downloaded it but I was waiting until I'd tested it out before I gave you feedback on it. Hopefully I'll have the opportunity over the weekend. No offence intended, just short on time this week.
Back to top
View user's profile Send private message 
icosahedron


Joined: 28 Nov 2011
Posts: 40
Location: UK

PostPosted: Sun 11 Dec 2011, 10:02    Post subject:  

You can safely return the attachment, the PET works a treat. Smile

I'll have to learn how Xsane works, but the basics seem pretty universal and the important thing is it can now see my scanner and capture images from it.

Thanks again, rcrsn51, problem solved. Smile
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 8563
Location: Stratford, Ontario

PostPosted: Sun 11 Dec 2011, 10:27    Post subject:  

Excellent. If you want a simpler scanning tool than Xsane, look at Peasyscan.
Back to top
View user's profile Send private message 
icosahedron


Joined: 28 Nov 2011
Posts: 40
Location: UK

PostPosted: Sun 11 Dec 2011, 12:56    Post subject:  

Thanks for the Peasyscan info, but since Xsane's already installed, I'll probably poke about with that when I next need to scan something. It can't be that difficult.

BTW, looking at your Peasyscan post reminded me - I 'uncommented' Epson before I installed the Pet, so I don't know if it was running on Epson or Epson2. Doesn't matter to me, but it might be important to the next reader.

Now let's see if I can figure how to add the word 'solved' to the thread title...
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 8563
Location: Stratford, Ontario

PostPosted: Sun 11 Dec 2011, 13:01    Post subject:  

icosahedron wrote:
BTW, looking at your Peasyscan post reminded me - I 'uncommented' Epson before I installed the Pet, so I don't know if it was running on Epson or Epson2. Doesn't matter to me, but it might be important to the next reader..

Neither. You are running on the "snapscan" backend. It is the only one that can detect your scanner. As a test, comment out this line in dll.conf and try to access your scanner.

You can make Xsane start a little faster by commenting out all the lines EXCEPT for snapscan.
Back to top
View user's profile Send private message 
icosahedron


Joined: 28 Nov 2011
Posts: 40
Location: UK

PostPosted: Mon 12 Dec 2011, 06:09    Post subject:  

Thanks for the info, but I'm not a dabbler. I'm an 'if it ain't broke, don't fix it' guy. The scanner was broke, but it ain't now, thanks to your PET. That's good enough for me. Smile
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [8 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Drivers
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0552s ][ Queries: 13 (0.0089s) ][ GZIP on ]