Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 21 Sep 2014, 20:36
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
How to use Hewlett Packard F4480 printer?
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
druidkat7

Joined: 17 Dec 2011
Posts: 4

PostPosted: Sat 17 Dec 2011, 09:08    Post_subject:  How to use Hewlett Packard F4480 printer?
Sub_title: I need to know the steps to download the HPLIP and get my printer going!
 

Hey folks...

I am completely new to Puppy. I "migrated" over from Ubuntu 9.10 because my computer just can't hack anything above that level--not without my graphics card "complaining" and making my monitor look like a distorted, late-night-TV "snow test pattern" when I try to select certain screensavers in Lucid Lynx.

So far so good, except I have no real clue how to search for, find and install the recent HPLIP drivers/GUI-Toolbox so that my HP F4480 All-In-One printer can run...I'd Google it now, but it's late and I like talking to people who have experience rather than sit in front of Google, frustrated as all heck at not knowing what I'm doing.

I know that HPLIP needs to be installed, but beyond that, how to configure my printer to use with Puppy is making ME tilt my head in dog-like confusion--or at worst, hide my head under my paws. Razz

I know that CUPS supports my printer from having run HPLIP in Ubuntu...but the steps to run in Puppy...surely they'd be different..???

Gotta hit the hay, but am looking forward to a reply.

Blessings,
Kat ^.^
Back to top
View user's profile Send_private_message 
druidkat7

Joined: 17 Dec 2011
Posts: 4

PostPosted: Sat 17 Dec 2011, 09:19    Post_subject: Found the CUPS wizard, but...
Sub_title: It "sees" my HP DeskJet F4400_series printer, but not printing yet...
 

...I assume I still need the HPLIP drivers? Can I get them from the Pup Control Panel?

Or...if I need to go elsewhere, where do I go and what exactly do I do?

Details are appreciated so I can copy and paste into a file for saving (and printing!) later--just in case I ever need to reboot Puppy.
Back to top
View user's profile Send_private_message 
maik.murks


Joined: 28 Mar 2011
Posts: 331
Location: at home, at work or on holidays

PostPosted: Sat 17 Dec 2011, 09:38    Post_subject: Re: Hewlett Packard F4480--How to configure it?
Sub_title: I need to know the steps to download the HPLIP and get my printer going!
 

druidkat7 wrote:
I know that HPLIP needs to be installed, but beyond that, how to configure my printer to use with Puppy is making ME tilt my head in dog-like confusion--or at worst, hide my head under my paws.


Hi druidkat7.

Configuring CUPS in Puppy is as easy as in every other Linux operating system. Just start your web browser and type "localhost:631" without the quotation marks - and immediately you should see the administration site of your installed CUPS.

Hope that helps.

Cheers Wink

Maik.Murks
Back to top
View user's profile Send_private_message 
druidkat7

Joined: 17 Dec 2011
Posts: 4

PostPosted: Sun 18 Dec 2011, 01:21    Post_subject: Re: Hewlett Packard F4480--How to configure it?
Sub_title: I need to know the steps to download the HPLIP and get my printer going!
 

maik.murks wrote:
druidkat7 wrote:
I know that HPLIP needs to be installed, but beyond that, how to configure my printer to use with Puppy is making ME tilt my head in dog-like confusion--or at worst, hide my head under my paws.


Hi druidkat7.

Configuring CUPS in Puppy is as easy as in every other Linux operating system. Just start your web browser and type "localhost:631" without the quotation marks - and immediately you should see the administration site of your installed CUPS.

Hope that helps.

Cheers Wink

Maik.Murks


Okay, I found what you were talking about, and it still says it's "recognizing" my HP F4400 series printer, and I even set my printer as "server default" to see if that would get it to print, but no dice--even though it's sending a "test print job."

I went to the "job log" and this is what I found:

localhost - - [17/Dec/2011:23:05:12 -0600] "POST /admin/ HTTP/1.1" 200 9728 CUPS-Add-Modify-Printer successful-ok
localhost - - [17/Dec/2011:23:05:12 -0600] "POST /admin HTTP/1.1" 200 2263 - -
localhost - - [17/Dec/2011:23:05:22 -0600] "POST /printers/HP_Deskjet_F4400_series HTTP/1.1" 200 470 Print-Job successful-ok
localhost - - [17/Dec/2011:23:06:14 -0600] "POST /admin/ HTTP/1.1" 200 54 - -
localhost - - [17/Dec/2011:23:06:14 -0600] "POST /admin/ HTTP/1.1" 200 139 CUPS-Set-Default successful-ok
localhost - - [17/Dec/2011:23:06:14 -0600] "POST /admin/ HTTP/1.1" 200 2235 - -
localhost - - [17/Dec/2011:23:06:38 -0600] "POST /printers/HP_Deskjet_F4400_series HTTP/1.1" 200 470 Print-Job successful-ok
localhost - - [17/Dec/2011:23:15:38 -0600] "POST /admin/ HTTP/1.1" 200 16 - -
localhost - - [17/Dec/2011:23:15:38 -0600] "POST /admin/ HTTP/1.1" 200 7286 - -


It says the "jobs were successful," but my printer made no noise at all...Not even so much as the whirr of the paper grabbers or anything.

I still feel like there's something missing--like maybe the HPLIP drivers? Confused

Here's some other info you might find useful:

Description: HP Deskjet F4400 series
Location:
Driver: HP DeskJet Series (color)
Connection: usb://HP/Deskjet%20F4400%20series?serial=CN9BHC21V305C5
Defaults: job-sheets=none, none media=na_letter_8.5x11in


Anyhow, I'm still mystified--but then again, like I said, I think I've been spoiled by Ubuntu. Wink So this time, it seems I *really* need to get my uber-geek on! Wink

Does any of the info in bold above help?

Thanks,
Kat ^.^
Back to top
View user's profile Send_private_message 
lluamco

Joined: 16 Mar 2007
Posts: 207
Location: Banyoles, Spain

PostPosted: Mon 19 Dec 2011, 16:03    Post_subject:  

You could try hplip packages in either http://murga-linux.com/puppy/viewtopic.php?p=444080#444080 or
http://murga-linux.com/puppy/viewtopic.php?p=439468&search_id=840887172#439468
Back to top
View user's profile Send_private_message 
druidkat7

Joined: 17 Dec 2011
Posts: 4

PostPosted: Wed 21 Dec 2011, 09:22    Post_subject:  Thanks!  

lluamco wrote:
You could try hplip packages in either http://murga-linux.com/puppy/viewtopic.php?p=444080#444080 or
http://murga-linux.com/puppy/viewtopic.php?p=439468&search_id=840887172#439468


Thanks, lluamco! I will try these out later.

Kat ^.^

_________________
"Never underestimate the power that's given to you!"--Jon Anderson (of Yes)
Back to top
View user's profile Send_private_message 
glene77is


Joined: 17 Aug 2010
Posts: 112
Location: Memphis, TN, USA

PostPosted: Sun 15 Jan 2012, 19:52    Post_subject: Re: Thanks!  

druidkat7 wrote:
lluamco wrote:
You could try hplip packages in either http://murga-linux.com/puppy/viewtopic.php?p=444080#444080 or
http://murga-linux.com/puppy/viewtopic.php?p=439468&search_id=840887172#439468


Thanks, lluamco! I will try these out later.

Kat ^.^


So!
How did that work out ?

My HP F4280 responds in like manner.

(So, I use the backup printer all the time. )
Smile

_________________
Puppy Linux is more fun than a barrel of M$ monkeys Razz
glene77is --- {^,^} --- electricity is shocking, Memphis, TN, USA.
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0735s ][ Queries: 12 (0.0042s) ][ GZIP on ]