Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 21 Dec 2014, 21:28
All times are UTC - 4
 Forum index » Taking the Puppy out for a walk » Announcements
Slacko Puppy 5.3.1 Released
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 14 of 19 Posts_count   Goto page: Previous 1, 2, 3, ..., 12, 13, 14, 15, 16, 17, 18, 19 Next
Author Message
01micko


Joined: 11 Oct 2008
Posts: 7841
Location: qld

PostPosted: Fri 23 Dec 2011, 22:16    Post_subject:  

I should start another thread for the compiz biz.. I want to build a record of systems that are running it successfully, CPU, graphics card and driver, RAM etc. .. so until I do, can you post those specs. Cool
_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
8-bit


Joined: 03 Apr 2007
Posts: 3398
Location: Oregon

PostPosted: Sat 24 Dec 2011, 06:04    Post_subject:
Sub_title: Compiz package working
 

I have a 10 year old Toshiba Satellite Laptop 1.8ghz 512megs ram Slacko loading from USB flash drive.

I just installed Compiz on it and it is very speedy with good graphics and no flashing or studder.
So that is getting down toward the low end of the scale as to computers.
I currently have Seamonkey, AbiWord, and a terminal open with free displaying memory usage as well as the boot desktop with rxvt.

My free on this PC, still speedy, is:

# free
total used free shared buffers
Mem: 497644 480224 17420 0 32044
Swap: 1052376 3096 1049280
Total: 1550020 483320 1066700
#

Now that is pretty impressive.
I dare someone with Windows to show me any desktop graphic effects even close to being comparable.

It would come up with some lame graphics rating that would say I would have to upgrade my PC to some unreal specs.
Back to top
View user's profile Send_private_message 
rhadon


Joined: 27 Mar 2008
Posts: 1293
Location: Germany

PostPosted: Sat 24 Dec 2011, 07:24    Post_subject:  

Well done Mick. Cool

Works fine and fast on my EeePc900.
Even the camera in Skype works. Very Happy

OK, some small issues, but not so important. The basics are working. Wink

As I mentioned often during the years, if the Super key isn't working, use keyboard model pc-104 or 105 instead of pc-102 (could happen with non english keyboard layouts).

I tried to use simple-ccsm. Installed flawless witout missing dependencies, but fails to run. See attachment, please.

The mesa driver seems to be a little bit problematic for me (also without compiz). Confused
Glxgears runs with ~300 fp5s and there seems to be a lot of sand between the gears. A little bit forward, a little bit backward, forward, backward... .

With xorg high in lupu-525 I get ~1500 fp5s.


On my Gericom laptop (see sig.) no go with Compiz. Crying or Very sad

Glxgears run with ~620 fp5s (gears turning fine).

With xorg high in lupu-525 I get ~3500 fp5s.

Attached output of compiz-check.

Any idea?

For my Eee it's like a christmas gift. Thank you.

Rolf
simple-ccsm.png
 Description   
 Filesize   100.68 KB
 Viewed   2581 Time(s)

simple-ccsm.png

compiz-check.png
 Description   with Gericom laptop
 Filesize   10.41 KB
 Viewed   2578 Time(s)

compiz-check.png


_________________
Ich verwende "frugal", und das ist gut so. Wink
Raspberry Pi without Puppy? No, thanks.
Back to top
View user's profile Send_private_message 
puppyluvr


Joined: 06 Jan 2008
Posts: 3229
Location: Chickasha Oklahoma

PostPosted: Sat 24 Dec 2011, 07:41    Post_subject:  

Very Happy Hello,
Ran the Compiz Helper pet..
Failed 4 of 5...
And I am running Compiz... Shocked

_________________
Close the Windows, and open your eyes, to a whole new world
http://puppylinuxstuff.meownplanet.net/puppyluvr/
Puppy Linux Users Group on Facebook

Puppy since 2.15CE...
Back to top
View user's profile Send_private_message Visit_website 
01micko


Joined: 11 Oct 2008
Posts: 7841
Location: qld

PostPosted: Sat 24 Dec 2011, 07:52    Post_subject:  

Hi Rolf

Well 1 out of 2 isn't too bad.

I want you to try something with the Gericom. Copy your Lupu xorg.conf over Slacko's. Restart X. Try the test again. If the test passes then try compiz.

I will have to see if simple cssm works in my Slackware installation. I couldn't get it to work with (IIRC) similar errors to what you post in Slacko. I didn't bother chasing it too hard.

Good luck, and Merry Christmas.

_________________
Woof Mailing List | keep the faith Cool |

Edited_time_total
Back to top
View user's profile Send_private_message Visit_website 
01micko


Joined: 11 Oct 2008
Posts: 7841
Location: qld

PostPosted: Sat 24 Dec 2011, 07:53    Post_subject:  

Shocked WTF?
puppyluvr wrote:
Very Happy Hello,
Ran the Compiz Helper pet..
Failed 4 of 5...
And I am running Compiz... Shocked


Laughing Runs ok?

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
Iguleder


Joined: 11 Aug 2009
Posts: 1927
Location: Israel, somewhere in the beautiful desert

PostPosted: Sat 24 Dec 2011, 08:09    Post_subject:  

Re-uploading my repository, all packages were rebuilt with many fixes.

Here's the full list of changes:
- Added UnNetHack. Cool
- Changed the default rxvt-unicode font to Terminus.
- Added Yad, with /opt/bin/zenity, a backwards-compatibility symlink for Zenity.
- Moved Terminus to /opt/share/fonts, this requires a change in /etc/fonts/fonts.conf.
- Fixed the missing menu icons problem with vitetris, bs, cmus and NetSurf.
- cmus no longer sets itself as the default audio player.
- Removed an unneeded icon from the wbar package.
- Prevented Moon-buggy from writing stuff to /opt/com.
- Removed the libelf dependency from GNU Screen.
- Added /opt/bin/rxvt, a symlink to urxvt.
- Added /opt/share man to the man pages search path, through man.conf.
- Removed the man pages for urxvtc and urxvtd.

_________________
My homepage
My GitHub profile
Back to top
View user's profile Send_private_message Visit_website MSNM 
ICQ 
rhadon


Joined: 27 Mar 2008
Posts: 1293
Location: Germany

PostPosted: Sat 24 Dec 2011, 09:23    Post_subject:  

01micko wrote:
Copy your Lupu xorg.conf over Slacko's. Restart X. Try the test again. If the test passes then try compiz.
Still no go, Mick. Same error message as before. I tested with lupu-525 and -528 (although I think, it's the same).In glxgears I have ~1000 fp5s instead of ~300, but the gears are running not so smooth as with xorg.conf from slacko.

Have a nice Christmas time,

Rolf

_________________
Ich verwende "frugal", und das ist gut so. Wink
Raspberry Pi without Puppy? No, thanks.
Back to top
View user's profile Send_private_message 
8-bit


Joined: 03 Apr 2007
Posts: 3398
Location: Oregon

PostPosted: Sun 25 Dec 2011, 03:32    Post_subject:  

I just wanted to mention that if one is running with the Compiz SFS file, a taskbar selection called "Close all open windows" can cause a lockup as it also closes the dummy xwin started using the terminal.
Is there a way around this one can try?

Is the openbox wm compiz compatable?

Have you started a Slacko Compiz thread yet?

Oh, Merry Xmas.

Figured that was appropriate for running xwin.
Back to top
View user's profile Send_private_message 
CatDude


Joined: 03 Jan 2007
Posts: 1497
Location: UK

PostPosted: Sun 25 Dec 2011, 15:01    Post_subject:  

Hi

    Computer.

      Make/Model: Acer 5552 (laptop)
      Processor: AMD Athlon(tm) II P340 Dual-Core Processor
      Memory: 4GB
      Graphics card: ATI Mobility Radeon HD 4200 Series
      Graphics driver: fglrx


    Code:
    # glxgears
    Running synchronized to the vertical refresh.  The framerate should be
    approximately the same as the monitor refresh rate.
    16002 frames in 5.0 seconds = 3199.591 FPS
    16895 frames in 5.0 seconds = 3376.747 FPS
    16900 frames in 5.0 seconds = 3379.946 FPS
    16888 frames in 5.0 seconds = 3376.651 FPS
    16900 frames in 5.0 seconds = 3377.999 FPS
    16435 frames in 5.0 seconds = 3285.071 FPS


    Code:
    # fgl_glxgears
    Using GLX_SGIX_pbuffer
    2953 frames in 5.0 seconds = 590.600 FPS
    3538 frames in 5.0 seconds = 707.600 FPS
    3540 frames in 5.0 seconds = 708.000 FPS
    3538 frames in 5.0 seconds = 707.600 FPS
    3536 frames in 5.0 seconds = 707.200 FPS
    3535 frames in 5.0 seconds = 707.000 FPS


Everything is wobbling along nicely. Very Happy

CatDude
.

_________________

Back to top
View user's profile Send_private_message 
8-bit


Joined: 03 Apr 2007
Posts: 3398
Location: Oregon

PostPosted: Sun 25 Dec 2011, 15:22    Post_subject:
Sub_title: Compiz in Slacko 5.3.1
 

I have began to have problems that may be attributed to the mouse.
Anyway, I had Slacko with Compiz running and went away from the computer.
When I returned to a black screen, the power save had kicked in, Slacko came back with the rxvt window that starts it in the middle of the screen and it then moved to its home position of the upper left of the screen.
Clicking on the menu button did not work although clicking on the terminal icon on the desktop did.
I went back and tried the menu button again and still no go.
So is it a problem of "If Compiz is already running" that the startup using rxvt is trying to run it again when exiting from the power screen saver?
I do not know and am just guessing here.

What window managers are compatible with Compiz?
I would like to try one of them other than dummy (no window manager) and xfce4.
Surely there is a nice window manager that would give me a desktop comparable to the default one that Slacko uses.

Also, maybe that is part of my problem in trying to run Slacko with no desktop manager.
In a case like that, what is being used for a desktop manager?
Is it Emerald?

I am open to trying a compatible desktop manager with compiz and short instructions on starting both compiz and a desktop manager without a lockup of one or the other.

So jump in with suggestions if you can.
Back to top
View user's profile Send_private_message 
01micko


Joined: 11 Oct 2008
Posts: 7841
Location: qld

PostPosted: Mon 26 Dec 2011, 04:16    Post_subject:  

rhadon wrote:
Still no go, Mick. Same error message as before. I tested with lupu-525 and -528 (although I think, it's the same).In glxgears I have ~1000 fp5s instead of ~300, but the gears are running not so smooth as with xorg.conf from slacko.

Have a nice Christmas time,

Rolf


Hi Rolf,

I have another experiment for the Gericom, I just tried this on my thinkpad and I got a noticeable improvement in Compiz performance. Smile . Forget glxgears! It's reading is terrible. Before I was getting upwards of 3000+frames per 5 seconds, now it's about 200!

Hers's what I did:
Code:
cp /etc/modprobe.d/radeon.conf  /etc/modprobe.d/radeon.bak
echo 'options radeon modeset=1' > /etc/modprobe.d/radeon.conf


This turns on kernel modesetting for your radeon. Reboot. You may need to restart X after reboot, I did because I got errors in /var/log/Xorg.0.log and the compiz-test failed. After X restart compiz-test passed. Started compiz well Smile . If it goes belly up (in other words X fails) then from console just type cp -f /etc/modprobe.d/radeon.bak /etc/modprobe.d/radeon.conf and reboot. You'll be back at square 1.

Lets' hope you can get a late Christmas present on the Gericom!

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
rhadon


Joined: 27 Mar 2008
Posts: 1293
Location: Germany

PostPosted: Mon 26 Dec 2011, 06:40    Post_subject:  

Hi Mick,

thanks for paying attention to my problem. Smile

I changed modeset=0 to 1 but the same error message appears:
Code:
Error: Software Rasterizer in use.


Maybe it's helpful when I attach my Xorg.0.log.

Near the bottom I find:
Quote:
[ 7118.801] (EE) AIGLX error: Calling driver entry point failed
[ 7118.817] (EE) AIGLX: reverting to software rendering
[ 7118.835] (II) AIGLX: Loaded and initialized /usr/lib/xorg/modules/dri/swrast_dri.so


I have no glue, is it harmless or does it cover the problem?

Anyway, Thank You

Rolf
Xorg.0.log.tar.gz
Description  after compiz-check, modeset=1
gz

 Download 
Filename  Xorg.0.log.tar.gz 
Filesize  8.68 KB 
Downloaded  222 Time(s) 

_________________
Ich verwende "frugal", und das ist gut so. Wink
Raspberry Pi without Puppy? No, thanks.
Back to top
View user's profile Send_private_message 
01micko


Joined: 11 Oct 2008
Posts: 7841
Location: qld

PostPosted: Mon 26 Dec 2011, 18:04    Post_subject:  

Compiz helper update .. scroll down VVVVVVV

________________________________________________

Quote:
I have no glue..

Hi Rolf, I guess you mean clue. Originally I thought you meant libglu
or libglew! Sorry I don't think swrast can do it, though you can try.

I have 2 ideas left...

1) try adding this to xorg.conf
Code:
# AccelDFS is enabled by default on PCI-E cards, but not on AGP cards.
        Option "AccelDFS"    "True"

I found it on a gentoo wiki.

2) Try the newer kernel. I read somewhere that the kernel module had been improved for radeon since 2.6.38. I don't know if the PAE will work with the celeron in your Gericom. It works in my eee, but not on my lappy with centrino(radeon) or my P4 brookdale.

==========================================

I have made improvements to the compiz-helper.

8-bit, this should solve focus problems as I am now using a tiny 1x1px gtkdialog gui as the dummy WM. I have been trialling it for a few days and it's a big improvement on my old lappy.

Have fun!
compiz_helper-002.pet
Description 
pet

 Download 
Filename  compiz_helper-002.pet 
Filesize  22.69 KB 
Downloaded  698 Time(s) 

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
puppyluvr


Joined: 06 Jan 2008
Posts: 3229
Location: Chickasha Oklahoma

PostPosted: Tue 27 Dec 2011, 02:31    Post_subject:  

Very Happy Hello,
Sorry, slow reply...
Running Compiz 82 on Lupu 2.6.38.4..
Failed nearly every test, but works fine..
Have Cairo stuff too, maybe explains it???

_________________
Close the Windows, and open your eyes, to a whole new world
http://puppylinuxstuff.meownplanet.net/puppyluvr/
Puppy Linux Users Group on Facebook

Puppy since 2.15CE...
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 14 of 19 Posts_count   Goto page: Previous 1, 2, 3, ..., 12, 13, 14, 15, 16, 17, 18, 19 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Taking the Puppy out for a walk » Announcements
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1131s ][ Queries: 13 (0.0172s) ][ GZIP on ]