Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 22 Aug 2014, 10:03
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Puppy Linux Windows Installer - V1.1 released
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 10 of 23 [338 Posts]   Goto page: Previous 1, 2, 3, ..., 8, 9, 10, 11, 12, ..., 21, 22, 23 Next
Author Message
emil

Joined: 10 Nov 2009
Posts: 616
Location: Austria

PostPosted: Fri 02 Dec 2011, 08:44    Post subject: Used Windows Installer for combined VirtualBox/Linux install  

Noryb009, I used your code to make a combined Virtualbox / Puppy installer.
Thank you very much for this project - my coding is very clumsy, I hope this is OK!

http://murga-linux.com/puppy/viewtopic.php?t=73921

It works similar than this Installer Creator - instead of the puppy files you have to copy in an exported VM "ova" file!

Cheers
emil
Back to top
View user's profile Send private message Visit poster's website 
shinobar


Joined: 28 May 2009
Posts: 2617
Location: Japan

PostPosted: Tue 06 Dec 2011, 10:18    Post subject: Puppy_Linux_528.exe  

OK, i made a mirror of Puppy_Linux_528.exe:
http://shino.pos.to/party/bridge.cgi?puppy/

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
Aitch


Joined: 04 Apr 2007
Posts: 6825
Location: Chatham, Kent, UK

PostPosted: Fri 09 Dec 2011, 21:23    Post subject:  

Advertised/posted on puppylinux.info

http://puppylinux.info/topic/puppy-windows-installer#post-2005

http://puppylinux.info/topic/win32exe-installer?replies=1#post-2004

Thanks noryb, shinobar Very Happy

Aitch Smile
Back to top
View user's profile Send private message 
RSH


Joined: 05 Sep 2011
Posts: 2393
Location: Germany

PostPosted: Sat 10 Dec 2011, 14:11    Post subject:  

Hello,

i have actually (just in these minutes) created a puppy linux setup.exe. Got some problems. Must remove all empty spaces and must define some path's like this:
Code:
!define PUPPY_SFS "\mnt\sdc2\PuppyLinuxInstallerCreator\lazy_528.sfs"


Now going offline to install the puppy in xp. Smile

RSH

_________________
LazY Puppy
RSH's DNA
SARA B.
Back to top
View user's profile Send private message 
noryb009

Joined: 20 Mar 2010
Posts: 539

PostPosted: Sat 10 Dec 2011, 14:17    Post subject:  

RSH: You can just use:
Code:
!define PUPPY_SFS "lazy_528.sfs"

It allows you to have spaces in the path.
Back to top
View user's profile Send private message 
RSH


Joined: 05 Sep 2011
Posts: 2393
Location: Germany

PostPosted: Sat 10 Dec 2011, 16:06    Post subject:  

The original line says:
Code:
!define PUPPY_SFS "lupu_520.sfs"

Looks like yours.
Code:
!define PUPPY_SFS "lazy_528.sfs"


I have just changed the lupu_520 to lazy_528. Only removing spaces came to success.

Don't know why... Confused

However, i did it two times and the second time i did it running the first created and installed puppy setup.

This your work is really fantastic and it makes the whole thing i am working on for about the last six months going perfect. It offers me new ways to provide puppy in a (imho) very special way and maybe turning some vegetables back into human. Very Happy

More to come...

Btw: I did it all using puppy without pupsave. Using wine.sfs.

Thanks for that!!!

RSH
setup.png
 Description   
 Filesize   59.43 KB
 Viewed   1551 Time(s)

setup.png


_________________
LazY Puppy
RSH's DNA
SARA B.
Back to top
View user's profile Send private message 
noryb009

Joined: 20 Mar 2010
Posts: 539

PostPosted: Sat 17 Dec 2011, 08:57    Post subject:  

531 and 531 PAE have been uploaded, sorry about the delay.

Link.
Back to top
View user's profile Send private message 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15117
Location: Paradox Realm

PostPosted: Sat 17 Dec 2011, 09:19    Post subject:  

many thanks link added here
http://puppylinux.org/wikka/Puppy53

_________________
Puppy WIKI
Back to top
View user's profile Send private message Visit poster's website 
PenguinPupLin

Joined: 23 Dec 2011
Posts: 126
Location: The Little Red Dot

PostPosted: Mon 26 Dec 2011, 13:07    Post subject: Quickset wary 511
Subject description: bootup problem
 

Thanks so much Shinobar for the quickset wary511 windows installer. I installed it on my Acer Travelmate notebook(from 2002) WinXP OS and everything works fine;merely changed the screen resolution to 1024x768,updated SeaMonkey to ver 2.5,etc. That was two days' ago. Today,I installed the gtk 2.28 lib file (because Seamonkey 2.5 requires at least 2.20 or higher,etc) and rebooted the PC to try another distro and saw this message :...Terminated. #Journal commit I/O error. Later when I try to get back into Wary 511,my screen was almost blank, i.e. xserver (vesa) was garbled. I tried xorgwizard a few times but to no avail. Any help appreciated.
Btw,is it recommended that I upgrade it to Wary 522 by copying the necessary files to the same subfolder? If not advisable,it's ok as it has worked well for me so far and I've tested Wary 522 and the touchpad mouse pointer would hang for no reason sometimes.
I think my pupsave file is damaged,so I booted into WinXP to delete it,then reboot into Wary511 ram mode and created a new pupsave;now it's working alright. Btw,tested Wary522 on the same noteboot but my synaptics touchpad mouse as well as the usb mouse that I plugged in would hanged in xvesa(xorg doesn't work),so I guess I would stick with your quickset wary511 which has been running fine so far. Thanks.
Back to top
View user's profile Send private message 
PenguinPupLin

Joined: 23 Dec 2011
Posts: 126
Location: The Little Red Dot

PostPosted: Fri 30 Dec 2011, 04:45    Post subject: Quickset Wary 511
Subject description: Shutdown and reboot problem
 

Hello, my Quickset wary 511 keeps getting "journal commit I/O error" whenever I reboot or shutdown. It was installed using Windows Installer-V1.1 released on my WinXP notebook. Before,my pupsave was corrupted after installing some programs in wary 511, after which I had to delete it in windows and reboot in Wary511 RAM mode to create a new one. And now again after installing and removing a few pets and packages, the journal commit I/O error problem resurfaces but surprisingly I can still boot into Wary511. Apart from this problem, I'm very happy and thankful for Shinobar's quickset wary511 windows installer as it has been working fine on my 10-yr-old Acer travelmate TM632 notebook. Is there anything I should do or look out for? Kindly advise.

Latest: The "journal commit I/O error " disappeared after I delete the puppy.swp that I created and use swapfilemanger to build a new one.
Back to top
View user's profile Send private message 
PenguinPupLin

Joined: 23 Dec 2011
Posts: 126
Location: The Little Red Dot

PostPosted: Wed 18 Jan 2012, 13:24    Post subject: Pupsave creation problem - Puppy Linux 528 Windows Installer
Subject description: Blank screen upon reboot,poweroff or exit to prompt
 

Hi, I used the windows installer in the 1st post to set up Lucid Puppy Linux 528 but could not create a savefile upon reboot or power off, the screen simply blanked off. It didn't even asked me if I wanted to create one. Exiting to prompt also resulted in blank screen.

My system is Windows Vista SP1 32-bit OS with Core2Duo 2.66GHz CPU, 3GB RAM and Radeon HD5450 512MB graphics card.

Slacko 5.3.1 installed and ran without a hitch. Lucid Windows Installer was the second one I tried. Both were checked for md5sums integrity to be matching.

My understanding is that the second windows installer onwards will automatically edit the menu.lst and copy the core puppy files in the created subdirectory. FYI, a full defrag in Windows was also done,it took me 3 hours.

Yes,my harddisk has a hidden recovery partition, so C: is recognised as sda2 and root is hd0,1.What went wrong? Please advise. TIA.
Back to top
View user's profile Send private message 
ICPUG

Joined: 24 Jul 2005
Posts: 1289
Location: UK

PostPosted: Wed 18 Jan 2012, 14:39    Post subject:  

There is nothing wrong with the Windows Installer. You would get this with the Live CD as well.

The problem is an incompatibility between Puppy and your graphics card. This has been noted for various versions of Radeon before. A search of the forum would find other people with this problem and how some have solved it. I think running with a vesa driver may solve the problem but this is a rather drastic solution as other graphic features (prefered resolution) may not be available with vesa.

I don't have a radeon so cannot suggest a solution.

Regarding the save file. One user created a blank one manually and saved it in the same directory as the puppy sfs file. It will then be seen at start up and perform OK.
Back to top
View user's profile Send private message 
PenguinPupLin

Joined: 23 Dec 2011
Posts: 126
Location: The Little Red Dot

PostPosted: Thu 19 Jan 2012, 12:24    Post subject:  

Thanks for telling me. Only managed to manually create a lupusave.3fs using the simplesave.pet.

Searched in vain for a solution to my Radeon HD5450 problem with lupu528. Used quickpet > Drivers > Test your graphics card, then downloaded the recommended ati_catalyst_10.10.lucid.pet driver but upon reboot found all the desktop icons greyed out except quickpet; even wifi failed to connect and had to be wired to do so.

This Radeon HD5450 with Puppy Linux 528 is real disappointing,frustrating, a PITA. Just my luck. The saving grace is Slacko 531 and Lighthouse Pup 503 both work fine,quite consoling.
Back to top
View user's profile Send private message 
PenguinPupLin

Joined: 23 Dec 2011
Posts: 126
Location: The Little Red Dot

PostPosted: Fri 20 Jan 2012, 10:15    Post subject: Radeon HD5450 issue with lupu528
Subject description: graphics card incompatibility problem
 

Solved : Ahh,the pain has finally subsided. Just to share my encounter.

First,thanks to ICPUG's advice to manually create savefile first, which I did courtesy of the simplesave.pet by stu90;thus bypassing the blank-screen-unable-to-create-savefile-problem.

Second, using quickpet>drivers>test your graphics card, and then accepting to download and install the recommended ati-flgrx-10.10-catalyst.lucid.pet didn't really solved my Radeon HD5450 card issue - the ati driver failed to load properly or performed with issues and all the desktop icons saved quickpet were greyed out.

Third, uninstalled the said ati 10.10 driver and used vesa.

Fourth, compiled the ati flgrx catalyst driver using the latest version 11.12 from AMD. Still the desktop icons were greyed out.

Fifth, downloaded and replaced the lupu528.sfs with the latest updated one 528.004 after having come across it on the web. Presto! the greyed icons were restored to original colourful state!

Lastly,perhaps,and on hindsight,provided I was aware of the updated lupu528.004.iso in the beginning, if I had straightaway replaced the original iso with the updated version,it might have saved me a lot of heartaches. Rolling Eyes

Latest: Running lupu528.004 in RAM mode with Radeon HD5450 still gives reboot/poweroff - no savefile option, just blank screen. Have to resort to creating blank savefile,running vesa and installing appropriate ati driver as above.
Back to top
View user's profile Send private message 
ICPUG

Joined: 24 Jul 2005
Posts: 1289
Location: UK

PostPosted: Mon 23 Jan 2012, 08:46    Post subject:  

Thanks for that detail on how you solved your problem. How big is that driver? Can we get it uploaded somewhere so other users can get it without having to compile it for themselves?
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 10 of 23 [338 Posts]   Goto page: Previous 1, 2, 3, ..., 8, 9, 10, 11, 12, ..., 21, 22, 23 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0984s ][ Queries: 13 (0.0129s) ][ GZIP on ]