Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 21 Aug 2014, 00:34
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Drivers
Nvidia drivers
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 5 [69 Posts]   Goto page: 1, 2, 3, 4, 5 Next
Author Message
shinobar


Joined: 28 May 2009
Posts: 2617
Location: Japan

PostPosted: Sun 09 Oct 2011, 00:38    Post subject:  Nvidia drivers
Subject description: precompiled SFS and getnvidia installer/PET/SFS builder
 

Nvidia drivers contains glx libraries which may conflict with those in the main sfs. In making Nvidia driver sfs, I made rc.nvidia script to collect these links.
I have made Nvidia drivers in SFS for some Puppy/Puplets.
You can build the latest driver automatically. For the older versions, you need manually download the archive from the vender site.

getnvidia-1.0.pet to install NVIDIA driver / build SFS/PET.
http://shino.pos.to/party/bridge.cgi?puppy/opt/
You need devx and kernel source package to build the kernel module. Required internet connection.
Recommended to build with new pupsave of 512MB or larger, or in RAM mode. I am not quite sure but If your RAM is less than 640MB, needs 500MB swap.
  1. Load devx package
  2. Load kernel source package
  3. Install getnvidia.
  4. Exit X and down to the command prompt
  5. Type 'getnvidia'.
NVIDIA Graphics tip is not essential to build (thanks to pemasu). You can build on another PC if the target PC has not enough power and/or internet connection.

For 64bit Puppies, Fatdog 64 or Lighthouse 64, try
getnvidia-1.0-64.pet
http://shino.pos.to/party/bridge.cgi?puppy/opt/pup64/
Note: the kernel source for the Fatdog 64 or Lighthouse 64 is contained in its each devx package.

PRECOMPILED:
You can find some pre-compiled SFS'es at
http://shino.pos.to/party/bridge.cgi?puppy/opt/
http://shino.pos.to/party/bridge.cgi?puppy/opt/pup4/
http://shino.pos.to/party/bridge.cgi?puppy/opt/pup5/
http://shino.pos.to/party/bridge.cgi?puppy/opt/pup64/
http://shino.pos.to/party/bridge.cgi?puppy/precise/opt/
http://shino.pos.to/party/bridge.cgi?puppy/lupu/opt/

Load, but do not run the nVidia Settings at this point of time, just exit the sfs_load, and run xorgwizard or reboot PC following the coming message.
Slacko 5.3.3 may need to reboot PC with your session saved before the xorgwizard.

NOTE: This sfs does not contain SDL nor glxgears. Install 'mesa-utils' or proper package if you want.
Install mesa package as for slacko if you need.

OLDER VERSIONS:
  • Puppy-431, Wary 5.1.1/5.3, Racy 5.3, All Lucid Puppy (nvidia-glx + libGLU and SDL)
    nvidia-glx-sdl-295.53.sfs ( 2012-05-28)
  • For Slacko 5.3.3 with kernel 3.1.10-slacko_4gA, or 3.1.10-slacko_paeA. . (contains glx, OpenGL and SDL)
    nvidia-glx-sdl-295.53-slacko.sfs (2012-05-28)
    http://shino.pos.to/party/bridge.cgi?puppy/opt/pup5/
  • For Slacko 5.3.x with kernel 2.6.37.6, 2.6.39.4, 3.1.10-slacko_4gA, or 3.1.10-slacko_paeA. . (contains glx, OpenGL and SDL)]nvidia-glx-sdl-295.49-slacko.sfs (2012-05-07)
    http://shino.pos.to/party/bridge.cgi?puppy/opt/pup5/
  • For major Puppies 4.3 and later except Slacko (nvidia-glx + libGLU and SDL)
    • Puppy-431 with kernel 2.6.30.5
    • All Wary up to 5.3 with kernel 2.6.31.14, 2.6.32.28, 2.6.32-smp, or 2.6.32-uni, 2.6.32.59
    • Racy 5.2.2/5.3 with kernel 3.0.7 or 3.0.25
    • All Lucid Puppy with kernel 2.6.33.2
    • Dpup Exprimo with kernel 2.6.39, 3.1.10-dpup, or 3.2.14-dpup
    • Saluki-15 and later with kernel 3.2.8-ski

    nvidia-glx-sdl-295.40.sfs (2012-04-13)
    http://shino.pos.to/party/bridge.cgi?puppy/opt/

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html

Last edited by shinobar on Tue 22 Oct 2013, 20:13; edited 50 times in total
Back to top
View user's profile Send private message Visit poster's website 
shinobar


Joined: 28 May 2009
Posts: 2617
Location: Japan

PostPosted: Thu 13 Oct 2011, 04:03    Post subject: nvidia-glx-sdl-285.05.09-1.sfs  

UPDATE: nvidia-glx-sdl-285.05.09-1.sfs supports Puppy 4.3 and later, Wary, Racy and Lucid.
_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
shinobar


Joined: 28 May 2009
Posts: 2617
Location: Japan

PostPosted: Fri 11 Nov 2011, 00:19    Post subject: nvidia-glx-sdl-285.05.09-2.sfs  

Add kernel module for Wary-5.2.2 (2.6.32-uni):
nvidia-glx-sdl-285.05.09-2.sfs ... For Puppy 4.3 and later, Wary and Lucid. (nvidia-glx + libGLU and SDL)
http://shino.pos.to/party/bridge.cgi?puppy/opt/

But it does not support Racy. It seems unstable for recent kernels.
A gimp issue with the nvidia driver and the Warry-5.2.
http://www.murga-linux.com/puppy/viewtopic.php?p=577166#577166

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
shinobar


Joined: 28 May 2009
Posts: 2617
Location: Japan

PostPosted: Wed 16 Nov 2011, 00:39    Post subject: UPDATE for Dpup Exprimo 5.x.10.2 SMP  

Add the kernel module for Dpup Exprimo 5.x.10.2 SMP, 3.1.0 kernel.
nvidia-glx-285.05.09-k2.6.39.4-dpup-2.sfs ... For Dpup Exprimo
http://shino.pos.to/party/bridge.cgi?puppy/opt/pup5/

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
shinobar


Joined: 28 May 2009
Posts: 2617
Location: Japan

PostPosted: Sun 11 Dec 2011, 01:29    Post subject: UPDATE to 290.10  

UPDATE to 290.10 for Puppy-431, Wary, Racy and Lucid.
Not yet for Slacko and etc.

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
shinobar


Joined: 28 May 2009
Posts: 2617
Location: Japan

PostPosted: Tue 20 Dec 2011, 11:17    Post subject: UPDATE: 290.10 for Slacko  

For Slacko RC/RC++ both kernel 2.6.37.6 and 2.6.39.4. (contains glx, OpenGL and SDL)
nvidia-glx-sdl-290.10-slacko.sfs (Update: 21-Dec-2011)
http://shino.pos.to/party/bridge.cgi?puppy/opt/pup5/

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
richardyusan


Joined: 14 Dec 2009
Posts: 35
Location: Indonesia

PostPosted: Tue 27 Dec 2011, 06:12    Post subject:  

thx shinobar!
really helped me!
Cool
Back to top
View user's profile Send private message Visit poster's website Yahoo Messenger 
zigbert


Joined: 29 Mar 2006
Posts: 5674
Location: Valåmoen, Norway

PostPosted: Wed 28 Dec 2011, 18:16    Post subject:  

I tested you latest sfs in Slacko 5.3.1, and I still haven't reached my goal to play Torcs on Slacko.
My card is a geforce 8400M GS which is listed in the supported card list.

Code:
# glxgears
Error: couldn't get an RGB, Double-buffered visual


Code:
# torcs
Visual Properties Report
------------------------
Compatibility mode, properties unknown.
GLUT: Fatal Error in torcs-bin: visual with necessary capabilities not found.



Thanks for any help
Sigmund

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
shinobar


Joined: 28 May 2009
Posts: 2617
Location: Japan

PostPosted: Wed 28 Dec 2011, 21:31    Post subject: NVidia driver SFS on Slacko  

zigbert wrote:
I tested you latest sfs in Slacko 5.3.1,

Make sure using the sfs for Slacko 5.3.x both kernel 2.6.37.6 and 2.6.39.4. (contains glx, OpenGL and SDL)
nvidia-glx-sdl-290.10-slacko.sfs (Update: 21-Dec-2011)
http://shino.pos.to/party/bridge.cgi?puppy/opt/pup5/

I ran Slacko 5.3.1 MAIN in RAM mode and loaded the sfs above and it shows glxgears with no problem. My card is GeForce 8800GTX.
It seems some conflict of the opengl/xcb. The problem maybe also comes from that the slacko is compiled "no-xcb" libs.(EDIT: Slacko 5.3.1 has xcb libs and they shall be used.)

If you have ever installed 'mesa' PET package or previous version of nVidia driver PET (or some other), it may make trouble. Its recovery is a bit complex:
  1. Switch the X driver to 'vesa'.
  2. Unload the nvidia driver SFS.
  3. Re-install the PET which causing the problem.
  4. Uninstall the PET to clean up.
  5. Re-load the nvidia driver SFS.
  6. Run the xorgwizard to switch to the nvidia.


But making new papsave from RAM mode can be easier. Cool

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
zigbert


Joined: 29 Mar 2006
Posts: 5674
Location: Valåmoen, Norway

PostPosted: Thu 29 Dec 2011, 13:49    Post subject: Re: NVidia driver SFS on Slacko  

shinobar wrote:
But making new papsave from RAM mode can be easier. Cool
Done! and it works Very Happy


Thanks a lot
Sigmund

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
BHINTZ

Joined: 08 Aug 2006
Posts: 140

PostPosted: Wed 04 Jan 2012, 21:28    Post subject:  

Is there any chance you might make a driver for the 310 kernel in exprimo and/or slacko.

I have tried to follow various directions and failed miserably

bob
Back to top
View user's profile Send private message 
shinobar


Joined: 28 May 2009
Posts: 2617
Location: Japan

PostPosted: Wed 04 Jan 2012, 22:31    Post subject: nvidia-glx-sdl-290.10-1  

UPDATE: nvidia-glx-sdl-290.10-1.sfs which supports Dpup Exprimo both with kernel 2.6.39 or 3.1.0
_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
BHINTZ

Joined: 08 Aug 2006
Posts: 140

PostPosted: Thu 05 Jan 2012, 11:26    Post subject:  

many thanks, suspend/resume now works fine

bob
Back to top
View user's profile Send private message 
PenguinPupLin

Joined: 23 Dec 2011
Posts: 126
Location: The Little Red Dot

PostPosted: Wed 11 Jan 2012, 02:55    Post subject:  

Glad to have found this thread. My 10-yr-old Acer Travelmate notebook uses the basic NVidia Geforce 2 Go (not Geforce Go something which are higher end). Checking your supported cards list showed the correct driver to be NVidia 96.43.xx but it also said it's no longer maintained. So for my Wary 511, Puppy 431 and lighthouse 5.0.3, which of your NVidia sfs should I use? Pardon if I've asked a dense question,still a noob.
Also on the same notebook,I multi-boot other "older" puppies such as Classic Pup 214X-TOP9 and Legacy OS 2 based on kernel 2.6.18.1, can any of your NVidia sfs be used? Eagerly await your reply.
Another thing to point out,in case it matters,is that as my notebook screen is faulty, I'm connecting it to an external LCD panel, Samsung SyncMaster 931C,capable of much higher resolutions and refresh rates. Wonder if there would be any synchronization problem.
Edit: The answer is none unless it's compiled with Nvidia96.43.xx for specific kernels.

Last edited by PenguinPupLin on Wed 11 Jan 2012, 10:51; edited 1 time in total
Back to top
View user's profile Send private message 
shinobar


Joined: 28 May 2009
Posts: 2617
Location: Japan

PostPosted: Fri 06 Apr 2012, 08:17    Post subject: nvidia-glx-sdl-295.33  

UPDATE: nvidia-glx-sdl-295.33-1.sfs (2012-04-12)
http://shino.pos.to/party/bridge.cgi?puppy/opt/
For major Puppies 4.3 and later except Slacko (nvidia-glx + libGLU and SDL)
  • Puppy-431 with kernel 2.6.30.5
  • All Wary up to 5.3 with kernel 2.6.31.14, 2.6.32.28, 2.6.32-smp, or 2.6.32-uni, 2.6.32.59
  • Racy 5.2.2/5.3 with kernel 3.0.7 or 3.0.25
  • All Lucid Puppy with kernel 2.6.33.2
  • Dpup Exprimo with kernel 2.6.39, 3.1.10-dpup, 3.2.11-dpup or 3.2.14-dpup
  • Saluki-15 and later with kernel 2.3.8-ski

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 5 [69 Posts]   Goto page: 1, 2, 3, 4, 5 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Drivers
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0870s ][ Queries: 13 (0.0061s) ][ GZIP on ]