Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 29 Jul 2014, 03:02
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Graphics
XnView MP 0.39 and XnConvert MP 1.1 combo sfs
Post new topic   Reply to topic View previous topic :: View next topic
Page 3 of 4 [54 Posts]   Goto page: Previous 1, 2, 3, 4 Next
Author Message
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sun 15 May 2011, 15:05    Post subject:  

xnviewmp-xncorverter-0.35-0.98-with-locales.sfs has been reuploaded using Argolance`s great advice. Locales should work now.

Thank you.

Last edited by pemasu on Wed 22 Jun 2011, 18:19; edited 1 time in total
Back to top
View user's profile Send private message 
sub13


Joined: 20 Sep 2008
Posts: 283
Location: Près de Marseille (France)

PostPosted: Sun 19 Jun 2011, 11:20    Post subject: Re: XnView MP 0.35 and XnConvert MP 0.98 combo sfs
Subject description: Image viewer and simple image editor
 

pemasu wrote:
Updated 6.3.2011. [b]X

Download: http://www.smokey01.com/pemasu/Sfs/xnviewmp-xncorverter-0.35-0.98-with-locales.sfs


bonjour

j'ai téléchargé ce fichier et tenté de l'installer avec setup:installer un fichier sfs

mais ça n'a pas marché tout s'est bloqué de plus cela a supprimé tout mes dossiers perso (heureusement sauvegardé sur clé usb)
---------------------------------
bon je vais essayer avec http://puppylinux.ca/members/bigbass/XnView-1.70.pet sur discussion http://www.murga-linux.com/puppy/viewtopic.php?search_id=1318649730&t=31351

pas d'entrée de menu, mais raccourci sur le bureau, semble fonctionner me reste à trouver pour langue en français Médor en parle ici ???

http://www.murga-linux.com/puppy/viewtopic.php?t=67710&sid=bc2747afd50a098fb39f9c25ccb161ea mais pas trouvé le fichier xnview_fr.qm

merci

_________________
portable Dell latitude D400
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sun 19 Jun 2011, 14:01    Post subject:  

sub13. I dont understand a word of french, but with gxlat I understood that you were not succesful in using this sfs.
Download the sfs and place it to the /mnt/home.
Do you know how to install sfs applications. You should have save file made and then launch bootmanager > choose which extra sfs files to load at bootup. scroll to xnview sfs and select it and then click add. Click ok or save or something. Then reboot. Now you should have this xnview sfs installed and menu entries are also in place. I have managed to get locales to work, Argolance was the brilliant mind who figured locales working out.

Translate this if you dont understand the brochedures correctly.
Back to top
View user's profile Send private message 
RetroTechGuy


Joined: 15 Dec 2009
Posts: 2666
Location: USA

PostPosted: Wed 22 Jun 2011, 15:15    Post subject: Re: XnView MP 0.35 and XnConvert MP 0.98 combo sfs
Subject description: Image viewer and simple image editor
 

pemasu wrote:
Updated 6.3.2011. XnView MP 0.35 and XnConvert MP 0.98 combo sfs.
26 Mb. Yes, I know, it is big. But it is getting closer to be good graphics app.

XnView MP 0.35: http://newsgroup.xnview.com/viewtopic.php?f=60&t=21616

XnCovert MP 0.98 http://newsgroup.xnview.com/viewtopic.php?f=79&t=21801

Download: http://www.smokey01.com/pemasu/Sfs/xnviewmp-xncorverter-0.35-0.98-with-locales.sfs


Thanks for all the work, Pemasu! I love XNView for photo management...

_________________
Add swapfile
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Mon 05 Sep 2011, 11:26    Post subject:  

Xnview 0.39 - Xnconverter 1.1 combo sfs has been uploaded.
See the first page.
Back to top
View user's profile Send private message 
Dromeno

Joined: 12 Sep 2008
Posts: 534

PostPosted: Sat 07 Jan 2012, 14:17    Post subject: Symbol lookup error for XNView 0.39 sfs in Lucid Puppy 525  

The XnView MP 0.39 and XnConvert MP 1.1 combo sfs works in puppeee but in Lucid Puppy 525 I get a symbol lookup error:

"undefined symbol: _ZN9QListData11detach_growEPii

Can somebody please inform me how I can solve this?

lots of thanx in advance - I love this viewer!
xnview_lookup_error.jpg
Description 
jpg

 Download 
Filename  xnview_lookup_error.jpg 
Filesize  99.93 KB 
Downloaded  368 Time(s) 
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sat 07 Jan 2012, 14:19    Post subject:  

Yes. You have conflicting Qt libs in the path. You could click the sfs open, when it is not mounted and check the qt libs and compare what qt libs you have installed with some other app.
Back to top
View user's profile Send private message 
Dromeno

Joined: 12 Sep 2008
Posts: 534

PostPosted: Tue 10 Jan 2012, 07:51    Post subject: How do I proceed to make it work?  

OK, pemasu thanx. But before I damage anything I want to make sure I dounderstand you:

I go to:

In the /mnt/+mnt+home+xnviewmp-xncorverter-0.39-1.1-with-locales.sfs/usr/lib

then copy the contents to my existing /usr/lib and overwrite?

But doesn't that happen automatically when an sfs is loaded?

So... how do I know which lib causes the conflict, and when I know that which one do I have to delete?
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Tue 10 Jan 2012, 12:35    Post subject:  

when you load whatever way sfs, it does not overwrite existing same named files or symlinks. So...if there are already another set of Qt libs with whatever version number, there are probably also symlinks to the base version....like...usr/lib/libQtCore.so.4

So...installing this sfs will lead non working situation due to previous Qt version and because symlinks are not updated. (will not be overwritten)

Best solution. I should create new sfs where the libs location is in /opt/xn (for example)

And make in /etc/profile.d new file to point to that location. When I have time, I will recreate the package.

To your problem. Since you probably have another set of Qt libs, which you probably need (Qt libs does not include to the Lucid Puppy) for some application...maybe vlc or umplayer ? ....I am not sure that there is much point by trying to get along with 2 set of Qt libs. I will try to make the package better compliant with other Qt stuff possibly already installed.
Back to top
View user's profile Send private message 
Dromeno

Joined: 12 Sep 2008
Posts: 534

PostPosted: Wed 11 Jan 2012, 05:39    Post subject:  

Pemasu thanks for putting your time into Xnview!

explanation:
Xnview is the fastest tool I have found (so far) which is able to browse full screen through a pile of photos and gives the user the option to rate the pics with a 5 star rating system. My girlfriend spent a couple of months in Austrralia and New Zealand, came back with thousands of photos and needs a system to select the best ones / throuw out the worst ones fast. But the Xnview 0.39 is the first version in which the arrow buttons work in combination with full screen mode and photo rating, which is the fastest option (faster than using the mouse)

It would be lovely if this particular Xnview can be made to work in the customized puppy 525 we both use, which already has a couple of other progs installed, so we do not need to create a new customized puppy from the base version.
Back to top
View user's profile Send private message 
RetroTechGuy


Joined: 15 Dec 2009
Posts: 2666
Location: USA

PostPosted: Wed 11 Jan 2012, 12:12    Post subject:  

Dromeno wrote:
Pemasu thanks for putting your time into Xnview!

explanation:
Xnview is the fastest tool I have found (so far) which is able to browse full screen through a pile of photos and gives the user the option to rate the pics with a 5 star rating system. My girlfriend spent a couple of months in Austrralia and New Zealand, came back with thousands of photos and needs a system to select the best ones / throuw out the worst ones fast. But the Xnview 0.39 is the first version in which the arrow buttons work in combination with full screen mode and photo rating, which is the fastest option (faster than using the mouse)

It would be lovely if this particular Xnview can be made to work in the customized puppy 525 we both use, which already has a couple of other progs installed, so we do not need to create a new customized puppy from the base version.


The one feature that I miss is that the old one, which I used under Windows, allowed simple drag and drop for photo organizing. It doesn't seem to work under this one (it the copies the photos instead)... Did I miss a setting/config somewhere?

_________________
Add swapfile
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Wed 11 Jan 2012, 19:38    Post subject:  

First page sfs and pet has been repackaged and uploaded. The location of Xnview, Xnconvert and needed libs are now in /opt/xn/*

Try, test and give feedback.
Back to top
View user's profile Send private message 
Dromeno

Joined: 12 Sep 2008
Posts: 534

PostPosted: Thu 12 Jan 2012, 12:58    Post subject: Still not working. Weird...  

Bizarre... I have tested the new sfs (unloaded the 0.34 one, then loaded the new one via boot manager and rebooted)

...but the very same lookup error is still there.

In the sfs I can see you have the libs moved to opt. So I am using the right sfs.

What else do you think it can be?
Back to top
View user's profile Send private message 
RetroTechGuy


Joined: 15 Dec 2009
Posts: 2666
Location: USA

PostPosted: Thu 12 Jan 2012, 13:25    Post subject: Re: Still not working. Weird...  

Dromeno wrote:
Bizarre... I have tested the new sfs (unloaded the 0.34 one, then loaded the new one via boot manager and rebooted)

...but the very same lookup error is still there.

In the sfs I can see you have the libs moved to opt. So I am using the right sfs.

What else do you think it can be?


I put it in and get no errors (of course, I didn't get errors on the previous 0.39 one either)...

_________________
Add swapfile
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Thu 12 Jan 2012, 15:04    Post subject:  

Dromeno. Sorry. I am clueless. I suggest you to try and test with fresh frugal install. And you could also try with installling the pet instead of sfs.

Edit. What happens if you launch in console, the xnview.sh, that launching wrapper file is the right launching file, it has export commands for finding right libs location before it lauches xnview. Same goes with xnconvert.sh.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 3 of 4 [54 Posts]   Goto page: Previous 1, 2, 3, 4 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Graphics
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1096s ][ Queries: 13 (0.0350s) ][ GZIP on ]