Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 28 Nov 2014, 17:33
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Desktop
Fluxbox Windowmanager
Post new topic   Reply to topic View previous topic :: View next topic
Page 4 of 4 [55 Posts]   Goto page: Previous 1, 2, 3, 4
Author Message
Masf

Joined: 19 Apr 2011
Posts: 5

PostPosted: Tue 19 Apr 2011, 17:47    Post subject:  

Hi, i open .xinitrc and see this:

Code:
#v3.95 support fbpanel tray/taskbar...
#only launch tray for w.m. without inbuilt tray...
if [[ "$CURRENTWM" != "jwm" && "$CURRENTWM" != "icewm" && "$CURRENTWM" != "startxfce4" && "$CURRENTWM" != "startfluxbox" ]];then
 if [ -f /usr/bin/fbpanel ];then
  #a bit of a hack: when 3builddistro runs fixmenus, which calls variconlinks,
  #which populates /var/local/icons with symlinks, /usr/local/lib/X11/pixmaps
  #is not yet populated (happens at first boot, from default icon theme)...
  [ ! -e /var/local/icons/home48.png ] && ln -fs /usr/local/lib/X11/pixmaps/* /var/local/icons/
  fbpanel &
 fi
 [ -f /usr/bin/lxpanel ] && lxpanel &
fi


I find "$CURRENTWM" != "startfluxbox" in the .xinitrc file, so i dont do anything,

I must change the && to -a ?


Also, i change the placement of the fluxbox panel to "top center" and now i see the two panels.

Edited

In another line of .xinitrc i can see:

Code:
CURRENTWM="`cat /etc/windowmanager`"


and the file windowmanager only have
Code:
fluxbox


Edited (again Rolling Eyes )

I change "startfluxbox" (in .xinitrc) for "fluxbox" and it works. Thanks

PD. Im using lucid-puppy 5.25
Back to top
View user's profile Send private message 
redandwhitestripes

Joined: 02 Jan 2009
Posts: 124

PostPosted: Tue 26 Jul 2011, 10:31    Post subject:  

Hi guys,
I've loved FB ever since the old Fluxpup fork was released a while back.

Back then, each window had a tab and you could group them together by middle clicking (i.e. mousewheel) and dragging.

With this release I can't get that to work and I've looked through the online documentation and played with the settings.

Anyone know how to get those tabs back?

Also, sometimes when I bring up the bottom-left corner menu, I want to close it by simply clicking outside it, but I can't. Instead I have to hit the 'esc' key which is a slight pain. Can anyone help with this, too?

Many, many thanks in advance.
Back to top
View user's profile Send private message 
aragon

Joined: 15 Oct 2007
Posts: 1698
Location: Germany

PostPosted: Mon 31 Oct 2011, 15:40    Post subject:  

uploaded actual version to first post.

aragon

_________________
PUPPY SEARCH: http://wellminded.com/puppy/pupsearch.html
Back to top
View user's profile Send private message 
starhawk

Joined: 22 Nov 2010
Posts: 3144
Location: Everybody knows this is nowhere...

PostPosted: Fri 13 Jan 2012, 22:36    Post subject:  

Does not work in Wary511-Uniproc... on my thinkpad, it starts to load and dies almost immediately. No idea how to diagnose the issue, either, TBH.
_________________

Back to top
View user's profile Send private message 
aragon

Joined: 15 Oct 2007
Posts: 1698
Location: Germany

PostPosted: Sat 14 Jan 2012, 08:20    Post subject:  

Hi starhawk,

Sorry can't help 4.31 is the newest puppy i'm running...

Aragon

_________________
PUPPY SEARCH: http://wellminded.com/puppy/pupsearch.html
Back to top
View user's profile Send private message 
Eyes-Only


Joined: 10 Aug 2006
Posts: 1046
Location: La Confederation Abenaquaise

PostPosted: Sat 14 Jan 2012, 15:16    Post subject:  

Starhawk? Have you tried opening a terminal window in "/usr/bin" and then typing "ldd fluxbox" ( without " " of course ) to get a dependency list to see whether or not you have any missing/unmet dependency issues?

I've run Aragon's package here on everything ranging from... hmm... Tux's ClassicPup-214-Top5, to KDPup-484, to all versions of Lucid-Pup, and from Racy to Slacko-5.3 - all without a single hiccup nor problem. Unfortunately I haven't been able to run it on any version of Wary to date as it simply refuses to run on my machine. Odd too! The one and only Puppy version/make to NOT run on my desktop. lol!!

Anyway, I hope that perhaps running a dependency check on your installed Fluxbox might help Starhawk. I know that for me this has occasionally picked up a dependency that the PPM has missed during install check.

Best of luck my friend!/Bonne chance mon ami!

Eyes-Only
"L'Peau-Rouge d'Acadie"

_________________
*~*~*~*~*~*
Proud user of LXpup and 3-Headed Dog. Cool
*~*~*~*~*~*
Back to top
View user's profile Send private message 
starhawk

Joined: 22 Nov 2010
Posts: 3144
Location: Everybody knows this is nowhere...

PostPosted: Sat 14 Jan 2012, 16:40    Post subject:  

Bonjour, Eyes-Only! Thank you for your suggestion, I have run the command you requested, and a screenshot of the results is attached to this post.

Kindly explain to me what all this gobbledegook means...

_________________

Back to top
View user's profile Send private message 
starhawk

Joined: 22 Nov 2010
Posts: 3144
Location: Everybody knows this is nowhere...

PostPosted: Sat 14 Jan 2012, 17:08    Post subject:  

Figured it out.

There is a necessary lib, attached to the first post of this thread, which Wary lacks. Guess the other Pups all have it. You *DON'T* need the -DEV version of the lib, just the one that's IIRC right below the screenshot of the whole thing.

_________________

Back to top
View user's profile Send private message 
Eyes-Only


Joined: 10 Aug 2006
Posts: 1046
Location: La Confederation Abenaquaise

PostPosted: Wed 18 Jan 2012, 10:43    Post subject:    

My sincere apologies for not having made it back in time to have helped you Starhawk - I don't make it to the forum as often as I would like. Sad

I'm glad, however, that you were able to figure out the answer to your problem! Very Happy Yes, that "ldd" command is really great and I frequently use it myself whenever something doesn't work - and it very often solves my problem as you yourself discovered as often it is only a missing lib which is needed for any programme to run properly.

In fact, this used to be the reason why I kept an updated install of a related Debian on a small partition of my drive - not that I was ever interested in using it as Puppy does it all for me! - but solely for finding missing libs that I wasn't able to find elsewhere. Well... that was MY work-a-round anyway. There are many, many, other ways of doing this as well, such as searching the Ubuntu/Debian web interface repositories for the files, searching in the PPM within Puppy ( this latter working the least-well for me though ), etc.

I hope all of this has helped in some small way for future installs of software, and I also hope that you're greatly enjoying Aragon's .pet of Fluxbox. It's a real beauty, isn't it? Very Happy

By the way: If you'd like to find even MORE themes for your Fluxbox besides those excellent ones here on the forum you may want to give http://www.box-look.org/ a try. I've found perhaps 50 more there! Shocked

Cheers/Amicalement,

Eyes-Only
"L'Peau-Rouge"

_________________
*~*~*~*~*~*
Proud user of LXpup and 3-Headed Dog. Cool
*~*~*~*~*~*
Back to top
View user's profile Send private message 
bones01

Joined: 11 Aug 2008
Posts: 371
Location: Melbourne, Aus

PostPosted: Tue 03 Apr 2012, 01:08    Post subject:
Subject description: Shutdown from WBAR with Fluxbox
 

Just thought I'd add this for anyone else trying to work this out.

I opened up /root/.wbarstuff/shutoff (open as text) and saw the code suggested 'wmshutdown'.

Looking at /root/.fluxbox/menu and scrolling down to the bottom, I saw that this used the term 'shutdownflux'

So I simply deleted 'wmshutdown' to 'shutdownflux' in the .wbarstuff file, and now the shutdown button on wbar (from wbar Configuration Centre -
http://www.murga-linux.com/puppy/viewtopic.php?t=52381&search_id=1546975310) works fine.

Bones

_________________
Dell Latitude D630 running Puppy 5.2.8 frugal, Macpup 525 frugal (if I can get it working again)
Precise Puppy 5.4 live DVD
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 4 of 4 [55 Posts]   Goto page: Previous 1, 2, 3, 4
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Desktop
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0788s ][ Queries: 13 (0.0122s) ][ GZIP on ]