Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 21 Aug 2014, 23:57
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects » Next Puppy Development » 5.x » Usability Issues (5.x dev)
Special characters can't be obtained since PL431...
Moderators: BarryK, Lobster
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [17 Posts]   Goto page: 1, 2 Next
Author Message
benny7440


Joined: 20 Apr 2009
Posts: 416

PostPosted: Thu 19 Jan 2012, 13:15    Post subject:  Special characters can't be obtained since PL431...
Subject description: Latin american special characters in/for Apanish
 

I was amazed at how simple the developers of PL 4.31 made it with respect to special characters introduction into a page: a combination of <Alt> key & the special character itself plus the regular character. The system took care of it automatically, with respect to interpretation.

Now, in PL 5.11, 525 & 528 can't use any keyboard combination to obtain any. I would like to know/learn what has changed between those puppies.

Is it fixable by just downloading & installing something?

Note: The speicial characters I need are for spanish. The way I used to obtain them with PL431 was by pressing Alt + <the special character> releasing all keys & then the regular character.

Thanks in advance for any tips!
Back to top
View user's profile Send private message 
disciple

Joined: 20 May 2006
Posts: 6427
Location: Auckland, New Zealand

PostPosted: Sun 22 Jan 2012, 07:34    Post subject:  

I suspect you are talking about "Dead keys", and your problem is that you are using the "US" keyboard layout rather than the "US international" keyboard layout (or something like that). Or maybe there is an explicit option to enable dead keys in the keyboard settings - have a look.

Also note that there are other ways to insert special characters, e.g. using a "Compose key" (my favourite), or by pressing "Shift-Ctrl-u" then the unicode code for the character.

_________________
DEATH TO SPREADSHEETS
- - -
Classic Puppy quotes
- - -
Beware the demented serfers!
Back to top
View user's profile Send private message 
benny7440


Joined: 20 Apr 2009
Posts: 416

PostPosted: Sun 22 Jan 2012, 15:13    Post subject:  

Thanks for responding, disciple!
I've a few questions regarding your post:
1) What do you mean by 'dead key'?
2) Tried a few moments ago to look for that thing of 'US keyboard layout' but didn't find it. What <Menu> entry should I choose for getting there?
3) I didn't find, either, any explicit option for any 'dead key' enabling...
4) What is that of a 'compose key'?
5) When I press <Ctl+Shift+u> all that I get is underscoring the keys I'm pressing down even when using the #-keypad at the extreme right of the keyboard. Could you clarify?
Thanks in advance for any help on this issue!
Back to top
View user's profile Send private message 
disciple

Joined: 20 May 2006
Posts: 6427
Location: Auckland, New Zealand

PostPosted: Mon 23 Jan 2012, 08:04    Post subject:  

1) Wikipedia is your friend Wink
Quote:
A dead key is different from a typical modifier key (such as AltGr or Option) in that, rather than being pressed and held while another key is struck, the dead key is pressed and released before striking the key to be modified.
In this case we are actually talking about a dead key combination (e.g. AltGr [right alt] +6) rather than a single key.
I find a standard dead key configuration annoying, as it has other dead keys that don't use AltGr, e.g. ' is a dead key, so to type an actual ' you need to press it twice.
2) It may have changed in the most recent Puppies, but you used to find it in Menu>Setup>Mouse/Keyboard wizard>Advanced Xorg configuration>Main>Layout variants.
4) A compose key is slightly different - instead of holding down AltGr and the accent key, then pressing the letter, you press the compose key, then press the accent then press the letter. You can set up a compose key at Menu>Setup>Mouse/Keyboard wizard>Advanced Xorg configuration>Options>Compose key.
5) Sorry, I should have mentioned that you need to press space afterwards.

_________________
DEATH TO SPREADSHEETS
- - -
Classic Puppy quotes
- - -
Beware the demented serfers!
Back to top
View user's profile Send private message 
benny7440


Joined: 20 Apr 2009
Posts: 416

PostPosted: Mon 23 Jan 2012, 11:37    Post subject:  

Sorry to insist on this but that thing of 'AltGr' isn't in my keyboard. The actual keyboard is referenced at the following link:

http://ts3.mm.bing.net/images/thumbnail.aspx?q=1532926827922&id=6eb8514650858730d35540c5de70587d

I tried to put the actual photo within this post but wasn't possible.

In your first sentence you mention the combination 'right alt + 6' and I'm thinking what '6'; the one at the numeric pad or the regular one? And, what does the '6' has to do with this in relation to the other numbers? I tried it & it just takes me to another tab within the ones opened in my browser (FF).

The other day I played a little around this issue & found the following chars.: á í ó ú : è; I think it was with Abiword. The last char. was the only 'accented "e"'(backwards) that I could find. I decided to make a text document & save it, for reference; I know I can use it in the meantime by pasting it somewhere within the text I'm writing for using its' parts but this's a less than optimal solution. I can include the expected accented 'e' within that file by finding it somewhere, copying & pasting it into my saved doc & I'll do it right after I post this.

Thanks for any other ideas, specially that of using a 'compose key', with this specific topic I need more info.
Back to top
View user's profile Send private message 
disciple

Joined: 20 May 2006
Posts: 6427
Location: Auckland, New Zealand

PostPosted: Mon 23 Jan 2012, 17:01    Post subject:  

If you choose the US international keyboard layout, it will turn the right Alt key into AltGr. (You could manually do this if you wanted, but there should be no need to, unless you don't want some of the other features of the layout - like the other dead keys I was complaining about.)

The US international keyboard layout is not for a different model of keyboard with different keys (hardware) - it just changes the behaviour of some of the keys (in software).

Quote:
I'm thinking what '6'; the one at the numeric pad or the regular one?

The regular one.

Quote:
And, what does the '6' has to do with this in relation to the other numbers?

6 is an example, because it has the ^ character on it (although I don't know if Spanish uses that accent Wink)

Quote:
I tried it & it just takes me to another tab within the ones opened in my browser (FF).

Have you selected the US international keyboard layout?

Quote:
The other day I played a little around this issue & found the following chars.: á í ó ú : è; I think it was with Abiword. The last char. was the only 'accented "e"'(backwards) that I could find. I decided to make a text document & save it, for reference; I know I can use it in the meantime by pasting it somewhere within the text I'm writing for using its' parts but this's a less than optimal solution. I can include the expected accented 'e' within that file by finding it somewhere, copying & pasting it into my saved doc & I'll do it right after I post this.

There is also a Puppy program called Pastelist designed to do that. My understanding was that it is included in Puppy. I haven't used it personally.

Quote:
specially that of using a 'compose key', with this specific topic I need more info.

What info do you need? The sequence of keys to press?
Most apps in Puppy are GTK, so see https://help.ubuntu.com/community/GtkComposeTable (I can't find the list on gtk.org at the moment).
This list is slightly different from the standard X compose key sequences - you can get GTK to use those by I think switching to the XIM "input method", but that disables something else (the Ctrl-Shift-u method if I remember correctly).

_________________
DEATH TO SPREADSHEETS
- - -
Classic Puppy quotes
- - -
Beware the demented serfers!
Back to top
View user's profile Send private message 
disciple

Joined: 20 May 2006
Posts: 6427
Location: Auckland, New Zealand

PostPosted: Mon 23 Jan 2012, 17:09    Post subject:  

Does the Puppy gui only allow you to choose certain keys as a compose key?
If you want to use another key (I like "Print screen"), you can do it manually http://www.murga-linux.com/puppy/viewtopic.php?p=319810&search_id=391285947#319810

_________________
DEATH TO SPREADSHEETS
- - -
Classic Puppy quotes
- - -
Beware the demented serfers!
Back to top
View user's profile Send private message 
benny7440


Joined: 20 Apr 2009
Posts: 416

PostPosted: Mon 23 Jan 2012, 18:45    Post subject:  

As far as I can remember (I just spent about 30 mins playing again with this but no good luck) there's no clue as to what choice is US International Keyboard. {Trying to practice the Ctl+Shift U thing I pressed the CAPS key & the audio went away: still don't know what's better for dealing with this thing of that key. Having spent about 30 mins more just to see if I was able to find one of the interesting chars. by luck but... as mentioned above: no good luck for me today.}
Now I'm remembering that one option that I selected was UTF-8 (not from the beginning, but right now it's selected. Is it advisable to deselect that option?
I'll check later the contents within that link, no I've to go out for a few hrs.
Thanks!
Back to top
View user's profile Send private message 
disciple

Joined: 20 May 2006
Posts: 6427
Location: Auckland, New Zealand

PostPosted: Tue 24 Jan 2012, 03:24    Post subject:  

Does your puppy have "Menu>Setup>Mouse/Keyboard wizard>Advanced Xorg configuration>Main>Layout variants"?
What are the available options there?

Quote:
Trying to practice the Ctl+Shift U thing I pressed the CAPS key & the audio went away:

That sounds like linux thinks your CAPS key is a mute key on a multimedia keyboard. One way to fix it is with xmodmap.
Are there other keys which aren't recognised correctly? You might like to search for information about using that particular keyboard model with Linux.

Quote:
Now I'm remembering that one option that I selected was UTF-8 (not from the beginning, but right now it's selected. Is it advisable to deselect that option?

No, that sounds like the locale setting, which IIRC is different from the keyboard layout. You can actually enable a number of keyboard layouts (e.g. for different languages) and switch between them while staying in the same locale.

_________________
DEATH TO SPREADSHEETS
- - -
Classic Puppy quotes
- - -
Beware the demented serfers!
Back to top
View user's profile Send private message 
benny7440


Joined: 20 Apr 2009
Posts: 416

PostPosted: Tue 24 Jan 2012, 11:38    Post subject:  

Thanks for responding, disciple! I've that Menu entry & the options are: 1) intl, 2) alt-intl, 3) dvorak & 4) rus.
I would like to have more info on that of having other keyboard layouts, e.g., how to proceed to have one & how to activate/deactivate it when I'm done.
One thing that I didn't mention that happenned yesterday (because I thought I was going to be able to fix it) was that while messing within the Menu options something I have pressed that activated a program that's refusing to be closed, cancelled or killed. The title of the said window is "PDF-Writer - Save As...". I wasn't using the PDF Viewer at the moment. I tried by pressing Cancel, Close (both, the button itself awa the icon in the corner, also by right-clicking on the tab at the button of the screen) & by going to the process manager, selecting the one that said/included pdf in it & pressing kill.
Today, I was surprised to see it again insisting to print something. I think this will bother me for a couple of days more until I find out how to stop it for good. Any ideas?
Back to top
View user's profile Send private message 
disciple

Joined: 20 May 2006
Posts: 6427
Location: Auckland, New Zealand

PostPosted: Tue 24 Jan 2012, 18:13    Post subject:  

Quote:
Thanks for responding, disciple! I've that Menu entry & the options are: 1) intl, 2) alt-intl, 3) dvorak & 4) rus.
I would like to have more info on that of having other keyboard layouts, e.g., how to proceed to have one & how to activate/deactivate it when I'm done.

I don't have Puppy in front of me at the moment, but I understand you can add additional layouts from
Menu>Setup>Mouse/Keyboard wizard>Advanced Xorg configuration>Layouts
Can you not figure out how to do it here?

And I understand that when you add a second layout Puppy will automatically enable fbxkb, which is a trayapp for displaying and changing the current layout.

N.B. there is also a program xxkb, which can display in each window's title bar instead of the tray, because different windows can have different layouts selected. I'm not certain if this works with Puppy's window manager(s) though.

Quote:
One thing that I didn't mention that happenned yesterday (because I thought I was going to be able to fix it) was that while messing within the Menu options something I have pressed that activated a program that's refusing to be closed, cancelled or killed.

Does "refusing" mean you can't kill it, or that it comes back again after you kill it?
Quote:
The title of the said window is "PDF-Writer - Save As...". I wasn't using the PDF Viewer at the moment. I tried by pressing Cancel, Close (both, the button itself awa the icon in the corner, also by right-clicking on the tab at the button of the screen) & by going to the process manager, selecting the one that said/included pdf in it & pressing kill.

Also try:
- right-clicking in the title bar and choosing to kill it (at least if your window manager is JWM).
- going into the print queue for CUPS-PDF (e.g. by going to localhost:631 in a browser) and cancelling the print job.
Quote:
Today, I was surprised to see it again insisting to print something.

Why were you surprised? Did you reboot in the meantime?
Quote:
I think this will bother me for a couple of days more until I find out how to stop it for good. Any ideas?

You should really start a new thread about this problem if it persists.

_________________
DEATH TO SPREADSHEETS
- - -
Classic Puppy quotes
- - -
Beware the demented serfers!

Last edited by disciple on Tue 24 Jan 2012, 18:31; edited 1 time in total
Back to top
View user's profile Send private message 
disciple

Joined: 20 May 2006
Posts: 6427
Location: Auckland, New Zealand

PostPosted: Tue 24 Jan 2012, 18:30    Post subject:  

benny7440 wrote:
Thanks for responding, disciple! I've that Menu entry & the options are: 1) intl, 2) alt-intl, 3) dvorak & 4) rus.
I would like to have more info on that of having other keyboard layouts, e.g., how to proceed to have one & how to activate/deactivate it when I'm done.

Some things I don't know:

- Whether or not Puppy's Mouse/Keyboard wizard allows you to set up more than one variant of the same keyboard layout (e.g. normal US and US international). I do know that X can support this (You can set them up using lxkb-config from LXDE, or the console command setxkbmap), so if the Mouse/Keyboard wizard does not support this then you should report it as a bug.

- Whether fbxkb just shows the same flag for both layout variants (which is what the lxpanel tray plugin lxpanel-xkb does), or if it will distinguish between them somehow.

- If you select e.g. the US international layout variant in the Mouse/Keyboard wizard, how to unselect it later, as the plain US layout isn't listed as a variant. Maybe you would need to remove the layout and add it again.

_________________
DEATH TO SPREADSHEETS
- - -
Classic Puppy quotes
- - -
Beware the demented serfers!
Back to top
View user's profile Send private message 
benny7440


Joined: 20 Apr 2009
Posts: 416

PostPosted: Thu 26 Jan 2012, 13:42    Post subject:  

Thanks for your kind help, disciple!

I´m not so sure exactly what I did but now I´ve all the interesting special characters for Spanish by way of selecting the ´modifier' key & then the key to be modified. In case I need the ´ḿodifier´ itself I just have to press it twice. Have to get used to it but that is ok.
Back to top
View user's profile Send private message 
disciple

Joined: 20 May 2006
Posts: 6427
Location: Auckland, New Zealand

PostPosted: Thu 26 Jan 2012, 17:47    Post subject:  

That sounds like the standard dead keys on the US international keyboard. Do they survive a reboot?

Quote:
In case I need the ´ḿodifier´ itself I just have to press it twice. Have to get used to it but that is ok.
You can see why I said I didn't like it Smile
But I guess the keyboard map you were using on 431 must have been some custom one if it didn't have that effect...

Does the <Right Alt> + <special character> + <letter> still not work? Note that it is normally only the right alt...

_________________
DEATH TO SPREADSHEETS
- - -
Classic Puppy quotes
- - -
Beware the demented serfers!
Back to top
View user's profile Send private message 
benny7440


Joined: 20 Apr 2009
Posts: 416

PostPosted: Fri 27 Jan 2012, 09:07    Post subject:  

Hello, disciple! Yes, they´re at hand each time I turn on the machine.
Yes, you´re right, it´s the right alt key that´s used for it but just for the ¨~¨ character because the accents just need to use the ¨´¨ key + the vowel.
Again, thanks a lot!
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 2 [17 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects » Next Puppy Development » 5.x » Usability Issues (5.x dev)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1085s ][ Queries: 12 (0.0045s) ][ GZIP on ]