Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 26 Nov 2014, 09:02
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
How to Upgrade Printing/Scanning in Classic Pup 2.14X
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
rcrsn51


Joined: 05 Sep 2006
Posts: 9260
Location: Stratford, Ontario

PostPosted: Sat 17 Sep 2011, 10:59    Post_subject:  How to Upgrade Printing/Scanning in Classic Pup 2.14X  

The following notes were tested with 214x-top9 and are a work in progress. Please provide feedback.

Update: After a week, there has been no feedback, so I have deleted the attachments. If anyone wants to do some testing, please post a message and I will replace them.

Printing

Classic Pup 2.14X has the old CUPS 1.1.23. There are several advantages to upgrading, including access to new driver packages like HPLIP.

Before performing this upgrade, you must have either made a pupsave file or done a full install.

1. Install the cups_upgrade_214-1.1.pet attached below.

2. Install CUPS 1.3.11 from here. Just install Items 1,2 and 5.

3. Install Ghostscript from here. Don't miss this step!

4. Install the Foomatic-rip filter from here.

5. Install the Set Default Printer utility from here.

6. Reboot

7. This setup contains no printer drivers, so you must install a package that supports your model. If you know that Gutenprint has an appropriate driver, install it from here.

For HP printers, get the latest driver package here.

Many of the other driver packages referenced in the above link will also work.

8. Run the CUPS wizard. You may need to clear your browser's cache to remove traces of the old CUPS.

9. Install your printer as usual. Set it as the default printer.

10. To print from an application, select "Print to LPR". If you have several printers installed, you can switch between them by running Set Default Printer. Find it in System > System Status and Config.

Scanning

1. Install the sane_214-1.0.19.pet attached below.

2. Install Peasyscan from here.

3. Reboot.

4. This setup contains no drivers for specific models, so you must install a scanner package. Many of the packages referenced here will work. Be aware that the hplip_scan package requires CUPS 1.3.11, which you have probably already installed.

For Canon scanners, you will need the older pixma-backend-431-1.0.21.pet from here.

5. Xsane is not included in this package. Instead, run Peasyscan from the Graphics menu.
Back to top
View user's profile Send_private_message 
ttuuxxx


Joined: 05 May 2007
Posts: 10843
Location: Ontario Canada,Sydney Australia

PostPosted: Wed 25 Jan 2012, 08:29    Post_subject:  

lol I was finally getting around to upgrading cups by using your packages and they are gone???
If you re-upload them I'll add them to 2.14x-top11 in a couple of months.
Thanks for your work on this Smile
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0541s ][ Queries: 12 (0.0063s) ][ GZIP on ]