Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 30 Oct 2014, 11:29
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Graphics
How to Enable Inkscape extensions in Puppy
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 2 Posts_count   Goto page: 1, 2 Next
Author Message
darkcity


Joined: 23 May 2010
Posts: 2465
Location: near here

PostPosted: Sat 05 Nov 2011, 22:22    Post_subject:  How to Enable Inkscape extensions in Puppy  

The reason Inkscape extensions don't work by just loading the standard Puppy PET is because they require Python, and Python libraries lxml (aka libxml) and numpy (aka ?).

This can be resolved by one of the following methods-

Option 1. Load python-2.6-lxmlnumpy-cut-i486.pet - This Pet includes all the parts of Python required to run the extensions. It is made by cutting down the Python from Slacko's devx. To install, download and run.
-This method works on Slacko 5.3.1, Slacko 5.6, Puppy 5.29 3-headed-dog and Polarpup 005.

---

Option 2. Load the appropriate developer devx.sfs - Many devx packages include Python 2.6 and the required libraries (though I couldn't understand exactly where lxml, numpy are derived from, maybe an include?).
-This works for Slacko 5.3.1 and Wary, but NOT Slacko 5.6 or Polarpup 005. Thanks to vtpup for finding this out.

--- ---

Whats in the python-2.6-lxmlnumpy-cut-i486.pet -
Code:
/usr/bin/python2.6
/usr/lib/libpython2.6.so.1.0
/usr/lib/python2.6/  *.pyc and *.so only
/usr/lib/python2.6/site-packages/lxml/ (2.2.8) *.pyc and *.so only
/usr/lib/python2.6/site-packages/numpy/ (1.4.1) *.pyc and *.so only
-minus /usr/lib/python2.6/test/

its 29M uncompressed, any help further reducing its size would be useful
; -)

---

A great feature in Inkscape is to be able to select vectors that are fully covered by ones above. This involves alt-clicking - which is already taken (by default) puppy and in JWM can't be reconfigured A work around is to use OpenBox window manager and config its mouse bindings see-
How to disable/config alt-click-move in OpenBox

----

original post
Quote:
I can not get any of Inkscape's extensions to work in Puppy. If I run Puppy the terminal it reveals the following error...

Quote:
Can't Spawn!!! spawn returns: Failed to execute child process "" (No such file or directory)


For example,

if I select 'Extensions > Render > Barcode', enter number and click apply.

I quick message box saying 'Barcode is processing' pops up and vanishes, nothing is done in inkscape, the above message is return in the terminal.

This happens with every extension I have tried. I've tried a few versions of 0.47 and 0.48 to the same effect (using Puppy 5.2Cool. Any suggestions or help appreciated.... Shocked


EDIT link to .pet now working

_________________
helping Wiki for help | IF SendSpace link = "dead" THEN PM me ("up file to http://meownplanet.net/")

Edited_times_total
Back to top
View user's profile Send_private_message Visit_website 
darkcity


Joined: 23 May 2010
Posts: 2465
Location: near here

PostPosted: Sun 06 Nov 2011, 07:51    Post_subject:  

the extensions are storage in

/usr/share/inkscape/extensions/

it may be a problem with the language the extensions are written,

how can I check what languages are installed?

some need python and some xml?

_________________
helping Wiki for help | IF SendSpace link = "dead" THEN PM me ("up file to http://meownplanet.net/")
Back to top
View user's profile Send_private_message Visit_website 
Aitch


Joined: 04 Apr 2007
Posts: 6825
Location: Chatham, Kent, UK

PostPosted: Mon 07 Nov 2011, 09:24    Post_subject:  

Try this

http://code.google.com/p/jessyink/wiki/Installation

or this

http://www.evilmadscientist.com/article.php/hershey

Inkscape wiki is down atm, otherwise try that....

also seems to need python AFAICT, see

http://wiki.xmoto.tuxfamily.org/index.php?title=Inkscape-0.4.0

Aitch Smile
Back to top
View user's profile Send_private_message 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15117
Location: Paradox Realm

PostPosted: Sat 12 Nov 2011, 14:23    Post_subject:  

You are using the full Inkscape and not Inkscape Lite (which is modified from an early Inkscape)?
_________________
Puppy WIKI
Back to top
View user's profile Send_private_message Visit_website 
darkcity


Joined: 23 May 2010
Posts: 2465
Location: near here

PostPosted: Tue 15 Nov 2011, 10:15    Post_subject:  

Yes, I'm using the so called 'full-versions' of 0.47 or 0.48.

It may be a problem with the language the extensions are written in, as the code files are in the directory.

I hadn't had chance to look into what Aitch said yet. I would be most grateful if someone could confirm this problem on their machine.

Probably the easiest way to test is install inkscape from the PPM and test any extension. Very Happy
Back to top
View user's profile Send_private_message Visit_website 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 11125
Location: Arizona USA

PostPosted: Sat 04 Feb 2012, 21:38    Post_subject:  

Don't know if this is relevant but I installed Inkscape .48 from PPM in Racy Puppy 5.2.1.90 only to find that it won't open .WMF (Windows Media File) files. have been unable to figure out how to open those files in Racy Puppy as yet. Here's the thread about it.
Back to top
View user's profile Send_private_message 
darkcity


Joined: 23 May 2010
Posts: 2465
Location: near here

PostPosted: Sun 05 Feb 2012, 06:31    Post_subject:  

Thats strange, will test later. I assume inkscape could open WMF in other puppies?
_________________
helping Wiki for help | IF SendSpace link = "dead" THEN PM me ("up file to http://meownplanet.net/")
Back to top
View user's profile Send_private_message Visit_website 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 11125
Location: Arizona USA

PostPosted: Sun 05 Feb 2012, 08:51    Post_subject:  

This is the first time I've tried to open WMF files. I have some older multisession Puppy DVDs. Today I should have time to find one and give it a try.
Back to top
View user's profile Send_private_message 
darkcity


Joined: 23 May 2010
Posts: 2465
Location: near here

PostPosted: Sun 05 Feb 2012, 09:00    Post_subject:  

someone written a convertor see post here

http://www.inkscapeforum.com/viewtopic.php?p=6162#p6162

its written for windozer so you'll need wine Cool

_________________
helping Wiki for help | IF SendSpace link = "dead" THEN PM me ("up file to http://meownplanet.net/")
Back to top
View user's profile Send_private_message Visit_website 
vovchik


Joined: 23 Oct 2006
Posts: 1285
Location: Ukraine

PostPosted: Sun 05 Feb 2012, 12:46    Post_subject:  

Dear puppians,

There are a few such converters floating around, including wmf2png, wmf2svg and wmf2x (for display). They basically work and I have used them. Thanks for the link above. I compiled the 4 progs that make up this package in Lucid and made a pet. They are command-line progs and seem to work. I tested on a few wmf files. have fun.

With kind regards,
vovchik
wmftosvg-alpha.pet
Description 
pet

 Download 
Filename  wmftosvg-alpha.pet 
Filesize  34.06 KB 
Downloaded  516 Time(s) 
Back to top
View user's profile Send_private_message 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 11125
Location: Arizona USA

PostPosted: Sun 05 Feb 2012, 14:10    Post_subject:  

Thanks vovchik. I installed wmftosvg in Racy 5.2.1.90. When I run it I get:
Code:
# wmftosvg
wmftosvg: /lib/libc.so.6: version `GLIBC_2.11' not found (required by wmftosvg)
#
Back to top
View user's profile Send_private_message 
vovchik


Joined: 23 Oct 2006
Posts: 1285
Location: Ukraine

PostPosted: Sun 05 Feb 2012, 14:33    Post_subject:  

Dear Flash,

My libc is:

Code:
/lib/libc.so.6 -> libc-2.11.1.so


To find out which version Racy has, run:

Code:
ls -l /lib/libc.so.6


That is the source of the problem. I have a suspicion that Racy has a newer libc, but, actually, the newer libs should be backwards compatible, so I don't get it.

With kind regards,
vovchik
Back to top
View user's profile Send_private_message 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 11125
Location: Arizona USA

PostPosted: Sun 05 Feb 2012, 14:41    Post_subject:  

Here's what I get:
Code:
# ls -l /lib/libc.so.6
lrwxrwxrwx 1 root root 14 2011-11-10 01:53 /lib/libc.so.6 -> libc-2.10.1.so
#
Back to top
View user's profile Send_private_message 
vovchik


Joined: 23 Oct 2006
Posts: 1285
Location: Ukraine

PostPosted: Sun 05 Feb 2012, 15:28    Post_subject:  

Dear Flash,

You have an older version of clib Sad. I'll try to use Puppy 3.01 for the compilation, which will work in nearly every recent Puppy and will post it soon.

With kind regards,
vovchik
Back to top
View user's profile Send_private_message 
vovchik


Joined: 23 Oct 2006
Posts: 1285
Location: Ukraine

PostPosted: Sun 05 Feb 2012, 15:46    Post_subject:  

Dear Flash,

Please try out the attached version. I compiled again using an older clib and it should now work.

With kind regards,
vovchik
wmftosvg-alpha-old-clib.pet
Description 
pet

 Download 
Filename  wmftosvg-alpha-old-clib.pet 
Filesize  33.96 KB 
Downloaded  524 Time(s) 
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 2 Posts_count   Goto page: 1, 2 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Graphics
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0789s ][ Queries: 13 (0.0047s) ][ GZIP on ]