Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 24 Oct 2014, 08:57
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Intermittant soundcard Intel8x0 [solved]
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [7 Posts]  
Author Message
darkcity


Joined: 23 May 2010
Posts: 2462
Location: near here

PostPosted: Wed 15 Feb 2012, 12:03    Post subject:  Intermittant soundcard Intel8x0 [solved]  

The soundcard sometimes works and other times not.

I've been trying to fix but now sound doesn't work at all.

I run alsaconf (wizard) and it detects the cards - see picture

however aplay reveals no soundcards

sh-4.1# aplay -l
aplay: device_list:240: no soundcards found...
sh-4.1#

I've tried reboot and selecting CA106 and Intel8x0, but no soundcards detected and retrovol won't start up

any ideas

Puppy 5.29 on Pentium 4

Idea
soundproblem.png
 Description   
 Filesize   21.93 KB
 Viewed   467 Time(s)

soundproblem.png


_________________
helping Wiki for help | IF SendSpace link = "dead" THEN PM me ("up file to http://meownplanet.net/")

Last edited by darkcity on Sat 24 Mar 2012, 06:47; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
Semme

Joined: 07 Aug 2011
Posts: 3970
Location: World_Hub

PostPosted: Wed 15 Feb 2012, 19:11    Post subject:  

DC, is the correct driver loaded and "in use" when it doesn't work: lspci -k
Back to top
View user's profile Send private message 
Peterm321

Joined: 29 Jan 2009
Posts: 236

PostPosted: Wed 15 Feb 2012, 21:08    Post subject:  

Quote:
any ideas

Puppy 5.29 on Pentium 4


I dont really know at all, though it appears that there is more than one soundcard attached to your computer. Is it possibe that the system could at times choke with this kind of configuration?

The commandline program alsamixer might be worth a look. F2 provides a list of useful files in the /proc/asound directory for viewing, and F6 to change the default soundcard. As I dont have more than one soundcard I dont know if this could help, maybe worth a try if no better advice arises.
SCRNDMP.PNG
Description  Screendump: command line program - alsamixer
png

 Download 
Filename  SCRNDMP.PNG 
Filesize  21.81 KB 
Downloaded  164 Time(s) 
Back to top
View user's profile Send private message 
darkcity


Joined: 23 May 2010
Posts: 2462
Location: near here

PostPosted: Thu 16 Feb 2012, 15:44    Post subject:  

Thanks for the help ; -)

I couldn't work it out. Both multimedia pci's were detected by puppy but the sound wizard wouldn't set them up. alsamixer would not start up. I've reverted to an earlier pup save file - sound is now back working. will monitor puppy to see why sometimes the sound doesn't start.

Idea

_________________
helping Wiki for help | IF SendSpace link = "dead" THEN PM me ("up file to http://meownplanet.net/")
Back to top
View user's profile Send private message Visit poster's website 
darkcity


Joined: 23 May 2010
Posts: 2462
Location: near here

PostPosted: Fri 24 Feb 2012, 11:18    Post subject:  

I think I've found the solution - control the order the sound modules are loaded in-

from
http://forums.debian.net/viewtopic.php?f=30&t=74659


Added code to/etc/modprobe.d/alsa-base.conf

Code:
#choose order of sound modules
options snd-ca0106 index=0
options snd-intel8x0 index=1
Arrow

will continue to monitor and report Twisted Evil

_________________
helping Wiki for help | IF SendSpace link = "dead" THEN PM me ("up file to http://meownplanet.net/")

Last edited by darkcity on Sat 24 Mar 2012, 06:48; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
postfs1


Joined: 27 Mar 2010
Posts: 831

PostPosted: Fri 24 Feb 2012, 20:58    Post subject:  

Maybe this example will help Arrow

http://www.murga-linux.com/puppy/viewtopic.php?p=404966#404966

_________________
  • I don't know why laboratories are named a hospitals.
  • The alive personage is like a tea bag with granules of unknown density inside, at that one the packet was made of organic material and was placed in the evaporated liquid or liquid.

Back to top
View user's profile Send private message 
darkcity


Joined: 23 May 2010
Posts: 2462
Location: near here

PostPosted: Sat 24 Mar 2012, 06:46    Post subject:  

soundcard is now correctly selected on every boot ; -)
_________________
helping Wiki for help | IF SendSpace link = "dead" THEN PM me ("up file to http://meownplanet.net/")
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 1 [7 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0579s ][ Queries: 13 (0.0072s) ][ GZIP on ]