Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 20 Dec 2014, 04:15
All times are UTC - 4
 Forum index » Advanced Topics » Cutting edge
GUI to download LibreOffice - beta quality
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 8 of 18 [262 Posts]   Goto page: Previous 1, 2, 3, ..., 6, 7, 8, 9, 10, ..., 16, 17, 18 Next
Author Message
gcmartin


Joined: 14 Oct 2005
Posts: 4506
Location: Earth

PostPosted: Mon 12 Mar 2012, 17:38    Post subject: Using JRE  

In the past, I've used JRE as it have automatically provided JAVA features for JAVA apps one mihgt use.

I use a LAN PC finder called AngryIP available as a JAVA app or as a PET installer which adds a menu item. And, with LibreOffice this allow full functioning of the product.

This is not a request for a change to anything, just an understand of how one get JAVA servcie for needed applications.

Thanks goes to Pemasu as he has score a wining hockey goal with the LibreOffice.PET he produced.

Thanks again to all

_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engine or use DogPile
Back to top
View user's profile Send private message 
greengeek

Joined: 20 Jul 2010
Posts: 2747
Location: New Zealand

PostPosted: Tue 13 Mar 2012, 15:05    Post subject: Re: Using JRE  

gcmartin wrote:
In the past, I've used JRE as it have automatically provided JAVA features for JAVA apps one mihgt use.

I use a LAN PC finder called AngryIP available as a JAVA app or as a PET installer which adds a menu item. And, with LibreOffice this allow full functioning of the product.


gcmartin - can you clarify this please? Are you saying that I don't need a JRE at all, I only need to install angryIP and then Libreoffice will be satisfied?

(I am a little confused because that seems different to your first post in this other topic:
http://murga-linux.com/puppy/viewtopic.php?t=67345
where I think you said "JAVA is required")

thanks in advance.
Back to top
View user's profile Send private message 
greengeek

Joined: 20 Jul 2010
Posts: 2747
Location: New Zealand

PostPosted: Tue 13 Mar 2012, 15:09    Post subject:  

vovchik wrote:
but nearly everything works without JRE, although I have it installed.

Thank you vovchik. Do you remember where you got the JRE from? (I installed a JRE pet to my Slacko53 install and ended up with icon problems and unwanted ROX alterations). I would like to find a good, clean, safe JRE just in case I need it)
Thx.
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7841
Location: qld

PostPosted: Tue 13 Mar 2012, 17:21    Post subject:  

Hi greengeek

Going by vovchik's info I would say that if you don't need Base (the database) you don't need Java. Angry IP scanner is a Java dependent IP address scanner and a totally separate, you don't need it unless you want to scan for ALL Ip addresses your machine can find (fun exercise!). It has nothing to do with LibreOffice.

I have had no problem with Java, which version did you have an issue with and from where did you get it? The lucid 1.6 update 24 version (iirc) seems stable on older gear (from reports).

You could try some from the follwing post:
http://www.murga-linux.com/puppy/viewtopic.php?t=67371

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
greengeek

Joined: 20 Jul 2010
Posts: 2747
Location: New Zealand

PostPosted: Tue 13 Mar 2012, 17:54    Post subject:  

01micko wrote:

I have had no problem with Java, which version did you have an issue with and from where did you get it? The lucid 1.6 update 24 version (iirc) seems stable on older gear (from reports).

Hi 01micko,
the JRE issue that some of us experienced with Libreoffice on Slacko53 is detailed here:
http://murga-linux.com/puppy/viewtopic.php?t=75299
(it is an obvious problem on Slacko due to the black desktop, but icon colour was not the only problem I had as a result. Other Rox options were "contaminated" also)

I will have a look at that other source for JRE.
many thanks.
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7841
Location: qld

PostPosted: Wed 14 Mar 2012, 06:15    Post subject:  

HI greengeek

Ah yes, I do remember your issue of getting a java package that was tainted with rox-filer settings.... that is one problem with getting a package from the forum, they aren't screened so you use at your own risk. Best thing to do if unsure about a package is to backup first.

Cheers

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
gcmartin


Joined: 14 Oct 2005
Posts: 4506
Location: Earth

PostPosted: Thu 15 Mar 2012, 18:52    Post subject: JRE with LibreOffice  

Sorry for the delay:

Below, the PPM seems to have a JRE that is without issues. I will check to see if the same is true of the forum recommendation that @01Micko shares.

The PPM doesn't indicate this to be a "full" version. It is a little confusing as it suggests "... Control Panel". But, it works without issues!

Should one of the ones listed in the forum does work without introducing issues, what should we do for those to be included in PPM by distro developers?

AngryIP was listed as it is a simple JAVA Jar/pet that has many uses in a local LANs for determining your local LAN's devices. I have been using this in Windows/Linux for the past 15 years. Lightning fast and "little to no" footprint when used.

2nd item of interest - LibreOffice

My concern for JRE is that it give MY use the opportunity to add, test, implement java apps should I need to use them. LibreOffice will allow me to run ALL of its facilities, thus I made a judgment call to want Java available should LibreOffice functions which use that need that without my having to chase down error messages that would erupt..

3rd item - LibreOffice PET Question
Is there a way for it to be available to SLACKO's PPM?

Lastly and in summary
BOTH the LibreOffice PET and the AngryIP PET/jar work without known issues when running. They are using the currently shown PPM JRE (below) in spite of the error received from the java command shown above. This is currently being run on a Live media system with 2 current save-sessions on a Intel Mobil 1.5GHz CPU with 1GB RAM. The PET from @Pemasu was installed on this SLACKO 3.2.7 and the system is running "snappily" without any issues from any of the system's components. See below for all currently PET installed.

Hope this helps
Installed Packages.png
 Description   Currently installed packages on SLACKO 5.3.2.7
 Filesize   17.19 KB
 Viewed   1160 Time(s)

Installed Packages.png

ERASEDIS.png
 Description   PPM does NOT have a JRE that installs on SLACKO without issues. (But, please understand, that aside from the issues, AngryIP works fine using this problematic version)
 Filesize   76.14 KB
 Viewed   1174 Time(s)

ERASEDIS.png


_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engine or use DogPile
Back to top
View user's profile Send private message 
Henry

Joined: 29 Jul 2006
Posts: 829
Location: Oregon USA

PostPosted: Fri 16 Mar 2012, 00:35    Post subject: LibreOffice- 3.5.1 SOLVED
Subject description: can't download it (Fixed with symlink)
 

Edit:
Code:
ln -s /usr/sbin/gtkdialog3 /usr/sbin/gtkdialog


3.5.1 was announced this morning (or last night).

I was able to download it and the help file from the normal place in the normal way, no problem. When I tried to get it with the GUI, I could not get the download started, although I could with the "testing" RC. Confirmed several times - did not seem to be a matter of availability.

Does the GUI automatically download the latest stable, or does the maintainer have to tweak it? Has anyone successfully got 3.5.1 through the GUI?

Thanks

Last edited by Henry on Fri 16 Mar 2012, 13:36; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
01micko


Joined: 11 Oct 2008
Posts: 7841
Location: qld

PostPosted: Fri 16 Mar 2012, 01:34    Post subject:  

Henry..

They can be slow to update the servers for Linux, working fine for me right now, give it another try.

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
Henry

Joined: 29 Jul 2006
Posts: 829
Location: Oregon USA

PostPosted: Fri 16 Mar 2012, 10:01    Post subject: SOLVED see message below  

Thanks for the quick reply!

I tried again. Got the green spinning splash: "Please wait a moment" for 45 minutes. . . The libre_download folder was created but stayed empty.

I have QuirkyNop 1.2 with Xfce (Thunar, no Rox, Opera, no Seamomkey or Firefox). Very clean system. What are the system requirements?

Henry

Last edited by Henry on Fri 16 Mar 2012, 13:38; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
Henry

Joined: 29 Jul 2006
Posts: 829
Location: Oregon USA

PostPosted: Fri 16 Mar 2012, 12:00    Post subject: SOLVED by symlink  

Back again - I read above the advice to

Code:
ln -s /usr/sbin/gtkdialog3 /usr/sbin/gtkdialog


This made a big difference. I was given some choices and got a yellow box that was trying to download the help file but failed. So maybe I'm seeing traffic congestion. Will try again.

Henry

Edit: OK now! Great program. Thanks
Back to top
View user's profile Send private message Visit poster's website 
buzby01

Joined: 11 Mar 2012
Posts: 15

PostPosted: Tue 20 Mar 2012, 07:18    Post subject:  

Just used get_LO.13 enGB to install LO 3.5.1 to Macpup 5.2.8. and all works perfectly even base with Java is working.

Thanks to all involved. Would like to know one thing though. This thread talks about converting the sfs to a pet package. could you point me in the right direction in how to achieve this and thanks again.

Cheers
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7841
Location: qld

PostPosted: Wed 02 May 2012, 09:08    Post subject:  

0.15 is out... so is Libreoffice 3.5.3

see main post

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
Jim1911

Joined: 19 May 2008
Posts: 2457
Location: Texas, USA

PostPosted: Wed 02 May 2012, 10:58    Post subject:  

01micko wrote:
0.15 is out... so is Libreoffice 3.5.3

see main post
Thanks, but now your great FATSlacko is already out of date. Rolling Eyes
Back to top
View user's profile Send private message 
Henry

Joined: 29 Jul 2006
Posts: 829
Location: Oregon USA

PostPosted: Wed 02 May 2012, 13:06    Post subject: Removed  

Removed, my error,
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 8 of 18 [262 Posts]   Goto page: Previous 1, 2, 3, ..., 6, 7, 8, 9, 10, ..., 16, 17, 18 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Cutting edge
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1094s ][ Queries: 13 (0.0168s) ][ GZIP on ]